语音和统一通信 : Cisco Unity Connection

与VMware的CUC恶劣的音频质量

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述进程识别音频质量问题是否是网络问题,或者与虚拟化应用程序的一个问题。

由思科 TAC 工程师撰稿。

问题

当更多实时语音应用程序虚拟化,它变得更加复杂排除故障音频质量问题。请使用Unity Connection作为主题此“实时语音应用程序”。

收集信息

  1. 第一步将确定提示符是否误解,当您留下Unity Connection时。为了采集数据包,捕获“使用情况网络捕捉eth0文件capture1大小全部计数100000"。

    注意:Cisco Unified Communications (CUC)提示符是确定不理想的质量的一条好基线。请勿使用用户记录了问候语,他们可以一个不可靠基准。

          
  2. 分析数据包捕获:Wireshark,支持mu-law G.711 A律或G.711。
  3. 用Wireshark检查流出的路由表协议(RTP)数据流的质量:
    1. 与默认设置的解码。
    2. 与选项“使用RTP时间戳”的解码在Wireshark。

可能的原因

如果两解码的数据流遇到语音质量问题,问题也许是提示符(WAV文件)或Unity Connection。

如果默认录音误解,但是使用RTP时间戳优良是,问题也许是资源/VMware

如果质量是可接受,当您听RTP数据流使用默认解码时,问题也许是CUC和电话之间的网络连通性。

注意:建议是采取从ESXi服务器连接的交换机的一数据包捕获并且检查质量。如果是坏的,很可能驱动程序被检查ESXi主机。

解决方案

如果问题指示问题是Unity Connection或WAV文件,首先验证录音的质量:

  1. 检查网络时间协议(NTP)。
    1. 如果客户安排多个NTP配置,请保证CUC频繁地不交换在两个之间。
    2. 确认NTP服务器是否有NTPv4 (数据包捕获) :“使用情况ntp状态”。
  2. 请使用Web GUI验证质量。
  3. 保证那里是在CUC的没有coredump。寻找已知bug :“使用情况核心活动列表”。
  4. 请使用眼镜蛇的备份编辑器验证质量。

如果问题指示问题是VMware请验证,遵从这些步骤:

  1. 验证适当的预定在Unity Connection虚拟机安排:在支持的平台验证CPU和RAM预约正如。
  2. 保证大接收卸载(LRO)为ESXi主机(与ESXi 5.1+)的不是一个问题被关闭。欲知更多信息,请参阅在UCS/UC应用程序部署的禁用LRO
  3. 采取CUC VM的快照。欲知更多信息,请参阅VMware快照

    注意:不支持Unity Connection VMs的快照并且也许导致与语音质量的问题。

  4. 保证VMware工具安装。请参阅VMware工具欲知更多信息。

    注意:VMware工具安装在VM上的网络接口卡(NIC)驱动程序改进网络性能。

  5. 保证同步VM用主机没有被检查。此选项用ESXi主机同步虚拟机的设备使用时间。在球形客户端,请导航选择虚拟机,并且用鼠标右键单击虚拟机的请编辑设置。从选项卡,请选择VMware工具>Advanced。保证同步访客时间用主机复选框被不选定。

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