IP : IP 路由

容易虚拟网络配置示例

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述容易虚拟网络(EVN)功能,设计为了提供容易,简单对配置在园区网络的虚拟化机制。它利用当前技术,例如虚拟路由和转发轻(VRF-Lite)和dot1q封装和不介绍其中任一新建的协议。

贡献用法布里斯Ducomble, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于下列硬件和软件版本:

  • Cisco运行软件版本15.0(1)SY1的Catalyst 6000 (Cat6k)系列交换机

  • Cisco 1000系列聚集的服务路由器(ASR1000)该运行软件版本3.2s

  • 运行Cisco IOS版本15.3(2)T和以后的Cisco 3925和3945系列集成服务路由器

  • 运行软件版本15.1(1)SG的Cisco Catalyst 4500 (Cat4500)和4900台(Cat4900)系列交换机

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

这是EVN功能的概述:

  • EVN功能使用VRF-Lite为了创建几个(32)路由上下文。

  • 在虚拟路由和转发(VRF)内的连接在第3层设备之间通过虚拟网络(VNET)中继保证。

  • VNET中继是正常dot1q中继。

  • 必须在VNET中继间传输的每个VRF应该配置与VNET标记。

  • 每VNET标记等于dot1q标记。

  • dot1q子接口自动地创建并且隐藏。

  • 主接口的配置由所有(hidden)子接口继承

  • 路由协议独立实例应该用于在VNET中继的每个VRF为了通知前缀可接通性。

  • 漏在VRF之间的动态路由(被反对静态路由)允许,不用使用边界网关协议(BGP)。

  • 功能为IPv4和IPv6支持。

配置

请使用在此部分描述为了配置EVN功能的信息。

注意:使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

此网络设置用于为了说明EVN配置和显示命令:

这是关于此设置的一些重要提示:

  • 从网络核心被执行通过VNET中继的两VRF定义(CUST-ACUST-B)。

  • 开放最短路径优先(OSPF)用于VRF为了通知可接通性。

  • VRF COM主机一定是可及的从VRF CUST-A和CUST-B的一个普通的服务器(100.1.1.100)。

  • 使用的镜像是i86bi_linux-adventerprisek9-ms.153-1.S

提示:在使用的Linux (IOL)的Cisco IOS设置可用的在这里

配置EVN

完成这些步骤为了配置EVN功能:

  1. 配置Vrf definition :
    vrf definition [name]
    vnet tag [2-4094]
    !
    address-family ipv4|ipv6
    exit-address-family
    !
    这是关于此配置的一些重要提示:

    • 思科建议您使用标记在2到1,000范围内。请勿使用保留VLAN 1,001至1,005。可以使用若需要延长的VLAN 1,006至4,094。

    • 不应该由当前使用VNET标记VLAN。

    • VNET标记应该是相同的在所有所有给的VRF的设备。

    • 应该配置地址famility ipv4|ipv6为了激活在相关AF的VRF。

    • 没有需要定义路由方向(RD),因为EVN不使用BGP。

    使用此设置,在所有4x核心路由器应该定义VRF。例如,在CORE-1 :
    vrf definition CUST-A
     vnet tag 100
     !
     address-family ipv4
     exit-address-family
    vrf definition CUST-B
     vnet tag 200
     !
     address-family ipv4
     exit-address-family
    请使用在所有的同一VNET标记路由器这些VRF。在CORE-4, VRF COM不要求VNET标记。目标是保持在CORE-4的VRF本地并且配置为了提供存取的漏和再分配对于从CUST-A和CUST-B的普通的服务器。

    输入此命令为了检查多种VNET计数器:
    CORE-1#show vnet counters
    Maximum number of VNETs supported: 32
    Current number of VNETs configured: 2
    Current number of VNET trunk interfaces: 2
    Current number of VNET subinterfaces: 4
    Current number of VNET forwarding interfaces: 6
    CORE-1#
  2. 配置VNET中继:
    interface GigabitEthernetx/x
     vnet trunk
     ip address x.x.x.x y.y.y.y
     ...
    这是关于此配置的一些重要提示:

    • trunk命令的vnet创建许多dot1q子接口作为定义与VNET标记VRF的数量。

    • trunk命令的vnet不能共存与在同一个物理接口的一些手工配置的子接口。

    • 此配置在路由接口(不是交换机端口),物理和portchannel允许。

    • IP地址(和其他命令)在物理接口应用由子接口继承。

    • 所有的子接口VRF使用同样IP地址。

    使用此设置,有两个VNET VRF,因此两子接口在配置的接口自动地创建,当VNET中继。您能输入显示派生设置命令为了查看自动地创建的隐藏的配置:

    这是当前运行的配置:
    CORE-1#show run | s Ethernet0/0 
    interface Ethernet0/0
     vnet trunk
     ip address 192.168.1.1 255.255.255.252
     !
    CORE-1#
    这是派生的配置:
    CORE-1#show derived-config | s Ethernet0/0
    interface Ethernet0/0
     vnet trunk
     ip address 192.168.1.1 255.255.255.252
    Interface Ethernet0/0.100
     description Subinterface for VNET CUST-A
     encapsulation dot1Q 100
     vrf forwarding CUST-A
     ip address 192.168.1.1 255.255.255.252
    interface Ethernet0/0.200
     description Subinterface for VNET CUST-B
     encapsulation dot1Q 200
     vrf forwarding CUST-B
     ip address 192.168.1.1 255.255.255.252
    CORE-1#
    如显示,所有子接口继承主接口的IP地址。

  3. 分配边缘(子)接口到VRF。为了分配接口或子接口到VNET VRF,请使用步骤和用于的那一样为了通常分配VRF :
    interface GigabitEthernet x/x.y
     vrf forwarding [name]
     ip address x.x.x.x y.y.y.y
     ...
    使用此设置,配置在CORE-1和CORE-4应用。这是CORE-4的一示例:
    interface Ethernet2/0
     vrf forwarding CUST-A
     ip address 10.1.2.1 255.255.255.0
    !
    interface Ethernet3/0
     vrf forwarding CUST-B
     ip address 10.2.2.1 255.255.255.0
    !
    interface Ethernet4/0
     vrf forwarding COM
     ip address 100.1.1.1 255.255.255.0
  4. 配置每个VRF的路由协议(这不是特定对EVN或VNET) :
    router ospf x vrf [name]
     network x.x.x.x y.y.y.y area x
     ...

    注意:此配置应该包括VNET中继地址以及边缘接口地址。


    使用此设置,两个OSPF进程定义,一个每个VRF :
    CORE-1#show run | s router os
    router ospf 1 vrf CUST-A
     network 10.1.1.0 0.0.0.255 area 0
     network 192.168.1.0 0.0.0.255 area 0
    router ospf 2 vrf CUST-B
     network 10.2.1.0 0.0.0.255 area 0
     network 192.168.1.0 0.0.0.255 area 0
    CORE-1#
    您能输入路由上下文模式为了查看与特定VRF涉及,不用在每命令的VRF规格的信息:
    CORE-1#routing-context vrf CUST-A
    CORE-1%CUST-A#
    CORE-1%CUST-A#show ip protocols
    *** IP Routing is NSF aware ***
    Routing Protocol is "ospf 1"
      Outgoing update filter list for all interfaces is not set
      Incoming update filter list for all interfaces is not set
      Router ID 192.168.1.13
      It is an area border router
      Number of areas in this router is 1. 1 normal 0 stub 0 nssa
      Maximum path: 4
      Routing for Networks:
        10.1.1.0 0.0.0.255 area 0
        192.168.1.0 0.0.0.255 area 0
      Routing Information Sources:
        Gateway         Distance      Last Update
        192.168.1.9          110      1d00h
        192.168.1.14         110      1d00h
      Distance: (default is 110)
    CORE-1%CUST-A#
    CORE-1%CUST-A#show ip os neighbor
    Neighbor ID     Pri   State         Dead Time   Address         Interface
    192.168.1.14      1   FULL/DR       00:00:30    192.168.1.14    Ethernet1/0.100
    192.168.1.5       1   FULL/BDR      00:00:37    192.168.1.2     Ethernet0/0.100
    10.1.1.2          1   FULL/BDR      00:00:33    10.1.1.2        Ethernet2/0
    CORE-1%CUST-A#

    注意show ip protocols命令输出显示与选定VRF涉及仅的信息。


    当您查看两VRF的时路由信息库(RIB),您能通过两VNET中继验证远程子网:
    CORE-1%CUST-A#show ip route 10.1.2.0   
    Routing Table: CUST-A
    Routing entry for 10.1.2.0/24
      Known via "ospf 1", distance 110, metric 30, type intra area
      Last update from 192.168.1.2 on Ethernet0/0.100, 1d00h ago
      Routing Descriptor Blocks:
      * 192.168.1.14, from 192.168.1.9, 1d00h ago, via Ethernet1/0.100
          Route metric is 30, traffic share count is 1
        192.168.1.2, from 192.168.1.9, 1d00h ago, via Ethernet0/0.100
          Route metric is 30, traffic share count is 1
    CORE-1%CUST-A#
    CORE-1%CUST-A#routing-context vrf CUST-B
    CORE-1%CUST-B#
    CORE-1%CUST-B#show ip route 10.2.2.0
    Routing Table: CUST-B
    Routing entry for 10.2.2.0/24
      Known via "ospf 2", distance 110, metric 30, type intra area
      Last update from 192.168.1.2 on Ethernet0/0.200, 1d00h ago
      Routing Descriptor Blocks:
      * 192.168.1.14, from 192.168.1.6, 1d00h ago, via Ethernet1/0.200
          Route metric is 30, traffic share count is 1
        192.168.1.2, from 192.168.1.6, 1d00h ago, via Ethernet0/0.200
          Route metric is 30, traffic share count is 1
    CORE-1%CUST-B#
    CORE-1%CUST-B#exit
    CORE-1#
    CORE-1#
  5. 确定在VRF之间的路由泄漏。路由泄漏通过路由复制执行。例如,在VRF的一些路由也许使可用为另一个VRF :
    vrf definition VRF-X
     address-family ipv4|ipv6
      route-replicate from vrf VRF-Y unicast|multicast
    [route-origin] [route-map [name]]
    这是关于此配置的一些重要提示:

    • VRF-X的RIB访问选定路由,根据从VRF-Y的命令参数。

    • VRF-X的复制的路由标记用[+]标志。

    • 组播选项允许使用从另一个VRF的路由反向路径转发(RPF)。

    • 路由始发地能有这些值之一:

      • 所有
      • bgp
      • 已连接
      • eigrp
      • isis
      • 移动
      • odr
      • ospf
      • RIP
      • 静态

    不同于名称指示,路由没有复制也没有被复制;这是有漏通过BGP普通的RT的正常的实际情形,不浪费额外内存。

    使用此设置,路由泄漏在CORE-4用于为了提供访问从CUST-A和CUST-B到COM (和反过来也是一样地) :
    vrf definition CUST-A
    address-family ipv4
    route-replicate from vrf COM unicast connected
    !
    vrf definition CUST-B
    address-family ipv4
    route-replicate from vrf COM unicast connected
    !
    vrf definition COM
    address-family ipv4
    route-replicate from vrf CUST-A unicast ospf 1 route-map USERS
    route-replicate from vrf CUST-B unicast ospf 2 route-map USERS
    !
    route-map USERS permit 10
    match ip address prefix-list USER-SUBNETS
    !
    ip prefix-list USER-SUBNETS seq 5 permit 10.0.0.0/8 le 32

    CORE-4#show ip route vrf CUST-A
    Routing Table: COM
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area,* - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override
    ...
       10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    O        10.1.1.0/24 [110/30] via 192.168.1.10, 3d19h, Ethernet1/0.100
           [110/30] via 192.168.1.5, 3d19h, Ethernet0/0.100
       100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C   +    100.1.1.0/24 is directly connected (COM), Ethernet4/0

    CORE-4#show ip route vrf CUST-B
    ...   10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    O        10.2.1.0/24 [110/30] via 192.168.1.10, 1d00h, Ethernet1/0.200
           [110/30] via 192.168.1.5, 1d00h, Ethernet0/0.200
       100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C   +    100.1.1.0/24 is directly connected (COM), Ethernet4/0

    CORE-4#show ip route vrf COM  
    ...
       10.0.0.0/24 is subnetted, 2 subnets
    O   +    10.1.1.0 [110/30] via 192.168.1.10 (CUST-A), 3d19h, Ethernet1/0.100
               [110/30] via 192.168.1.5 (CUST-A), 3d19h, Ethernet0/0.100
    O   +    10.2.1.0 [110/30] via 192.168.1.10 (CUST-B), 1d00h, Ethernet1/0.200
               [110/30] via 192.168.1.5 (CUST-B), 1d00h, Ethernet0/0.200

       100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C        100.1.1.0/24 is directly connected, Ethernet4/0
    这时,复制的路由在仅内部网关路由协议(IGP)、那么CE-A-2和CE-B-2没有被传播访问COM服务(100.1.1.100),没有CE-A-1和CE-B-1。

    您能也使用路由泄漏从或对一个全局表:
    vrf definition VRF-X
     address-family ipv4
      route-replicate from vrf >global unicast|multicast [route-origin]
    [route-map [name]]
      exit-address-family
     !
     exit
    !
    global-address-family ipv4 unicast
     route-replicate from vrf [vrf-name] unicast|multicast [route-origin]
    [route-map [name]]
  6. 定义路由泄漏传播。被泄漏的路由在目标VRF RIB没有被复制。换句话说,他们不是目标VRF RIB的部分。在路由器进程之间的正常再分配不工作,因此您必须明确地定义路由属于RIB的VRF连接:
    router ospf x vrf VRF-X
     redistribute vrf VRF-Y [route-origin] [route-map [name]]
    从在VRF-X运行的VRF-Y的被泄漏的路由在OSPF程序再分布。这是在CORE-4的一示例:
    router ospf 1 vrf CUST-A
     redistribute vrf COM connected subnets route-map CON-2-OSPF
    !
    route-map CON-2-OSPF permit 10
     match ip address prefix-list COM
    !
    ip prefix-list COM seq 5 permit 100.1.1.0/24
    因为只有在VRF COM的一已连接路由route-map在这种情况下没有必要。 当前有可接通性对COM服务(100.1.1.100)从CE-A-1和CE-B-1 :
    CE-A-1#ping 100.1.1.100
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 100.1.1.100, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    CE-A-1#

    CE-B-1#ping 100.1.1.100
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 100.1.1.100, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    CE-B-1#

调整VNET中继

此部分提供您能使用为了调整VNET中继的信息。

中继列表

默认情况下,配置与VNET标记的所有VRF在所有允许VNET中继。中继列表允许您指定已授权VRF列表在VNET中继的:

vrf list [list-name]
 member [vrf-name]
!
interface GigabitEthernetx/x
 vnet trunk list [list-name]

注意:应该有每个允许VRF一条线路。

为例, CORE-1为在VNET中继的VRF CUST-B被调整在CORE-1和CORE-2之间:

vrf list TEST
member CUST-A
!
interface ethernet0/0
vnet trunk list TEST

如显示,并列为在中继间的VRF CUST-B的OSPF断开:

%OSPF-5-ADJCHG: Process 2, Nbr 192.168.1.2 on Ethernet0/0.200 from FULL to DOWN,
Neighbor Down: Interface down or detached

VRF的CUST-B子接口删除:

CORE-1#show derived-config | b Ethernet0/0 
interface Ethernet0/0
 vnet trunk list TEST
 ip address 192.168.1.1 255.255.255.252
!
interface Ethernet0/0.100
 description Subinterface for VNET CUST-A
 encapsulation dot1Q 100
 vrf forwarding CUST-A
 ip address 192.168.1.1 255.255.255.252
!

每VRF中继属性

默认情况下, dot1q子接口继承物理接口的参数,以便所有的子接口VRF有同样属性(例如费用和验证)。您能调整中继参数每VNET标记:

interface GigaEthernetx/x
 vnet trunk
 vnet name VRF-X
  ip ospf cost 100
 vnet name VRF-Y
  ip ospf cost 15

您能调整这些参数:

CORE-1(config-if-vnet)#?
Interface VNET instance override configuration commands:
  bandwidth     Set bandwidth informational parameter
  default       Set a command to its defaults
  delay         Specify interface throughput delay
  exit-if-vnet  Exit from VNET submode
  ip            Interface VNET submode Internet Protocol config commands
  no            Negate a command or set its defaults
  vnet          Configure protocol-independent VNET interface options
CORE-1(config-if-vnet)#
CORE-1(config-if-vnet)#ip ?    
  authentication      authentication subcommands
  bandwidth-percent   Set EIGRP bandwidth limit
  dampening-change    Percent interface metric must change to cause update
  dampening-interval  Time in seconds to check interface metrics
  hello-interval      Configures EIGRP-IPv4 hello interval
  hold-time           Configures EIGRP-IPv4 hold time
  igmp                IGMP interface commands
  mfib                Interface Specific MFIB Control
  multicast           IP multicast interface commands
  next-hop-self       Configures EIGRP-IPv4 next-hop-self
  ospf                OSPF interface commands
  pim                 PIM interface commands
  split-horizon       Perform split horizon
  summary-address     Perform address summarization
  verify              Enable per packet validation
CORE-1(config-if-vnet)#ip

在本例中, OSPF开销每个CORE-1的VRF更改,因此CORE-2路径使用CUST-A和CORE-3路径CUST-B的(默认值是10)

interface Ethernet0/0
vnet name CUST-A
ip ospf cost 8
!
vnet name CUST-B
ip ospf cost 12
!

CORE-1#show ip route vrf CUST-A 10.1.2.0

Routing Table: CUST-A
Routing entry for 10.1.2.0/24
Known via "ospf 1", distance 110, metric 28, type intra area
Last update from 192.168.1.2 on Ethernet0/0.100, 00:05:42 ago
Routing Descriptor Blocks:
* 192.168.1.2, from 192.168.1.9, 00:05:42 ago, via Ethernet0/0.100
Route metric is 28, traffic share count is 1
CORE-1#
CORE-1#show ip route vrf CUST-B 10.2.2.0

Routing Table: CUST-B
Routing entry for 10.2.2.0/24
Known via "ospf 2", distance 110, metric 30, type intra area
Last update from 192.168.1.14 on Ethernet1/0.200, 00:07:03 ago
Routing Descriptor Blocks:
* 192.168.1.14, from 192.168.1.6, 1d18h ago, via Ethernet1/0.200
Route metric is 30, traffic share count is 1
CORE-1#

每链路VNET标记

默认情况下,在Vrf definition定义的VNET标记使用所有中继。然而,您能使用一不同的VNET标记每中继。

此示例描述您连接到一个非EVN有能力设备的方案,并且您以一手工的中继使用VRF-Lite,并且另一个VLAN使用全局VNET标记:

使用此设置,在CORE-1和CORE-2之间的中继使用CUST-A的VNET标记更改从100101

interface Ethernet0/0
vnet name CUST-A
  vnet tag 101

在此更改在CORE-1后发生,一新的子接口创建:

CORE-1#show derived-config | b Ethernet0/0       
interface Ethernet0/0
vnet trunk
ip address 192.168.1.1 255.255.255.252
!
interface Ethernet0/0.101
description Subinterface for VNET CUST-A
encapsulation dot1Q 101
vrf forwarding CUST-A
ip address 192.168.1.1 255.255.255.252
!
interface Ethernet0/0.200
description Subinterface for VNET CUST-B
encapsulation dot1Q 200
vrf forwarding CUST-B
ip address 192.168.1.1 255.255.255.252

如果此更改在一端仅发生,则连接在相关的VRF丢失,并且OSPF断开:

%OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.5 on Ethernet0/0.101 from FULL to DOWN,
Neighbor Down: Dead timer expired

一旦同一VNET标记在CORE-2使用,连接恢复,并且dot1q标记101在该中继使用,当100在CORE-1仍然使用到CORE-3中继时:

%OSPF-5-ADJCHG: Process 1, Nbr 192.168.1.5 on Ethernet0/0.101 from LOADING to
FULL, Loading Done

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

相关信息



Document ID: 117974