路由器 : Cisco ASR 9000 系列汇聚服务路由器

L2对XR L2VPN配置转换进程的交换配置

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述如何转换Cisco IOS第二层交换配置到Cisco IOS XR Layer2虚拟专用网络(L2VPN)配置。

贡献用曼纽尔Irizarry,大卫鲍尔斯和塞缪尔Milstead, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文没有限制对特定软件,然而限制对使用以太网虚拟电路的9000系列聚集的服务路由器(ASR)有关的硬件版本(EVC)型号为了配置L2VPN。ASR 9000系列路由器使用EVC型号,而载波运行Cisco IOS XR的路由系统(CRS)路由器不。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

ASR 9000系列路由器值得注意地不跟随IEEE型号Layer2 (L2)配置, 802.1Q802.1AD。反而它使用EVC型号。EVC型号允许Cisco IOS XR有效利用当前802.1Q VLAN标记用一个新的方式。传统上, VLAN标记定义了分类, VLAN,转发,并且使用的内容可寻址内存(CAM)表为了执行MAC地址查找。使用EVC型号,此概念被分离为了准许更多灵活性和更加高的缩放。EVC型号排除最大4,096的VLAN的Cisco IOS限制。

EVC使用这些构建模块:

  • 以太网流点(EFP) - EFP是使用为了分类流量在物理下的L2逻辑子接口或捆绑接口。

  • EVC - EVC是L2单个实例的一端到端表示。EFP定义作为EVC的终端在节点内的。由于多个EVCs能穿过一个物理接口, EFP配置的主要目的将认可属于在该接口的特定EVC的流量和应用转发动作和特定功能对那EVC。

  • 网桥域(BD) - BD是以太网广播域内部对设备。BD使您分离从广播域的VLAN。BD有一对多的映射用EFPs :所有在一个节点的EFPs特定的EVC分组与使用BD。如果EFPs属于同样BD并且有同一个BD编号,则EFPs接收流量,即使他们有不同的VLAN号。

问题

在ASR 9000系列路由器的Cisco IOS XR使用以太网虚拟电路(EVC)型号。EVC型号没有中继、VLAN接口或者Switch Virtual Interface (SVI)的概念。必须转换中继、VLAN接口和SVIs从Cisco IOS到Cisco IOS XR配置通过sub-interface、L2VPN BDs和网桥虚拟接口(BVI)。当他们首先移植到Cisco IOS XR时, EVC型号也许新建对一些Cisco IOS用户。

解决方案

在Cisco IOS XR的配置包括三个步骤:

  1. 通过一接口或sub-interface的配置创建EFP与l2transport选项,代表VLAN。

  2. 创建BD为了分组EFPs。

  3. 当第3层(L3)时SVIs是需要的,请通过在Cisco IOS XR的接口BVI配置,而不是在Cisco IOS的接口VLAN,为了为属于BD的L2接口提供基本L3功能。

注意:BVI接口不支持VLAN标记;如此为了BVI能处理在EFP的入口流量,在入口在出口必须弹出和添加VLAN标记。这用重写命令完成。

转换配置

此示例说明如何转换一配置从Cisco IOS到Cisco IOS XR。

IOS配置

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

创建EFP接口。Cisco IOS XR实现EFP和EVC配置的结构CLI。为了配置EFP,请使用这些接口配置命令:

  • l2transport命令-此命令识别子接口、物理端口或者套件波尔特parent接口作为EFP。

  • encapsulation命令-此命令用于为了指定VLAN匹配标准。

  • 重写命令-此命令用于为了指定VLAN标记重写标准。

Interfate的TenGigabitEhternet 13/3 (中继端口) ASR 9000配置

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

为了添加本地VLAN 1, untag流量和创建与dot1q无标记封装的一l2transport sub-interface。请使用encapsulation dot1q无标记命令在l2transport接口下或sub-interface,如果端口连接对端口为在IOS设备的交换端口访问配置。

示例如下:

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

在EFP创建后, BVI接口可以创建和被添加到BD。BVI接口用于为了适应在Cisco IOS的接口VLAN。

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

BVI接口编号不一定需要匹配VLAN标识符。同样真实对L2传输接口的子接口号。然而,为了清晰在本例中, BVI编号匹配dot1q标记以及EFP子接口号。

在本例中, l2-vpn BD创建为了一起桥接EFPs和BVI :

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

网桥组(BG)是配合几BDs同一个功能组的一部分的一不运行的配置层级。它作用正建立有他们的域的广泛单个组,与有多个域的一组相对。

等效命令

此表列出在Cisco IOS的其他可以使用的命令和在Cisco IOS XR的等效命令配置在BD下:

IOSIOS XP
switchport block单播}充斥未知单播禁用
switchport port-security maximummac限制最大数量(范围5-512000)
switchport端口安全违规mac限制操作(充斥、NO-充斥,关闭) mac限制通知(两个,无,陷阱)
MAC地址表通知MAC移动需要配置以下:mac安全操作无mac安全记录日志
switchport port-security mac-address接口x mac限制最大y静态MAC地址H.H.H

相关信息



Document ID: 116500