路由器 : Cisco ASR 903 系列汇聚服务路由器

ASR 903 Port-Channel组在EVC配置以后的成员摆动

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述解决方案对Port-Channel组成员摆动的问题,在以太网虚拟连接(EVC)后在Cisco ASR 903系列聚合服务路由器配置。

贡献用阿梅尔易卜拉希莫维奇, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息根据Cisco ASR 903系列聚合服务配置的路由器作为有Port-Channel的一个运营商边缘设备往用户边缘设备。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

问题

摆动的Port-Channel组成员开始,在您配置以太网虚拟连接后(EVC);当您删除EVC配置时, Port-Channel组成员不再摆动。

日志显示输出类似于此:

GigabitEthernet0/0/4 taken out of port-channel1
GigabitEthernet0/0/4 added as member-2 to port-channel1
GigabitEthernet0/0/5 taken out of port-channel1
GigabitEthernet0/0/5 added as member-2 to port-channel1

此问题是特定对有EVC的ASR 903端口通道和被看到在此配置示例方面:

!
interface Port-channel1
mtu 1604
no ip address
no negotiation auto
service instance 999 ethernet
encapsulation dot1q 999
rewrite ingress tag pop 1 symmetric
bridge-domain 999
!
service instance 1700 ethernet
encapsulation dot1q 1700
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.1 1700 encapsulation mpls pw-class TE101
!
service instance 1820 ethernet
encapsulation dot1q 1820
rewrite ingress tag pop 1 symmetric
xconnect 172.26.225.15 1820 encapsulation mpls pw-class TE305
!
interface GigabitEthernet0/0/4
mtu 1604
no ip address
negotiation auto
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active
!
interface GigabitEthernet0/0/5
mtu 1604
no ip address
negotiation auto
cdp enable
service-policy input Core-In
service-policy output Core-Out
channel-group 1 mode active

解决方案

当您配置有EVC的端口通道在ASR 903时,您必须配置与无标记封装和第2层协议的1个EVC。例如:

interface Port-channel1
!
service instance 1 ethernet
encapsulation untagged
bridge-domain 1
l2protocol peer
!

关于ASR 903服务实例和端口通道的更多信息,参考配置的以太网虚拟连接的EFPs和EtherChannel部分在思科ASR 903路由器的


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 116116