统一计算 : Cisco UCS Manager

UCS FCoE上行链路配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述如何配置在以太网(FCoE) uplink端口的光纤信道。在思科统一计算系统(UCS)版本2.1和以上版本中,在以太网(FCoE)支持的多跳跃光纤信道介绍。此支持允许运载光纤信道(FC)和以太网从两单独的链路的上行链路巩固到单个上行链路。

注意:Unified uplink端口是与统一的端口不同。所有结构互连(FI),包括生成1,能统一uplink端口。然而,仅生成2 FIs统一端口。

贡献用克里斯托弗布朗, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息根据UCS管理器(UCSM)版本2.1。您必须运行至少版本2.1(1a)为了使用本文。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

配置

支持的配置

总计这些配置,您能替换与同一个类型的Port-Channel的所有链路。例如,如果配置显示一条链路,它可以配置与一Port-Channel。然而,您不能有一以太网和一个Unified端口同样Port-Channel的。

FCoE上行链路用虚拟端口信道(vPC)

此配置不包含统一的链路,但是它是集成FCoE uplink端口的简便的方法到您的当前环境。此配置排除需要交叉FC结构。

交叉连接与别住

在此配置中,连结5000系列交换机(N5ks)和FIs是交叉连接的,但是没波尔特一起开辟信道。这允许您有一些统一的uplink端口,但是您仍然维护一个著名的网络设计。

所有Unified Uplink端口

此配置提供多数巩固。切记这些链路可以也是端口通道,但是所有链路必须是统一的uplink端口。这可能是最普通的实施。

在UCS的配置

有配置UCS的三个步骤:

  1. 配置虚拟存储区域网络(VSAN)。
  2. 配置Unified Uplink端口。
  3. 配置端口通道(可选)。

配置VSAN

在此配置中, VSAN 500是在结构A外面,并且VSAN 600是在结构B.外面。这是您会使用为了创建一个正常FC的一VSAN的相同的配置。

配置Unified Uplink端口

Unified上行链路在GUI隐藏。为了做一个统一的端口,您必须首先配置它作为上行链路或FCoE上行链路。然后,您能配置它,一个统一的端口。此配置不删除第一个角色。反而,它创建有两个的接口。

确保这时设置您的VSAN。

这时,您的UCS为统一的流量配置。此示例不使用端口通道。然而,您能通常这时配置端口通道。确保设置VSAN在Port-Channel的VSAN选项卡下。

在N5k的配置

在N5k的配置包括3个步骤:

  1. Enable (event) FCoE和默认服务质量(QoS)设置。创建FCoE VLAN并且绑定VSAN对它。
  2. 配置以太网接口(或Port-Channel)。
  3. 创建虚拟光纤信道(vfc)并且绑定它对以太网接口。

注意:UCS是默认情况下N波尔特虚拟化(NPV)交换机,因此上行交换机需要在N波尔特Identifer Virtulization (NPIV)模式(请输入功能npiv命令为了启用)。 请参阅配置N波尔特虚拟化关于此功能的更多信息。

启用FCoE并且默认QoS设置

如果N5k为FCoE,已经配置您能跳到此步骤。如果N5k没有为FCoE配置,参考的附录A在说明的本文结束时。

配置以太网接口(或端口通道)

这是通常连接对UCS的接口的配置。 确保允许FCoE VLAN。

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

这是一个非常基本中继配置的示例。注意没有在此接口的FCoE配置。

配置vfc

这是vfc的配置,处理从UCS的所有FCoE流量:

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

有注意的一些个点在本例中:

  • vfc编号不重要。只要已经不是在使用中的,它可以是任何。
  • 这是中继结构(TF)端口,因此请确保允许您的VSAN。
  • 绑定此对面对UCS的接口。这是FCoE流量发送/已接收的物理接口。它在VLAN发送关联与VSAN。

这时,您安排一切充分地配置。输入show interface vfc xx命令为了保证VSAN出现。

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

如果VSAN不,请验证您的配置和您的连接。如果它仍然是请向下,摆动N5k的以太网端口。

这时,您运用您的正常FC配置(引导程序策略,区域)。

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。

附录A - N5k基本FCoE配置

为了配置FCoE的N5k,回车:

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

这些命令首先启用FCoE,然后启用为FCoE是需要的默认QoS策略。如果有自定义QoS设置,请使用那些作为基础。这是默认配置:

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

正如你看到的这些策略创建FCoE数据流类别,为NO-丢弃指示它,并且给它专用带宽。您能修改这些,当您需要(例如,为了添加巨型帧)。

其次,您需要绑定VSAN到VLAN :

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

这告诉N5k VLAN 500是FCoE VLAN,并且进来的所有流量应该交换到VSAN 500。

这时,您的N5k为FCoE配置并且为UCS连接准备。



Document ID: 116188