思科接口和模块 : Cisco Unified SIP 代理

如何配置Cisco Unified SIP代理的故障切换

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2016 年 4 月 21 日) | 反馈

简介

本文讨论两个选项使用为了配置冗余(故障切换) Cisco Unified SIP代理的。

贡献用兰迪元吴, Cisco TAC工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • 热备用路由器协议 (HSRP)
  • DNS
  • Cisco Unified SIP代理(尖顶)

组件

本文档中的信息根据尖顶。

本文档中的信息都是基于特定实验室环境中的设备编写的。用于本文的所有设备开始与一清除默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

创建故障抗性默认网关

能力创建故障抗性默认网关是该的关键特性Cisco Unified SIP代理(尖顶)提供。有您能使用达到尖顶的冗余的两个选项。一个是使用域名系统服务器DNS SRV;其他是创建虚拟服务器。热备份路由协议(HSRP)是虚拟服务器可以创建的机制。本文第一部分简要地描述如何实现DNS SRV。其余和多数本文如何描述HSRP ?s功能可以实现为了检测问题在集成业务路由器(ISR)机箱或在service-module尖顶本身。

选项1 — DNS SRV

在此选项,请配置上行元素(元素传送呼叫到尖顶)使用DNS。如果尝试到达cusp1失败, Next条目在DNS SRV和尝试的上行元素查询能使用cusp2。必须适当地配置DNS为了此能工作。

  1. 首先,必须创建两个DNS SRV (服务)记录,一个每个尖顶的。指向cusp1的记录有一更加高优先级。

  2. 其次,必须创建两个DNS A (主机名)记录,以便在DNS SRV记录的目的地可以是解决的。此示例显示什么DNS服务器在其记录应该包含。

116015-configure-failover-cusp-01.png

选项两— HSRP

此图表提供基本体系结构如何配置HSRP的尖顶。左侧是上行SIP元素,并且右侧是下行SIP元素。在这些元素之间是一个虚拟路由器用192.168.20.7的IP地址。两个上行和下行元素导致往虚拟路由器的IP地址的SIP流量。在虚拟路由器里面是两实际路由器:主要的和第二。这两路由器共享此同样虚拟IP地址,并且他们的配置是完全相同和两例外。所以,在本文给的配置是相同的为两路由器。

注意:两个尖顶的HSRP配置单个路由器的未测试。采取此解决方案和为多个尖顶展开它也许是可能的,但是它不此时支持。

116015-configure-failover-cusp-02.png

设置基本连通性

首先,路由器和刀片之间的设置的连接。虽然这在其他文档被覆盖,在本文冗余讨论。在本例中,主路由器有192.168.20.80地址,并且其尖顶有192.168.20.81地址。

interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

附属路由器有192.168.20.90地址,并且其尖顶有192.168.20.81地址。

interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

设置路由器级别故障切换

其次,必须配置路由器级别故障切换。这介入其中一路由器作为主要的和其他的指定作为第二。有一个轻微的区别在两路由器的配置里。

这是主路由器的配置:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 100

这是附属路由器的配置:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 90

两路由器安排他们的备用IP地址设置为虚拟路由器;然而,主路由器比附属一个有一高优先级。那含义,而其他事是相同的,主路由器被认为活动,并且所有SIP流量去通过主路由器然后该路由器的尖顶。附属路由器在待机和只接管,如果主路由器因故断开,例如断电。

跟踪接口

必须也设置HSRP检测尖顶级别失败。如果主路由器模子的尖顶某人的原因,但是路由器是未受影响的,什么发生?SIP流量继续发送到主路由器的尖顶。必须更改路由器的优先级根据在每个路由器查找的尖顶的状态。

方式执行此将设置ICMP回音对从每个路由器的尖顶。在这种情况下,响应发送每两(2)秒,与一一(1)秒超时。更低这些值是,然后越快速路由器能检测尖顶发生故障。然而,如果ICMP回音设置的太低,这可能导致错误肯定。在本例中的最后配置行开始响应并且设置它发生永久。

注意:ICMP回音不能跟踪SIP端口的状态。如果问题在端口级别, HSRP故障切换不可能启动。重申;如果路由器出故障,另一个路由器接管;如果IP服务级别协定的ping (SLA)失败,另一个路由器接管;如果SIP失效,这没有检测。

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now

必须设置对象跟踪该响应的状态。对象编号在这种情况下是100。如果此对象的状态发生故障,必须由20设置接口减少路由器的优先级。这意味着主路由器的尖顶是否去非激活由于某种原因,其优先级从100将下降到80。其优先级比那是然后较少第二,有优先级90。如果待机0优先占用设置,强制附属路由器对主要的接替, SIP流量然后去附属尖顶。

track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
standby 0 track 100 decrement 20
standby 0 preempt

主路由器的HSRP配置

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 100
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

附属路由器的HSRP配置

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 90
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

相关信息



Document ID: 116015