IP : 边界网关协议(BGP)

Allowas在BGP配置示例的功能

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文描述两分支路由器通过ISP和运行边界网关协议(BGP)连接在他们之间的方案。两分支路由器(R1和R2),虽则不同的位置的,共享同一样编号。一旦路由从分组(R1到达在这种情况下)对服务提供商(SP)网络,他们用客户AS将标记。一旦SP通过它到另一分支路由器(R2),默认情况下,路由将丢弃使用同一样编号,如果另一个分组也运行BGP以SP。在此方案中, neighbor allowas-in命令发出为了允许BGP在另一侧注入更新。本文提供帮助您了解Allowas在BGP的功能的一配置示例。

注意: 此功能仅可用于真 eBGP 对等体。您无法对作为不同联盟子 AS 成员的两个对等体使用此功能。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

此部分提交您以信息配置本文描述的功能。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112236-allowas-in-bgp-config-example-1.gif

配置

本文档使用以下配置:

在Router_A的配置
Router_A#interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
 ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/1
 no switchport
 ip address 192.1.12.2 255.255.255.0
!
router eigrp 100
 network 1.1.1.1 0.0.0.0
 network 2.2.2.2 0.0.0.0
 network 3.3.3.3 0.0.0.0
 network 192.1.12.0
 auto-summary
!

在路由器R1的配置
R1#interface Loopback22
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.1.12.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 172.16.12.1 255.255.255.0
!
!
router eigrp 100
 network 192.1.12.0
 no auto-summary
!
router bgp 121
 no synchronization
 bgp router-id 22.22.22.22
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255 

!--- This is the advertising loopback address.

 redistribute eigrp 100 

!--- This shows the redistributing internal routes in BGP.

 neighbor 172.16.12.2 remote-as 500 

!--- This shows the EBGP connection with ISP.

 neighbor 172.16.12.2 ebgp-multihop 5
 no auto-summary
!

此示例显示EIGRP运行在Router_A和R1之间:

r1#show ip eigrp neighbors
IP-EIGRP neighbors for process 100
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.1.12.2              Fa0/0             14 01:17:12  828  4968  0  7

此示例显示路由器R1如何学习从Router_A的路由通过EIGRP :

r1#show ip route eigrp 100
D    1.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    2.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0
D    3.0.0.0/8 [90/156160] via 192.1.12.2, 00:02:24, FastEthernet0/0

此示例显示路由器R1如何建立与运行BGP AS500的ISP的BGP连接:

r1#show ip bgp summary
BGP router identifier 22.22.22.22, local AS number 121
BGP table version is 19, main routing table version 19
7 network entries using 924 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 840 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2184 total bytes of memory
BGP activity 40/33 prefixes, 42/35 paths, scan interval 60 secs

Neighbor        V          AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
172.16.12.2     4        500      86      76       19    0    0 00:25:13        2

此示例显示R1如何宣布BGP获取的路由:

r1#show ip bgp
BGP table version is 19, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          192.1.12.2          156160         32768 ? 
*> 2.0.0.0          192.1.12.2          156160         32768 ?
*> 3.0.0.0          192.1.12.2          156160         32768 ?
*> 10.10.12.0/24    172.16.12.2              0             0 500 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
r> 172.16.12.0/24   172.16.12.2              0             0 500 i
*> 192.1.12.0       0.0.0.0                  0         32768 ?
r1#ping 10.10.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.12.2, timeout is 2 seconds:
!!!!!  
!--- This is the connectivity with Router 2 across the Internet cloud.

在路由器R2的配置
R2#interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Serial1/0
 ip address 10.10.12.1 255.255.255.0

router bgp 121
 no synchronization
 bgp router-id 33.33.33.33
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255 

!--- This is the advertising loopback address.
 
 neighbor 10.10.12.2 remote-as 500 

!--- This is the EBGP connection with ISP.

 neighbor 10.10.12.2 ebgp-multihop 5
no auto-summary

路由器R2不学习从路由器R1的任何路由。

因为BGP设法避免路由环路,这是自然行为。例如,包含重复的自治系统编号所有前缀的readvertisement (ASN)默认情况下禁用。

再分布的EIGRP路由(1.0.0.0、2.0.0.0, 3.0.0.0)和从R1的BGP内部路由22.22.22.22没有由R2接收,当他们起源于在互联网间的同样ASN。因为R2在AS路径看到其自己的AS编号(121), R2不上那些路由。

r2#show ip bgp
BGP table version is 20, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i

为了允许包含重复的ASN所有前缀的readvertisement,请使用neighbor allowas-in命令在路由器R2的路由器配置模式。

r2(config-router)#neighbor 10.10.12.2 allowas-in
r2#clear ip bgp*
r2#show ip bgp
BGP table version is 10, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.0.0.0          10.10.12.2                             0 500 121 ?
*> 2.0.0.0          10.10.12.2                             0 500 121 ?
*> 3.0.0.0          10.10.12.2                             0 500 121 ?
r> 10.10.12.0/24    10.10.12.2               0             0 500 i
*> 22.22.22.22/32   10.10.12.2                             0 500 121 i
*  33.33.33.33/32   10.10.12.2                             0 500 121 i
*>                  0.0.0.0                  0         32768 i
*> 172.16.12.0/24   10.10.12.2               0             0 500 i
*> 192.1.12.0       10.10.12.2                             0 500 121 ?

现在请设法从R1 ping到R2 :

r2#ping 22.22.22.22
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms

验证

当前没有可用于此配置的验证过程。

故障排除

错误消息

“Message:%BGP%邻居A.B.C.D recv假路由:AS环路错误消息接收。

此通知意味着CE路由器接收的BGP路由有其自己的AS编号在AS路径和认为CE路由器的一条路由器环路。作为应急方案,请配置与的CE路由器allowas在功能如前一个示例所示。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 112236