????????? : Cisco Catalyst 6500 系列多层交换机特性卡

在VRF-Lite配置示例的Catalyst 6500 EIGRP

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

本文描述如何配置在虚拟路由转发(VRF)的EIGRP -在Cisco Catalyst 6500系列交换机的轻。静态路由在交换机配置和通过在交换机之间的EIGRP再分布。

先决条件

要求

Cisco 建议您了解以下主题:

  • EIGRP 的基础知识

  • Catalyst 6500配置的基础知识

使用的组件

本文档中的信息根据Catalyst 6500系列交换机该运行软件版本12.2(33).SXH6。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

使用一个接口, VRF轻允许服务提供商支持两个或多个VPN用重叠IP地址。VRF轻也被叫做多VRF CE或多VRF用户边缘设备。以前, VRF轻仅支持与RIP、OSPF和BGP。但是在最新版本, VRF轻也支持与EIGRP。本文提供一EIGRP的示例在VRF轻静态VRF路由通过对其他交换机的EIGRP再分布的CLI配置的。

配置在Catalyst 6500的VRF-Lite

这些是配置在Catalyst 6500的VRF轻的指南:

  • 有VRF轻的一交换机由多个用户共享,并且所有客户有他们自己的路由表。

  • 由于客户使用不同的VRF表,可以重新使用同样IP地址。被交迭的IP地址允许用不同的VPN。

  • VRF轻让多个用户共享PE和CE之间的同一条物理链路。有多个VLAN的中继端口分离在客户中的数据包。所有客户有他们自己的VLAN。

  • 对于PE路由器,没有在使用VRF轻或使用多个CES之间的区别。

  • 只要他们与那些其他客户,不交迭客户能使用多个VLAN。客户的VLAN被映射对使用识别在交换机存储的适当的路由表的特定路由表ID。

  • VRF轻不影响信息包交换的速率。

CLI 配置

此部分显示CLI配置:

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

排除故障EIGRP

在EIGRP看到的常见问题是本地路由器不设立一EIGRP邻居关系用相邻路由器。

静态路由对EIGRP的不是Redistriubted

  1. 请使用默认度量值静态路由在redistribute static命令

  2. 删除并且添加redistribute static命令在路由器;静态路由10.0.0.0/8显示在EIGRP拓扑下。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 112245