语音和统一通信 : Cisco Unified Border Element

Cisco Unified Border Element高可用性(HA)使用HSRP配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

Cisco Unified Border Element (多维数据集)通过全套设备冗余配置提供高可用性(HA),当实现在思科集成业务路由器生成2路由器(ISR G2)平台。求全套设备冗余的立方利用长可用的基于路由器的Hot Standby Routing Protocol (HSRP)路由器技术。

HSRP技术通过路由IP数据流提供高网络可用性从主机在网络,无需取决于在所有单个路由器的可用性。HSRP用于路由器的一组选择活动路由器和备用路由器。HSRP监控两个内部和外部接口–,如果任何接口断开,全部的设备假定有得下来,暂挂设备变为激活并且接收活动路由器的责任。

全套设备冗余使用HSRP协议形成一个HSRP活动/等待对路由器。活动/等待对共享同样虚拟IP地址和连续交换状态消息。多维数据集会话信息在活动/等待对是检查点路由器间。如果活动路由器应该去计划的服务中断或计划外的原因,这使备用路由器立即接收所有多维数据集呼叫处理责任。

多维数据集全套设备冗余HA实施支持在SIP-SIP呼叫HSRP切换的媒体保存,但是呼叫信令没有保留。此功能自Cisco IOS�软件版本15.1.2T支持。最新的Cisco IOS软件版本15.2.3T支持呼叫信令保存。

注意: 欲知更多信息,参考Cisco Unified Border Element协议独立功能和设置配置指南, Cisco IOS版本15.2M&T

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 基础知识如何配置和使用Cisco IOS语音

  • 基础知识如何配置和使用多维数据集

  • 基础知识HSRP高可用性如何在一般路由器平台工作

设置的多维数据集ISR G2全套设备冗余基本要求包括:

  • 两个相同的ISR G2s配备有UC技术包许可证(SL-29-UC-K9或SL-39-UC-K9)安装, 1G DRAM和Cisco IOS软件版本15.1.2T或以后

  • 两路由器在同样以太网LAN必须物理的查找。

  • 两路由器的多维数据集配置是相同的,并且必须从一个路由器手工复制到其他。

  • 一个路由器被选定HSRP活动路由器,第二是待机。有轻微的区别在主备路由器之间的HSRP配置里。

  • SIP-SIP呼叫流

使用的组件

本文档中的信息根据最低软件版本多维数据集8.5 (Cisco IOS版本15.1.2T),实现在Cisco 2900或3900系列集成服务路由器生成2 (ISR G2)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

全套设备冗余要求两相同的ISR-G2平台:作为激活配置的一,其他作为待机。HSRP在物理接口配置建立HSRP组。

如果有心跳线故障,当活动路由器断开时,第二个备用路由器接收第一个路由器的IP路由地址并且继续转发以前路由到第一个路由器的同样RTP数据包。

建立的呼叫RTP数据流是检查点在主备路由器之间通过HSRP协议。所以建立的呼叫媒介流在从激活的HSRP故障切换保留到备用路由器。呼叫在一种瞬时状态(没有建立的呼叫或者是在被修改与转移或暂挂功能过程中)在故障切换时被断开。并且,任何呼叫使用DSP服务例如转码没有保留。

配置

本部分提供有关如何配置本文档所述功能的信息。

多维数据集HSRP配置遵从步骤一特定定货,包括:

  1. Enable (event)多维数据集和多维数据集冗余

  2. Enable (event) HSRP

  3. 配置HSRP通信传输

  4. 配置在接口的HSRP

  5. 配置HSRP计时器

  6. 配置梅迪亚不活动计时器

  7. 配置SIP绑定对HSRP地址

  8. 重新加载路由器

  9. 指向附加的软交换多维数据集HSRP虚拟地址

在步骤1-5完成后,请重新加载两路由器。只有当HSRP在路由器时,第一次配置重新加载要求。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

此图表显示一个活动/等待对的拓扑在Cisco Unified Communications Manager (CUCM)和服务提供商(SP) SIP中继之间的一SIP中继部署的ISR G2路由器用于PSTN访问。

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-01.gif

步骤 1:Enable (event)多维数据集和多维数据集冗余

在两路由器的Enable (event)多维数据集:

voice service voip 
  mode border-element
  allow-connections sip to sip

启用多维数据集冗余并且呼叫在两路由器的checkpointing :

voice service voip 
  redundancy

步骤 2:Enable (event) HSRP

Enable (event)在两路由器的路由器冗余机制, where:

  • 方案–冗余状态跟踪的方案

  • 待机– enable (event)暂挂(HSRP)状态跟踪的方案

  • SB – HSRP备用组组名

redundancy inter-device
  scheme standby SB

步骤 3:配置HSRP通信传输

配置HSRP相互设备通信传输如下:

活动配置:

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13

备用配置:

ipc zone default
  association 1
   no shutdown
   protocol sctp
     local-port 5000
       local-ip 10.10.24.13
     remote-port 5000
       remote-ip 10.10.24.14

注意: 从配置远程SCTP参数的“本地ScTP”提示符的退出如下:

XFR-2(config)#ipc zone default
XFR-2(config-ipczone)#association 1
XFR-2(config-ipczone-assoc)#protocol sctp 
XFR-2(config-ipc-protocol-sctp)#no sh
XFR-2(config-ipczone-assoc)#protocol sctp
XFR-2(config-ipc-protocol-sctp)#local-port 5000
XFR-2(config-ipc-local-sctp)#local-ip 10.10.24.13
XFR-2(config-ipc-local-sctp)#exit
XFR-2(config-ipc-protocol-sctp)#remote-port 5000
XFR-2(config-ipc-remote-sctp)#remote-ip 10.10.24.14
XFR-2(config-ipc-remote-sctp)#end

这些是用于此配置的字段的说明:

  • ipc区域默认–配置相互设备通信协议(IPC)并且输入IPC区域配置模式。请使用此命令启动活动和暂挂设备之间的通信链路。

  • 关联1 –配置在两个设备之间的一个关联并且输入IPC关联配置模式。在此下,请配置关联的详细信息例如传输协议、本地端口、本地IP地址、远程端口和远程IP地址。从1的有效关联ID范围到255。没有默认关联ID。

  • 未关闭–重新启动一个已禁用关联和其相关的传输协议。对于对传输协议参数的所有更改,此关联必须被关闭。

  • 协议sctp –配置流控制传输协议(SCTP)作为此关联的传输协议并且启动SCTP协议配置模式。

  • local-port port_num –定义了本地SCTP端口号使用通信与冗余对等体。

  • 本地IP ip_addr –定义了本地路由器的IP地址使用通信与冗余对等体。本地IP地址必须匹配在冗余路由器的远程IP地址。

  • 远程端口port_num –定义了远程SCTP端口号使用通信与冗余对等体。

  • 远程IP ip_addr –定义了对等`路由器的远程IP地址用于用本地设备通信。所有远程IP地址必须指向同一个设备。

注意: 必须设置local-port和远程端口到5000在主备路由器。

步骤 4:配置在接口的HSRP

配置HSRP相互设备通信传输如下:

活动配置

interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

备用配置

interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt		  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3

这是用于此配置的字段的说明:

  • 0/6 –定义了备用组组编号。

  • Keepalive –使HSRP的Keepalive能监控up/down事件。

  • 暂挂延迟–延迟HSRP初始化,直到物理接口是UP。

  • 待机x ip –定义了虚拟IPv4 IP地址共享在活动和暂挂设备之间。此命令启用在接口的HSRP。

  • 待机x优先占用–在热备件组中允许路由器变为活动路由器,当优先级高于其他HSRP配置的路由器时。如果不在配置里使用standby preempt命令路由器,该路由器不变为活动路由器,即使优先级高于其他路由器。

  • 暂挂x优先级–定义了用于选择活动路由器的热备件优先级。它范围自1到255 1表示最低优先级和255最高优先级的地方。

    注意: 在备用优先级是相同的处,有高IP地址的设备呈现活动路由器的角色。

  • 待机x名称–定义了匹配在步骤定义的方案2备用组的名称(“SB ")。对于多个HSRP组,名称只使用作为一暂挂方案的同一待机在配置里允许。

  • 待机6跟踪1减少量10 –定义了优先级跟踪。关于接口跟踪的更多信息,请点击此处。

  • bfd间隔500 min_rx 500 multiplier 3 –定义了双向转发检测。

要避免竞争状态,当路由器启动时,并且接口出来设立联系方式(“Hello ")在主备路由器之间,也推荐配置以下:

interface GigabitEthernet0/0
  standby delay minimum 30 reload 60

关于此命令的更多信息,请点击此处。

步骤 5:配置HSRP计时器

有两个重要HSRP计时器:

  • Hello计时器:在连续的HSRP hello消息之间的间隔从一个给的路由器。此计时器可以以秒钟或毫秒配置在HSRP接口下。默认值是3秒。

  • 保持计时器:接收Hello信息和假定发送路由器发生故障之间的间歇。这次可以以秒钟或毫秒配置在HSRP接口下。默认值是8秒。

步骤4的配置中, HSRP hello和暂挂计时器设置为他们的默认值。所以,他们没在配置里明确地出现。Hello/暂挂计时器的推荐值是默认值。

注意: 如果应该使用非默认值,您必须配置每个路由器使用同样Hello时间和保持计时器值。

使用以下CLI, Hello计时器和保持计时器可以配置在HSRP接口下:

Router(config-if)#standby 0 timers ?
  <1-254>  Hello interval in seconds
  msec     Specify hello interval in milliseconds

Router (config-if)#standby 0 timers 2 ?
  <3-255>  Hold time in seconds
  msec     Specify hold interval in milliseconds
Router(config-if)#standby 0 timers 2 msec 40

在先前配置中, Hello计时器设置为2秒和保持计时器到40毫秒。

注意: 您能降低计时器设置加速故障切换或抢占。然而,避免增加的CPU请使用,并且多余的备用状态飘荡,推荐不设置Hello计时器在少于1秒和保持计时器在少于4秒。

步骤 6:配置梅迪亚不活动计时器

如果实时协议(RTP)数据包没有在可配置时间段,接收梅迪亚不活动计时器使活动/等待路由器对监控和断开呼叫。

当呼叫的RTP数据包没有由活动/等待路由器时接收, SIP梅迪亚不活动计时器释放会话。这用于防护装置防御也许已经起因于故障切换的所有挂起会话,在正常呼叫断开没有清楚呼叫情况下。

在两路由器应该配置梅迪亚不活动计时器的同一持续时间。默认值是28秒。此计时器配置如下:

ip rtcp report interval 3000
gateway
  media-inactivity-criteria all
  timer receive-rtp 86400
  timer receive-rtcp 5

步骤 7:配置SIP绑定对HSRP地址

配置多维数据集SIP消息传送使用HSRP虚拟地址在SIP消息传送。

dial-peer voice 100 voip
  description to-SIP
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1

一旦HSRP配置在物理接口下,并且bind命令发出,对物理IP地址的呼叫将发生故障。这是因为侦听socket的SIP当前一定对虚拟IP地址,但是信令数据包使用物理IP地址,并且不可能被处理。

步骤 8:重新加载路由器

一旦所有上述配置完成,冗余显示输出如下:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
  Pending Scheme: Standby (Will not take effect until next reload)
      Pending Groupname: b2bha
  Scheme: <NOT CONFIGURED>
  Peer present: UNKNOWN
  Security: Not configured

当重新加载路由器后HSRP配置启用如下:

活动路由器

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
  Scheme: Standby
      Groupname: b2bha Group State: Active
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

备用路由器

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
  Scheme: Standby
      Groupname: b2bha Group State: Standby
  Peer present: RF_INTERDEV_PEER_COMM
  Security: Not configured

步骤 9:点附加的软交换对多维数据集HSRP虚拟地址

CUCM、IP-PBX, SIP代理或路由呼叫求立方的SP SBC或SP软交换在他们的SIP消息传送必须使用HSRP虚拟地址。对多维数据集物理IP地址的SIP消息没有处理与HSRP配置。

双连接的多维数据集HSRP冗余的全双工配置示例

这是活动和暂挂多维数据集路由器的完整配置示例。在这些配置中, HSRP hello和暂挂计时器在CLI输出中使用他们的默认值各自3和8秒和没有明确地显示。

活动路由器配置

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.14
      remote-port 5000
        remote-ip 10.10.24.13
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.14 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
   standby 0 preempt
  standby 0 priority 50
  standby 0 track 2 decrement 10 
  standby 0 name SB
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.14 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

备用路由器配置

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
        local-ip 10.10.24.13
      remote-port 5000
        remote-ip 10.10.24.14
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
!
redundancy inter-device
  scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 10.10.25.13 255.255.255.0
  duplex auto
  keepalive
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 10.10.25.1
  standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
		standby 0 track 2 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
interface GigabitEthernet0/1
  ip address 10.10.24.13 255.255.255.0
  duplex auto
  speed auto
  media-type rj45
  standby delay minimum 30 reload 60
  standby version 2
  standby 6 ip 10.10.24.1
  standby 6 priority 50
		standby 6 preempt
  standby 6 track 1 decrement 10
     bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000
!
track 1 interface GigabitEthernet0/0 line-protocol 
!
track 2 interface GigabitEthernet0/1 line-protocol  
!
dial-peer voice 100 voip
  description to-SIP
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
  voice-class sip bind control source-interface GigabitEthernet0/0
  voice-class sip bind media source-interface GigabitEthernet0/0  
!
dial-peer voice 200 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
  voice-class sip bind control source-interface GigabitEthernet0/1
  voice-class sip bind media source-interface GigabitEthernet0/1
!
gateway 
  media-inactivity-criteria all
  timer receive-rtcp 5
  timer receive-rtp 1200

单一附属的多维数据集HSRP冗余的全双工配置示例

当一个双连接的多维数据集是多数常见配置,特别是SP SIP中继连接的时,配置多维数据集与一单一附属的多维数据集部署的HSRP全套设备冗余如给在此部分也是可能的。

活动路由器配置

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.8
     remote-port 5000
       remote-ip 1.2.175.12
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.8 255.255.0.0
  duplex auto
  speed auto
  keepalive
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
 standby 0 preempt
  standby 0 priority 50
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

备用路由器配置

ipc zone default
  association 1
    no shutdown
    protocol sctp
      local-port 5000
       local-ip 1.2.175.12
     remote-port 5000
       remote-ip 1.2.175.8
!
voice service voip
  mode border-element
  allow-connections sip to sip
  redundancy
  sip
    bind control source-interface GigabitEthernet0/0
    bind media source-interface GigabitEthernet0/0
!
redundancy inter-device
 scheme standby SB
!
redundancy
!
interface GigabitEthernet0/0
  ip address 1.2.175.12 255.255.0.0
  duplex auto
  speed auto
  standby delay minimum 30 reload 60
  standby version 2
  standby 0 ip 1.2.175.100
  standby 0 priority 50
		standby 0 preempt
  standby 0 name SB
  standby 0 track 1 decrement 10
  bfd interval 500 min_rx 500 multiplier 3
!
ip rtcp report interval 3000 
!
dial-peer voice 5 voip
  description to-SIP-application
  destination-pattern 9T
  session protocol sipv2
  session target ipv4:x.x.x.x
!
dial-peer voice 9 voip
  description to-CUCM
  destination-pattern 555....
  session protocol sipv2
  session target ipv4:y.y.y.y
!
gateway 
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200

删除HA配置

完成这些步骤为了从多维数据集路由器删除一以前被输入的HSRP配置:

  1. 删除应用级冗余配置。

    Router(config)#voice service voip 
    Router(config-voice service voip)#no redundancy
  2. 删除暂挂方案配置在相互设备配置模式下。

    Router(config)#redundancy inter-device 
    Router(config-red-interdevice)#no scheme standby b2bha
    % Redundancy interdevice scheme change will not take effect until 
    configuration is saved and device reloaded
  3. 保存对内存的配置更改并且重新加载路由器。

    Router(config)#write
    Router#reload
  4. 在重新加载,发出此命令检查后HSRP禁用:

    Router#show redundancy inter-device
    Redundancy inter-device state: RF_INTERDEV_STATE_INIT
      Scheme: <NOT CONFIGURED>
      Peer present: UNKNOWN
      Security: Not configured
    
  5. 禁用在两个设备之间的关联并且删除SCTP配置。

    Router(config)#ipc zone default
    Router(config-ipczone)#association 1
    Router(config-ipczone-assoc)#shutdown
    Router(config-ipczone-assoc)#no protocol sctp
    Router(config-ipczone-assoc)#no association 1
    Router(config-ipczone)#exit
    Router(config)#no ipc zone default
  6. 通过使用HSRP命令的no表,从接口删除HSRP配置。

    Router(config)#interface gigabitEthernet 0/0
    Router(config-if)#no standby 0 name
    Router(config-if)#no standby 0 priority 
    Router(config-if)#no standby 0 ip
  7. 保存配置更改。

    Router(config)#write

以使用笔记为特色

  • 用于一个HSRP对的两路由器应该是相同的(保证级同一的性能和的呼叫量)。

  • 全套设备冗余在SIP-SIP呼叫流的配置支持, SIP传输可以是UDP-UDP或UDP-TCP

  • HSRP虚拟地址支持IPv4只寻址。

  • 建立的呼叫媒体流在故障切换保留,但是信令不是。所以,不可能修改保留的呼叫(保留/恢复、转移、会议等等)。

  • 涉及附加服务例如转码、DTMF相互作用、IVR、SIP-TLS、RSVP、STUN, RTP-SRTP转换或者传真/modem功能的呼叫在故障切换没有保留。

  • 视频流没有保留在切换,虽然音频流可以保留。

  • 每个路由器支持多个HSRP组,但是仅一HSRP组每个物理接口。

  • 不支持与HSRP的环回地址, bind命令的SIP必须使用HSRP虚拟IP地址。

  • 在主备路由器之间的配置同步手工,那里是没有自动化。必须手工做配置更改对两路由器。

验证

请使用下面CLI验证HSRP配置是正确和工作。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

验证冗余状态

验证冗余状态用显示redundancy inter-device并且显示冗余状态命令。redundancy inter-device信息例如redundancy inter-device陈述的这些show命令。

在相互设备配置被执行前,显示输出如下:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Protocol: <NOT CONFIGURED>

XFR-2#show redundancy states
my state = 3  -NEGOTIATION 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Down      Reason: Simplex mode

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

在相互设备配置在路由器重启前后被执行,但是,显示输出如下:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_INIT
Pending Scheme: Standby (Will not take effect until next reload)
Pending Groupname: b2bha
Scheme: <NOT CONFIGURED>
Peer present: UNKNOWN
Security: Not configured

在路由器重启以后,显示输出如下显示“Init”状态:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_PNC_NO_HSRP
Scheme: Standby
Groupname: b2bha Group State: Init
Peer present: UNKNOWN
Security: Not configured

CUBE_XFR#show redundancy states 
my state = 3  -NEGOTIATION 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (this unit is still initializing)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

在切换期间,例如活动路由器发生故障,并且,当备用路由器交换对变为激活时,显示输出如下:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 1  -DISABLED 
Mode = Simplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (system is simplex (no peer unit))
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

在切换,但是,在路由器交换了Hello状态消息前,显示输出以后如下:

CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_HSRP_STDBY_PNC
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_NO_COMM
Security: Not configured

在Hello状态消息交换,显示输出如下后:

XFR-2#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_ACT
Scheme: Standby
Groupname: b2bha Group State: Active
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
  
XFR-2#show redundancy states
my state = 13 -ACTIVE 
peer state = 8  -STANDBY HOT 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = disabled (peer unit not yet in terminal standby state)
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0  
 
CUBE_XFR#show redundancy inter-device
Redundancy inter-device state: RF_INTERDEV_STATE_STDBY
Scheme: Standby
Groupname: b2bha Group State: Standby
Peer present: RF_INTERDEV_PEER_COMM
Security: Not configured
        
CUBE_XFR#show redundancy states
my state = 8  -STANDBY HOT 
peer state = 13 -ACTIVE 
Mode = Duplex
Unit ID = 0

Maintenance Mode = Disabled
Manual Swact = cannot be initiated from this the standby unit
Communications = Up

client count = 14
client_notification_TMR = 30000 milliseconds
RF debug mask = 0x0

验证HSRP状态

验证HSRP状态用show standby brief命令。此命令显示在HSRP的简要输出包括HSRP接口、备用组组编号、优先级、激活和备用IP地址以及虚拟IP地址。show standby命令给全双工,详细信息。

Router1#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active     Standby      Virtual IP
Gi0/0       0    50    Active  local      9.13.25.134  9.13.25.22

Router2#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active       Standby  Virtual IP
Gi0/0       0    50    Standby 9.13.25.133  local    9.13.25.22

在切换以后验证呼叫状态

显示语音高可用性summary命令用于验证:

  • 呼叫checkpointing在备用路由器的在切换以后

  • 在激活的梅迪亚非活动计数,当呼叫结束

  • 检查本地和非本土(例如,保留)呼叫,当呼叫两个类型存在

  • 识别漏的RTP出现, HA, SPI会话

在切换以后显示呼叫checkpointing在备用路由器的

在本例中, 800呼叫从激活是检查点到待机在切换以后。

CUBE_XFR#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 3100
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state STANDBY HOT
Peer current rf state ACTIVE
Voice HA Standby is not available.
System has not experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer NOT READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 0
Total number of checkpoint requested received (Standby): 971
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 800
Media Inactivity event count: 0

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
Checkpoint get buffer failure count: 0

当呼叫结束时,请显示在激活的梅迪亚非活动计数

在本例中,梅迪亚非活动计时器清除800呼叫。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

-----------------------------
First a few entries in HA DB:
-----------------------------

---------------------------------------
First a few entries in Sync Pending DB:
---------------------------------------

----------------------------

======== Voice HA Process INFO ========
Active process current tick: 4213
Active process number of tick events pending: 0
Active process number of tick events processed: 0
voice service voip is  configured to have redundancy

======== Voice HA RF INFO ========
Voice HA RF Client Name: VOIP RF CLIENT
Voice HA RF Client ID: 1345
My current rf state ACTIVE
Peer current rf state STANDBY HOT
Voice HA Active and Standby are in sync.
System has experienced switchover.

======== Voice HA CF INFO ========
Voice HA CF Client Name: CHKPT VOIP SYMPHONY
Voice HA CF Client ID: 252
Voice HA CF Client Status: Peer READY; TP flow ON.

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

Checkpoint CREATE overflow: 0
Checkpoint MODIFY overflow: 0
Checkpoint DELETE overflow: 0
HA DB elememnt pool overrun count: 0
HA DB aux element pool overrun count: 0
HA DB insertion failure count: 0
HA DB deletion failure count: 0
Tick event pool overrun count: 0
Tick event queue overrun count: 0
Checkpoint send failure count: 0
   Checkpoint get buffer failure count: 0

检查本地和非本土(保留的)呼叫,当两个存在

呼叫的数量在系统的显示如下:

  • 呼叫总数= “呼叫编号在HA DB呼叫[+]编号的在HA同步待定DB的”。这是100 + 50 = 150在下面示例输出中。

  • 总数保留(非本土)呼叫= “呼叫编号在HA保留的会话DB的”。这是70在下面示例输出中。

  • 本地呼叫(呼叫建立总数,自从故障切换并且没保留在故障切换)是差异在上一个两个编号中。在本例中,它是150 – 70 = 80。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 100
Number of calls in HA sync pending DB: 50
Number of calls in HA preserved session DB: 70

识别漏的RTP出现, HA, SPI会话

媒体非活动清除的保留的(非本土)呼叫总数是= “托塔尔在待机接收的待机接收CREATE” – “总删除”,当下面的输出显示。比较有“梅迪亚非活动事件计数的”此编号以及下来媒体事件数量显示voip fpi stats命令的输出显示的。

XFR-2#show voice high-availability summary
======== Voice HA DB INFO ========
Number of calls in HA DB: 0
Number of calls in HA sync pending DB: 0
Number of calls in HA preserved session DB: 0

======== Voice HA COUNTERS ========
Total number of checkpoint requests sent (Active): 971
Total number of checkpoint requested received (Standby): 800
Total CREATE received on Standby: 800
Total MODIFY received on Standby: 0
Total DELETE received on Standby: 0
Media Inactivity event count: 800

验证SIP IP地址捆绑

show sip-ua status命令显示SIP绑定的状态。

Router1#show sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): DISABLED
SIP User Agent bind status(media): DISABLED
Snapshot of SIP listen sockets : 2
            Local Address      Listen Port  Secure Listen Port
=============================  ===========  ==================
 10.10.25.14                     5060         5061
 10.10.24.14                     5060         5061
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70

验证当前CPU使用

history命令的show process CPU用于定期验证CPU利用率百分比。

检查CPU利用率,在执行切换前并且继续进行一牵强的故障切换,只有当CPU利用率少于70%时是。show process CPU排序的命令可能重复也发出有CPU利用率的想法一特定的进程的。

验证在切换期间,呼叫处理

检查BYE消息数量用于statistics命令的show sip-ua验证呼叫丢包在切换期间。在切换期间的进行中的呼叫丢弃。仅建立的呼叫保留。

在切换期间, show interface记帐命令用于验证媒体路径确认。

Router#show interfaces g0/0 accounting
GigabitEthernet0/0 
Protocol  Pkts In   Chars In   Pkts Out   Chars Out
Other     1         58         6          360
IP        406       178841     201        16394
ARP       569       34292      0          0
CDP       116       31672      22         7304

检查IP “数据包在”,并且“数据包”抵抗–这些应该增加以一合理的速率。例如,如果使用G.711 20ms封包化和no vad,您应该看到信息包计数器增加大约50每秒钟。

强制测试的手工的故障切换

全套设备冗余使用HSRP支持含义呼叫的一个梅迪亚有状态的切换媒体(RTP)呼叫没有保留,但是没有信令。所以,仅呼叫在活动状态(“sendrecv”连接模式的媒体路径)保留,而呼叫在瞬时状态(非活动状态,媒体路径不“sendrecv”连接模式的)在切换期间,没有保留。

发生在有一个不变混合物呼叫在临时的真实的环境的切换(呼叫建立或被修改)和已建状态,那里永远将是在故障切换期间丢弃的一定数量的呼叫。预计的呼叫断线整体数量可以预计:(0.3 + HSRP保持计时器) * CPS.

完成下面步骤强加一个手工的切换检查配置和操作正确。

要保证平稳的强制切换,请执行以下:

  • 监控在活动/等待对的CPU利用率%。激活将有更加高的CPU利用率,积极地处理呼叫,而待机将显示0 CPU利用率,因为它是空闲,直到切换发生。

  • 当活动路由器的CPU利用率是不大于70%时,请保证一个手工的切换执行。所有切换导致在CPU利用率的一尖峰。

  • 请使用显示voip RTP连接并且显示语音高可用性概略的命令确保现有呼叫在活动/等待路由器对间同步。

HSRP切换以前介入活动路由器重新载入,而备用路由器以前接管并且变为处理新建的呼叫和维护媒介流的新的活动路由器保留的呼叫的,直到他们完成。新的活动路由器将保持作为活动路由器,直到另一个切换发生。

手工的(牵强的)切换可以在任何一个这些方式中达到:

  • 由CLI “冗余交换行为强制”启动它在活动路由器。

  • 活动路由器的重新加载

  • 活动路由器的硬重新启动

  • 拔出HSRP接口或电源电缆活动路由器。

  • 关闭活动路由器的HSRP接口。

  • 在活动/等待路由器的HSRP接口的所有参数的上一个变化没有关闭关联的在IPC模式下导致路由器重启。所以,必须关闭接口,在所有变动做前,除非使用此作为触发强加切换。

show voip rtp connections命令在切换以后表示活动连接数量在两个主备路由器的。

因为信令信息不检查点, show call active voice brief命令不在切换以后显示在备用路由器的任何输出。

执行和验证单个切换的步骤

完成这些步骤:

  1. 根据在本文的配置部分配置HSRP全套设备冗余。

  2. 重新加载并且保留两路由器在rommon。

  3. 启动一个路由器。在它是UP后,请发出显示冗余状态命令并且确保它显示我的状态一样活动和对等体状态象禁用。这能需要一会儿以后启动。

    XFR-2#show redundancy states
    my state = 13 -ACTIVE 
    peer state = 1  -DISABLED
  4. 启动第二个路由器。在它是UP后,请发出显示冗余状态命令确保它显示我的状态一样待机热和对等体状态象激活。

    CUBE_XFR#show redundancy states
    my state = 8  -STANDBY HOT 
    peer state = 13 -ACTIVE
  5. 开始在系统间的一个或更多呼叫。发出显示语音高可用性摘要并且显示voip RTP连接on命令两个主备路由器确保呼叫上和检查点。

  6. 通过重新加载活动路由器测试切换。如果使用一个电话做呼叫,您能听电话确保路径保留的媒体。如果使用测试设备,您能使用数据包显示确定呼叫的媒体是否流:

    Router#show interfaces g0/0 accounting
    GigabitEthernet0/0 
    Protocol  Pkts In   Chars In   Pkts Out   Chars Out
    Other     1         58         6          360
    IP        406       178841     201        16394
    ARP       569       34292      0          0
    CDP       116       31672      22         7304
  7. 测试介质非活动:终止呼叫。重复表示voip RTP连接。在梅迪亚非活动计时器逾期以后,不应该有没有其他活动RTP连接。您能通过显示语音也检查此高可用性summary命令和寻找:

    Router#show voice high-availability summary | include media
    Media Inactivity event count: 1

    梅迪亚非活动事件计数应该显示1。

验证单个呼叫的屏幕画面保留在故障切换

在故障切换前的显示:

  • 活动路由器(#01)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-02.gif

  • 备用路由器(#02)

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-03.gif

重新加载活动路由器(#01)强制故障切换:

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-04.gif

备用路由器(#02)接管作为新建的激活,呼叫保留(待机=新建的激活) :

http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-05.gif

以前激活的路由器(#01)重新加载作为新的备用路由器和呼叫在新的待机保留。

  • 新的暂挂(#01)路由器:

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-06.gif

  • 新的活动(#02)路由器:

    http://www.cisco.com/c/dam/en/us/support/docs/voice-unified-communications/unified-border-element/112095-cube-hsrp-config-07.gif

故障排除

本部分提供的信息可用于对配置进行故障排除。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

这些显示,并且调试指令在全套设备冗余期间故障排除是有用的:

show redundancy state
show redundancy inter-device
show standby brief
show standby internal
show sip-ua status
show sip-ua statistics
show voice high-availability summary
show voip rtp connection | include connection
show arp
debug voip ccapi all
debug voip ccapi error
debug voip rtp session
debug voip rtcp session
debug voip rtp error
debug voip rtcp error
debug voice high-availability all
debug voice high-availability error
debug ccsip info
debug ccsip messages
debug ccsip media
debug ccsip error
debug standby terse

注意: 请勿打开在运载大容积激活的呼叫流量的系统的很大数量的调试。

注意: 在每个切换,在路由器重启以后,在新的备用路由器必须重新启用调试。

每个路由器在HSRP组中参与协议通过实现一台简单状态机。所有路由器在初始状态开始。

  1. 初始:这是开始的状态并且表明HSRP不运行。此状态通过配置更改进入或,当接口首先出来。

  2. 学习:路由器未确定虚拟IP地址和不看到了一个认证的Hello消息从活动路由器。在此状态下路由器仍然等待收到活动路由器的来信。

  3. 侦听:路由器认识虚拟IP地址,但是两者都不能起作用的或备用的路由器。它侦听来自那些路由器的 hello 消息。

  4. 发言:路由器传送定期Hello消息和积极参与激活和备用路由器的选择。除非有虚拟IP地址,路由器不能输入发言状态。

  5. 待机:该路由器适合作为下一个活动路由器的候选者,并定期发送 hello 消息。除了临时状态,在组中必须有至多一个路由器在备用状态。

  6. 主动:路由器当前转发被发送对组的虚拟MAC IP地址的数据包。该路由器定期发送 hello 消息。除临时状态以外,在组中必须有至多一个路由器在活动状态。

故障排除提示:为什么有两活动路由器?

当两路由器不能发现从彼此的HSRP Hello这发生。

  • 检查每个路由器是否能ping其他的IP接口地址。否则,然后路由器之间的通信发生故障。

  • 请使用debug standby命令发现路由器是否是发送并且/或者接收HSRP hello数据包。如果对等体发送Hello,但是他们然后没有接收检查show interfaceshow controller命令发现接口是否侦听对HSRP组播地址。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 112095