交换机 : Cisco Nexus 7000 系列交换机

连结7000系列交换机RSPAN配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文描述如何配置监控以太网端口之间的流量两不同连结7000系列交换机的连结7000系列交换机的一远程交换端口分析程序(RSPAN)会话。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 具有 Nexus 7000 系列交换机的配置基础知识

  • 有基础知识远程交换端口分析程序(RSPAN)

使用的组件

本文档中的信息根据连结7000系列NX-OS设备。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

您能使用交换端口分析器(SPAN)为了分析穿过交换机端口或VLAN,发送流量的复制到目的地端口网络分析器连接到交换机的网络流量。

为了延长SPAN, RSPAN启用多个交换机的远程监控在间您的网络的。连结7000系列交换机在什么被限制能执行与RSPAN。RSPAN VLAN不可能使用作为SPAN目的地。所以,连结7000交换机能只使用RSPAN作为传输VLAN或一个源VLAN和下拉菜单数据从RSPAN VLAN。您不能放置什么到从连结7000交换机的RSPAN VLAN。

配置

此配置示例使用两不同连结7000系列交换机的源端口和网络分析器连接一连结7000交换机的一个目的地端口。独立的Ethernet1/1链路设置在两个设备之间:一条链路作为间距目的地和其他连接作为对RSPAN VLAN的访问。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113438-rspan-nexus-7000-01.jpg

此示例在此表里使用列出的端口:

设备 源端口 目的端口
连结1 以太网2/15和2/16 Ethernet1/1
连结2 Ethernet1/1, 2/26到2/28 以太网2/37到2/40

从连结1交换机,从来源的SPAN流量运载到目的地端口并且复制在RSPAN VLAN上。流量在对连结2交换机的链路然后转发在Ethernet1/1接口。其次, RSPAN VLAN流量发送到设备,例如SwitchProbe设备或其他远程监控(RMON)探测器或者安全设备,能收到和分析数据包的目的地端口。

配置

本文档使用以下配置:

连结1
Nexus1#configure terminal


!--- Configure the interface VLAN 15 as RSPAN VLAN.

Nexus1(config)#vlan 15 
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit



!--- Configure the switchport interface as a SPAN destination.

Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit



!--- Configure the SPAN session.

Nexus1(config)#monitor session 1


!---Configure the source port.

Nexus1(config-monitor)#source interface ethernet 2/15-16


!--- Configure the destination port.

Nexus1(config-monitor)#destination interface ethernet 1/1


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit

连结2
Nexus2#configure terminal


!--- Configuration of interface VLAN 15 as RSPAN VLAN.

Nexus2(config)#vlan 15 
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit


!--- Configure the switchport interface to access in RSPAN VLAN.

Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit



!--- Configure the switchport interfaces as a SPAN destination.

Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit



!--- Configure the SPAN session.

Nexus2(config)#monitor session 1


!--- Configure the source port.

Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15


!--- Configure the destination port.

Nexus2(config-monitor)#destination interface ethernet 2/37-40


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

这是某些SPAN和RSPAN验证命令:

连结1 :

  • 请使用show monitor命令为了显示RSPAN会话的状况。

    Nexus1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • 请使用show monitor session [session session_number]命令为了显示ERSPAN会话配置。

    Nexus1# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/15       Eth1/16
        tx            : Eth1/15       Eth1/16
        both          : Eth1/15       Eth1/16
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
    destination ports : Eth1/1
    
    Legend: f = forwarding enabled, l = learning enabled
  • 请使用all命令的show monitor session为了显示在设备的所有ERSPAN会话配置。

连结2 :

  • 请使用show monitor命令为了显示ERSPAN会话的状况。

    Nexus2# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • 请使用show monitor session [session session_number]命令为了显示ERSPAN会话配置。

    Nexus2# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/21       Eth1/22       Eth1/23
        tx            : Eth1/21       Eth1/22       Eth1/23
        both          : Eth1/21       Eth1/22       Eth1/23
    source VLANs      :
        rx            : 15
        tx            : 15
        both          : 15
    filter VLANs      : filter not specified
    destination ports : Eth1/27       Eth1/28       Eth1/29       Eth1/30
    
    Legend: f = forwarding enabled, l = learning enabled

相关信息


Document ID: 113438