无线/移动 : "无线, LAN (WLAN)"

ISR无线配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述如何说出思科传统和下一代集成服务路由器(ISR)之间的差别并且提供关于如何的信息配置他们。

贡献用Surendra BG, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

有不同种类的Cisco ISR,并且仅一些他们集成与路由器的Cisco IOS。例如,与传统851W、857W、871W和877W ISR,您必须通过Telnet/安全壳SSH访问路由器,或者请使用Security Device Manager (SDM)为了访问无线配置。比较起来,某下一代ISR,例如861W, 881W, 891W, 1941W, 819W,来用无线接入点(AP)已经集成,并且可以分开访问与AP网桥虚拟接口(BVI)接口(与GUI或Telnet/SSH)。

识别传统和下一代ISR

为了识别ISR,请输入show ip interface brief命令在路由器。

如果接口WLAN-AP 0接口WLAN Gig 0是存在接口列表,则意味着它是下一代路由器并且有集成无线AP在路由器里面。您能通过CLI访问此与Telnet/SSH或从GUI。

注意:如果为861W、881W、891W或者1941W看不到接口在接口列表的WLAN-AP 0,则意味着路由器不支持无线。

对于传统路由器,这是什么出现,当您输入show ip int brief命令

如显示,为传统路由器,您请参阅仅无线接口直接地在IOS。 

配置

有用于的不同的说法为了配置ISR。为了配置传统路由器, IOS技术支持无线,您必须通过每个VLAN的BVI接口配置路由器。并且,您必须通过BVI桥接流量用无线接口和VLAN接口网桥。如果使用多个服务设备识别器(Ssid),则必须映射每SSID到每个VLAN,并且必须映射每个VLAN对一个唯一网桥组(BG)通过一个分开的BVI接口。

另一方面,当您配置下一代ISR时,然后配置是较少复杂。您必须建立路由器和AP之间的连接,并且配置AP正所有其他独立AP。将有单个BVI接口,与多个子接口,帮助传达在多个SSID和VLAN之间。

下一代ISR可以与Cisco Unified无线管理器(CUWM)体系结构同步。AP模块在路由器里面可以转换到轻量级接入点协议(无线接入点(CAPWAP)模式LWAPP) /Control和供应,注册到无线局域网控制器(WLC)。此部分描述如何转换从自治和LWAPP的AP模块。

注意:861W不支持LWAPP模式。

传统ISR配置示例

此配置示例使用两个VLAN (中的每一被映射对与WiFi保护的访问的一不同的SSID -预共用的关键的VLAN1和VLAN 2) (WPA-PSK)安全:

en
conf t

vlan 2 mapped to GUESTRITS SSID..Use the vlan
  as per the network configuration


dot11 ssid GUESTRITS
vlan 2
mbssid
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123


dot11 ssid INTERNAL
vlan 1                               >> vlan 1 mapped to INTERNAL SSID
authentication open
mbssid
authentication key-management wpa
wpa-psk ascii 0 cisco123
!

!
bridge irb                          <<< Enables IRB. Allows bridging of
                                        traffic

!

interface Dot11Radio0
no ip address
mbssid
!
encryption vlan 1 mode ciphers tkip  << Encryption            
!
encryption vlan 2 mode ciphers tkip
!
ssid GUESTRITS
!
ssid INTERNAL
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0
  basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1             <<< Corresponding Sub Interface
encapsulation dot1Q 1 native            configuration for Radio
bridge-group 1                      <<< Bridging between VLAN 1 and
bridge-group 1 subscriber-loop-control  Dot11 0.1
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!


interface Dot11Radio0.2               <<< Corresponding Sub Interface
encapsulation dot1Q 2                     configuration for Radio
bridge-group 2                        <<< Bridging between VLAN 2 and
bridge-group 2 subscriber-loop-control    Dot11 0/2  
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!


interface Vlan1
no ip address
bridge-group 1                        <<< Bridging between VLAN 1 and
                                          Dot11 0/1

 

interface Vlan2
no ip address
bridge-group 2                        <<< Bridging between VLAN 2 and
!                                         Dot11 0.2


interface BVI1                         << BVI 1 for VLAN 1
ip address 10.0.0.2 255.255.255.0               
!
interface BVI2                         << BVI 2 for VLAN 2
ip address 192.168.1.1 255.255.255.0
!

!
bridge 1 protocol ieee                <<< Mandatory Bridging commands
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

下一代ISR配置示例

完成这些步骤为了配置Next Generation路由器:

  1. 设立路由器和AP之间的连接与是可用的在路由器的反向控制台接口(接口WLAN-AP 0)。请使用IP地址此接口(您能分配IP地址,或者请使用x命令的Ip unnumbered VLAN)为了分配IP。

    这是使用vlan命令的Ip unnumbered的示例:

    en
    conf t
    int wlan-ap 0
    ip unnumbered vlan 1
    no shut

    当您输入显示ip int增殖比命令,这出现:



    这帮助您登陆到AP模块。

  2. 输入session命令服务模块的WLAN AP 0为了登陆到AP。



    按照同一进程用于为了配置独立AP。关于更多的配置示例,请参阅配置示例和TechNotes索引页。

    如果您的部署包括多个VLAN或Ssid,您必须设置WLAN-GIG 0接口作为允许在路由器的需要的VLAN的中继端口。


升级从轻量的ISR AP到自治

当集成AP运行LWAPP镜像,例如AP801-RCVK9W8-MAP801-RCVK9 "W8" -时M (指示LWAPP),或者W7 (指示一自治镜像), config t命令不工作;AP应该使用自治镜像为了运行命令。为了解决此问题,您必须升级从轻量的ISR AP到自治。

输入这些命令:

Router>en
Router#config t
Router(config t)#service-module wlan-ap0 bootimage autonomous

用这些命令,您能更改AP模式。如果希望AP装载和运行一自治镜像,使用自治在前面的命令。如果希望AP装载和启动与LWAPP镜像,则类型统一并且重新加载AP用此命令:

Router(config t)#service-module wlan-ap 0 reload

这设置AP对自治。大多数情况的处理工作。然而,如果遇到问题,您能使用手动程序:

  1. 下载在您的笔记本电脑上的Tftpd32并且安装它。下载AP801系列的最新的IOS镜像:

    1. 导航对Cisco.com。
    2. 在屏幕的顶部附近单击支持选项卡。
    3. 点击 Download Software
    4. 选择无线,然后选择集成路由器和交换机从产品下拉列表。
    5. 选择路由器型号
    6. 选择适当的IOS镜像:12.4(21a)JY (或以上,如期望的一样)。
  2. 登陆到从路由器的AP模块,并且输入这些命令:

    • AP>en
    • AP#debug capwap控制台cli或调试lwapp控制台cli
    • AP#config t (此配置命令当前运作)
    • AP (config t) #int GIG 0或int FA 0
    • AP (设置- int) # IP地址<address> <mask> (请保证您有连接对您的笔记本电脑IP地址,并且他们是两个在相同子网)
    • AP (设置- int) #no关闭
    • AP (设置- int) #end
  3. 输入存档下载命令为了升级AP到自治:

    • AP#archive download-sw /force-reload /overwrite tftp:// <TFTP IP地址(膝上型计算机IP) >/<Autonomous image.tar >
    • AP#archive download-sw /overwrite /force-reload tftp://10.0.0.4/ap801-k9w7-tar.124-21a.JY.tar

    这完成手动配置进程。

    注意:如果AP在自治模式,并且要转换它到LWAPP,使用存档下载命令并且选择LWAPP恢复镜像而不是自治思科互联网网络操作系统(AIO)镜像。

验证 

当前没有可用于此配置的验证过程。

故障排除 

目前没有针对此配置的故障排除信息。 

相关信息


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 116579