交换机 : Cisco Nexus 1000V 系列交换机

连结1000V系列交换机端口信道配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述最佳实践使用,当您部署在思科连结1000V系列交换机时(N1KV)的端口通道。N1KV要求包含超过每台主机一个接口的端口配置文件的端口通道。

贡献用卡洛斯卢佩茨和马修Wronkowski, Cisco TAC工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • N1KV
  • 思科统一计算系统(UCS)
  • 思科连结和Catalyst系列交换机

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • N1KV
  • UCS

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

配置

此部分包含这些配置:

在UCS B系列服务器的N1KV在终端-主机模式

思科UCS使用刀片和上行网络之间的两个多样化的路径。目前,结构Interconnects不支持链接聚合控制协议(LACP) /virtual端口通道(vPC)向南往前端。这意味着必须使用一个静态端口信道从N1KV方面。因为上行交换机不支持多机箱EtherChannel, MAC别住要求。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

在UCS C系列服务器或机架安装服务器的N1KV连接对连结有vPC的5000/7000交换机

在此拓扑方面,每个货架服务器物理的连接到两不同连结交换机-一个电缆到每交换机。因为允许链路的最好的流量分布和不制造混乱的新增内容/减法, LACP是首选的模式。假设,上行连结交换机已经有配置的一条vPC对等体链路。

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

在UCS C系列服务器或机架安装服务器的N1KV连接到交换机,不用vPC

在此拓扑方面,每个货架服务器物理的连接到两不同交换机,但是vPC不是可用的。唯一的支持的配置是MAC别住。此配置与在UCS B系列服务器使用的那是相同的。)不支持静态端口信道(模式,因为上行交换机不支持多机箱EtherChannel技术。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

在UCS C系列服务器或机架安装服务器的N1KV连接对6500个VSS或栈开关

在此拓扑方面,上行交换机作为单个机箱。这允许N1KV连接LACP。

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

在UCS C系列服务器或机架安装服务器的N1KV连接对单个上行交换机用静态端口信道

在此拓扑方面,服务器是单址的对一上行交换机。此拓扑不提供交换机冗余并且不是最佳实践。

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

验证

使用本部分可确认配置能否正常运行。

show run interface po{X} membership
show port-channel summary

故障排除

本部分提供了可用于对配置进行故障排除的信息。

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 116739