无线/移动 : 服务集标识 (SSID)

自治Aironet访问接入点和多个SSID在Cisco IOS配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述如何配置多个服务设备识别器(Ssid)有在Cisco IOS 软件和自治Cisco Aironet接入点的多个VLAN的。

贡献用Surendra BG, Cisco TAC工程师。

先决条件

要求

此配置示例假设您配置DHCP池在Cisco IOS交换机或路由器或者在一个专用的DHCP服务器。

为了完成此配置,思科建议您有Cisco IOS CLI命令基础知识。

使用的组件

  • 运行Cisco IOS和支持多层交换的任何交换机
  • Cisco Aironet 访问点

背景信息

SSID是无线联网设备使用建立并维护无线连接的唯一标识符。在网络或子网的多个访问点能使用同样Ssid。Ssid区分大小写,并且能包含32字母数字字符。请勿包括空间在您的Ssid。

您能配置在您的Cisco Aironet 1200系列接入器的16 Ssid和分配不同的配置设置到每SSID。所有Ssid同时是活跃的;使用任何Ssid,即客户端设备能联合到接入点。

如果希望接入点允许从在他们的配置方面不指定一SSID的客户端设备的关联,您能设置访客SSID。接入点在其信标包括访客SSID。接入点的默认SSID, tsunami,设置对guest模式。然而,保持您的网络安全,您应该禁用在多数接入点的guest模式SSID。

如果您的接入点将是中继器或是作为中继器的一parent的根访问权限访问接入点,您能设置一SSID用于中继模式。您能分配认证用户名和密码到中继模式SSID允许中继器验证到您的网络类似客户端设备。

如果您的网络使用VLAN,您能分配一SSID到VLAN。使用SSID的客户端设备在该VLAN分组。

视频

此视频显示在本文描述的配置:

AP配置

此配置使用VLAN (1, 2和3)与本地作为V :LAN1和映射对3不同的Ssid (一,两和三)在任何Cisco Aironet接入点。

  • SSID一使用WEP加密。
  • SSID两用途WPA-PSK。
  • SSID三用途WPA-2-PSK。
  • 假设AP以太网端口连接到交换机的fa 2/1端口。
  • 广播全部3 Ssid。
  • 如果使用单个SSID,请使用模式命令在SSID下。
  • 如果使用多个SSID,请使用mbssid命令在SSID下和在无线接口下

注意:guest模式改写多个基本SSID (MBSSID)。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

完成这些步骤为了配置AP :

步骤1.配置SSID并且映射它对各自的VLAN。

Enable
Conf t
Dot11 ssid one
Vlan 1
Authentication open
Mbssid Guest-mode
End


Enable
Conf t
Dot11 ssid two
Vlan 2
authentication open
authentication key-management wpa
wpa-psk ascii 7
Mbssid Guest-mode
End


Enable
Conf t
Dot11 ssid three
Vlan 3
authentication key-management wpa version 2
wpa-psk ascii 7
Mbssid Guest-mode
End

步骤2.分配加密到与各自的VLAN的不同的Ssid。

Enable
Int dot11 0
Mbssid
ssid one
ssid two
ssid three

encryption vlan 1 mode wep mandatory
encryption vlan 1 key 1 size 40bit
encryption vlan 2 mode ciphers tkip
encryption vlan 3 mode ciphers aes-ccm

步骤3.配置Dot11 radio0和以太网的子接口。

在AP :

AP# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
AP(config)# interface Dot11Radio0.1
AP(config-subif)# encapsulation dot1Q 1 native
AP(config-subif)# bridge group 1

AP(config-subif)# interface FastEthernet0.1
AP(config-subif)# bridge group 1
AP(config-subif)# encapsulation dot1Q 1 native
AP(config-subif)# end
AP# write memory

AP(config)# interface Dot11Radio0.2
AP(config-subif)# encapsulation dot1Q 2
AP(config-subif)# bridge group 2

AP(config-subif)# interface FastEthernet0.2
AP(config-subif)# bridge group 2
AP(config-subif)# encapsulation dot1Q 2
AP(config-subif)# end
AP# write memory

AP(config)# interface Dot11Radio0.3
AP(config-subif)# encapsulation dot1Q 3
AP(config-subif)# bridge group 3

AP(config-subif)# interface FastEthernet0.3
AP(config-subif)# bridge group 3
AP(config-subif)# encapsulation dot1Q 3
AP(config-subif)# end
AP# write memory

AP(config)# bridge irb
Ap(config)# bridge 1 route ip
Ap(config)# end
Ap# wr

在交换机上:

en
conf t
int fa 2/1
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,2,3
end

步骤4.验证。

  • 在AP,请使用show dot11 associations命令。您必须发现全部3 Ssid。
ap#show dot11 associations

802.11 Client Stations on Dot11Radio0:

SSID [one] :
SSID [two] :
SSID [three] :
  • 从AP ping到交换机VLAN接口。您应该能ping。

管理与管理IP地址的AP

分配IP地址到网桥虚拟接口(BVI) AP :

Enable
Conf t
Int bvi 1
Ip address
No shut
End

验证

请使用显示ip int增殖比on命令AP,并且验证所有接口是正在运行的。


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 116118