网络管理 : 思科设备发现协议 (CDP)

Cisco发现协议行为在路由器和交换机之间的

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈

简介

本文描述思科设备发现协议(CDP)行为在运行Cisco IOS的路由器和交换机之间的。

是独立的媒体和的协议的CDP是思科所有权第2层协议,并且运行在所有Cisco生产的设备。Cisco设备传送CDP通告对组播目的地地址01-00-0c-cc-cc-cc每个连接的网络网络界面。这些组播信息包由通过他们的连接的网络网络界面支持CDP的Cisco交换机和其他网络设备接收。

贡献用Meghana Tandon, Sumanth Srinath和Vishnu Asok, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。本文适用于运行Cisco IOS的所有Cisco路由器和交换机。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

CDP计时器和CDP保持时间

默认情况下, CDP通告发送在支持子网访问协议的接口的每60秒(SNAP)报头,包括以太网,帧中继和ATM。保持时间在表里指定一个条目的寿命。即,如果通告没有从一个设备接收期限超出维持时间,设备信息丢弃(默认180秒)。

为了更改默认CDP计时器(60秒)和Cdp holdtime (180秒),请输入cdp计时器,并且cdp holdtime Cisco IOS配置分别发出命令。更改可以用show cdp命令验证,显示当前设备的CDP设置。

Router#show cdp
Global CDP information:
        Sending CDP packets every 60 seconds
        Sending a holdtime value of 180 seconds
        Sending CDPv2 advertisements is enabled

CDP,默认情况下,在所有接口启用。然而,有选项禁用CDP整体上路由器的或在a每接口上。

拓扑

交换机配置路由器配置
Switch#show run int fa1/0/23

Building configuration...
Current configuration : 267 bytes
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 power inline never 
 spanning-tree portfast
 spanning-tree guard root
end


int vlan 10
ip address 10.111.51.3 255.255.255.224
int vlan 21
ip address 10.111.48.3 255.255.255.128
Router#show run int gi0/1
interface GigabitEthernet0/1
  no ip address
  no ip redirects
  duplex auto
  speed auto
 media-type rj45
end


interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
  shutdown
end

interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
 end

interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

在路由器的接口有dot1q子接口gi0/0.1、gi0/0.10和gi0/0.21分别配置与VLAN1, 10和21。在交换机的接口是所有VLAN允许的中继链路。

Router#show ip int brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  administratively down down
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

交换机显示路由器作为有效CDP邻居如显示此处:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router           Fas 1/0/23        145             R S I  3845      Gig 0/1.10

同一on命令路由器不直接地显示连接的交换机。

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

运行CDP的调试为了帮助确定原因(debug cdp {数据包|邻接|事件})。

注册路由器

此条目在缓存被找到。

CDP-PA: version 2 packet sent out on GigabitEthernet0/1 --->the packet is sent out on gi0/1

注册交换机

CDP-PA: version 2 packet sent out on FastEthernet1/0/23
CDP-EV: No space for insertion of civic location
CDP-EV: No space (1068) for insertion of location information.
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

根据上一个日志,路由器没有收到从交换机的任何CDP数据包在任何连接的接口。与管理性被关闭的dot1q封装的接口。因此,当交换机发送CDP数据包时,数据包由路由器丢弃。

注意:在路由器上,与最低VLAN/dot1q封装的子接口选择作为首选的子接口传送CDP数据包。在交换机上, CDP数据流在VLAN总是更喜欢配置的最低。即VLAN1总是,不可能从VLAN数据库删除。当交换机发送CDP作为标记信息包或未标签的信息包从属在配置的本地VLAN于中继链路时, CDP协议不同运行。

在交换机上, CDP数据流在VLAN总是更喜欢配置的最低。即VLAN1总是,不可能从VLAN数据库删除。

当交换机发送CDP作为标记信息包或未标签的信息包从属在配置的本地VLAN于中继链路时, CDP协议不同运行。

情形 1:交换机发送一标记为的CDP数据包

Switch configuration:
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 end

第 1 种情况:有在路由器配置的VLAN1的子接口Up/Up

interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end

interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end


GL.S.14-3800-8#show ip int brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  up                    up
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

交换机发送在将由路由器接收作为标记信息包的VLAN1的CDP数据包。路由器检查发现其子接口中的任一是否配置与VLAN1 dot1q封装并且是UP。如果此检查是成功的那么CDP数据包由在千兆以太网0/1.1的路由器处理。

路由器将生成在是up/up和已配置的与VLAN1 dot1q封装的最号码少的子接口的一CDP数据包(或最低VLAN)。

在此方案中,路由器发送在FastEthernet1/0/23的交换机接收的gi0/1.1的无标记CDP数据包。

注册交换机

CDP-PA :在FastEthernet1/0/23派出的版本2数据包。此条目在缓存被找到。

CDP-PA: Packet received from Router on interface FastEthernet1/0/23

注册路由器 

CDP-PA :在GigabitEthernet0/1.1派出的版本2数据包。CDP-PA :从在接口GigabitEthernet0/1.1的交换机接收的数据包。此条目在缓存被找到。

CDP-EV: Lookup for ip phone with idb= GigabitEthernet0/1.1
ip= 10.111.51.3 mac= 0021.567e.e219 platform= cisco WS-C3750-24P

输入show cdp neighbor命令在路由器。

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        149             R S I  3845      Gig 0/1.1

输入show cdp neigh命令在路由器。

Router#show cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge>
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,>
                  D - Remote, C - CVTA, M - Two-port Mac Relay>

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID>
Switch          Gig 0/1.1          158             S I   WS-C3750- Fas 1/0/23

第 2 种情况:更改在路由器接口的配置,以便您没有与VLAN1的任何子接口

!

interface GigabitEthernet0/1.1
 end
!

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/0.1       unassigned      YES unset  up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  up                    up
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

分析

交换机发送在fa1/0/23的CDP标记信息包。当路由器收到数据包时,检查发现在路由器的一子接口是否为VLAN1的encapsulation dot1q配置。目前没有配置的子接口。

因而路由器收到在主接口的CDP数据包。路由器收到在主接口的数据包的原因是,因为VLAN1是活跃的。输入确认的显示vlan-switch命令。即使路由器没有为VLAN1配置的任何接口CDP数据包仍然接收。

Router#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------

1    default                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

在这样方案中从路由器的CDP数据包通过gi0/1发送。

注册交换机

CDP-PA: version 2 packet sent out on FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

此条目在缓存被找到。

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

注册路由器

CDP-PA: version 2 packet sent out on GigabitEthernet0/1>
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

此条目在缓存被找到。

CDP-EV: Lookup for ip phone with idb= GigabitEthernet0/1 ip= 10.111.51.3 
mac= 0021.567e.e219 platform= cisco WS-C3750-24P

在交换机上:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        123             R S I  3845      Gig 0/1

在路由器上:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1            160             S I   WS-C3750- Fas 1/0/23

当所有接口配置与封装VLAN如本地时,您看到相似的行为。

方案 2:交换机发送一无标记CDP数据包

Switch configuration:

interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport mode trunk
 end

第 1 种情况: VLAN1配置的接口Up/Up

interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

当交换机发送CDP数据包到路由器时,发送未标签的信息包,本地VLAN使用此通信。因而路由器收到在VLAN1配置的接口的数据包。路由器检查是否安排dot1q封装VLAN1配置,并且接口up/up。如果此检查是成功的,路由器通过该接口发送数据包。

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        5               R S I  3845      Gig 0/1.1

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.1          8               S I   WS-C3750- Fas 1/0/23

注册路由器

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.1
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1.1

条目没有在缓存被找到。

注册交换机

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

条目没有在缓存被找到。

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

第 2 种情况: 在VLAN配置Up/Up的路由器和两者都不的接口接口有指定的一个本地VLAN

interface GigabitEthernet0/1.1
encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
encapsulation dot1Q 10 native
ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
encapsulation dot1Q 21
ip address 10.111.48.1 255.255.255.128
end

分析

当交换机发送CDP数据包到路由器时,发送未标签的信息包,本地VLAN使用通信。因为有在本身,配置的VLAN1路由器收到数据包经过gi0/1.1。路由器证实是否安排VLAN1配置或其他本地VLAN配置。在当前案件中,接口gi0/1.10配置与本地关键字。因而路由器通过gi0/1.10子接口发送数据包。

此输出在此方案被看到:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        5               R S I  3845      Gig 0/1.1

在路由器的CDP邻居结果显示此处:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.10         7               S I   WS-C3750- Fas 1/0/23

注册路由器

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.10
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1.1

条目没有在缓存被找到。

注册交换机

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

条目没有在缓存被找到。

CDP-PA :在FastEthernet1/0/23派出的版本2数据包

实例3:其它WRR加权修改 没有VLAN1配置的接口,但是接口没有配置的一个本地关键字

interface GigabitEthernet0/1.1
 end

interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

当交换机发送数据包到路由器时,发送在本地VLAN的未标签的信息包。路由器收到数据包经过gi0/1。 路由器证实是否安排VLAN1配置或其他本地VLAN配置。

这里, gi0/1.10接口为封装配置如本地,因而路由器通过gi0/1.10发送数据包。

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        156             R S I  3845      Gig 0/1

Router#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.10         0               S I   WS-C3750- Fas 1/0/23

注册路由器 

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.10
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

条目没有在缓存被找到。

注册交换机

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

条目没有在缓存被找到。

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

实例4:修改队列极限缓冲区分配 路由器没有Vlan dot1q封装,并且本地VLAN没有指定

interface GigabitEthernet0/1.1

 end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

当交换机发送数据包到路由器时,发送无标记CDP数据包,当通信在本地VLAN。路由器收到数据包经过gi0/1。 路由器证实是否安排VLAN1配置或其他本地VLAN配置。在这里没有同样地接口,因而路由器通过gi0/1发送数据包(在主接口)。

此输出在此方案被看到:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        7               R S I  3845      Gig 0/1

在路由器的输出显示此处:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1           7               S I   WS-C3750- Fas 1/0/23

注册路由器

CDP-PA: version 2 packet sent out on GigabitEthernet0/1
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

条目没有在缓存被找到。

注册交换机

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

条目没有在缓存被找到。

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

摘要

路由器收到一标记为的CDP数据包

子接口配置与VLAN1管理上下降状态/下来。

路由器丢弃CDP数据包。交换机不会列出作为CDP邻居。 

子接口配置与VLAN1 UP/UP。本地VLAN没有指定。

路由器发送并且收到在此子接口的数据包。

路由器没有配置的VLAN1没有本地关键字,并且其中任一子接口是配置的/。

数据包在主接口横越。在两个方向的CDP工作。

路由器收到一无标记CDP数据包

子接口配置与VLAN1管理上下降状态/下来。

路由器丢弃CDP数据包。交换机不会列出作为CDP邻居。

子接口配置与VLAN1 UP/UP。本地VLAN没有指定。

路由器发送并且收到在此子接口的数据包。在两个方向的CDP工作。

路由器没有配置的VLAN1,并且子接口都没有配置与本地关键字。

路由器收到在主接口的CDP数据包,但是在本地关键字配置的子接口发送他们。

路由器没有配置的VLAN1和本地关键字。

CDP数据包在主接口横越。在两个方向的CDP工作。



Document ID: 118736