交换机 : Cisco Nexus 1000V 交换机

连结1000v VXLAN配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述如何配置虚拟可扩展LAN (VXLAN)在思科连结1000V (N1kV)系列交换机。

贡献用约瑟夫Ristaino, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

此部分描述VXLAN功能和如何是可以实现为了寻址在数据中心内的可扩展性限制。

关于VXLAN

因为在帧的VLAN ID字段只是12个位,限制VLAN数量到4,096与保留的一些。VXLAN功能引入24位ID字段,扩展可能性包括16百万不同的LAN分段可能性。这类似于转换从IPv4到IPv6。

对于比较,这是标准帧布局:



这是VXLAN封装的帧布局:



使用VXLAN传输,最初的Layer2 (L2)帧在第3层(L3)数据包被封装。目的地然后DE封装数据包并且发送包含内根据目的地媒体访问控制(MAC)地址的帧。这允许在当前基础设施的被分段的流量并且允许网络反映L2在数据中心间的域。并且,它启用增强例如发怒数据中心vMotions。

使用VXLAN技术是实用的在要求您为客户扩展和提供基础设施的环境。此的好的实例是VMware vCloud导向器,供应商部署他们的客户的资源。这包括从使用VMware网络的服务器、网络资源,或者N1kV供给动力的思科网络的计算机资源。供应商使用VLAN作为传输机制承租人VXLANs。没有VXLAN,承租人给他们自己的VLAN,能迅速扩展至4,096限制。每个承租人当前分配VXLAN,并且能为传输使用基础设施VLAN。这是可扩展和仍然分段。


VXLAN需求

为了VXLAN能工作,必须完成这些需求:

  • 必须增加在传输中的最大转换单元(MTU)大小到50个字节或在虚拟机(VMs)必须减小MTU大小。

  • 在传输的VLAN (以太网报头(14)网关必须配置代理地址解析协议(ARP) + UDP报头(8) + IP报头(20) + VXLAN报头(8) = 50个字节)。

  • 必须配置组播路由(组播模式)。

    注意:这仅是为VXLANs在版本1.5和版本1.5之前同组播模式。版本1.5包与N1kV版本4.2.1.SV2(2.1)。此版本支持传输单播方法。

  • 必须配置互联网组管理协议(IGMP)窥探查询器或独立于协议的组播(PIM)。

  • 必须通过所有防火墙允许用户数据报协议(UDP)端口8472。

    注意:这是使用封装的数据流的端口。

  • 在每台主机必须配置VMkernel接口。

    注意:这些呼叫VXLAN隧道终点(VTEP)。他们封装和解除封装在环境的VXLAN流量。您能使用您使用l3control的同样VMkernel。

VXLAN模式

在VXLAN版本1.5,包在N1kV版本4.2.1.SV2(2.1), VXLAN在组播模式或单播模式能运行。这两个模式描述在此部分。

多播模式

每个VXLAN有已分配组播组IP。当VM加入VXLAN时,虚拟以太网模块(VEM)发送Igmp加入请求给已分配组。广播,组播和泛洪流量发送对所有VTEPs;单播流量发送对目的地VTEP。

单播模式

对于广播,组播和未知单播帧,每个VXLAN发送流量对在同样VXLAN安置VM每个VTEP的目的IP地址。如果超过一个VTEP存在,只有一个VTEPs选择收到泛洪流量,类似于在思科统一计算系统(UCS)的一个指定广播接收方。VEMs然后使用IP地址作为目的地VTEP封装。

使用单播模式,也有MAC分配功能。使用此功能, VSM了解所有从所有的MAC地址VEMs并且映射他们对指定VTEP。充斥和复制,因为VEM总是认识特定目的地VM的,目的地VTEP排除。

注意:这为由同样VSM管理的VEMs只支持。

配置

请使用此部分为了配置在N1kV系列交换机的VXLAN。

启用VXLAN功能

输入这些命令为了启用VXLAN功能:

Nexus1000v# conf t Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# feature segmentation

验证功能启用

输入显示功能|grep分段命令为了验证功能启用:

Nexus1000v(config)# show feature | grep segmentation
network-segmentation 1 enabled
segmentation 1 enabled

配置默认模式

注意:默认模式是仅单播,没有MAC分配。 在本文的此示例配置组播对后单播的模式的模式作为默认和转变。

请勿输入分段模式唯一的命令为了配置默认模式:

Nexus1000v(config)# no segment mode unicast-only

配置VTEP波尔特配置文件

现在您必须配置VTEPs使用的波尔特配置文件。波尔特配置文件配置类似于其他访问波尔特配置文件,当VXLAN功能被添加。一旦vxlan的功能配置, VEM使用指定VMkernel封装和解封装。作为指定接收方选择一部分,它也包括信息。

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# port-profile type vethernet VTEP
Nexus1000v(config-port-prof)# vmware port-group
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access vlan 168
Nexus1000v(config-port-prof)# capability vxlan
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled

创建VTEP VMKernel接口

完成这些步骤为了创建VTEP VMkernel接口:

  1. 创建VMkernel并且移动它向VXLAN启用的波尔特配置文件:





  2. 选择有功能vxlan已配置的VTEP波尔特配置文件:



  3. 分配VTEP在您的外部VLAN的一个IP地址:



  4. 完成向导。

创建网桥域

网桥域定义了分段ID (VXLAN ID)和组播组(IP地址)。

输入这些命令为了创建网桥域:

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# bridge-domain 192.168.1.x
Nexus1000v(config-bd)# segment id 5000
Nexus1000v(config-bd)# group 239.1.1.1

创建VMs的VXLAN波尔特配置文件

为了VMs能使用VXLAN,您必须创建他们的一波尔特配置文件。波尔特配置文件配置是相同的,但是访问网桥域而不是VLAN。

输入这些命令为了创建VMs的VXLAN波尔特配置文件:

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# port-profile type vethernet vxlan-192.168.1.x
Nexus1000v(config-port-prof)# vmware port-group
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access bridge-domain 192.168.1.x
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled

验证网桥域

一旦放置VMs到波尔特配置文件,您必须验证网桥域的设置正确,并且VMs包括。

输入bridge domain命令的显示为了验证网桥域:

Nexus1000v# show bridge-domain 192.168.1.x

Bridge-domain 192.168.1.x (2 ports in all)
Segment ID: 5000 (Manual/Active)
Mode: Multicast (override)
MAC Distribution: DisableGroup IP: 239.1.1.1
State: UP Mac learning: Enabled
Veth18, Veth19

检验连通性

此镜像说明如何验证您的VMs有在内部VXLAN的连接:

对单播模式的交换机

现在您必须换成仅单播模式和验证您仍然有连接。

输入这些命令为了换成单播模式:

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# bridge-domain 192.168.1.x
Nexus1000v(config-bd)# segment mode unicast-only

验证单播网桥域

输入bridge domain命令的显示为了验证单播网桥域:

Nexus1000v# show bridge-domain 192.168.1.x

Bridge-domain 192.168.1.x (2 ports in all)
Segment ID: 5000 (Manual/Active)
Mode: Unicast-only (override)
MAC Distribution: DisableGroup IP: 239.1.1.1
State: UP Mac learning: Enabled
Veth18, Veth19

验证在单播模式的连接

此镜像说明如何验证在单播模式的连接:

配置VXLAN网关

此部分给予VXLAN网关的概述并且描述使用为了部署它的进程。

关于VXLAN网关

VXLAN网关创建为了为VXLAN分段提供方式通信与正常VLAN分段。它允许在VXLANs的VMs与在外部VLAN的物理服务器联络。这与VMware vShield设备是可比较的,允许在内部网络的VMs与在供应商网络的其他机器联络。

在Cisco连结1x10系列设备安装的此网关是一虚拟服务刀片(VSB)。当您安装在连结1x10系列设备时的VXLAN网关,您必须运行设备以灵活的网络类型(类型5)。

注意:VXLAN网关要求在N1kV许可授权的先进,因此您必须保证您有足够的许可证,在您换成先进的版本同svs交换机版本提前的in命令配置模式前。

启用功能

为了启用VXLAN网关,您必须启用在N1kV的功能。输入这些命令为了启用功能:

Nexus1000v(config)# feature vxlan-gateway
Nexus1000v(config)# 2013 Aug 1 18:34:20 Nexus1000v %SEG_BD-2-VXLAN_GATEWAY_ENABLED:
  Feature vxlan-gateway enabled

Nexus1000v(config)# show feature | grep gateway
vxlan-gateway 1 enabled

准备VXLAN网关的VSM

在VSM必须设置VXLAN网关的波尔特配置文件在安装之前。这些配置文件包括一上行链路波尔特配置文件和一vEthernet波尔特配置文件VTEP的,用这些命令配置:

Nexus1000v(config)# feature vxlan-gateway
Nexus1000v(config)# 2013 Aug 1 18:34:20 Nexus1000v %SEG_BD-2-VXLAN_GATEWAY_ENABLED:
  Feature vxlan-gateway enabled


Nexus1000v(config)# show feature | grep gateway
vxlan-gateway 1 enabled

现在您必须配置VXLAN网关VTEP波尔特配置文件,包括功能vxlan功能以及传输IP地址VXLAN网关使用为了传输流量。输入这些命令为了配置它:

Nexus1000v(config)# port-profile vxgw-vtep  <---No vmware port-group cmd;
  Not published to vCenter
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access vlan 168
Nexus1000v(config-port-prof)# capability vxlan
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled
Nexus1000v(config-port-prof)# transport ip address 10.10.168.25 255.255.255.0
  gateway 10.10.168.254

VXLAN网关要求两个物理转接接口的一波尔特配置文件。在Port-Channel中继必须配置这些链路。支持链路汇聚控制协议(LACP)和静态端口通道。

网关采取VXLAN分段并且映射它对802.1Q VLAN。这在服务实例配置。

注意:在网关注册后,您能也配置服务实例。

输入这些命令为了配置Port-Channel中继:

Nexus1000v(config)#port-profile type ethernet vxlan-gw-uplink <---No vmware
  port-group cmd.
Nexus1000v(config-port-prof)# switchport mode trunk
Nexus1000v(config-port-prof)# switchport trunk allowed vlan 119,219,319
Nexus1000v(config-port-prof)# mtu 9000
Nexus1000v(config-port-prof)# channel-group auto mode active
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# description Virtual PP push in opaque data to vxgw
Nexus1000v(config-port-prof)# state enabled
Nexus1000v(config-port-prof)# service instance 168
Nexus1000v(config-port-prof-srv)# encapsulation dot1q 168 bridge-domain 192.168.1.x
Nexus1000v(config-port-prof-srv)#

为了注册有VSM的VXLAN网关,您必须记录下来主要的和附属MAC地址由VSMs。输入显示vms从VSM的内部信息命令:

Nexus1000v# show vms internal info  Global svs connection mode: ipv4
Cached IP address: 10.10.168.2
DVS INFO:
-------------
DVS name: [Nexus1000v]
UUID: [ee 63 3c 50 04 b1 6d d6-58 61 ff ba 56 05 14 fd]
Description: [(null)]
Config version: [91]
Max ports: [8192]
DC name: [jristain]
OPQ data&colon; size [723], data&colon; [data-version 1.0]

switch-domain 27
switch-name Nexus1000v
cp-version 4.2(1)SV2(2.1)
control-vlan 1
system-primary-mac 00:50:56:bc:6a:3d
active-vsm packet mac 00:50:56:bc:2a:5f
active-vsm mgmt mac 00:50:56:bc:57:4e
standby-vsm ctrl mac 0050-56bc-74f1
inband-vlan 1
svs-mode L3
l3control-ipaddr 10.10.168.2

您能当前安装在连结1x10系列设备的VXLAN网关。

安装在1x10设备的VXLAN网关

一旦复制VXLAN网关软件对Bootflash :连结1x10系列设备的储存库目录,您能创建VSB。输入这些命令为了创建它:

1010(config)# virtual-service-blade VXGW
1010(config-vsb-config)# virtual-service-blade-type
  new vxgw.4.2.1.SV2.2.1.iso

输入显示虚拟服务刀片命令为了验证该的接口您创建在VSB :

1010(config-vsb-config)# show virtual-service-blade name VXGW
virtual-service-blade VXGW
Description:
Slot id: 1
Host Name:
Management IP:
VSB Type Name : vx-gw-1.5
Configured vCPU: 3
Operational vCPU: 3
Configured Ramsize: 2048
Operational Ramsize: 2048
Disksize: 3
Heartbeat: 0


Legends: P - Passthrough
--------------------------------------------------------------------
Interface Type MAC VLAN State Uplink-Int
Pri Sec Oper Adm
--------------------------------------------------------------------
VsbEthernet1/1 gw-uplink1 up up
VsbEthernet1/2 management 168 up up
VsbEthernet1/3 gw-uplink2 up up
internal NA NA NA up up
HA Role: Primary
HA Status: NONE
Status: VSB NOT PRESENT
Location: PRIMARY
SW version:
HA Role: Secondary
HA Status: NONE
Status: VSB NOT PRESENT
Location: SECONDARY
SW version:
VSB Info:

检查网络摘要为了查看可用的uplink端口。必须放置到直通模式和别住VXLAN网关接口到连结1x10系列设备上行链路。进入summary命令的show network为了查看网络摘要:

1010(config-vsb-config)# show network summary
Legends: P - Passthrough
------------------------------------------------------------------------------
Port State Uplink-Interface Speed RefCnt MTU Nat-Vlan
Oper Admin Oper Admin Oper Admin
------------------------------------------------------------------------------
Gi1 up up 1000 1 9000
Gi2 up up 1000 1 9000
Gi3 up up 1000 0 9000
Gi4 up up 1000 0 9000
Gi5 up up 1000 0 9000
Gi6 up up 1000 0 9000
control0 up up Gi1 Gi1 1000 9000
mgmt0 up up Gi2 Gi2 1000 9000

VSB建立接口对连结1x10系列设备uplink端口并且设置他们为直通模式的Pin。您必须也配置管理VSB接口的VLAN ID。 

注意:保证您有在上行接口启用的LACP。当您配置这些部分时,上行链路接口执行LACP。

输入VSB建立接口对uplink端口的这些命令为了管脚:

1010(config-vsb-config)# interface gw-uplink1 uplink GigabitEthernet3
1010(config-vsb-config)# interface gw-uplink2 uplink GigabitEthernet4
1010(config-vsb-config)# interface gw-uplink1 mode passthrough
1010(config-vsb-config)# interface gw-uplink2 mode passthrough
1010(config-vsb-config)# interface management uplink GigabitEthernet2
1010(config-vsb-config)# interface management vlan 168

一旦网络uplink端口配置,请启用VSB并且验证部署是成功的。有许多字段您必须输入信息到,当您部署VSB时;以前描述的您必须从VSM添加主要的和暂挂MAC地址。服务模块是VXLAN网关。并且,两个IP地址是需要的为了完成安装。

1010(config-vsb-config)# enable
Enter vsb image: [vxgw.4.2.1.SV2.2.1.iso]
Enter the VSM domain id[1-4095]: 27
Enter Management IP version [V4]: [V4]
Enter Management IP address of service module on primary: 10.10.168.101
Enter Management subnet mask of service module on primary: 255.255.255.0
Enter default gateway IP address of service module on primary: 10.10.168.254
Enter management IP address of service module on secondary: 10.10.168.102
Enter management subnet mask of service module on secondary: 255.255.255.0
Enter default gateway IP address of service module on secondary: 10.10.168.254
Enter HostName: VXLANGW
Enter the password for 'admin': S0lT3st1ng
VSM L3 Ctrl IPv4 address : 10.10.168.2
VSM Primary MAC Address: 0050.56bc.6a3d
VSM Standby MAC Address: 0050.56bc.74f1
Enter VSM uplink port-profile name: vxgw-pc
Enter VTEP port-profile name: vxgw-vtep
----Details entered----
DomainId : 27
IPV4V6 : V4PriMgmtIpV4 : 10.10.168.101
PriMgmtIpV4Subnet : 255.255.255.0
PriGatewayIpV4 : 10.10.168.254
SecMgmtIpV4 : 10.10.168.102
SecMgmtIpV4Subnet : 255.255.255.0
SecGatewayIpV4 : 10.10.168.254
HostName : VXLANGW
Password : S0lT3st1ng
VSMIpV4 : 10.10.168.2
VSMPriMac : 0050.56bc.6a3d
VSMStdbyMac : 0050.56bc.74f1
UplinkPPName : vxgw-pcVSMEncapPPName : vxgw-vtep

Do you want to continue installation with entered details (Y/N)? [Y]
Note: VSB installation is in progress, please use show virtual-service-blade
  commands to check the installation status.
Note: VSB installation may take up to 5 minutes.

输入显示虚拟服务刀片summary命令在连结1x10系列设备为了验证VSB部署并且启动:

1010(config-vsb-config)# show virtual-service-blade summary

------------------------------------------------------------------
Name HA-Role HA-Status Status Location
------------------------------------------------------------------
VXGW PRIMARY ACTIVE VSB POWERED ON PRIMARY
VXGW SECONDARY NONE VSB DEPLOY IN PROGRESS SECONDARY

验证在VSM的模块

VXLAN网关在VSM配置里当前被添加作为模块。输入show module命令在VSM为了验证:

Nexus1000v# show module

Mod Ports Module-Type Model Status
--- ----- ------------------------- ------------- -----------
1 0 Virtual Supervisor Module Nexus1000V ha-standby
2 0 Virtual Supervisor Module Nexus1000V active *
3 248 Virtual Ethernet Module NA ok
4 248 Virtual Ethernet Module NA ok
5 332 Virtual Ethernet Module NA ok
6 332 Virtual Ethernet Module NA ok
7 4 Virtual Service Module VXLAN Gateway ok
8 4 Virtual Service Module VXLAN Gateway ok

Mod Sw Hw
--- -------------- --------------------------------------------
1 4.2(1)SV2(2.1) 0.0
2 4.2(1)SV2(2.1) 0.0
3 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
4 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
5 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
6 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
7 4.2(1)SV2(2.1) Linux 2.6.27.10
8 4.2(1)SV2(2.1) Linux 2.6.27.10

Mod Server-IP Server-UUID Server-Name
--- -------------- ------------------------------------ -----------
1 10.10.168.2 NA NA
2 10.10.168.2 NA NA
3 10.10.168.1 24266920-d498-11e0-0000-00000000000f 10.10.168.1
4 10.10.168.4 24266920-d498-11e0-0000-00000000000e 10.10.168.4
5 10.10.168.5 d54be571-831f-11df-aaa7-d0d0fd095a08 10.10.168.5
6 10.10.168.3 24266920-d498-11e0-0000-00000000000c 10.10.168.3
7 10.10.168.101 e6b86534-5d0c-4cde-a48e-2b555f929d2b VXLANGW
8 10.10.168.102 06cc2f30-bc2b-4b6f-a7d2-4e712c530761 VXLANGW

形成高可用性

现在您能配置在一个高性能的(HA)对的模块。

输入在VSM的show module服务模块命令为了验证模块的状况:

Nexus1000v# show module service-module

Mod Cluster-id Role HA Mode Status
--- ---------- ----------- ---------- -------
7 0 Unconfigured Standalone Init
8 0 Unconfigured Standalone Init

为了配置HA,请保证集群编号匹配在VXLAN网关上行链路波尔特配置文件的服务实例:

Nexus1000v# configure t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# service 7 role primary ha-cluster 1
Nexus1000v(config)# service 8 role secondary ha-cluster 1

验证VXLAN网关形成一个HA对。并且,请验证端口通道为LACP配置,并且他们是主动:

Nexus1000v# show module service-module

Mod Cluster-id Role HA Mode Status
--- ---------- ----------- -------- -------
7 1 Primary HA Active
8 1 Secondary HA Standby
Nexus1000v# show port-channel summary

Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)

-----------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
-----------------------------------------------------------
1 Po1(SU) Eth NONE Eth4/1(P) Eth4/2(P)
2 Po2(SU) Eth NONE Eth3/1(P) Eth3/2(P)
3 Po3(SU) Eth NONE Eth6/1(P) Eth6/2(P)
4 Po4(SU) Eth NONE Eth5/2(P)
5 Po5(SD) Eth NONE --
6 Po6(SU) Eth LACP Eth7/1(P) Eth7/3(P)
7 Po7(SU) Eth LACP Eth8/1(P) Eth8/3(P)

输入服务HA团星命令是否想要对切换VXLAN网关:

Nexus1000v# service ha-cluster 1 switchover

注意:此切换命令跟一个传统连结操作系统的(NXOS)不同切换命令,因为您必须切换该HA的集群您创建。

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序工具仅限注册用户)支持某些 show 命令。请使用Output Interpreter Tool为了查看show命令输出分析

VSM CLI

验证VTEPs在VSM正确地被编程:

Nexus1000v# show bridge-domain 192.168.2.x vteps

D: Designated VTEP I:Forwarding Publish Incapable VTEP

Bridge-domain: 192.168.2.xVTEP Table Version: 9

Port Module VTEP-IP Address VTEP-Flags
------ ------- ---------------- -------------
Veth11 3 10.17.168.20 (D)
Veth28 4 10.17.168.22 (D)
Veth21 7 10.17.124.70 (DI*) <---- VXLAN GW
Veth22 8 10.17.124.70 (DI) <---- VXLAN GW (Standby)

VEM命令

有许多VEM发出命令(VEMCMDs)您能使用为了验证配置,查看统计信息和验证您的VXLAN设置。为了查看可用命令,搜索与vemcmd的数据库|grep vxlan命令:

~ # vemcmd | grep vxlan

show vxlan interfaces Show the VXLAN Encap Interfaces
show vxlan-encap ltl <ltl> Show VXLAN Encap Information
show vxlan-encap mac <MAC.MAC.MAC>
show vxlan-stats Show VXLAN port stats for all ports
show vxlan-stats bd-all Show VXLAN port stats for all BDs
show vxlan-stats ltl <ltl> Show VXLAN port stats detail
show vxlan-stats ltl-detail Show all VXLAN ports stats detail
show vxlan-stats ltl <ltl> bd-all cookie <number>
show vxlan-stats ltl <ltl> bd-name <bd-name>
show vxlan-vteps Show VXLAN VTEPs
show vxlan-vteps bd-name <bd-name>
show vxlan threads Show the VXLAN thread stats
clear vxlan threads Clear the VXLAN thread stats
show vlan-vxlan mapping Show VXLAN VLAN mappings

输入vemcmd显示vxlan接口命令为了验证VEM编程与正确VTEP :

~ # vemcmd show vxlan interfaces
LTL VSM Port IP Seconds since Last Vem Port
IGMP Query Received
(* = IGMP Join Interface/Designated VTEP)
------------------------------------------------------------
51 Veth6 10.10.168.22 33 vmk2*

注意*在输出中显示是在主机的指定接收方的VTEP。

因为最后IGMP查询在一些时间以后,接收编号转变到0您应该也验证秒钟。NXOS的默认IGMP查询时期是125秒。这证明, IGMP查询在VTEP接收,并且组播传输是工作。

注意:您在show ip igmp snooping组on命令的输出中看不到VTEP vEthernet端口N1kV。 默认情况下,所有网桥域组的组播数据流在传输VLAN被充斥;因此, IGMP探听在N1kV没有使用。

输入vemcmd显示<x>命令vxlan encap的ltl为了查看特定VM的封装信息:

~ # vemcmd show vxlan-encap ltl 53

Encapsulation details for LTL 53 in BD "192.168.1.x":
Source MAC: 00:50:56:bc:77:25
Segment ID: 5000
Multicast Group IP: 239.1.1.1

Encapsulating VXLAN Interface LTL: 51
Encapsulating Source IP: 10.10.168.22
Encapsulating Source MAC: 00:50:56:6d:7a:25

Pinning of VXLAN Interface to the Uplink:
LTL IfIndex PC_LTL VSM_SGID Eff_SGID iSCSI_LTL* Name
51 1c000050 561 32 0 0 vmk2= IGMP Join

输入vemcmd显示vxlan统计on命令主机为了验证VXLAN的统计信息。为每VM Local Target Logic (LTL)发生的此命令显示封装数量和DE封装。

注意:所有广播和组播数据流分类作为Mcast/Repl Encaps。这是因为必须发送流量到所有VTEPs。单播流量分类作为Ucast Encaps。如果尝试排除故障ARP不完成的问题,则请验证Mcast/Repl Encaps列随每个ARP请求增加。

~ # vemcmd show vxlan-stats
LTL Ucast Mcast/Repl Ucast Mcast Total
Encaps Encaps Decaps Decaps Drops
51 7557 507 8012 0 0
53 7137 431 7512 0 0

输入vemcmd显示12分段5001命令为了验证源主机动态地了解目的地的MAC地址:

~ # vemcmd show l2 segment 5001
Bridge domain 14 brtmax 4096, brtcnt 2, timeout 300
Segment ID 5001, swbd 4097, "192.168.2.x"
Flags: P - PVLAN S - Secure D - Drop
Type MAC Address LTL timeout Flags PVLAN Remote IP DSN
Static 00:50:56:bc:77:25 55 0 0.0.0.0 0
Dynamic 00:50:56:bc:19:5b 561 0 10.17.168.22 0

故障排除

目前没有针对此配置的故障排除信息。


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 117618