IP : 开放最短路径优先 (OSPF)

OSPFv3虚链路配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文在配置提供一示例在开放最短路径第一版本3 (OSPFv3)的虚链路。OSPFv3在OSPF第2版展开为IPv6路由前缀的和大号IPv6地址提供支持。

对于每虚链路,一重要的安全信息datablock为虚链路创建。由于在每个接口必须打开一安全socket,将有每个接口的一对应的安全信息datablock在中转区域。安全socket状态在接口的安全信息datablock被保持。在重要的安全信息datablock的State字段反映所有的状态为虚链路打开的安全插槽。如果所有安全插槽是UP,则虚链路的安全状态将设置对。

在一虚链路的发送的数据包与IPsec必须使用预先确定的源地址和目的地址。在路由器的区域的内部区域前缀LSA找到的第一个本地区域的地址使用作为源地址。此源地址在区域数据结构保存,并且打开使用的,当请巩固时插槽和在虚链路的发送的数据包。虚链路不会过渡到点到点状态,直到源地址选择。并且,当源或目的地址更改时,上一个巩固插槽必须关闭,并且新建请巩固打开的插槽。

此配置示例使用area virtual-link命令定义在路由器配置模式的一条OSPF虚拟链路。

注意: 每个虚拟链路邻居必须包括中转区域ID和对应的虚拟链路邻居路由器ID为了能适当地配置的虚链路。请使用exec命令的show ip ospf发现路由器ID。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 完成 OSPF 网络策略和 IPv6 网络计划。

  • 启用 IPv6 单播路由。

  • 在接口上启用 IPv6。

使用的组件

本文档不限于特定的软件和硬件版本。

在本文的配置根据在Cisco IOSï ¿  ½软件版本软件12.4 (15)T 13的Cisco 3700系列路由器。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113204-ospfv3-vlink-config-01.gif

配置

本文档使用以下配置:

  • 路由器 R1

  • 路由器 R2

  • 路由器 R3

  • 路由器R4

路由器 R1
hostname R1
! 
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes

路由器 R2
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 virtual-link 3.3.3.3
!

路由器 R3
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 !

interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 virtual-link 2.2.2.2
!

路由器R4
hostname R4
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:4::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
ipv6 router ospf 10
 router-id 4.4.4.4
 log-adjacency-changes
!

验证

请使用这些命令验证配置:

在路由器 R1 中

输出清楚显示路由器R1能顺利地ping路由器R4的环回地址。

ping ipv6
R1#ping ipv6
Target IPv6 address: fe01:4::4

Ping Loopback 0 interface of R4
   	
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/72/96 ms

在路由器 R2 中

show ipv6 ospf neighbor命令在a提供邻居信息每接口上。

show ipv6 ospf neighbor
R2# show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3                 0   FULL/  -                -                22        OSPFv3_VL0   

Virtual Link Between R2 & R3
       
1.1.1.1                 1   FULL/DR         00:00:35         4                 Ethernet1/0
3.3.3.3                 0   FULL/  -           00:00:31      12                Serial2/0

在路由器R4中

输出清楚显示路由器R4能顺利地ping路由器R1回环接口。

ping ipv6
R4#ping ipv6
Target IPv6 address: fe01:1::1				

Ping Loopback 0 interface of R1

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/224 ms

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 113204