安全 : Cisco AnyConnect 安全移动客户端

AnyConnect客户端的RSA SecurID验证Cisco IOS头端配置示例的

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 6 日) | 反馈

简介

本文描述如何配置Cisco IOS设备验证有一次密码(OTPs)和使用的AnyConnect客户端Rivest沙米尔Addleman (RSA) SecurID服务器。

注意:OTP验证不研究没有增强请求的CSCsw95673CSCue13902修正的Cisco IOS版本。

贡献用Atri巴苏, Cisco TAC工程师和Vasavi Yellampalli, Cisco工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • RSA SecurID服务器设置
  • 在Cisco IOS头端的SSLVPN配置
  • Web VPN

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • CISCO2951/K9
  • Cisco IOS软件, C2951软件(C2951-UNIVERSALK9-M),版本15.2(4)M4,发行软件(fc1)

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

虽然AnyConnect客户端总是支持基于OTP的验证,在Cisco Bug ID的CSCsw95673修正之前, Cisco IOS头端没有处理RADIUS访问-查询消息。 在首次登录提示符(其中用户输入他们“永久性”用户名和密码)后, RADIUS传送“访问-查询”信息到Cisco IOS网关,要求用户输入他们的OTP :

 RADIUS/ENCODE: Best Local IP-Address 10.7.7.1 for Radius-Server 10.7.7.129
 RADIUS(0000001A): Sending a IPv4 Radius Packet
 RADIUS(0000001A): Send Access-Request to 10.7.7.129:1812 id 1645/17,len 78
 RADIUS:  authenticator C3 A1 B9 E1 06 95 8C 65 - 7A C3 01 70 E1 E1 7A 3A
 RADIUS:  User-Name           [1]   6   "atbasu"
 RADIUS:  User-Password       [2]   18  *
 RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
 RADIUS:  NAS-Port            [5]   6   6
 RADIUS:  NAS-Port-Id         [87]  16  "203.0.113.238"
 RADIUS:  NAS-IP-Address      [4]   6   10.7.7.1
 RADIUS(0000001A): Started 5 sec timeout
 RADIUS: Received from id 1645/17 10.7.7.129:1812, Access-Challenge, len 65
 RADIUS:  authenticator 5D A3 A6 9D 1A 38 E2 47 - 37 E8 EF A8 18 94 25 1C
 RADIUS:  Reply-Message       [18]  37
 RADIUS:   50 6C 65 61 73 65 20 65 6E 74 65 72 20 79 6F 75  [Please enter you]
 RADIUS:   72 20 6F 6E 65 2D 74 69 6D 65 20 70 61 73 73 77  [r one-time passw]
 RADIUS:   6F 72 64               [ ord]
 RADIUS:  State               [24]  8
 RADIUS:   49 68 36 76 38 7A            [ Ih6v8z]

这时, AnyConnect客户端预计显示请求他们的OTP的用户的一另外的弹出窗口,但是,因为Cisco IOS设备没有处理访问-查询消息,这从未发生,并且客户端秀手旁观直到连接时间的空闲。

然而,自Version15.2(4)M4, Cisco IOS设备应该能处理基于质询的认证机制。

配置

网络图

其中一可适应安全工具(ASA)和Cisco IOS头端之间的差异是Cisco IOS路由器/交换机/接入点(AP)只支持RADIUS和TACACS。他们不支持RSA所有权协议SDI。然而RSA服务器支持SDI和RADIUS。所以,为了使用在Cisco IOS头端的OTP验证,必须为RADIUS协议和RSA服务器配置Cisco IOS设备作为RADIUS令牌服务器。

注意:欲了解更详细的信息关于在RADIUS和SDI之间的区别,参考RSA ASA和ACS的令牌服务器和SDI协议使用情况的理论部分。如果SDI要求,则必须使用ASA。

注意:使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

  1. 配置认证方法和验证、授权和统计(AAA)服务器组:
    aaa new-model
    !
    !
    aaa group server radius OTP-full
    server 10.7.7.129
    !
    aaa group server radius OTP-split
    server 10.7.7.129 auth-port 1812
    !
    aaa authentication login default local
    aaa authentication login webvpn-auth group OTP-split
    aaa authorization exec default local
    aaa authorization network webvpn-auth local
  2. 配置RADIUS服务器:
    radius-server host 10.7.7.129 auth-port 1812
    radius-server host 10.7.7.129
    radius-server key Cisco12345
  3. 配置路由器作为安全套接字协议层VPN (SSLVPN)服务器:
    crypto pki trustpoint VPN-test2
    enrollment selfsigned
    revocation-check crl
    rsakeypair VPN-test2
    !
    !
    crypto pki certificate chain VPN-test2
    certificate self-signed 02
    3082021B 30820184 A0030201 02020102 300D0609 2A864886 F70D0101 05050030
    29312730 2506092A 864886F7 0D010902 1618494E 4E424545 2D524F30 312E636F
    7270726F 6F742E69 6E74301E 170D3133 30313134 31313434 32365A17 0D323030
    31303130 30303030 305A3029 31273025 06092A86 4886F70D 01090216 18494E4E
    4245452D 524F3031 2E636F72 70726F6F 742E696E 7430819F 300D0609 2A864886
    F70D0101 01050003 818D0030 81890281 8100B03E D15F7D2C DF84855F B1055ACD
    7BE43AAF EEB99472 50477348 45F641C6 5A244CEE 80B2A426 55CA223A 7F4F89DD
    FA0BD882 7DAA24EF 9EA66772 2CC5A065 584B9866 2530B67E EBDE8F57 A5E0FF19
    88C38FF2 D238A136 B32A114A 0187437C 488073E9 0E96FF75 F565D684 987F2CD1
    8CC7F53C 2D419F90 EF4B9678 6BDFCD4B C7130203 010001A3 53305130 0F060355
    1D130101 FF040530 030101FF 301F0603 551D2304 18301680 146B56E9 F770734C
    B0AB7360 B806E9E1 E1E15921 B3301D06 03551D0E 04160414 6B56E9F7 70734CB0
    AB7360B8 06E9E1E1 E15921B3 300D0609 2A864886 F70D0101 05050003 81810006
    0D68B990 4F927897 AFE746D8 4C9A7374 3CA6016B EFFA1CA7 7AAD4E3A 2A0DE989
    0BC09B17 5A4C75B6 D1F3AFDD F97DC74C D8834927 3F52A605 25518A42 9EA454AA
    C5DCBA20 A5DA7C7A 7CEB7FF1 C35F422A 7F060556 647E74D6 BBFE116F 1BF04D0F
    852768C3 2E972EEE DAD676F1 A3941BE6 99ECB9D0 F826C1F6 A944340D 14EA32
    quit
    ip cef
    !
    !
    crypto vpn anyconnect flash0:/webvpn/anyconnect-win-3.1.02026-k9.pkg sequence 1
    !
    interface Loopback1
    ip address 192.168.201.1 255.255.255.0
    !
    interface GigabitEthernet0/0
    description WAN 0/0 VODAFONE WAN
    ip address 203.0.113.63 255.255.255.240
    no ip redirects
    no ip unreachables
    duplex auto
    speed auto
    !
    !
    interface Virtual-Template3
    ip unnumbered Loopback1
    !
    ip local pool SSLVPN-pool 192.168.201.10 192.168.201.250
    !
    webvpn gateway gateway_1
    hostname vpn.cisco.com
    ip address 203.0.113.63 port 443
    http-redirect port 80
    ssl trustpoint VPN-test2
    inservice
    !
    webvpn context webvpn-context
    secondary-color white
    title-color #669999
    text-color black
    virtual-template 3
    aaa authentication list webvpn-auth
    gateway gateway_1
    !
    ssl authenticate verify all
    inservice
    !
    policy group policy_1
    functions svc-enabled
    svc address-pool "SSLVPN-pool" netmask 255.255.255.0
    svc keep-client-installed
    svc split include 192.168.174.0 255.255.255.0
    svc split include 192.168.91.0 255.255.255.0
    default-group-policy policy_1
    !
    end

注意:对于更多关于怎样的一个详细配置指南设置在Cisco IOS设备的SSLVPN,参考IOS路由器的AnyConnect VPN (SSL)客户端有CCP配置示例的

验证

当前没有可用于此配置的验证过程。

故障排除

为了排除故障流入AnyConnect客户端连接的整个认证过程,您能使用这些调试:

  • debug radius authentication
  • debug aaa authentication
  • 调试WebVPN验证

命令输出解释程序工具仅限注册用户)支持某些 show 命令。请使用Output Interpreter Tool为了查看show命令输出分析。

注意:使用 debug 命令之前,请参阅有关 Debug 命令的重要信息



Document ID: 118778