IP : 组播

配置在Cisco IOS内的mVPN配置文件

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2016 年 4 月 21 日) | 反馈

目录

相关的思科支持社区讨论

简介

本文描述如何配置在Cisco IOS内的每组播VPN (mVPN)配置文件。

注意:在本文描述的配置应用对服务商边缘路由器。

贡献用卢克De Ghein, Cisco TAC工程师。

先决条件

要求

在您继续进行在本文描述的配置前,请验证是否有一mVPN配置文件的支持在运行Cisco IOS的特定平台。

使用的组件

本文档中的信息根据Cisco IOS的所有版本。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

配置

此部分描述如何配置在Cisco IOS内的mVPN配置文件。

注意:使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

mVPN配置文件

注意:不是Cisco IOS当前支持所有的配置文件。

注意:虚拟路由/转发(VRF)使用在本文中是VRF一Rosen MLDP重命名默认MDT

mVPN配置文件配置为全局上下文或每个VRF。当您配置在Cisco IOS时的mVPN配置文件您能使用旧有或新方法为了定义VRF。

这是旧有方法的示例:

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

这是新方法的示例:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family

对于配置文件在全局上下文,必须启用组播路由

ip multicast-routing

对于配置文件在Vrf context,必须为VRF启用组播路由

ip multicast-routing vrf one

您能启用记录日志多点标签转发协议(MLDP)用配置文件的此global命令与MLDP :

mpls mldp logging notifications

必须为在供应商边缘客户边缘(PE-CE)链路的服务商边缘路由器启用独立于协议的组播(PIM)两个案件的(全局或Vrf context) :

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

MLDP的FRR

法塞特为MLDP重路由(FRR)是可用的在Cisco IOS。MLDP是控制层面协议的组播数据流必须使用主数据流工程(TE)通道为了有FRR保护的流量。主要的TE隧道可以是一手工的TE隧道或主要的自动隧道。必须由TE FRR保护链路,由一个手动备份通道或备份自动隧道。

此示例使用一个手工的主要的和手动备份通道。

必须配置此global命令为了MLDP能使用多协议标签交换(MPLS)流量工程隧道:

mpls mldp path traffic-eng

此配置使用由主要的一跳通道使用的保护的接口:

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

此配置使用备份通道:

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

此配置使用主要的一跳通道:

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

注意:因为在已保护通道,必须启用MLDP mpls IP配置在主要的通道要求。autoroute announce配置要求为了保证TE隧道用于转发流量。

MLDP的MBB

请做,在Cisco IOS支持工间休息时间(MBB)前功能,但是使用固定延迟仅的方法,在新的路径是可用的后。没有查询/确认在Cisco IOS的机制。

这是使用为了配置MBB固定延迟的global命令:

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

默认情况下默认值是0,那么那里是没有MBB。

配置文件

此部分描述每mVPN配置文件的必需的配置。

配置文件0默认MDT - GRE - PIM C mcast发信号

请使用此配置配置文件0 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
  neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

注意:对于此配置文件,在全局回环接口必须启用PIM。必须用于地址家族(AF) IPv4组播分配树(MDT) PIM信令的所有类型在核心(不仅PIM源特定组播(SSM))。

配置文件1默认MDT - MLDP MP2MP - PIM C mcast发信号

请使用此配置配置文件1 :

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
  mdt default mpls mldp 10.100.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.2.9 remote-as 65002
  neighbor 10.2.2.9 activate
exit-address-family

配置文件2分成的MDT - MLDP MP2MP - PIM C mcast发信号

     

Cisco IOS当前不支持配置文件2,并且MLDP不支持与多点对多点的分成的MDT (MP2MP)。

配置文件3默认MDT - GRE - BGP-AD - PIM C mcast发信号

请使用此配置配置文件3 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

  

注意:对于此配置文件,在全局回环接口必须启用PIM。由于使用PIM的边界网关协议自动发现号(BGP-AD),不再有对AF IPv4 MDT的需要,为配置文件0是需要的。

配置文件4分成的MDT - MLDP MP2MP - BGP-AD - PIM C mcast发信号

Cisco IOS当前不支持配置文件4,并且MLDP不支持与MP2MP的分成的MDT。

配置文件5分成的MDT - MLDP P2MP - BGP-AD - PIM C mcast发信号

Cisco IOS当前不支持配置文件5,并且PIM信令不在分成的MDT支持。

配置文件6 VRF MLDP -带内信令

请使用此配置配置文件6 :

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

描出7个全局MLDP带内信令

请使用此配置配置文件7 :

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

配置文件8全局静态- P2MP-TE

此部分描述配置文件的8必需的配置在TE首端和TE尾端路由器。

TE数据转发路由器

请使用此配置在TE数据转发路由器的配置文件8 :

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

注意:目的地列表为点对多点(P2MP) TE隧道的尾端路由器要求。往尾端路由器的路径选项可以明确或动态。

TE尾端路由器

请使用此配置在TE尾端路由器的配置文件8 :

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

注意:静态mroute为往TE数据转发路由器的来源要求在全局上下文。

配置文件9默认MDT - MLDP - MP2MP - BGP-AD - PIM C mcast发信号

请使用此配置配置文件9 :

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

配置文件10 VRF静态- P2MP TE - BGP-AD

Cisco IOS当前不支持配置文件10,并且BGP-AD不为P2MP TE支持。

配置文件11默认MDT - GRE - BGP-AD - BGP C mcast发信号

请使用此配置配置文件11 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1 
  mdt overlay use-bgp
route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

注意:对于此配置文件,在全局回环接口必须启用PIM。由于使用PIM的BGP-AD,不再有对AF IPv4 MDT的需要,为配置文件0是需要的。

配置文件12默认MDT - MLDP - P2MP - BGP-AD - BGP C mcast发信号

请使用此配置配置文件12 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

配置文件13默认MDT - MLDP - MP2MP - BGP-AD - BGP C mcast发信号

请使用此配置配置文件13 :

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

配置文件14分成的MDT - MLDP P2MP - BGP-AD - BGP C帆柱信令

请使用此配置配置文件14 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

配置文件15分成的MDT - MLDP MP2MP - BGP-AD - BGP C帆柱信令

Cisco IOS当前不支持配置文件15,并且MLDP不支持与MP2MP的分成的MDT。

配置文件16默认MDT静态- P2MP TE - BGP-AD - BGP C mcast发信号

Cisco IOS当前不支持配置文件16。

配置文件17默认MDT - MLDP - P2MP - BGP-AD - PIM C mcast发信号

请使用此配置配置文件17 :

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

配置文件18默认MDT静态- P2MP TE - BGP-AD - PIM C mcast发信号

Cisco IOS当前不支持配置文件18。

配置文件19默认MDT - IR - BGP-AD - PIM C mcast发信号

Cisco IOS当前不支持配置文件19和入口复制(IR)。

配置文件20默认MDT - P2MP-TE - BGP-AD - PIM - C mcast发信号

TE Cisco IOS当前不支持配置文件20和P2MP自动隧道。

配置文件21默认MDT - IR - BGP-AD - BGP - C mcast发信号

Cisco IOS当前不支持配置文件21和IR。       

配置文件22默认MDT - P2MP-TE - BGP-AD BGP - C mcast发信号

TE Cisco IOS当前不支持配置文件22和P2MP自动隧道。  

   

配置文件23分成的MDT - IR - BGP-AD - PIM C mcast发信号

Cisco IOS当前不支持配置文件23和IR。          

配置文件24分成的MDT - P2MP-TE - BGP-AD - PIM C mcast发信号

TE Cisco IOS当前不支持配置文件24和P2MP自动隧道。

配置文件25分成的MDT - IR - BGP-AD - BGP C mcast发信号

Cisco IOS当前不支持配置文件25和IR。       

配置文件26分成的MDT - P2MP TE - BGP-AD - BGP C mcast发信号

TE Cisco IOS当前不支持配置文件26和P2MP自动隧道。

内部自控的mVPN

在此部分的信息,以为正确的配置在路由器实现为了使AS间MPLS VPN可操作为单播,提供。

选项D不为mVPN支持。

方案A

正常mVPN配置为方案A要求。您能有在自治系统的所有配置文件,并且配置文件在不同自治系统不必须配比。

PIM

对于选项B和C,如果回环接口IP地址从边界网关协议(BGP)重新分配到另一Autonomous Systems (AS)的内部网关路由协议(IGP),然后PIM矢量没有要求。

方案B

仅自控系统间(Inter-AS) mVPN支持与配置文件0 (用非被分段的通道)。

正常mVPN配置为方案B要求。AF可以使用仅IPv4 MDT;AF不支持IPv4 MVPN。

与路由辨别器(RD)的PIM矢量起源在PE路由器要求,有此更多的配置的:

ip multicast vrf one rpf proxy rd vector

自治系统边界路由器(ASBRs)必须有在ASBR对ASBR链路启用的PIM。ASBRs必须也有AF为内部边界网关协议(iBGP)邻居和ASBR外部边界网关协议(eBGP)邻居配置的IPv4 MDT。

此更多的配置在ASBR要求:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

选项C

仅自控系统间(Inter-AS) mVPN支持与配置文件0 (用非被分段的通道)。

正常mVPN配置为选项C要求。另一AS的PE环回前缀由在AF IPv4的BGP通告。

没有RD的PIM矢量起源在PE路由器也要求,有此更多的配置的:

ip multicast rpf proxy vector

ASBRs必须有在ASBR对ASBR链路启用的PIM。ASBRs必须也有AF为iBGP邻居和ASBR EBGP邻居配置的IPv4 MDT。

此更多的配置在ASBR要求:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

注意:在自治系统之间的AF IPv4 MDT在路由反射器(RR)可能也配置在一EBGP多跳会话而不是ASBRs的。

MLDP

当前不支持方案B。

选项C

没有递归转发等效类(FEC)的支持在Cisco IOS。因此, PE环回的再分配由iBGP的到另一个AS里不是满足的,因为P (供应商)路由器缺乏PE路由器的知识另一个AS的。

如果PE环回由IGP重新分配到另一个AS,有支持。在这种情况下,支持与分成的MDT的配置文件和全网状P2MP MLDP。不可能使用AF IPv4 MDT这里;AF必须使用IPv4 MVPN。BGP mVPN会话能运作在观点扫描器和RR之间。在RR之间,已经有为AF VPNv4/6运作的EBGP多跳会话。

必须启用MLDP BGP-AD。Inter-AS关键字在PE路由器要求为了保证BGP-AD类型1路由没有无导出属性

与MLDP全网状P2MP的配置文件

此部分描述配置文件的12和17配置。

配置文件17配置

这是在PE路由器的配置配置文件的17 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

这是在ASBRs的配置配置文件的17 :

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

注意mpls IP配置在ASBRs之间的链路要求为了有在他们之间的MLDP结邻。

这是在RR的配置配置文件的17 :

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

配置文件12配置

此配置是相同的象用于配置文件的那17,但是有另外的C组播信令由BGP。

这是在PE路由器的配置配置文件的12 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

与MLDP分成的MDT的配置文件

此部分描述配置文件的14配置。

配置文件14配置

这是在PE路由器的配置配置文件的14 :

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

这是在ASBRs的配置配置文件的14 :

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

注意mpls ip在ASBRs之间的链路要求为了有在他们之间的MLDP结邻。

这是在RR的配置配置文件的14 :

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Csc

提供此信息,以为正确的配置在路由器实现为了有载波的载波(Csc) MPLS VPN可操作为单播。

仅配置文件0为Csc支持。这意味着可以有与支持组播的VPN的分层的Csc。Csc的VPN有0配置的mVPN配置文件。运营商网络有0配置的mVPN配置文件。这意味着有正常mVPN配置,在Csc的Csc PE路由器和在载波的PE路由器,然后没有为组播需要的更多的配置。

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。



Document ID: 118985