IP : 开放最短路径优先 (OSPF)

与多区域邻接配置示例的OSPF

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文描述如何配置多区域邻接的开放最短路径优先(OSPF)链路状态路由协议。

贡献用Narendra Naukwal, Cisco TAC工程师。

先决条件

要求

Cisco 建议您了解以下主题:

  • OSPF

  • 多区域邻接

思科也建议这些需求符合,在您尝试在本文描述的配置前:

  • 在网络必须预先配置OSPF链路状态路由协议。

  • 仅两台OSPF扬声器使用之间OSPF多区域功能操作的接口在。多区域在点对点的网络类型的仅OSPF工作。

使用的组件

本文档中的信息根据多区域OSPF。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

背景信息

OSPF链路状态路由协议使用区域的概念,是在OSPF域内的子域。在区域内的一个路由器维护该区域完整拓扑信息。默认情况下,接口能只属于一个OSPF区域。这能的网络不仅导致次优路由,但是可能也导致其他问题,如果网络没有正确地设计。

当多区域邻接在接口时配置, OSPF扬声器形成超过一个邻接(ADJ)在该链路。多区域接口是逻辑, ADJ形成的点对点接口。本文描述多区域OSPF ADJ可以用于为了在问题附近工作和符合网络要求的方案。

配置

网络图

在此网络图中,使用network/OSPF域。系统要求从Router5 (R5)的流量对R1 (10.1.1.1)总是穿过R3。假设, R3是在所有流量应该路由的网络的一防火墙,或者R3和R4之间的链路比R2和R4之间的链路有更多带宽。无论如何,系统要求流量必须流经R3,当从R5通过到R1时(10.1.1.1/32前缀)。

初始配置

此部分通过R5描述R1的初始配置。

R1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

R2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

默认行为

使用到位先前配置,此部分描述默认路由器行为。

这是从R5的trace到10.1.1.1。注意流量穿过R2,不是R3 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec   <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec   <<< R2
3 192.168.12.1 8 msec * 3 msec        <<< R1

在此网络中,路由器R4必须做出决策,并且应该直接地路由流量到R3,不到R2,根据系统要求。

这是在R4的一个路由表示例:

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

量度30用前缀的10.1.1.1/32此路由关联。由自治系统边界路由器的这归结于默认度量20 (ASBR) (R2)和一开销10使用在R4的接口Eth0/2。

从R4的路径到10.1.1.1/32前缀通过R3更加长。这里,以太网接口的0/2开销在R4 (往R2的路径)被修改为了验证是否更改行为:

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

这是从R5和show ip route命令输出的trace从R4 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec   <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
  Route metric is 120, traffic share count is 1

当trace显示,从R5的流量采取同一个路径,并且流量不通过R3流。并且,如show ip route 10.1.1.1 on命令所显示R4的输出,在R4的开销100 (以太网接口0/2)加起作用和路由的开销对前缀是120 (反对到30)。然而,路径仍然没有更改,并且流量的需求能流在R3间没有符合。

为了确定此行为的原因,这是R4 show ip ospf border-routers命令输出(在R4以太网接口0/2的开销仍然设置到100) :

R4#show ip ospf border-routers
            OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

在R4,您能看到有(的两区域边界路由器ABR) (0.0.0.2,是R2和0.0.0.3,是R3),并且R2是ASBR。此输出也显示ASBR的区域内(i)信息。

现在,以太网接口0/2在R4被关闭为了确定是否通信流通过R3和为了看到show ip ospf border-routers命令输出如何出现:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

这是从R5和show ip route命令输出的trace从R4 :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec   <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago  <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

如显示,当以太网接口0/2在R4时被关闭,流量穿过R3。并且,用往R3的路由关联的开销只是40,而往10.1.1.1/32的开销通过R2是120。OSPF协议仍然喜欢通过R2路由流量而不是R3,即使到达10.1.1.1/32的开销通过R3是更低。

这再次是show ip ospf border-routers输出在R4 :

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

要求为了到达ASBR的信息是域间信息。然而,该区域内的信息详细信息如何到达ASBR在用两个路径关联的域间信息更喜欢不考虑OSPF开销。

为此,路径通过R3未被选,即使开销通过R3更低。

这里,以太网接口0/2带来在R4的备份:

interface Ethernet0/2
no shutdown
end
!

从R5的trace表明路由操作请回到以前被观察的那些(流量不通过R3流) :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec   <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec   <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

有多种方式您能解决此问题(此列表不是详尽的) :

  • 更改在R2和R3之间的区域到90,然后修改开销。

  • 添加R2和R3之间的另一条链路并且配置它在区域99

  • 请使用多区域ADJ。

参考下一部分为了发现多区域OSPF ADJ工作的方式用,并且如何能解决手头此的问题。

多区域邻接配置

如前所提及,多区域ADJ可以用于为了形成多点指向在单条链路的逻辑邻接。需求是只必须有在链路的两台OSPF扬声器,并且在广播网络,您必须手工更改OSPF网络类型到在链路的点对点

此功能允许多个区域将共享的单个物理链路并且创建共享链路的其中每一个的一个区域内路径区域。

为了符合此要求,您必须配置OSPF在R2和R3之间的多区域ADJ在链路Ethernet0/1,当前仅在Area 0

这是R2的配置:

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

这是R3的配置:

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

OSPF ADJ在虚链路出现:

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

这是新形成的ADJ :

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:03:01
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:01:41
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec

验证

为了验证您的配置是否适当地工作,请输入show ip ospf border-routers命令在R4 :

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

如显示,是被使用的为了路由流量对R2的区域内信息(0.0.0.2)/ASBR是通过R3。这应该解决以前被提及的问题。

这是从R5的trace :

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec   <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1

如显示,从被注定对10.1.1.1通过R3适当地流的R5的流量和系统要求符合。

输入show ip ospf neighbor命令在R2、R3和R4为了验证ADJs是否设立:

R2#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.3       0  FULL/ -  00:00:39   192.168.23.3   Ethernet0/1 
0.0.0.4       0  FULL/ -  00:00:37   192.168.24.4   Ethernet0/2
0.0.0.3       0  FULL/ -  00:00:33   192.168.23.3   OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:34   192.168.23.2   Ethernet0/1 
0.0.0.2       0  FULL/ -  00:00:35   192.168.23.2   OSPF_MA0 
0.0.0.4       0  FULL/ -  00:00:39   192.168.34.4   Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:32   192.168.24.2   Ethernet0/2  
0.0.0.5       0  FULL/ -  00:00:32   192.168.45.5   Ethernet0/1
0.0.0.3       0  FULL/ -  00:00:35   192.168.34.3   Ethernet0/0

注意:在这些输出中, Ethernet0/1接口条目指示在Area 0的ADJ,并且OSPF_MA0接口条目指示在区域99的多区域ADJ。

R4以太网接口0/2仍然有一开销100,并且路径通过R3在R4被选。如果此开销删除, R4然后路由流量直接地对R2作为以前。

这是配置和show ip route命令输出在R4与在R4以太网接口仍然配置的Ip ospf cost 100 0/2 :

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

这是配置和show ip route命令输出在R4,当您取消开销时:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
     Route metric is 30, traffic share count is 1

故障排除

目前没有针对此配置的故障排除信息。


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 118879