语音和统一通信 : Cisco Unity Connection 版本 8.0

Cisco Unity Connection 8.5:尝试切换版本时出现错误

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

在 Cisco Unity Connection 集群从版本 7.x/8.x 升级到版本 8.5(1) 后,当 switch-version 命令运行时,进程会在几分钟后出错。本文提供怎样故障排除此问题的相关信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息是基于 Cisco Unity Connection 8.5(1)。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

问题

在 Cisco Unity Connection 8.5(1) 的集群从版本 7.x 和 8.x 升级后,无法完成 utils system switch-version 命令。因此,集群无法完成升级。并且,此错误消息位于版本切换日志 (cuc-version-switch.log):

Cannot insert a null into column (tbl_handler.partitionobjectid)

此问题记录在思科漏洞 ID CSCtr59602 中(仅限注册用户)。

解决方案

解决方法要求移除受影响的用户,以便 switch-version 命令成功运行。不能使用 Unity Connection Administration 移除受影响的用户,且需要使用 csp_subscriberdelete 存储过程。

run cuc dbquery unitydirdb execute procedure csp_subscriberdelete
(pObjectId='8af5fef8-8001-460e-861d-992ec1d857a8')

您需要将对象 ID 替换为受影响用户的对象 ID,并在需要时重新运行,直至所有受影响的用户都已从系统中移除。此后,重新运行 utils system switch-version 命令。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 113285