语音 : 介质网关控制协议 (MGCP)

启用 VRF 的路由器上的 MGCP 支持配置示例

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文档描述了如何在启用了语音路由和转发 (VRF) 的路由器上配置消息网关控制协议 (MGCP)。

关于 MGCP,您应了解两个主要元素:

端点就是指定网关上的任何语音端口。这些语音端口提供了模拟端口(如外围交换局 (FXO)/外围交换站 (FXS))和数字中继线(如 T1 或 E1)到 PSTN 的连接。网关可以有多个终端,这取决于其包含的端口数量。

呼叫代理是语音系统中的外部控制设备。Cisco CallManager 是本文档中所引用的呼叫代理。在 MGCP 中,呼叫代理是用来全面控制网关的设备。这是一个非常高效的系统,因为所有管理都是由呼叫代理执行的。网关一端上需要的设置非常少,因为所有路由模式和 Dial Plan 配置在Cisco CallManager上。

请务必记住,此协议仅用于控制。语音数据并不会通过 MGCP 协议本身进行传输。所有语音数据传输都是在电话与网关之间直接进行的。此图形描述了 MGCP 通信关系:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

在此示例中,思科 IP 电话使用内部呼叫控制协议 (SCCP) 与 Cisco CallManager 通信。实际语音数据通过 Real-time Transport Protocol (RTP) 在两个设备之间直接传输。MGCP 仅由 Cisco CallManager 使用,用来控制网关。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 思科 IOS 软件 12.4(24)T 4 版本

  • Cisco 2800 系列路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

MGCP 和 VRF Lite

VRF 路由智能在 MGCP 协议中不存在。

因为 MGCP 不是“VRF 感知”协议,因此您无法配置 IOS 语音网关来将 MGCP 流量放入语音 VRF。不管 VRF 配置如何,MGCP 流量只会使用路由器的默认路由表。

在典型 VRF 部署中,有两种支持 MGCP 的解决方案。请参阅以下典型 VRF 网络场景:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

您可使用两个路由器建立一个路由,即,使用 MGCP 网关作为一个基本路由器(没有 VRF),向进行 MPLS VRF 路由的第二个路由器提供以太网流量。然后,您可以通过 VRF 路由器路由 MGCP 流量,因为它只是一项路由技术,并且 MGCP 是无感知的。

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

另一个相似的解决方案是使用单个 VRF 路由器并利用第二个可用接口将 MGCP 流量导向到语音网络。

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

将接口连接至交换网络上的语音 VLAN,这样可允许 MGCP 协议通过 VRF 接口返回路由器,最终到达 CallManager。

VRF 路由器的全局路由只需要提供一个 IP 和一个指向 VRF 接口的 IP 的静态路由或者语音 VLAN 的 DHCP 地址。请参阅以下配置详细信息:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

验证

当前没有可用于此配置的验证过程。


相关信息


Document ID: 113180