无线 : 思科 2500 系列无线控制器

Cisco 2500系列无线控制器部署指南

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈

简介

本文档是思科 2500 系列无线控制器的部署指南。Cisco 2500系列无线控制器是零售、企业分支和中小型企业的一个有效系统无线解决方案。当网络增长,控制器在网络能扩展。

Cisco 2500系列无线控制器混和到Cisco Unified无线网络(CUWN)并且与Cisco轻量级接入点(AP)一起使用和思科无线控制系统(WCS)或Cisco网络控制系统(NCS)或头等基础设施(PI)为了提供全系统的无线局域网功能。无线AP之间的Cisco 2500系列无线控制器提供实时通信和其它设备为了提供集中化安全策略、访客访问、无线入侵防御系统(wIPS),上下文意识(位置),无线电频率(RF)管理和服务质量(QoS)移动服务的例如语音和视频和OfficeExtend接入点(OEAP)支持远程工作者解决方案的。

Cisco 2500系列无线控制器支持最多50轻量AP增量与至少的5个AP许可证5 AP许可证,做它零售和中小型企业的一个有成本效益的解决方案。Cisco 2500系列无线控制器提供与802.11 a/b/g的稳健覆盖或提供与使用的史无前例的可靠性802.11n、802.11ac和Cisco NEXT-GENERATION无线解决方案和Cisco企业网状网。

贡献用尼古拉斯Darchis, Cisco TAC工程师。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息是基于思科 2500 系列无线控制器的。

硬件规格

  • 数据端口- 4 x 1千兆以太网端口

  • 控制台端口- 1个x RJ45

  • 外部 48V 电源

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

附加功能

  • 无线接入点(CAPWAP)协议控制和供应的支持。

  • 在CAPWAP数据的加密建立隧道((可选)的DTL)。

  • 基于许可的 AP 数量。AP统计- 50 (在步骤5, 25, 50)。这增加到75自版本7.4软件代码。

  • 支持的客户端计数- 500 (在所有状态)。这增加到1000自版本7.4软件代码。

  • 支持的标记计数- 500。

  • 就绪的三杀-支持数据、语音和视频。

  • 整体数据流吞吐量500 Mbps (无论许多端口连接)。这增加对1Gbps自版本7.4软件代码。

  • 林克聚合组(滞后)仅可用自版本7.4软件代码和以后。

  • 在版本7.4软件代码和以后, 2504能作为15个移动性通道的一个移动性锚点往其他控制器。

  • 2504支持新建的移动性(即移动性用聚合的访问控制器例如3850/5760)在版本8.0及以后。

注意:2504不在版本8.0前支持有线的访客功能,和组播单播功能(仅multicast-multicast)。它也不支持在版本8.1介绍的Lync SDN和Flexconnect AVC功能。

注意:对于支持的功能一准确列表,请检查版本注释您的特定软件版本,包含不支持WLC 2504功能

Cisco 2500系列无线控制器的硬件体系结构

这些部分提供一更加极大的见解到Cisco 2500系列无线控制器的体系结构。

思科 2500 系列无线控制器具有与思科 2106 无线控制器相同的物理外形尺寸。思科 2500 系列无线控制器具备多核 CPU,可以同时处理数据平面和无线数据流量。CPU能处理控制平面应用程序,处理必要的所有管理数据流“控制”无线网络。

思科 2500 系列无线控制器具有 1 GB 系统内存。支持两种类型的存储设备以存储软件映象。引导闪存包含引导代码,紧凑型闪存包含可存储多个映像的应用代码。前面板有四个千兆以太网端口。其中两个端口具有符合 802.3af 标准的以太网供电能力。所有端口均可转发流向/来自无线网络的流量。在以太网(PoE)端口的电源Cisco 2500系列无线控制器的不会支持直接地附加的AP,虽然那些AP也许启动和加入,它不是一个支持的方案。

思科 2500 系列无线控制器由外部 48VDC 电源模块供电。该电源模块可以处理从 110VAC 到 240VAC 不等的输入功率。

思科 2500 系列无线控制器的基本配置

您需要准备下列工具并了解相关信息后才可以安装无线控制器:

  • 无线控制器硬件:

    • 控制器及出厂时提供的电源线和安装硬件

    • 网络、操作系统的业务网和AP电缆如所需求CLI控制台的

    • CLI 控制台上的 VT-100 终端仿真程序(PC、笔记本电脑或掌上电脑)

    • 连接 CLI 控制台和控制器的空调制解调器串行电缆

  • 本地TFTP server (要求为了下载操作系统软件更新)。思科使用的是一台完整的 TFTP 服务器。这意味着第三方 TFTP 服务器无法在与 Cisco WCS 相同的工作站上运行,因为它们使用的是相同的通信端口。

如果控制器第一次启动没有前期配置,自动地加入到请求您一系列的配置信息的向导。该向导首先提示输入用户 ID 和口令。无法绕过此向导,您必须输入其询问的所有信息。

警告:请勿将 PoE 电缆连接到控制台端口。此操作损坏控制器。

控制器配置通过CLI

在配置控制器以执行基本操作之前,需要将它连接到使用 VT-100 终端仿真程序(例如 HyperTerminal、ProComm、Minicom 或 Tip)的 PC。要将 PC 连接到控制器的控制台端口,请完成以下步骤:

  1. 将空调制解调器串行电缆上的 RJ-45 连接器插入控制器的控制台端口,将该电缆的另一端插入 PC 的串行端口。

  2. 启动 PC 的终端仿真程序。

  3. 为终端仿真程序配置以下参数:

    • 9600 波特

    • 8 个数据位

    • 无流控制

    • 1 个停止位

    • 无奇偶校验

Cisco 2500系列无线控制器有4千兆以太网端口。默认情况下,每个端口均是一个 802.1Q VLAN 中继端口。该端口的 VLAN 中继特性是不可配置的。

接口是控制器中的逻辑实体。接口有多个参数关联与它;哪iinclude IP地址、默认网关(IP子网),主要的物理端口、附属物理端口、VLAN标记和DHCP服务器。由于不使用 LAG,每个接口至少要映射到一个主物理端口和一个可选的辅助端口。多个接口可以映射到一个单一的无线控制器端口。

无线控制器上有多种类型的接口,其中四个是静态类型且必须存在,在设置时进行配置:

  • 管理接口(静态类型且在设置时配置;强制性)

  • Ap-manager接口-没要求为Cisco 2500系列无线控制器

  • 虚拟接口(静态类型且在设置时配置;强制性)

  • 动态接口(用户定义)

管理接口是控制器和连接的带内管理的默认接口对企业服务例如验证、授权和统计(AAA)服务器。管理接口还可用于控制器和 AP 之间的通信。管理接口一致是在控制器的唯一的“可ping通的”在波段之内接口IP地址。默认情况下管理接口操作类似AP管理器接口。

与对此启用的“动态AP管理”选项的动态接口使用作为隧道源从控制器的数据包到AP和作为目的地从AP的CAPWAP数据包到控制器。AP 管理器的动态接口 IP 地址必须具备唯一性。通常,该地址在和管理接口相同的子网中配置,但这不是必须的要求。如果是思科 2500 系列无线控制器,单个动态 AP 管理器就可以支持任意数量的 AP。然而,作为一种最佳实践,建议提供 4 个独立的动态 AP 管理器接口,并将它们与 4 个千兆接口相关联。默认情况下,管理接口也可用作 AP 管理器接口,并关联到某个千兆接口。结果,如果使用管理接口,您只需要创建3个更加动态的AP管理器接口和关联他们到剩余3千兆接口。

虚拟接口用于支持移动性管理、DHCP 中继和嵌入式第 3 层安全(例如访客 Web 身份验证和 VPN 终端)。必须为虚拟接口配置一个未分配的且未使用的网关 IP 地址。一个典型的虚拟接口是 1.1.1.1。虚拟接口地址是不连通的,且不应存在于网络中的任何路由表内。

动态接口由用户创建,类似于无线局域网客户端设备的 VLAN。思科 2500 系列无线控制器支持多达 16 个动态接口。动态接口必须在唯一的 IP 网络和 VLAN 中配置。每个动态接口都可用作关联到它所映射的无线 LAN (WLAN) 的无线客户端的 DHCP 中继接口。WLAN关联服务集标识(SSID)对接口和配置与安全、QoS、无线电策略和其他无线网络参数。每个控制器可配置多达 16 个 WLAN。管理服务器,例如RADIUS服务器和Ntp server,不应该在动态接口子网,然而应该在管理接口子网或其他子网没被添加到WLC。

注意:Cisco 2500系列无线仅控制器支持滞后在版本7.4软件代码和以后。

配置邻接交换机

默认情况下,思科 2500 系列无线控制器的所有四个端口都是 802.1Q 中继端口。该系列的控制器始终连接到邻接交换机上的千兆以太网端口。邻接交换机端口配置为 802.1Q 中继,而该中继仅允许使用合适的 VLAN。所有其他 VLAN 都受到修剪。这不是必要的,然而是部署最佳实践,因为,当毫不相关的VLAN被修剪时,优化性能的控制器只处理相关帧。

以下是 802.1Q 交换机的端口配置:

switchport 
switchport trunk encapsulation dot1q
switchport trunk native vlan X
switchport trunk allowed vlan X
switchport mode trunk
end

配置思科 2500 系列无线控制器

配置有启动向导的控制器

此向导输出从版本7.4软件被采取,因此也许是有些不同的在其它软件软件版本。

(Cisco Controller)(Cisco Controller)


Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup


Would you like to terminate autoinstall? [yes]:
AUTO-INSTALL: starting now...
rc = 0
AUTO-INSTALL:no interfaces registered.
AUTO-INSTALL: process terminated - no configuration loaded


System Name [Cisco_b2:19:c4] (31 characters max):WLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (3 to 24 characters): *******
Re-enter Administrative Password                 : *******

Enable Link Aggregation (LAG) [yes][NO]: no

Management Interface IP Address: 10.48.39.212
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 10.48.39.5
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1 to 4]: 1
Management Interface DHCP Server IP Address: 10.48.39.5

Virtual Gateway IP Address: 1.1.1.1

Multicast IP Address: 239.1.1.1

Mobility/RF Group Name: Nico

Network Name (SSID): none

Configure DHCP Bridging Mode [yes][NO]: no

Allow Static IP Addresses [YES][no]: yes

Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.

Enter Country Code list (enter 'help' for a list of countries) [US]: BE

Enable 802.11b Network [YES][no]: yes
Enable 802.11a Network [YES][no]: yes
Enable 802.11g Network [YES][no]: yes
Enable Auto-RF [YES][no]: yes

Configure a NTP server now? [YES][no]: yes
Enter the NTP server's IP address: 10.48.39.33
Enter a polling interval between 3600 and 604800 secs: 3600

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Configuration saved!
Resetting system with new configuration...


Configuration saved!
Resetting system

注意:先前配置是示例。它也许与一个安装有所不同到另一个。

(Cisco Controller) >show sysinfo

Manufacturer's Name.............................. Cisco Systems Inc.
Product Name..................................... Cisco Controller
Product Version.................................. 7.4.121.0
Bootloader Version............................... 1.0.20
Field Recovery Image Version..................... 7.6.101.1
Firmware Version................................. PIC 16.0


Build Type....................................... DATA + WPS

System Name...................................... WLC
System Location..................................
System Contact...................................
System ObjectID.................................. 1.3.6.1.4.1.9.1.1279
IP Address....................................... 10.48.39.212
Last Reset....................................... Software reset
System Up Time................................... 0 days 0 hrs 14 mins 58 secs
System Timezone Location.........................
System Stats Realtime Interval................... 5
System Stats Normal Interval..................... 180


--More-- or (q)uit
Configured Country............................... BE  - Belgium
Operating Environment............................ Commercial (0 to 40 C)
Internal Temp Alarm Limits....................... 0 to 65 C
Internal Temperature............................. +31 C
External Temperature............................. +35 C
Fan Status....................................... 4300 rpm

State of 802.11b Network......................... Enabled
State of 802.11a Network......................... Enabled
Number of WLANs.................................. 1
Number of Active Clients......................... 0

Memory Current Usage............................. Unknown
Memory Average Usage............................. Unknown
CPU Current Usage................................ Unknown
CPU Average Usage................................ Unknown

Burned-in MAC Address............................ 84:78:AC:B2:19:C0
Maximum number of APs supported.................. 75

安装许可证

思科 2500 系列无线控制器没有安装任何许可证。如果不安装任何许可证,AP 将无法加入控制器。当您去向前,推荐安装在Cisco 2500系列无线控制器的适当的许可证为了与控制器一起使用。思科 2500 系列无线控制器附带了一个为期 60 天(即 8 周零 4 天)的评估许可证。评估许可证只是一个基础许可证。

指定许可证在有CLI或GUI的控制器可以安装。通过 CLI 和 GUI 都可以检查已安装的许可证。在两种情况下,应该有主机许可证文件的TFTP server。

(Cisco Controller) >license install ?
<url> tftp://<server ip>/<path>/<filename>
(Cisco Controller)

show license all 命令可以显示已安装的许可证。

注意:此许可证包含数据 DTLS 功能。

(Cisco Controller) >show license all

License Store: Primary License Storage
StoreIndex: 2 Feature: base-ap-count Version: 1.0
License Type: Permanent
License State: Active, In Use

License Count: 50/50/0
License Priority: Medium
StoreIndex: 3 Feature: data encryption Version: 1.0
License Type: Permanent
License State: Active, In Use

License Count: Non-Counted
License Priority: Medium
License Store: Evaluation License Storage
StoreIndex: 0 Feature: base Version: 1.0
License Type: Evaluation
License State: Active, Not in Use, EULA accepted
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
License Count: Non-Counted
License Priority: Low
StoreIndex: 1 Feature: base-ap-count Version: 1.0
License Type: Evaluation
License State: Inactive
Evaluation total period: 8 weeks 4 days
Evaluation period left: 8 weeks 4 days
License Count: 50/0/0
License Priority: None
(Cisco Controller) >

在思科 2500 系列无线控制器中启用 DTLS

要在一个 AP 或(尤其是)一组 AP 上启用 DTLS,请确保您已在控制器中安装了数据加密许可证。选择 AP 详细信息后,可以从“Advanced”选项卡中为每个 AP 启用 DTLS(数据加密)。

选择AP,去高级选项卡。,并且检查数据加密复选框。

(Cisco Controller) >config ap link-encryption enable ? 
<Cisco AP> Enter the name of the Cisco AP. all Apply the configuration for
all capable Cisco AP
(Cisco Controller) >config ap link-encryption enable J-3502E
(Cisco Controller) >show ap link-encryption all
Encryption Dnstream Upstream Last
AP Name State Count Count Update
-------------- --- -------- -------- ------
J-3502E En 102 747 22:12
J-1262 Dis 0 0 22:12
J-1040 Dis 0 0 22:13
J-1140 Dis 0 0 22:10

(Cisco Controller) >show dtls connections

AP Name Local Port Peer IP Peer Port Ciphersuite
------------ ------------- ------------- ---------- ------------------
J-3502E Capwap_Ctrl 10.10.10.116 41066 TLS_RSA_WITH_AES_128_CBC_SHA
J-3502E Capwap_Data 10.10.10.116 41066 TLS_RSA_WITH_AES_128_CBC_SHA
J-1262 Capwap_Ctrl 10.10.10.120 45543 TLS_RSA_WITH_AES_128_CBC_SHA
J-1040 Capwap_Ctrl 10.10.10.122 65274 TLS_RSA_WITH_AES_128_CBC_SHA
J-1140 Capwap_Ctrl 10.10.10.123 4825 TLS_RSA_WITH_AES_128_CBC_SHA

(Cisco Controller) >

配置PI并且添加Cisco 2500系列无线控制器

PI是用于的当前管理软件管理Cisco 2500系列无线控制器。更早版本呼叫WCS或NCS。它提供先进的管理工具类似无线覆盖显示和基于位置的服务。有在管理系统(头等Infrastructure/NCS/WCS)的软件版本和WLC软件版本之间的密切关系。请参阅无线软件兼容性矩阵以及头等基础设施和WLC版本注释关于支持的兼容的版本。头等基础设施使用SNMP为了管理无线控制器、接入点和客户端设备。思科 2500 系列无线控制器设备需要正确配置 SNMP。

完成这些步骤:

  1. 登陆对与URL的PI Web接口:

    https://<prime-ip-address>

  2. SNMPv2 是在思科 2500 系列无线控制器上配置的。为了通过控制器Web接口配置SNMPv2,请选择Management> SNMP >公共。在思科 2500 系列无线控制器中,只读和读写社区的默认设置分别为公共和私有。您可以根据需要添加或修改。为了简单起见,这里使用的是默认值。

  3. 在PI接口,请选择操作>设备工作区。选择从菜单栏添加设备。注意这也许有所不同从属,如果使用从PI的经典主题或,如果您ucs NCS或WCS。

  4. 输入Cisco 2500系列无线控制器管理接口的IP地址并且配置适当的SNMP参数。单击 Ok

    控制器成功地添加,并且Cisco 2500系列无线控制器准备由PI设置。

为了验证Cisco 2500系列无线控制器,在PI后被添加,请返回检查在设备工作区,如果顺利地被同步并且被管理。错误的SNMP凭证也许留给它“不受管理”。

思科 2500 系列无线控制器的部署场景

Cisco 2500系列无线控制器提供一个有效Unified无线解决方案。虽然该控制器具有多个 10/100/1000 端口,但它无法充当交换机或路由器。不建议使用不同端口来实现集线器/交换机的功能。此基本的点是使佳性能的关键因素脱离控制器。

Cisco 2500系列无线控制器支持多上行链路端口。在版本7.4中及以后您能使用滞后为了构件EtherChannel和对待几个端口作为一连接。或者,您能禁用滞后和配置管理和动态接口在不同的物理端口可以配置的系统,并且数据流能反复交换在下从各自物理端口的网络。

跳起与管理接口的Cisco 2500系列无线控制器也支持广泛AP管理器(AP负载均衡)广泛AP管理器可以配置除Ap-manager之外的地方。在这种情况下,建议将所有 AP 管理器放在与管理接口相同的子网中。

<CISCO2504> >show interface summary

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2 2 10 10.10.10.12 Dynamic Yes No
apmgr3 3 10 10.10.10.13 Dynamic Yes No
apmgr4 4 10 10.10.10.14 Dynamic Yes No
management 1 10 10.10.10.10 Static Yes No
virtual N/A N/A 1.1.1.1 Static No No

<CISCO2504> >

在上面的输出中,管理接口和 AP 管理器一起绑定到端口 1。另外创建的三个 AP 管理器创建到与管理接口相同的子网中的其他物理端口(2、3 和 4)上。

加入控制器的AP是被均衡这样的负载控制器的每个端口共享负载50 AP。每个端口在先前配置里允许13 AP加入控制器。

也可以在与管理接口不同的子网中设置多个 AP 管理器。但是,在这种情况下,建议禁用管理接口的 AP 管理器,并在与管理接口不同的子网中的不同物理端口上创建另一个 AP 管理器接口。在此场景中,所有这些 AP 管理器都应位于同一个子网中。

<CISCO2504> >show interface summary

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
--------------------- ---- -------- -------------- ------- ------ -----
apmgr2 2 11 10.10.11.12 Dynamic Yes No
apmgr3 3 11 10.10.11.13 Dynamic Yes No
apmgr4 4 11 10.10.11.14 Dynamic Yes No
management 1 10 10.10.10.10 Static No No
virtual N/A N/A 1.1.1.1 Static No No

<CISCO2504> >

在上一个输出中,管理和Ap-manager没有跳起。在此场景中,可以在与管理接口不同的子网中创建多个 AP 管理器,并映射到不同的物理端口。

注意:内部DHCP服务器只运作(为无线客户端)与DHCP代理启用。

下面介绍思科 2500 系列无线控制器支持的一些场景和示例配置。

场景 1

与一嵌入式Ap-manager的管理接口在Port1配置。两个 WLAN 是在控制器上配置的。WLAN 1 和 WLAN 2 都映射到管理接口。

简单拓扑包含已连接到 Catalyst 3560 交换机的思科 2500 系列无线控制器。控制器上的千兆以太网端口 1 连接到交换机上的千兆以太网端口 1/0/1。

Switch#sh run int gig 1/0/1
Building configuration...

Current configuration : 123 bytes
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
end

Switch#

在Cisco 2500系列无线控制器的管理接口配置是直接的并且有启用的动态AP管理。

配置了两个 WLAN。WLAN1和WLAN2被映射对管理接口并且服务客户端。

<CISCO2504> >show wlan summ

Number of WLANs.................................. 2

WLAN ID WLAN Profile Name / SSID Status Interface Name
------- ------------------------------------- -------- --------------------
1 WLAN1 / WLAN1 Enabled management
2 WLAN2 / WLAN2 Enabled management

<CISCO2504> >

DHCP 代理已启用的内部 DHCP 服务器

DHCP服务器TestVlan10在控制器和此范围服务AP和客户端配置。控制器上的 DHCP 服务器的配置很简单。

<CISCO2504> >show dhcp summary

Scope Name Enabled Address Range
TestVlan10 Yes 10.10.10.100 -> 10.10.10.200


<CISCO2504> >show dhcp detailed TestVlan10
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.10.100
Pool End.................................. 10.10.10.200
Network................................... 10.10.10.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.10.10 0.0.0.0 0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0 0.0.0.0 0.0.0.0
Netbios Name Servers...................... 0.0.0.0 0.0.0.0 0.0.0.0

<CISCO2504> >

这是从Cisco 2500系列无线控制器的GUI的DHCP配置捕获:

在所有思科无线控制器上都默认启用 DHCP 代理。

在所有先前配置, VLAN10在交换机没有被标记。来自交换机的所有流量都传输到控制器的端口 1。AP和客户端的流量转发到无标记的控制器。

AP 连接到采用这些交换机端口配置的 Catalyst 交换机。交换机端口可以配置为中继端口或接入端口。

Switch#sh run int gig 1/0/9
Building configuration...

Current configuration : 132 bytes
!
interface GigabitEthernet1/0/9
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport mode trunk
end

Switch#sh run int gig 1/0/10
Building configuration...

Current configuration : 66 bytes
!
interface GigabitEthernet1/0/10
switchport access vlan 10
end

Switch#

AP 可以加入控制器,并且 AP 的状态可以在控制器上进行验证。有加入控制器,并且可以由在此捕获的状态确认的两AP :

<CISCO2504> >show ap join stats summary all

Number of APs.............................................. 2

Base Mac AP EthernetMac AP Name IP Address Status
00:22:90:96:69:00 00:22:90:90:ab:d3 AP0022.9090.abd3 10.10.10.103 Joined
ec:44:76:b9:7d:c0 c4:7d:4f:3a:e3:78 APc47d.4f3a.e378 10.10.10.105 Joined


<CISCO2504> >show ap summary

Number of APs.................................... 2

Global AP User Name.............................. Not Configured
Global AP Dot1x User Name........................ Not Configured

AP Name Slots AP Model Ethernet MAC Location
---------------- ----- ----------------- ----------------- ----------------
AP0022.9090.abd3 2 AIR-LAP1142N-A-K9 00:22:90:90:ab:d3 default location
APc47d.4f3a.e378 2 AIR-CAP3502E-A-K9 c4:7d:4f:3a:e3:78 default location

Port Country Priority
---- ------- ------
1 US 1
1 US 1

加入控制器的AP可能由在控制器的AP的摘要也验证。配置AP名称和AP安装的位置。

配置控制器名称和IP地址在高可用性下为了填装AP。

使用此配置, AP加入已配置的控制器作为第一个首选。

DHCP 代理已禁用的外部 DHCP 服务器

这是一项通用的设置,所有思科控制器都在实践中用它执行部分部署。配置几乎是相同的象以前注释,但是有DHCP代理禁用。

在此场景中的 AP 管理器接口都指向外部 DHCP 服务器。

注意:建议启用一个内部 DHCP 服务器或一个外部 DHCP 服务器。

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
!

DHCP 代理已启用的外部 DHCP 服务器

这是一项通用的设置,是面向所有思科控制器的最佳实践之一。此配置几乎与上一部分中介绍的配置相同,但 DHCP 代理被启用。

在此场景中的管理接口总是指向外部 DHCP 服务器。

ip dhcp excluded-address 10.10.11.1 10.10.11.150
!
ip dhcp pool VLAN11
network 10.10.11.0 255.255.255.0
default-router 10.10.11.1
!

场景 2

AP 管理器已启用的管理接口映射到端口 1。动态接口 dynamic11 映射到另一个用于传输数据流量的物理接口(端口 2)。WLAN 1被映射对管理接口,并且WLAN 2被映射对动态接口。

在控制器上配置多个 DHCP 作用域。这个已配置的 DHCP 作用域 TestVlan11 映射到控制器上已配置的动态接口。

<CISCO2504> >show dhcp summary

Scope Name Enabled Address Range
TestVlan10 Yes 10.10.10.100 -> 10.10.10.200
TestVlan11 Yes 10.10.11.100 -> 10.10.11.200


<CISCO2504> >show dhcp detailed TestVlan11
Scope: TestVlan10

Enabled................................... Yes
Lease Time................................ 36400 <10 hours 6 minutes 40 seconds>
Pool Start................................ 10.10.11.100
Pool End.................................. 10.10.11.200
Network................................... 10.10.11.0
Netmask................................... 255.255.255.0
Default Routers........................... 10.10.11.10 0.0.0.0 0.0.0.0
DNS Domain................................
DNS....................................... 0.0.0.0 0.0.0.0 0.0.0.0
Netbios Name Servers...................... 0.0.0.0 0.0.0.0 0.0.0.0

<CISCO2504> >

DHCP 代理已启用的内部 DHCP 服务器

默认情况下,DHCP 代理在控制器上启用,和在前面的一个截图中看到的一样。动态接口 dynamic11 已配置,并映射到 VLAN11。该接口还映射到已配置的内部 DHCP 服务器。没有为动态 AP 管理启用动态接口。

已配置的 WLAN 之一映射到管理接口,第二个 WLAN 映射到已配置的动态接口 dynamic11。主 DHCP 服务器对于此场景中的配置是必需的,但应指向管理接口。

DHCP 代理已禁用的外部 DHCP 服务器

客户端从已配置的外部DHCP服务器顺利地获得IP地址。验证内部 DHCP 服务器的状态并确保内部 DHCP 服务器被禁用。

DHCP 代理已启用的外部 DHCP 服务器

客户端从已配置的外部DHCP服务器顺利地获得IP地址。

场景 3

AP 管理器已启用的管理接口映射到端口 1。端口 2 被配置为一个备份端口。WLAN 1 映射到管理接口。

在此场景中,管理接口和动态接口都可通过内部或外部 DHCP 服务器配置到端口 1。端口 1 和 2 连接到 2 个不同的交换机。这可以为第 2 层和第 3 层交换网络提供冗余,如该拓扑和界面截图所示。

场景 4:滞后

在版本7.4在WLC的及以后软件方面,配置滞后是可能的。注意所有2504 WLC吞吐量逗留1 Gbps,无论许多端口您连接。

在此方案中,端口1和2 WLC 2504连接到在端口8和10的同一交换机被捆绑到port-channel1。它要求插入所有WLC端口到同一交换机(除非一旦在VSS的2台在VPC的Catalyst 6000或连结)。

(Cisco Controller) >show port summary

STP Admin Physical Physical Link Link
Pr Type Stat Mode Mode Status Status Trap POE
-- ------- ---- ------- ---------- ---------- ------ ------- -------
1 Normal Forw Enable Auto 1000 Full Up Enable N/A
2 Normal Forw Enable Auto 1000 Full Up Enable N/A
3 Normal Disa Enable Auto Auto Down Enable N/A
4 Normal Disa Enable Auto Auto Down Enable N/A


(Cisco Controller) >show lag summary

LAG Enabled

(Cisco Controller) >show interface summary


Number of Interfaces.......................... 2

Interface Name Port Vlan Id IP Address Type Ap Mgr Guest
-------------------------------- ---- -------- --------------- ------- ------ -----
management LAG untagged 10.48.39.212 Static Yes No
virtual N/A N/A 1.1.1.1 Static No No

(Cisco Controller) >show interface detailed management

Interface Name................................... management
MAC Address...................................... 84:78:ac:b2:19:cf
IP Address....................................... 10.48.39.212
IP Netmask....................................... 255.255.255.0
IP Gateway....................................... 10.48.39.5
External NAT IP State............................ Disabled
External NAT IP Address.......................... 0.0.0.0
VLAN............................................. untagged
Quarantine-vlan.................................. 0
Active Physical Port............................. LAG (13)
Primary Physical Port............................ LAG (13)
Backup Physical Port............................. Unconfigured
DHCP Proxy Mode.................................. Global
Primary DHCP Server.............................. 10.48.39.5
Secondary DHCP Server............................ Unconfigured
DHCP Option 82................................... Disabled
ACL.............................................. Unconfigured
mDNS Profile Name................................ Unconfigured
AP Manager....................................... Yes
Guest Interface.................................. No
L2 Multicast..................................... Enabled

您能看到选择接口的端口在WLC当前是不可能的,因为他们全部附加对永远将显示作为第13)的滞后端口套件(。

在交换机上,参加套件的所有端口必须有一模一样的配置(中继本地VLAN和特别是允许VLAN)。在本例中,允许VLAN对是最佳实践的什么被限制了在WLC将使用。

一旦接口与channel-group命令x模式一起被捆绑,端口信道接口第x创建。其中任一请促进配置的更改应该再完成在端口通道接口和不在单个端口。

Nico3560C#show run int g0/8
Building configuration...

Current configuration : 208 bytes
!
interface GigabitEthernet0/8
switchport access vlan 33
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
end

Nico3560C#show run int g0/10
Building configuration...

Current configuration : 182 bytes
!
interface GigabitEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
mls qos trust dscp
channel-group 1 mode on
end


Nico3560C#show etherchannel 1 summ
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) - Gi0/8(P) Gi0/10(P)

Nico3560C#

Nico3560C#show run int po1
Building configuration...

Current configuration : 131 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,30-39
switchport mode trunk
end

 命令eterchannel负载均衡src-dst-ip在交换机也要求全局此的能工作。

这些是用户实现的一些设计为了有效利用无线服务到他们的有CUWN的客户端设备。

部署Cisco2500无线控制器的指南

思科2500系列无线控制器的以太网端口不工作作为交换机端口(即两台机器直接地连接对这些端口不能与彼此联络)。您在这些端口不应该连接服务器,例如DHCP, TFTP,等等,并且盼望无线客户端和AP收到从此DHCP服务器的一个IP地址。

思科 2500 系列无线控制器的以太网端口只有正确配置了数据接口(管理接口和动态接口)或 AP 管理器接口后才能用于连接/上行到网络基础设施。

如果思科 2500 系列无线控制器上的多个以太网端口上行到基础设施交换机,应确保数据接口(管理接口或动态接口)或 AP 管理器接口配置为这些上行端口。使用的物理以太网端口,因为不应该留下对一在下交换机的一上行链路没有配置。这也许导致意外行为。

组播单播不是在Cisco 2500系列无线控制器的一个支持的配置。结果,因为HREAP/Flexconnect AP只与组播单播一起使用, HREAP/Flexconnect AP不能对接收组播流量。

Web快速设置

在版本7.6.130和以上, WLC提供GUI的Express版本。它是方式通过GUI配置显示您第一次连接的它,但是也是一简化的监控的控制板。

在第一GUI连接您将看到此:

此页显示所有监视数据以容易和可访问方式。为了到达“旧有”和完整GUI,您能点击先进在右上角。一旦是在Advanced模式,您不可以回到快速GUI,除非配置WLC。作为快速设置GUI的好处,您将有在返回的WLC页的右上角的一个家庭按钮对Express监听页。

为了通过快速设置GUI配置2504,您需要连接PC到端口2,等待导致的SYS启用绿色,然后浏览对在您的浏览器的192.168.1.1。这在端口2只运作,允许您连接WLC端口1网络连通性的。

控制器的配置通过快速设置GUI也更改多种默认设置改善匹配小型企业部署。

一个特殊向导为配置然后将出现:

高可用性

在版本7.5软件代码和以后, 2500可以采购作为HA-SKU。这意味着2504能然后作为N+1 WLC。它仍然不支持AP SSO。

万一其移动组所有其他WLC发生故障, HA SKU WLC不要求许可证并且突出那里。它可以然后支持最大数量AP计数许可证90天,开始,当原始WLC失败,并且,当开始的APS加入HA-SKU。没有在N+1 redudancy的配置复制。检查高性能的部署指南关于HA的更多信息。

当您启用HA SKU备用单元时,把非HA SKU WLC变成HA SKU也是可能的:


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


Document ID: 113034