IP : IP 可被路由的协议

两个不同服务提供商(多宿)间的 BGP 的 IPv6 配置示例

2016 年 10 月 25 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

边界网关协议 (BGP) 是用于实现 Internet 连接冗余的关键协议之一。当您将网络连接到两个不同的 Internet 服务提供商 (ISP) 时,此操作称为多宿主。多宿主可提供冗余和网络优化。它选择为资源提供最佳路径的 ISP。在采用多个服务提供商运行 BGP 时,存在自治系统 (AS) 可能成为中转 AS 的风险。这会导致 Internet 流量通过 AS,可能占用路由器 CPU 的所有带宽和资源。本文档对此问题进行讨论,并提供相应的配置示例。

先决条件

要求

在您继续之前,请参考此文档:

两个不同服务提供商(多宿)间的 BGP 的示例配置

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco 2800系列路由器用Cisco IOS�软件版本12.4(13r)T

  • 装有 Cisco IOS 软件版本 12.4(13r)T 的 Cisco 3800 系列路由器

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

/image/gif/paws/112228/bgp2isp-01.gif

在此网络中,路由器 A 连接至两个不同的服务提供商 SP-A 和 SP-B,形成多宿主,其中 1010:1010::/64 和 2020:2020::/64 由 AS 101 向外部通告,网络 1212:1212::/64 从两个不同的 AS,即 AS 202 和 AS 303 进行接收。

注意: 这是链路到视频(在Cisco支持社区的联机leavingcisco.com ) BGP多宿该提供概述并且提关于怎样的建议排除故障普通的BGP问题类似同位体和高CPU。

BGP 多宿主:设计和故障排除 - 网络直播视频leavingcisco.com

配置

本文档使用以下配置:

路由器 A
Router-A#
ipv6 unicast-routing

!---Enables the forwarding of IPv6 packets.

ipv6 cef
interface Serial3/0
 description CONNECTED TO SP-A
 ip address 192.168.10.1 255.255.255.0
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
 clock rate 64000
!
interface Serial3/1
 description CONNECTED TO SP-B
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 clock rate 64000
!
 router bgp 101
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 remote-as 202

!--- Configures SP-A as neighbor.

 neighbor 1202:ABCD::21B:54FF:FEA9:24B0 ebgp-multihop 2
 neighbor 2303:ABCD::21B:54FF:FE54:FB10 remote-as 303

!--- Configures SP-B as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21B:54FF:FEA9:24B0 activate
  neighbor 2303:ABCD::21B:54FF:FE54:FB10 activate
  network 1010:1010::/64
  network 2020:2020::/64
 exit-address-family
!

服务提供商 A
SP-A#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 1202:ABCD::/64 eui-64
 ipv6 enable
 no fair-queue
!
router bgp 202
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 1202:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configuers Router A as neighbor.

 !
 address-family ipv6
  neighbor 1202:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

服务提供商 B
SP-B#
ipv6 unicast-routing
ipv6 cef
interface Serial1/0
 no ip address
 ipv6 address 2303:ABCD::/64 eui-64
 no fair-queue
!
router bgp 303
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 2303:ABCD::21C:58FF:FEED:3E90 remote-as 101

!--- Configures as Router A as neighbor.

 neighbor 2303:ABCD::21C:58FF:FEED:3E90 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 2303:ABCD::21C:58FF:FEED:3E90 activate
  network 1212:1212::/64
 exit-address-family
!

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • 路由器 A 与两个 ISP 配对

    Router-A#
    show bgp ipv6 unicast summary
    
    BGP router identifier 1.1.1.1, local AS number 101
    BGP table version is 6, main routing table version 6
    3 network entries using 447 bytes of memory
    4 path entries using 304 bytes of memory
    4/2 BGP path/bestpath attribute entries using 496 bytes of memory
    2 BGP AS-PATH entries using 48 bytes of memory
    0 BGP route-map cache entries using 0 bytes of memory
    0 BGP filter-list cache entries using 0 bytes of memory
    BGP using 1295 total bytes of memory
    BGP activity 3/0 prefixes, 14/10 paths, scan interval 60 secs
    
    Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
    1202:ABCD::21B:54FF:FEA9:24B0   4   202   108     119   6    0    0 00:31:41   1
    2303:ABCD::21B:54FF:FE54:FB10   4   303   108     121   6    0    0 00:25:1    1
    
    !--- Indicates that Router A is peering with both the ISP SP-A and SP-B
    
    
  • 路由器 A 从 SP-A 和 SP-B 获取路由

    Router-A#show bgp ipv6 unicast
    BGP table version is 6, local router ID is 1.1.1.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   ::                       0                          32768 i
    *  1212:1212::/64   2303:ABCD::21B:54FF:FE54:FB10 0  0 303 i
    *>                              1202:ABCD::21B:54FF:FEA9:24B0 0  0 202 i
    *> 2020:2020::/64   ::                       0                         32768 i
  • 在 SP-A 上:

    SP-A#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 2.2.2.2
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
    *> 1212:1212::/64   ::                       0            32768              i
    *> 2020:2020::/64   1202:ABCD::21C:58FF:FEED:3E90 0 0 101 i
  • 在 SP-B 上:

    SP-B#sh bgp ipv6 unicast
    BGP table version is 4, local router ID is 3.3.3.3
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
                  r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    
       Network          Next Hop            Metric LocPrf Weight Path
    *> 1010:1010::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i
    *  1212:1212::/64   2303:ABCD::21C:58FF:FEED:3E90  0                 101 202 i
    *>                  ::                       0         32768 i
    *> 2020:2020::/64   2303:ABCD::21C:58FF:FEED:3E90 0             0 101 i

故障排除

使用 debug bgp ipv6 update 命令以便显示关于更新的调试信息,帮助确定对等体状态。


相关信息


Document ID: 112228