语音和统一通信 : Cisco Unified Communications Manager Express

Cisco 统一通信管理器Express :SIP实施指南

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文为设置独立Cisco Unified Communications Manager Express (CME)该用途SIP电话提供逐步指导。本文略述一个Cisco Unified Communications Manager Express系统用四个SIP电话,有设置的Cisco Unified Communications Manager Express系统和SIP电话配置的。

注意: 虽则本文包括配置步骤准许Cisco Unified Communications Manager Express与Cisco Unity Express兼容, Cisco Unity Express配置是在范围本文外面。参考Cisco CallManager Express /Cisco Unity Express配置示例关于Cisco Unified Communications Manager Express和Cisco Unity Express配置的更多信息。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下硬件版本:

  • Cisco运行Cisco Unified Communications Manager Express 4.2以Cisco IOS 软件版本12.4(11)XW2的2801

  • 9波尔特两倍范围10/100BASE-T以太网交换机HWIC

  • 思科7970个SIP电话

  • 思科3911 SIP电话

本文档中的信息根据这些固件版本:

  • 7970个IP电话(SIP) — SIP70.8-2-1S

  • 3911个IP电话(SIP) — SIP3951.8-0-2-9

参考的Cisco Unified CME和Cisco IOS软件版本兼容性矩阵为了确定适当的SIP固件使用每个Cisco Unified Communications Manager Express版本。因为使用Cisco Unified Communications Manager Express 4.2,参考Cisco Unified Communications Manager Express 4.2规格链路。

SIP phoneloads可以从这些位置下载:

在您解两个压缩在您的TFTP文件夹后的压缩文件,请复制在Cisco Unified Communications Manager Express闪存上的所有固件文件与您的TFTP server。确保您复制在闪存上的所有这些文件。

SIP3951.8-0-2-9.loads
SIP3951.8-0-2-9.zz
DSP3951.0-0-0-1.zz
BOOT3951.0-0-0-9.zz
SIP70.8-2-1S.loads
term70.default.loads
term71.default.loads
apps70.8-0-2-55.sbn
cnu70.8-2-0-55.sbn 
cvm70.sip.8-2-0-55.sbn
dsp70.8-2-0-55.sbn
jar70.sip.8-0-2-25.sbn

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

这些表概述在此设置使用的编址方案。

目的 VLAN 网络 接口 接口地址
语音 192 192.168.10.0/24 VLAN 192 192.168.10.1/24
数据 100 10.10.10.0/24 VLAN 100 10.10.10.1/24

协议 电话类型 分机号 电话号码外部掩码
SIP 7970 101 4085251001
SIP 7970 102 4085251002
SIP 3911 103 4085251003
SIP 3911 104 4085251004

语音邮件实验号码 100 AA试验 110
MWI 800 MWI 801

注意: 请使用为了得到关于用于此部分的命令的更多信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/99946/cme-sip-guide01.gif

系统配置

本文档使用以下配置:

配置 DHCP

配置两个独立的DHCP池是必要的;IP电话使用语音DHCP池和仅供PC使用数据DHCP池。IP电话需要Use DHCP选项150为了提供TFTP server的IP地址。

如果有任何设备在任何一个池用静态IP地址,请确保这些地址从DHCP池被排除为了避免地址冲突。寻址从路由器的IP电话和PCs接收的您能使用show ip dhcp binding命令为了验证。

DHCP 配置
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1
   default-router 192.168.10.1

配置快速以太网接口和连接孔

在此部分,您配置数据和语音VLAN的VLAN接口并且分配连接孔到他们的各自的VLAN。

注意: 在VLAN的配置之前,请务必添加上一个VLAN对VLAN数据库用这些命令:

快速以太网接口和交换端口配置
CME-SIP#vlan database
% Warning: It is recommended to configure VLAN from config mode,
 as VLAN database mode is being deprecated. Please consult user
  documentation for configuring VTP/VLAN in config mode.

CME-SIP(vlan)#vlan 100
VLAN 100 modified:
CME-SIP(vlan)#vlan 192
VLAN 192 modified:
CME-SIP(vlan)#exit
APPLY completed.
Exiting....
CME-SIP#

配置将连接的连接孔对语音和数据VLAN。IP电话自动地分配到分配到数据VLAN直接地连接到switchport或连接的语音VLAN和PCs到在IP电话的switchport。

DHCP 配置
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! 
 interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
! !
interface Vlan100
description Data VLAN
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
description Voice VLAN
 ip address 192.168.10.1 255.255.255.0

配置TFTP

此配置准许Cisco Unified Communications Manager Express为IP电话他们的固件服务。

注意: 此配置是必须。

TFTP 配置
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn

配置基本电话功能

配置语音服务参数

配置系统允许呼叫从SIP到SIP终端和启用SIP管理员。

注意: 此配置是必须。

语音服务参数配置
voice service voip
allow-connections sip to sip 

!--- Enable SIP to SIP calls.

sip
registrar server expires max 1200 min 300 

!--- Enable Cisco IOS SIP registrar.

配置语音寄存器全局参数

在此部分,您配置语音寄存器全局参数。

注意: 语音SIP的寄存器全局配置类似于SCCP电话的telephony-service配置参数。

注意: 此配置是必须。

语音寄存器全局参数配置
voice register global                     
 mode cme  

!--- Set Cisco IOS SIP registrar to CME mode.

 source-address 192.168.10.1 port 5060 

!--- Set the source address for phone registration.

 max-dn 20 

!--- Set max extensions.

 max-pool 10 

!--- Set max phones.

 load 7970 SIP7 SIP70.8-2-1S 

!--- Specify phone loads for each phone type.

 load 3911 SIP3951.8-0-2-9 

!--- Specify phone loads for each phone type.

 authenticate register 

!--- Set authentication for phone registration.

 authenticate realm cisco.com 
 tftp-path flash:  

!--- Specify path for tftp files.

 create profile 

!--- Create configuration files for all phones.

 dialplan-pattern 1 4085251... extension-length 3  

!--- Configure dial-plan pattern for the system.

这是链路到在解释步骤leavingcisco.com 注册有Cisco Unified Communications Manager Express的一个IP电话的Cisco支持社区的一个视频(CME)使用SIP协议, :

注册一个79xx系列IP电话使用在CUCME的SIP协议leavingcisco.com

/image/gif/paws/99946/cme-sip-guide02.gif

配置对Cisco Unity Express的连接

配置必要的dial-peer和MWI ephone-dn与Cisco Unity Express兼容。为了Cisco Unified Communications Manager Express能兼容与Cisco Unity Express,紧接配置SIP Cisco Unified Communications Manager Express作为一个用户代理(B2BUA)是必要的,因此意味着所有信令和RTP数据流通过Cisco Unified Communications Manager Express。此配置要求为了启用连接到Cisco Unity Express。

Cisco Unity Express连接配置
dial-peer voice 2 voip
    destination-pattern 1.0  

!--- Specify destination-pattern to reach CUE VM and AA.

    session target ipv4:10.1.10.1  

!--- Configure IP address to reach Cisco Unity Express.

    session protocol sipv2
    dtmf-relay sip-notify  

!--- Configure DTMF method to communicate with Cisco Unity Express.

    b2bua  

!--- Enable B2BUA for Cisco Unified Communications Manager Express
!--- for calls to Cisco Unity Express.

    codec g711ulaw 
    no vad

配置Cisco Unity Express叫牌的MWI支持为了启用SIP电话的MWI。

Cisco Unity Express MWI配置
ephone-dn 11
number 800
mwi on
!
ephone-dn 12
number 801
mwi off

配置分机和参数

配置语音寄存器dn为了创建ephone的分机号。在上一个网络拓扑里,有四扩展,需要创建如给此处。

注意: 此配置是必须。

分机配置
voice register dn 1 
name Phone1 

!--- Set display name.

label 4085251001  

!--- Set display label.

number 101 

!--- Set extension number.

call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch  

!--- Allow this number to be watched (presence).

! 
voice register dn 2 
name Phone2
label 4085251002
number 102 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch
!
voice register dn 3 
name Phone3
label 4085251003
number 103 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch 
! 
voice register dn 4 
name Phone4
label 4085251004
number 104 
call-forward b2bua noan 100 timeout 20  

!--- Configure call forward noan to voicemail pilot.

call-forward b2bua busy 100 timeout 20  

!--- Configure call forward busy to voicemail pilot.

allow watch

配置SIP电话

配置语音寄存器每SIP电话的池参数。

注意: 语音SIP电话的寄存器池与SCCP电话的ephone是相同的。

注意: 此配置是必须。

语音寄存器池参数配置
voice register pool  3
 id mac 001A.A11B.500E  

!--- Specify phone mac-address.

 type 3911  

!--- Specify phone type.

 number 1 dn 3  

!--- Assign button 1 dn tag 3.

 dtmf-relay sip-notify  

!--- Configure dtmf-relay sip-notify to work 
!--- with Cisco Unity Express.

 codec g711ulaw  

!--- Specify codec.

 username user1 password cisco  

!--- Configure username and password for SIP registrar.

注意: DTMF的多种方法可以配置在语音有在Cisco Unity Express的一语音信箱的寄存器池下,但是为每SIP电话,配置dtmf-relay SIP通知、

configure提前参数

在此部分,您配置SIP电话的先进的参数例如在线状态以忙碌闪亮指示领域(BLF)状态。与BLF的在线状态允许SCCP电话或SIP电话监控另一SIP扩展状况,启用在电话之间的在场信息。

注意: 这是可选配置。

这些电话技术支持SIP在Cisco Unified Communications Manager Express的在线状态服务。

限制

BLF Call-List
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.
BLF Speed-Dial
Supported only on Cisco Unified IP Phone 7941G, 7941GE, 7961G, 7961GE, 7970G, and 7971GE.

内部线路的Enable (event)在线状态

完成这些步骤为了使路由器接受从内部观察员和SIP中继的流入在线状态请求。

1.  enable 
2.  configure terminal 
3.  sip-ua 
4.  presence enable 
5.  exit 
6.  presence 
7.  max-subscription number 
8.  presence call-list 
9.  end
启用内部线路的在线状态
Presence  

!--- Enable presence service.

 presence call-list  

!--- Enable BLF monitoring of directory numbers.

 max-subscription 120  

!--- Configure max number watched sessions.

!
sip-ua
 presence enable  

!--- Enable router to accept incoming presence request.

启用将观看的目录号

完成这些步骤为了启用用目录号关联的线路将监控由电话注册对Cisco Unified通信Express路由器。当presentity和电话能订阅到其线路状态通过BLF呼叫列表和BLG快速拨号功能,线路启用。没有在能有其线路受监视电话的种类的限制;所有线路在任何IP电话或在支持的语音网关的一个模拟电话可以是presentity。

1.  enable 
2.  configure terminal 
3.  voice register dn dn-tag 
4.  number number 
5.  allow watch 
6.  end
启用将观看的目录号
voice register dn  1
 number 101
 allow watch  

!--- Allow this number to be watched.

 name Phone1
 label 4085251001

注意: 重复需要观看的每个分机号的此配置。此步骤已经被实行了,当您第一配置了语音寄存器dns。

使SIP电话监控快速拨号和呼叫列表的BLF状态

观察员能监控用内部和外部目录号关联的线路状况(presentities)通过BLF快速拨号和BLF呼叫列表在线状态功能。完成这些步骤为了启用在SIP电话的BLF通知功能:

1.  enable 
2.  configure terminal 
3.  voice register pool pool-tag 
4.  number tag dn dn-tag 
5.  blf-speed-dial tag number label string 
6.  presence call-list 
7.  exit 
8.  voice register global 
9.  mode cme 
10.  create profile 
11.  restart 
12.  end
使SIP电话监控快速拨号和呼叫列表的BLF状态
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list  

!--- Enable this phone to have presence call list.

 dtmf-relay sip-notify  
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"  

!--- Enable this line to monitor extension 1002.

 blf-speed-dial 3 103 label "3911-1"  

!--- Enable this line to monitor extension 1003.

 blf-speed-dial 4 104 label "3911-2"  

!--- Enable this line to monitor extension 1004.

注意: 在您更改SIP电话配置时候,请务必进行重新启动

注意: 参考如何配置在线状态服务关于SIP在线状态服务的配置的更多信息。

配置并行搜索组

在此部分,扩展102, 103和104分配到一个并行搜索组。一个并行搜索组是在组中同时敲响所有成员的搜索组。

并行搜索组配置
voice hunt-group 1
pilot 180  

!--- Configure Hunt group pilot number.

list 102, 103, 104  

!--- Specify members in hunt-group.

final 100  

!--- Specify final number as Voicemail Pilot.

CME- SIP实施:配置示例

此部分为使用SIP电话的设置一独立Cisco Unified Communications Manager Express提供完整配置示例。

CME- SIP实施:配置示例
CME-SIP#show version
Cisco IOS Software, 2801 Software (C2801-IPVOICE-M), Version 12.4(11)XW2, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Mon 02-Jul-07 19:10 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)T6, RELEASE SOFTWARE (fc1)

CME-SIP uptime is 18 hours, 55 minutes
System returned to ROM by reload at 17:01:34 UTC Wed Oct 3 2007
System image file is "flash:c2801-ipvoice-mz.124-11.XW2.bin"

Cisco 2801 (revision 4.1) with 235520K/26624K bytes of memory.
Processor board ID FHK084510HS
11 FastEthernet interfaces
1 terminal line
2 Voice FXO interfaces
3 DSPs, 48 Voice resources
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

CME-SIP#show running-config
Building configuration...

Current configuration : 6227 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-SIP
!
boot-start-marker
boot-end-marker
!
logging buffered 999999
no logging console
enable password cisco
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.10
ip dhcp excluded-address 192.168.10.1 192.168.10.10
!
ip dhcp pool data
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1 
!
ip dhcp pool voice
   network 192.168.10.0 255.255.255.0
   option 150 ip 192.168.10.1 
   default-router 192.168.10.1 
!
!
no ip domain lookup
multilink bundle-name authenticated
!
!
!
voice service voip 
 allow-connections sip to sip
 sip
  registrar server expires max 1200 min 300
!
!
!
!
!
voice register global
 mode cme
 source-address 192.168.10.1 port 5060
 max-dn 20
 max-pool 10
 load 7970 SIP70.8-2-1S
 load 3911 SIP3951.8-0-2-9
 authenticate register
 authenticate realm cisco.com
 voicemail 100
 tftp-path flash:
 create profile sync 0000589556325309
!
voice register dn  1
 number 101
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone1
 label 4085251001
!
voice register dn  2
 number 102
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone2
 label 4085251002
!
voice register dn  3
 number 103
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone3
 label 4085251003
!
voice register dn  4
 number 104
 call-forward b2bua noan 100 timeout 20
 allow watch
 name Phone4
 label 4085251004
!
voice register pool  1
 id mac 0016.47CD.9BD7
 type 7970
 number 1 dn 1
 presence call-list
 dtmf-relay sip-notify
 username user1 password cisco
 codec g711ulaw
 blf-speed-dial 2 102 label "Phone2"
 blf-speed-dial 3 103 label "3911-1"
 blf-speed-dial 4 104 label "3911-2"
!
voice register pool  2
 id mac 0014.6948.1D52
 type 7970
 number 1 dn 2
 dtmf-relay sip-notify
 username user2 password cisco
 codec g711ulaw
!
voice register pool  3
 id mac 001A.A11B.4FCE
 type 3911
 number 1 dn 3
 dtmf-relay sip-notify
 username user3 password cisco
 codec g711ulaw
!
voice register pool  4
 id mac 001A.A11B.500E
 type 3911
 number 1 dn 4
 dtmf-relay sip-notify
 username user4 password cisco
 codec g711ulaw
!
voice hunt-group 1 parallel
 final 100
 list 102,103,104
 pilot 180 
!
!
!
!
voice-card 0
!
!
!
archive
 log config
 hidekeys
!
!
!
interface Loopback0
 ip address 10.1.10.2 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine0/0
 ip unnumbered Loopback0
 service-module ip address 10.1.10.1 255.255.255.0
 service-module ip default-gateway 10.1.10.2
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/3/0
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/1
 description 7970 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/2
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/3
 description 3911 Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/4
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/5
 description Phone
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/6
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/7
 description Phone
 switchport access vlan 192
 switchport trunk native vlan 100
 switchport mode trunk
 switchport voice vlan 192
 spanning-tree portfast
!
interface FastEthernet0/3/8
 switchport access vlan 192
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan192
 ip address 192.168.10.1 255.255.255.0
!
ip route 10.1.10.1 255.255.255.255 Service-Engine0/0
!
!
ip http server
!
!
!
tftp-server flash:BOOT3951.0-0-0-9.zz
tftp-server flash:SIP3951.8-0-2-9.zz
tftp-server flash:DSP3951.0-0-0-1.zz
tftp-server flash:SIP3951.8-0-2-9.loads
tftp-server flash:SIP70.8-2-1S.loads
tftp-server flash:term70.default.loads
tftp-server flash:term71.default.loads
tftp-server flash:apps70.8-0-2-55.sbn
tftp-server flash:cnu70.8-2-0-55.sbn 
tftp-server flash:cvm70.sip.8-2-0-55.sbn
tftp-server flash:dsp70.8-2-0-55.sbn
tftp-server flash:jar70.sip.8-0-2-25.sbn
!
control-plane
!
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
!
!
!
dial-peer voice 2 voip
 description ** cue voicemail pilot number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 100
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
dial-peer voice 3 voip
 description ** cue auto attendant number **
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 110
 b2bua
 session protocol sipv2
 session target ipv4:10.1.10.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
presence
 presence call-list
 max-subscription 120
!
sip-ua 
 presence enable
!
!
telephony-service
 max-ephones 24
 max-dn 72
 ip source-address 10.100.100.10 port 2000
 system message CME1
 time-zone 5
 voicemail 100
 max-conferences 8 gain -6
 call-forward pattern .T
 web admin system name cisco secret 5 $1$4FC/$CMer08o/KELFlVrhL5QRO0
 dn-webedit 
 time-webedit 
 transfer-system full-blind
 transfer-pattern 9.T
!
!
ephone-dn  11
 number 800
 mwi on
!
!
ephone-dn  12
 number 801
 mwi off
!
!
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

CME-SIP#

验证

当前没有可用于此配置的验证过程。

故障排除

本部分提供的信息可用于对配置进行故障排除。

SIP IP电话不获得拨号音

不能获得拨号音的SIP IP电话的一个常见原因是有有同一分机的另一个电话。自Cisco Unified Communications Manager Express 4.2, SIP电话不支持共享线路。因此, SIP电话不能共享同一分机在多个电话。另外,请确保SIP电话配置有一适当的分机。

为了解决此问题,请确保这些发生:

  • SIP电话有配置的分机,并且分机在SIP电话显示。

  • 没有另一个SIP或SCCP电话配置与同一分机。

IP电话不能升级到最新的固件

疏忽的很可能原因能能升级电话未命中在Cisco Unified Communications Manager Express闪存或丢失tftp-server命令放置的固件文件。

设法这些步骤为了解决此问题:

  • 检查必要的固件文件在闪存存储。执行dir flash :发出命令为了检查闪存文件。

  • 确认是否更新OS79XX.TXT文件反射正确固件。79XX电话检查此文件为了装载适当的固件和从SCCP变成SIP。

  • 检查确保,正确tftp-server语句为每个固件文件被添加。请参阅配置TFTP部分。

  • 确保load命令下面语音寄存器全局为SIP电话的每种类型被添加。请参阅配置语音寄存器全局参数部分。

为了排除故障进一步,请收集这些调试为了发现电话是否能从Cisco Unified Communications Manager Express闪存获得适当的电话负载。

Debug tftp events

无法设置电话

的很可能原因能设置是电话是电话没有与TFTP server选项的适当的IP地址。

  • 确认电话收到IP地址和正确的TFTP服务器IP地址。

  • 确保所有适当的语音寄存器global命令被添加。请参阅配置语音寄存器全局参数部分。

  • 检查您使用在每语音寄存器池配置下的正确MAC地址。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 99946