交换机 : Cisco Catalyst 3750 系列交换机

Catalyst 3750,3560系列交换机上的PIM存根路由

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

组播控制平面数据流由在LAN环境的每个路由器总是看到。Stub IP组播用于减少和最小化在接入层的LAN被看到的多余的组播数据流和保存在媒体的带宽转发组播数据流到上行分配/核心层。

在Catalyst 3750及3560系列交换机、PIM Stub组播功能支持组播路由在分布层之间和接入层中。它支持PIM接口的两种类型:上行链路PIM接口和PIM无源接口。特别是,配置的一个路由接口与PIM被动模式不通过/转发PIM控制层面流量;它只通过/转发IGMP流量。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • PIM终端路由器不发送分布式路由器之间的中转流量。此行为由单播(EIGRP)残余部分路由强制执行。适当的单播残余部分路由配置是要求的协助此PIM终端路由器行为。PIM残余部分功能不防止配置RIP、静态路由或者PIM RP的路由器管理员绕过此限制。

  • 已进行定向连接仅组播(IGMP)接收方和来源在第2层访问域允许。访问域不支持PIM协议。

  • 不支持冗余的PIM终端路由器拓扑。

使用的组件

本文档中的信息基于 Catalyst 3750 交换机中的输出。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置还可用于以下交换机类型:

  • Catalyst 3750及3560系列交换机

Cisco Catalyst 3750和3560交换机支持PIM末节组播路由代码版本12.2(37)SE和以后。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

PIM SSM在uplink端口用于与上游路由器联络。用户能使用其他PIM模式(例如,密集或稀疏)。

关于组播路由的配置的更多信息在3750系列交换机的,参考配置IP组播路由

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

/image/gif/paws/98289/pim_stub-1.gif

配置

本文档使用以下配置:

完成这些步骤配置PIM残余部分路由:

  1. 发出此命令启用组播路由全局在交换机或交换机堆叠:

    mix_stack(config)#ip multicast-routing distributed
    
  2. 发出此命令定义SSM范围与默认组范围的IP组播地址:

    mix_stack(config)#ip pim ssm default
    
  3. 发出此命令启用在上行链路的PIM SSM :

    mix_stack(config)#interface GigabitEthernet3/0/25
    
    
    !--- By default switch configures the Layer 2 parameters.
    So in order to configure the Layer 3 parameter, use the next command.
    
    mix_stack(config-if)#no switchport
    
    mix_stack(config-if)#ip pim sparse-dense-mode
    
  4. 发出此命令启用在VLAN接口的PIM残余部分路由:

    mix_stack(config)#interface vlan100
    mix_stack(config-if)#ip pim passive
    

交换(mix_stack)配置

mix_stack#show run
Building configuration...
 
Current configuration : 7810 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname mix_stack
!
!
switch 2 provision ws-c3750e-24pd
switch 3 provision ws-c3750g-24ts
switch 5 provision ws-c3750-24fs
switch 9 provision ws-c3750e-24pd
!
ip routing
!
!
ip multicast-routing distributed
!
!--- Output suppressed.
!
!
vlan 100
!
!
interface GigabitEthernet2/0/1
switchport access vlan 100
no keepalive
spanning-tree portfast
!
interface GigabitEthernet2/0/2
switchport access vlan 100
no keepalive
spanning-tree portfast
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet3/0/25
no switchport
ip address 3.1.1.2 255.255.255.248
ip pim sparse-dense-mode
!
!
!--- Output suppressed.
!
!
interface GigabitEthernet9/0/24
no switchport
ip address 10.1.1.1 255.255.255.0
ip pim passive
no keepalive
!
!
!--- Output suppressed.
!
!
interface Vlan1
no ip address
!
interface Vlan100
ip address 100.1.1.1 255.255.255.0
ip pim passive
!
!
!--- Output suppressed.
!
! 
ip pim ssm default
!
!
!--- Output suppressed.
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
speed 115200
line vty 0 4
login
line vty 5 15
login
!
end

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

发出show ip pim interface命令为了显示是每个接口的enable (event)的PIM Stub。

mix_stack#show ip pim interface 

Address    Interface               Ver/    Nbr     Query   DR     DR
                                   Mode    Count   Intvl   Prior

3.1.1.2    GigabitEthernet3/0/25   v2/SD   1       30      1      3.1.1.2
100.1.1.1  Vlan100                 v2/P    0       30      1      100.1.1.1
10.1.1.1   GigabitEthernet9/0/24   v2/P    0       30      1      10.1.1.1

发出show ip igmp groups详细信息显示加入特定组播源/组的感兴趣客户端。

mix_stack#show ip igmp groups 232.0.0.9 det

Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source,
Ac - Group accounted towards access control limit

Interface: GigabitEthernet9/0/24
Group: 232.0.0.9
Flags: SSM 
Uptime: 00:00:10
Group mode: INCLUDE
Last reporter: 10.1.1.2
CSR Grp Exp: 00:02:57
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 00:00:10 stopped 00:02:57 Yes CM

Interface: Vlan100
Group: 232.0.0.9
Flags: SSM 
Uptime: 01:42:08
Group mode: INCLUDE
Last reporter: 100.1.1.3
CSR Grp Exp: 00:02:00
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, M - SSM Mapping, L - Local,
Ac - Channel accounted towards access control limit)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
200.1.1.3 01:42:12 stopped 00:02:00 Yes CM
mix_stack#

发出show ip mroute验证组播流从来源转发给感兴趣客户端。

mix_stack#show ip mroute 232.0.0.9
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, 
Z - Multicast Tunnel, z - MDT-data group sender, 
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(200.1.1.3, 232.0.0.9), 01:44:23/00:02:52, flags: sTI
Incoming interface: GigabitEthernet3/0/25, RPF nbr 3.1.1.1
Outgoing interface list:
GigabitEthernet9/0/24, Forward/Sparse-Dense, 00:02:24/00:02:50
Vlan100, Forward/Sparse-Dense, 01:44:23/00:02:52

相关信息


Document ID: 98289