思科接口和模块 : Cisco Anomaly Guard ??

通信媒体模块IP连通性

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文提供关于IP连通性如何的详细信息设立与通信媒体模块(CMM)。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息根据Cisco IOS 12.4。

规则

关于文件规则的信息,请参见Cisco技术提示规则

背景信息

通信媒体模块是提供语音终端、转码和会议服务的语音通信模块。它在6500交换机或7600路由器的机箱可以安装。

这些适配器在CMM基础模块可以安装:

  • 6端口T1/E1端口适配器

  • 24波尔特FXS端口适配器

  • 临时会议及编码转换(ACT)端口适配器

一般, SUP2或Sup720在6500交换机安装或7600运行CatOS软件或本地IOS软件的路由器。

CMM基础模块连接对背板6500或7600与内部千兆以太网接口。另外,每个ACT模块有一个内部快速以太网连接到6500或7600。

此表描述端口映射:

底板连接 CMM接口名称 本地IOS接口名称 CatOS接口名称
CMM基本模块 Gig1/0 Gig x/1 x/1
ACT梅迪亚card1 Fas0/0 启远地x/2 x/2
ACT梅迪亚卡2 Fas1/0 启远地x/3 x/3
ACT梅迪亚卡3 Fas2/0 启远地x/4 x/4
ACT梅迪亚卡4 Fas3/0 启远地x/5 x/5

注意: “x”是在CMM安装的6500个或7600个机箱的插槽编号。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

配置

本文档使用以下配置:

  • 千兆位的IP地址和快速以太网接口“静态”已配置的。不支持DHCP。

  • 千兆位的IP地址和快速以太网接口属于相同子网。

  • 千兆接口配置与IP地址和子网掩码。

  • 快速以太网接口配置与255.255.255.255 IP地址和子网掩码。

  • 千兆位和快速以太网接口配置作为“switchport”在6500交换机和7600路由器。

  • 千兆位和快速以太网接口配置是同样虚拟LAN (VLAN)的一部分。

  • CMM用默认IP路由配置这样所有流量发送到默认网关。默认网关也许是在6500交换机或7600路由器配置的VLAN接口的IP地址。

  • CMM用在slot 2, 3和4.的ACT模块。千兆位和快速以太网接口配置用从172.168.1.0网络的IP地址。

通信媒体模块
interface GigabitEthernet1/0
 ip address 172.168.1.16 255.255.255.0
 no ip proxy-arp
 no negotiation auto
 no keepalive
!
interface FastEthernet1/0
 description ACT Media card – Slot 2
 ip address 172.168.1.17 255.255.255.255
 no ip proxy-arp
!
interface FastEthernet2/0
 description ACT Media card – Slot 3
 ip address 172.168.1.18 255.255.255.255
 no ip proxy-arp
!
interface FastEthernet3/0
 description ACT Media card – Slot 4
 ip address 172.168.1.19 255.255.255.255
 no ip proxy-arp
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.168.1.1

6500/7600运行IOS (本地模式)的Supervisor

!--- CMM is installed on Slot 2 and VLAN 2 is used


interface GigabitEthernet2/1
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/3
 description ACT Media card – Slot 2
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/4
 description ACT Media card – Slot 3
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface FastEthernet2/5
 description ACT Media card – Slot 4
 switchport 
 switchport access vlan 2
 switchport mode access
 no ip address 
!
interface Vlan2
 ip address 172.168.1.1 255.255.255.0

6500/7600 Supervisor运行CatOS (混合模式)

!--- CMM is installed on Slot 2 and VLAN 2 is used


!--- Configuration in the Supervisor

#module 2 : 5-port Communication Media Mod.		
set vlan 2 2/3-5


!--- Configuration in the MSFC

interface Vlan2
 ip address 172.168.1.1 255.255.255.0

数据包流

ACT模块的快速以太网接口用于只发送和收到ACT模块的RTP数据包(转码和电话会议)。其他非RTP数据包(例如ICMP Ping请求和回复)从ACT模块被发送到Supervisor通过千兆以太网接口。如果起源于ACT模块的RTP数据包通过千兆以太网接口被发送而不是快速以太网接口,转码和会议呼叫也许体验单向音频。

当CMM的快速以太网接口的IP地址从Cat6500交换机ping或从任何地方CMM的外部时, ICMP echo请求通过快速以太网接口到达CMM。然而,因为ICMP是非RTP数据包,从ACT模块的ICMP echo应答通过千兆接口被发送。

于T1或E1端口适配器和FXS模块终止或发起的语音呼叫的RTP数据包通过千兆以太网接口被发送。

故障排除

命令

您能使用这些显示和调试指令为了排除故障IP连通性问题:

  • 在MSFC中,请使用这些命令:

    • show arp

    • debug ip arp

    • debug ip icmp

  • 在CMM,请使用这些命令:

    • show arp

    • debug ip arp

    • debug ip icmp

另外, SUP720提供能使用获取帧和数据包的一个内部嗅探器工具。协助的联系方式TAC用此工具。

示例输出

情形 1:IP连通性没有设立。

显示输出:

MSFC#show arp        
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.168.1.16           0   0011.92b7.3fe6  ARPA   Vlan2
Internet  172.168.1.1            -   000b.45b6.aa3c  ARPA   Vlan2
Internet  14.1.16.1              0   000f.232c.f3bf  ARPA   Vlan1
Internet  172.168.1.17           0   Incomplete      ARPA   
Internet  14.1.17.149            -   000b.45b6.aa3c  ARPA   Vlan1
Router#

从MSFC的调试:


No response from CMM


MSFC#ping 172.168.1.17

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
                 dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP throttled out the ARP Request for 172.168.1.17

5d00h: IP ARP: creating incomplete entry for IP address: 10.1.1.46 interface Vlan101


CMM sends ARP reply, but the 6500 is not installing the ARP

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
       dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP rep filtered src 172.168.1.17 0011.92b7.3fe8, 
       dst 172.168.1.1 000b.45b6.aa3c it's our address

方案 2:IP连通性设立。

显示输出:

MSFC#show arp        
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.168.1.16           0   0011.92b7.3fe6  ARPA   Vlan2
Internet  172.168.1.1            -   000b.45b6.aa3c  ARPA   Vlan2
Internet  14.1.16.1              0   000f.232c.f3bf  ARPA   Vlan1
Internet  172.168.1.17           0   0011.92b7.3fe8  ARPA   Vlan2
Internet  14.1.17.149            -   000b.45b6.aa3c  ARPA   Vlan1
Router#

从MSFC的调试:


Debugs from MSFC

MSFC#

5d00h: IP ARP: sent req src 172.168.1.1 000b.45b6.aa3c,
               dst 172.168.1.17 0000.0000.0000 Vlan2
5d00h: IP ARP: rcvd rep src 172.168.1.17 0011.92b7.3fe8, dst 172.168.1.17 Vlan2
5d00h: ICMP: echo reply rcvd, src 172.168.1.17, dst 172.168.1.1

Debugs from CMM

CMM#
*Mar  6 00:03:19.134: IP ARP: sent rep src 172.168.1.17 0011.92b7.3fe8,
                      dst 172.168.1.17 ffff.ffff.ffff FastEthernet1/0
*Mar  6 00:03:19.134: IP ARP rep filtered src 172.168.1.17 0011.92b7.3fe8, 
                      dst 172.168.1.17 ffff.ffff.ffff it's our address
*Mar  6 00:03:21.082: ICMP: echo reply sent, src 172.168.1.17, dst 172.168.1.1
*Mar  6 00:03:21.082: ICMP: echo reply sent, src 172.168.1.17, dst 172.168.1.1
  

相关信息


Document ID: 91263