????????? : Cisco Catalyst 6500 系列/7600 系列无线服务模块 (WiSM)

Catalyst 6500 系列 WLSM 到 Catalyst 6500 系列 WiSM 迁移指南

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文着重从一现有无线局域网服务模块(WLSM)的迁移策略到无线服务模块(WiSM)。仔细规划和执行是绝对必要的在从思科WLSM的迁移对思科WiSM。

本文的读者群落包括企业网络管理器和个人在规划涉及的企业的IT基础设施的内所有级别,实现或者维护基于WLSM的无线网络。一附属受众包括在提供产品涉及的个人和集成服务或者支持给企业IT组织。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco Catalyst 6500系列WLSM

  • Cisco Catalyst 6500系列WiSM

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

概述

从Catalyst WLSM的一个迁移策略到Catalyst WiSM平台包括这些操作的规划和执行:

  • 计划为并且安装Catalyst WiSM。

  • 安装Catalyst WiSM平台。

  • 安装Catalyst WiSM的思科无线控制系统(WCS)网络管理平台。

  • 移植从Catalyst WLSM的配置到Catalyst WiSM-based平台继续所有轻量和转换的自治接入点支持。

  • 移植对轻量级接入点协议(LWAPP)的自治IOS�接入点-已启用IOS平台(超出本文的范围之外)。

  • 培训Catalyst WiSM平台和解决方案的技术支持人员。

  • 当迁移完成时,请整理传统配置。

结构上差异

Cisco Catalyst 6500系列WLSM

Cisco Catalyst 6500系列WLSM可以安装,并且配置在其中任一请打开3, 6, 9或者13 SLOT Cisco Catalyst 6500系列交换机的slot配备有Supervisor引擎720。Cisco Catalyst 6500系列WLSM与Cisco Aironet自治接入点和Cisco工作无线局域网解决方案引擎(WLSE)一起使用。

Cisco Catalyst 6500系列WLSM在分布层或数据中心典型地部署。它在配线间很少部署。自治接入点连接到任何第3层网络的所有交换机端口。上行交换机或路由器不必须配置,并且特定VLAN分配或中继没有要求。在流量积极地通过前,自治接入点可以验证作为可靠网络设备。

其中一个最重要的概念介绍与使用WLSM是移动组。无线客户端体验无缝的漫游(保养所有其IP会话),当移动在配置的两接入点之间是同样移动组的部分时。移动组在接入点定义由服务集标识(SSID)无线电侧的和网络ID之间的一唯一映射有线的侧的。网络ID代表重叠的逻辑网络被建立在现有基础设施顶部使用通用路由封装(GRE)通道,并且其对SSID的映射替换那在SSID和VLAN ID之间。

参考Cisco Catalyst 6500系列无线局域网服务模块(WLSM)部署指南关于如何配置和部署WLSM的详细信息。

/image/gif/paws/71251/cat-6500-wlsm-wism-migration-1.gif

注意VLAN仍然关联与每SSID。这些VLAN在接入点在接入层或分布层交换机当前仅定义,并且不需要配置。配置的VLAN部分的唯一的目的将提供一约束在加密之间关联与VLAN给一特定SSID。

dot11 vlan-name Emp vlan 3
!
dot11 ssid Employee
 vlan 3
 authentication open eap eap_methods 
 authentication network-eap eap_methods 
 authentication key-management wpa
 mobility network-id 3 
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !        
 encryption vlan 3 mode ciphers tkip
 !
 ssid Employee
interface Tunnel3
 description mGRE for employees
 ip address 10.10.3.1 255.255.255.0
 no ip redirects
 ip mtu 1476
 ip dhcp snooping packets
 tunnel source Loopback3
 tunnel mode gre multipoint
 mobility network-id 3
!

Cisco Catalyst 6500系列WiSM

Cisco Catalyst 6500系列WiSM是Cisco无线LAN控制器(WLC)家族也呼叫的Cisco Unified无线网络的成员。思科WiSM与Cisco Aironet轻量级接入点(拉普)和思科WCS一道工作。Cisco WiSM顺利集成到存在Cisco Catalyst 6500系列企业网络。它扩展传送对主的安全,企业无线访问,分组和远程校园。它通信使用LWAPP为了设立接入点和模块之间的安全连接在间第3层网络。从流量处理观点,于无线客户端起源关联对拉普的所有数据流由接入点封装并且运载对WLC,聚集流量并且到/从有线网络代表单点入口和出口IP数据流的。

然而,这些差异存在:

  • 流量从接入点被以隧道传输到集中化控制器,有效利用而不是LWAPP GRE。

  • 控制和数据流通过LWAPP运载。数据流使用UDP端口12222,控制流量在UDP端口12223被封装,并且移动性消息使用UDP端口16666/16667。

  • 控制流量是高级加密标准(AES) -已加密和数据无危险是。

  • 没有每定义SSID的一个分开的逻辑通道。仅单个逻辑通道被构建在每接入点和WLC之间。此LWAPP通道用于运载所有无线客户端的数据流关联对接入点,不管他们关联与的SSID。

cat-6500-wlsm-wism-migration-2.gif

迁移策略

升级产品软件

升级在这些产品的软件:

  • Supervisor 720需要运行Cisco IOS软件版本12.2(18)SXF2或以上

  • Catalyst 6500 WLSM需要运行1.4.1或以后

  • Catalyst 6500 WiSM需要运行3.2.78.4或以后

  • Cisco Aironet接入点需要运行Cisco IOS软件版本12.3.7JA2或以上(为了将转换到LWAPP)

实现配置

实现这些配置:

  • 配置Supervisor 720支持思科WiSM。

  • 配置WiSM管理接口的VLAN在Supervisor 720。

  • 配置WiSM的动态接口的VLAN在Supervisor 720的。

  • 配置DHCP对服务接口的范围或静态配置IP地址。

  • 为路由问题测试新的第3层网络。

参考思科WiSM配置指南并且排除故障并且配置关于关于怎样的详细信息(WiSM)设置的最初的无线服务模块完成这些配置。

配置Catalyst 6500 WiSM移植从Catalyst 6500 WLSM的SSID

一旦思科WLSM体系结构,在接入点配置的SSID被映射对建立隧道所有客户端的流量到Catalyst 6500的移动性网络。这些多点GRE (mGRE))通道有在主机WLSM Catalyst 6500的Supervisor 720模块的一终接点。通道的另一个逻辑终端在参加第3层移动性网络的所有接入点存在。一旦思科WiSM平台, SSID代表作为WLAN。每WLAN关联对管理接口或一个话务员定义的动态接口。话务员定义的动态接口是类似于VLAN并且作为无线客户端的一个DHCP中继。

在每移动组的Supervisor 720模块必须定义一mGRE通道。这是一mGRE隧道接口的示例在Supervisor 720的。所有无线客户端使用隧道接口的IP地址作为默认网关。移动性网络ID定义了此作为唯一移动性网络。为此通道定义的移动性网络ID也定义在其中一个接入点SSID定义以下为了识别其参与此第3层移动性网络。

注意: 移动组是为一些一起分组共享的特性例如一个普通的验证或加密机制无线客户端,或者用户类型的一组例如访客和员工。

此输出显示在Supervisor 720的配置:

interface Tunnel172
 description to_wireless_clients
 ip address 172.16.1.1 255.255.255.0
 ip helper-address 10.1.1.11
 no ip redirects
 ip dhcp snooping packets
 tunnel source Loopback100
 tunnel mode gre multipoint
 mobility network-id 172

此输出显示在接入点的对应的配置:

interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption vlan 172 mode ciphers tkip
 !
 ssid light
    vlan 172
    authentication network-eap eap_methods
    authentication key-management wpa
    mobility-network-id 172

为了转换此配置到WiSM体系结构,您需要创建一个新的动态/VLAN接口,分配它在一不同的子网的一个IP地址,并且连结它与WLAN。

WLAN接口名称对应于在Cisco Aironet接入点的SSID名称。在本例中它是“灯”。当您维护一相似的名称时,用户体验最小。唯一的差异是IP地址分段从无线客户端分配IP地址。

  1. 创建在Supervisor 720的新的VLAN并且添加它到VLAN数据库。

    c6506-t(config)#interface vlan 45
    c6506-t(config-if)#ip add 172.16.2.1 255.255.255.0
    c6506-t(config-if)#no shut
    c6506-t(config-if)#end
    c6506-t(config)#vlan 45
    c6506-t(config-vlan)#state active
    c6506-t(config-if)#end
    
  2. 允许在建立中继的千兆接口的VLAN。

    c6506-t(config)#interface range gig 1/1-4
    c6506-t(config-if-range)#switchport mode trunk
    c6506-t(config-if-range)#switchport trunk encap dot1q
    c6506-t(config-if-range)#switchport trunk native vlan 201
    c6506-t(config-if-range)#switchport trunk allowed vlan 201,45
    c6506-t(config-if-range)#mls qos trust dscp
    c6506-t(config-if-range)#spanning-tree portfast
    c6506-t(config-if-range)#channel-group 1 mode on
    c6506-t(config-if-range)#end
    
  3. 一旦VLAN在中继接口允许,在端口信道接口自动地允许。

    c6506-t#show run interface port-channel 1
    !
    interface Port-channel1
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 201
     switchport trunk allowed vlan 45,201
     switchport mode trunk
     no ip address
    end
    c6506-t#
  4. 完成这些步骤为了通过Web接口创建在Catalyst 6500 WiSM的动态接口。

    1. 选择Controller>接口并且点击

      cat-6500-wlsm-wism-migration-3.gif

    2. 输入接口名称和VLAN ID并且单击应用

      cat-6500-wlsm-wism-migration-4.gif

    3. 输入适当的IP地址信息和DHCP服务器信息并且单击应用

      cat-6500-wlsm-wism-migration-5.gif

    4. 选择WLAN并且单击为了添加在思科WiSM的一新的SSID。

      cat-6500-wlsm-wism-migration-6.gif

    5. 添加SSID并且单击应用

      cat-6500-wlsm-wism-migration-7.gif

    6. 更改接口名称参数对适当的VLAN。

      其他安全参数,例如适当的RADIUS服务器和加密设置应该对应于在思科自治接入点的配置。在本例中,接口名称更改对VLAN45,并且第2层安全类型更改对WPA2

      cat-6500-wlsm-wism-migration-8.gif

      这是新的SSID灯。

      cat-6500-wlsm-wism-migration-9.gif

    7. 如果使用一新的SSID,其他配置没有要求。如果使用一现有SSID,升级仅一个RF域每次为了防止在Catalyst 6500 WSLM和Catalyst 6500 WiSM之间的移动性问题。

    8. 一旦WLAN配置,请检查WLAN策略是否正确。例如, ACL, QoS,等等。

    9. 确保思科WCS是正在运行的并且准备配置管理思科WiSM。

接入点的LWAPP转换

从自治访问接入节点模式的迁移到轻量级模式是可能的在这些Cisco Aironet接入点平台:

  • 所有Cisco Aironet 1130 AG接入点

  • 所有Cisco Aironet 1240 AG接入点

  • 对于所有基于 IOS 的 1200 系列模块化接入点(1200/1220 Cisco IOS 软件升级版、1210 和 1230 AP)平台来说,能否支持此迁移取决于无线电:

    • 如果支持 802.11G、MP21G 和 MP31G

    • 如果支持802.11A、CB21A和CB22A

  • Cisco Aironet 1200系列接入点可以升级与支持的无线电的所有组合—仅仅G, A或者G和A。

.。在您可执行升级前,接入点必须运行Cisco IOS软件版本12.3(7)JA或以上。参考升级对轻量级模式的自治Cisco Aironet接入点关于转换步骤的更多信息。

在控制器中的接入点分配在思科WiSM

如果接入点已经配置与静态IP地址,接入点保留IP地址,在从自治模式转换到LWAPP模式后。如果接入点不在Layer2 IP子网和控制器一样,则CISCO-LWAPP-CONTROLLER@localdomain DNS解析是唯一的保证控制器发现机制。在您装载Cisco IOS软件版本12.3(7)JX前,升级工具能配置名称服务器。验证名称服务器能适当地解决CISCO-LWAPP-CONTROLLER@localdomain,在您开始升级程序前。

您能也使用根据厂商的DHCP选项43返回一个或更多控制器IP地址到在DHCP提供消息的一接入点。接入点传送LWAPP发现消息对在DHCP选项43接收控制器的管理IP地址。有关详细信息,请参阅附录 A:配置轻量级Cisco Aironet接入点的DHCP选项43在Windows 2003年关于如何的企业DHCP服务器配置在Windows 2003年企业DHCP服务器的DHCP选项的更多信息43。

测验用接入点有限数量

在管理员是容易访问的位置开始与单个接入点的迁移进程然后尝试执行远程位置。一旦接入点转换对LWAPP模式,并且思科WiSM配置完成,请测试无线客户端为:

  • 安全设置

  • 标准应用类似电子邮件,互联网访问,数据库应用程序,等等

  • 在看到的接入点和的检查之间的平稳漫游客户端是否保留IP地址,当漫游在接入点之间时。

  • 使用文件传输协议(FTP),所有传输控制协议(TCP)最大分段尺寸(MSS)问题—请下载大互联网页或转移文件。

  • 从无线接入点的可接受吞吐量根据设计

全面部署

为了通过更加大的接入点编号快速移动,请安装在超过一计算机的升级工具多自治接入点同时转换的对LWAPP支持接入点的。

故障排除

遵从特定问题的正常故障排除程序在WLC。参考的无线局域网控制器(WLC)欲了解更详细的信息排除故障FAQ在故障排除。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 71251