长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

Cisco DSL路由器配置与故障排除指南-Cisco DSL路由器作为动态IP地址的PPPoE客户端

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

您的 Internet 服务提供商 (ISP) 已向您的 Cisco 数字用户线 (DSL) 路由器分配一个动态公共 IP 地址。

提示:如果不熟悉如何配置Cisco设备,并且希望按照逐步的操作进行配置,参考PPPoE的逐步配置与动态IP地址的

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

要执行的任务

  • 设计一个您的专用LAN的编址方案。

  • 在思科 DSL 路由器以太网接口上配置 IP 地址、子网掩码和 TCP 最大报文段长度 (MSS) 调整。

  • 配置ATM接口(Asymetric数字用户线(ADSL)接口)有ATM永久虚拟电路(PVC)和封装的Cisco DSL路由器。

  • 比12.2(13)T配置思科IOS�软件的一以太网点对点协议(PPPoE)虚拟专用数据网络(VPDN)组旧。

  • 创建并且配置Cisco DSL路由器的拨号接口PPPoE的与一个经过协商的IP地址。

  • (网络地址转换[NAT]) —配置在Cisco DSL路由器的NAT允许共享拨号接口的动态公网IP地址。

    • 可选:NAT池,如果您的ISP提供了额外的IP地址。

    • 可选:静态NAT,如果互联网用户需要对内部服务器的访问。

  • 使用 IP 地址、子网掩码、默认网关和域名系统 (DNS) 服务器配置每个 PC 客户端。

    (动态主机配置协议[DHCP]) —或者,如果想要Cisco DSL路由器分配您的PC客户端的动态IP地址,请配置每个PC通过DHCP自动地得到IP地址和DNS服务器。

PC 上可能需要的配置步骤

如果您的思科 DSL 路由器软件支持 ip tcp adjust-mss 1452ip adjust-mss 1452 配置命令,则无需进一步操作,您即可继续执行配置部分的操作。

如果您的思科 DSL 路由器软件不支持 ip tcp adjust-mss 1452ip adjust-mss 1452 配置命令,则您必须对通过思科 DSL 路由器访问互联网的 LAN 中的每台 PC 更改最大传输单元 (MTU) 大小。

完成这些步骤为了更改MTU大小:

  1. 下载Dr. TCP Utility的新版本leavingcisco.com

  2. 刷新浏览器页面以确保页面为最新页面。

  3. 运行 Dr. TCP 实用程序。

  4. 从菜单中选择你的以太网适配器;

  5. 在MTU字段的类型1492

  6. 单击应用为了保存更改,然后单击退出

  7. 重新启动 PPPoE PC 客户端。

当步骤完成,因此您需要运行工具一次只每个PC时,注册表更改保存。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

配置

提示:如果不熟悉如何配置Cisco设备,并且希望按照逐步的操作进行配置,参考PPPoE的逐步配置与动态IP地址的

有动态IP地址的Cisco DSL路由器

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
 vpdn-group pppoe
  request-dialin
   protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than 12.2(13)T.

!
!
ip subnet-zero
!


!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported,  
 !--- try this configuration statement:
 !--- ip adjust-mss 1452   


 
!--- If this command is not supported in your current Cisco DSL Router software
 !--- release, either upgrade to the latest Cisco DSL Router software or follow the 
 !--- procedure in the "Possible Required Configuration Steps on the PC" 
 !--- section of this document. 

 


!--- For NAT:


ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address negotiated
 mtu 1492


!--- For NAT:


 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication chap pap callin
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!


!--- For NAT:


ip nat inside source list 1 interface dialer1 overload


!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> 
!---  <last ip address> netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer 1


!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network was 10.10.10.0, configuring 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 would allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

验证

当前没有可用于此配置的验证过程。

故障排除

如果您的DSL服务是工作不正常,请参阅排除故障Cisco DSL路由器PPPoE客户端

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 71118