长距离以太网 (LRE) 和数字用户线 (xDSL) : 非对称数字用户线 (ADSL)

Cisco DSL路由器配置与故障排除指南- PPPoE :>DSL路由器作为PPPoE客户端故障排除

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 23 日) | 反馈


目录


简介

您数字用户线路DSL连接不能正常工作的原因有很多。本文目标是查出失败的原因和修复它。第一故障排除步骤将确定您的异步数字用户线路(ADSL)服务哪块层发生故障。故障可能发生在三个层面。

  • 第1层–对您的ISP数字用户线路访问多路复用器的DSL物理连通性

  • 第2.1层- ATM连通性

  • 第2.2层-ATM 上的点对点协议(PPPoA),以太网上的点对点协议(PPPoE),RFC1483桥接或者RFC1483路由

  • 第3层- IP

确定从那层开始故障排除的最简单的方法是发行命令show ip interfacebrief。此指令输出根据您配置的不同会有轻微不同。

827-ESC#show ip interface brief
Interface     IP-Address     OK?     Method    Status     Protocol
ATM0          unassigned     YES     manual 	   up         up
ATM0.1        unassigned     YES     unset  	   up         up
Ethernet0     10.10.10.1     YES     manual    up         up

如果ATM0和ATM0.1的状态启用,并且协议启用,请开始发现并解决问题在第2层。

如果 ATM 接口关闭,或不断地开启然后关闭(即不能一直保持开启),则在第 1 层开始故障排除。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

第1层问题

在Cisco DSL路由器的前面板的载波检测(CD)灯是开/关?

如果cd灯是亮的,请参阅本文第2层问题部分

如果CD灯是关闭的,请继续下个问题。

您使用的ISP支持Alcatel芯片组的DSLAM吗 ?

与您的ISP验证此信息。

Cisco DSL路由器背面的DSL端口是否插入到DSL墙上插座?

如果DSL端口没有插入到DSL墙上插座,请用4针或6针RJ-11电缆连接端口到墙壁。这是标准电话电缆。

ATM接口是否处于administratively down状态?

为确定 ATM0 接口是否处于管理性关闭状态,请在路由器的启用模式下发出此命令:

Router#show interface atm 0
ATM0 is administratively down, line protocol is down
<... snipped ...> 

如果ATM0接口状态是administratively down,请在ATM0接口下发出no shutdown指令。

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface atm 0
Router(config-if)#no shut
Router(config-if)#end
Router#write memory

管脚引线是否是正确的?

如果ATM0接口状态是down/down,路由器在ADSL线路没看见的载波。这通常指二个问题之一:

  1. 在DSL墙上插座的有效的针是不正确的。

  2. 您的ISP未在墙上插座开启DSL服务。

Cisco DSL路由器xDSL端口管脚引线

RJ-11连接器通过一个标准RJ-11 6针模块化插座提供与外部媒介的xDSL连接。

说明
3 XDSL_Tip
4 XDSL_Ring

为了确定 ATM0 接口是否不断关闭,请在路由器的启用模式下发出 show interface atm 0 命令

Router#show interface atm 0
ATM0 is down, line protocol is down
<... snipped ...>

如果ATM接口状态是down和down-不是administratively down -请检查您的DSL墙上插座管脚引线。DSL路由器使用一个标准的RJ-11 (4 Pin或6 Pin)电缆提供ADSL连接给墙上插座。RJ-11电缆的中心位置的一对针被用于运载ADSL信号(6针电缆上的针3和针4,4针电缆上的针2和针3)。

如果肯定您有在墙上插座的正确管脚,并且ATM0接口仍然发生故障下来和,请替换在DSL端口和您的墙上插座之间的RJ-11电缆。如果接口仍然发生故障下来和,在您替换RJ-11电缆后,请与您的ISP联系并且安排ISP验证DSL服务在您使用的墙上插座启用。

如果您不确定的在您的墙上插座的哪个针是Active的,请询问您的ISP。

您是否有Cisco 827正确的电源?

如果验证您的DSL电缆是好,并且您有插脚,下一步是确保您有827的正确电源。

注意: 827 使用的电源与其他 800 系列路由器不同。

为了确定您是否有正确的电源,在电源处背面寻找Output +12V 0.1A, -12V 0.1A, +5V 3A, -24v 0.12A和-71V 0.12A。如果您的电源未命中+12V,并且-12V提供,则是为一个不同的Cisco 800系列路由器,并且不工作在827。请注意,如果您使用错误的电源, Cisco 827加电,但是无法充分培训(连接)到ISP DSLAM。

DSL 工作模式是否正确?

如果第1层故障排除程序至此的一切都是正确的,下一步是保证您有正确的DSL操作模式。如果您不确定 ISP 所使用的 DMT 技术,则思科建议您使用 dsl operating-mode auto。这些是配置操作模式自动检测的指令:

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#interface atm 0
Router(config-if)#dsl operating-mode auto
Router(config-if)#end
Router#write memory

电路是否被正确地测试/供应?

从您的ISP或电话公司得到此信息。

第 2 层问题

是否具有正确的 PVC 值 (VPI/VCI)?

使用PPPoE部署没有动态地发现您的永久虚拟电路(PVC)虚拟路径标识符/虚拟信道标识符(VPI/VCI)值的简单的方法。如果不是肯定的您的PVC值,请与您的ISP联系。

接收从您的ISP的数据?

如果有正确PVC值,下一步是验证您尝试协商与您的ISP的PPP。为了执行此,发出show interface atm0命令和检查输入和输出数据包。

Router#show interface atm0
ATM0 is up, line protocol is up
Hardware is DSLSAR (with Alcatel ADSL Module)
MTU 4470 bytes, sub MTU 4470, BW 128 Kbit, DLY 16000 usec, 
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Encapsulation(s): AAL5, PVC mode
24 maximum active VCs, 256 VCS per VP, 1 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 5 bits/sec, 0 packets/sec
5 minute output rate 7 bits/sec, 0 packets/sec
100 packets input, 5600 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
250 packets output, 1400 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out

如果输入信息包计数器增加,您应该收到从您的ISP的PPPoE协商信息包。如果这不是实际情形,请呼叫您的ISP。

如果输出限制计数器增加,您应该发送PPPoE协商信息包。如果这不是实际情形,请检查在路由器的配置。如果PPP适当地配置, PPP协商信息包连续被派出ATM0接口。

如果数据包在仅出站方向增加,请继续在本文的故障排除步骤。

PPPoE会话上升?

PPPoE在两个相位内被执行。第一阶段是PPPoE会话建立,并且第二阶段是PPP协商。必须在标准的PPP参数的协商之前设立PPPoE。确定的简便的方法是否有一次活动PPPoE会话是发出show vpdn命令

Router#show vpdn
%No active L2TP tunnels
%No active L2F tunnels
%No active PPTP tunnels
PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
PPPoE Tunnel Information
Session count: 1
PPPoE Session Information
SID  RemMAC          LocMAC          Intf   Vast   OIntf   VP/VC
0    0000.0000.0000  0000.0000.0000         UNKN   ATM0    8/35

在本例中, PPPoE会话不是活跃的。这由SID 0表示和RemmacLocMAC 0000.0000.0000。如果在此状态,请继续对下一部分。

是顺利地协商的如下所示:的PPPoE会话

Router#show vpdn
%No active L2TP tunnels 
%No active L2F tunnels 
PPPoE Tunnel and Session Information Total tunnels 1 sessions 1
PPPoE Tunnel Information
Session count: 1

PPPoE Session Information
SID  RemMAC           LocMAC          Intf    Vast   OIntf   VP/VC
1    0050.7359.35b7   0001.96a4.84ac  Vi1     UP     ATM0    8/35

在本例中您能看到SID是一个非零编号,并且RemmacLocMAC字段被填充。另一关心的领域是浩大的,指示PPP是否顺利地协商并且验证。如果浩大是UP, PPP顺利地协商并且验证,并且能继续到为什么能我访问与PPPoE,但是不是其他的一些网页?本文的部分。如果浩大是DOWN,请继续下一部分。

接收从聚合路由器的PPPoE答复?

如果不让一次活动PPPoE会话建立,您需要发出debug vpdn pppoe-events命令确定什么PPPoE不出现。

Router#debug vpdn pppoe-events
*Mar  3 21:49:38.030: Sending PADI: vc=8/35
*Mar  3 21:49:38.030: padi timer expired
*Mar  3 21:50:10.030: Sending PADI: vc=8/35
*Mar  3 21:50:10.030: padi timer expired
*Mar  3 21:50:42.030: Sending PADI: vc=8/35
*Mar  3 21:50:42.030: padi timer expired
*Mar  3 21:51:14.030: Sending PADI: vc=8/35
*Mar  3 21:51:14.030: padi timer expired
*Mar  3 21:51:46.030: Sending PADI: vc=8/35
*Mar  3 21:51:46.030: padi timer expired
Router#undebug all

在本例中, Cisco DSL路由器不断地发送PPPoE动态发现开始(PADI)帧对ISP没有答复。PADI帧是第一在一系列的PPPoE呼叫建立帧。如果您的ISP不回应PPPoE动态发现提供(PADO), PPPoE协商不成功。此问题的唯一的解决方案将与您的ISP联系。

如果成功协商PPPoE,您的debug vpdn pppoe-events输出看似类似此输出:

Router#debug vpdn pppoe-events
*Mar  3 21:49:38.030: Sending PADI: vc=8/35
*Mar  3 21:50:10.030: PPPOE: we've got our pado and the pado timer went off
*Mar  3 21:50:35.030: OUT PADR from PPPoE tunnel
*Mar  3 21:50:50.030: IN PADS from PPPoE tunnel
Router#undebug all

如果PPPoE顺利地协商,请继续关于排除故障PPP的下一部分。

PPP适当地协商?

如果第1层上,并且有正确VPI/VCI,下一步是确保PPP适当地出现。为了完成此,您需要运行一系列的调试on命令Cisco DSL路由器和解释输出。您使用的主要的调试debug ppp协商。命令的此输出是成功的PPP协商的示例:

Router#debug ppp negotiation

PPP protocol negotiation debugging is on

Router#
2w3d: Vi1 PPP: No remote authentication for call-out
2w3d: Vi1 PPP: Phase is ESTABLISHING
2w3d: Vi1 LCP: O CONFREQ [Open] id 146 len 10
2w3d: Vi1 LCP: MagicNumber 0x8CCF0E1E (0x05068CCF0E1E)
2w3d: Vi1 LCP: O CONFACK [Open] id 102 Len 15
2w3d: Vi1 LCP: AuthProto CHAP (0x0305C22305)
2w3d: Vi1 LCP: MagicNumber 0xD945AD0A (0x0506D945AD0A)
2w3d: Di1 IPCP: Remove route to 20.20.2.1
2w3d: Vi1 LCP: I CONFACK [ACKsent] id 146 Len 10
2w3d: Vi1 LCP: MagicNumber 0x8CCF0E1E (0x05068CCF0E1E)
2w3d: Vi1 LCP: State is Open
2w3d: Vi1 PPP: Phase is AUTHENTICATING, by the peer
2w3d: Vi1 CHAP: I CHALLENGE id 79 Len 33 from "6400-2-NRP-2"
2w3d: Vi1 CHAP: O RESPONSE id 79 Len 28 from "John"
2w3d: Vi1 CHAP: I SUCCESS id 79 Len 4
2w3d: Vi1 PPP: Phase is UP
2w3d: Vi1 IPCP: O CONFREQ [Closed] id 7 Len 10
2w3d: Vi1 IPCP: Address 0.0.0.0 (0x030600000000)
2w3d: Vi1 IPCP: I CONFREQ [REQsent] id 4 Len 10
2w3d: Vi1 IPCP: Address 20.20.2.1 (0x030614140201)
2w3d: Vi1 IPCP: O CONFACK [REQsent] id 4 Len 10
2w3d: Vi1 IPCP: Address 20.20.2.1 (0x030614140201)
2w3d: Vi1 IPCP: I CONFNAK [ACKsent] id 7 Len 10
2w3d: Vi1 IPCP: Address 40.1.1.2 (0x030628010102)
2w3d: Vi1 IPCP: O CONFREQ [ACKsent] id 8 Len 10
2w3d: Vi1 IPCP: Address 40.1.1.2 (0x030628010102)
2w3d: Vi1 IPCP: I CONFACK [ACKsent] id 8 Len 10
2w3d: Vi1 IPCP: Address 40.1.1.2 (0x030628010102)
2w3d: Vi1 IPCP: State is Open
2w3d: Di1 IPCP: Install negotiated IP interface address 40.1.1.2
2w3d: Di1 IPCP: Install route to 20.20.2.1
Router#

有失败四个要点PPP协商的:

  • 从远程设备(您的ISP)的无响应

  • 不开放的链路控制协议(LCP)

  • 认证失败

  • IP Control Protocol (IPCP)失败

从您的ISP的无响应

不响应您的ISP不应该是问题,因为您已经验证数据包在入站方向的ATM0接口增加。然而,如果看到数据包增加在入站方向的ATM0,并且,当您运行debug ppp协商时您收到此输出,请与您的ISP联系验证数据包被发送到Cisco DSL路由器。

Router#debug ppp negotiation
*Mar 1 04:04:50.718: Vi1 PPP: Treating connection as a callout
*Mar 1 04:04:50.718: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 0 load]
*Mar 1 04:04:50.718: Vi1 PPP: No remote authentication for call-out
*Mar 1 04:04:50.722: Vi1 LCP: O CONFREQ [Closed] id 1 Len 10 

!--- "O" specifies an outbound packet.

*Mar 1 04:04:50.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:04:52.722: Vi1 LCP: TIMEout: State REQsent
*Mar 1 04:04:52.722: Vi1 LCP: O CONFREQ [REQsent] id 2 Len 10 

!--- "O" specifies an outbound packet.

*Mar 1 04:04:52.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:04:54.722: Vi1 LCP: TIMEout: State REQsent
*Mar 1 04:04:54.722: Vi1 LCP: O CONFREQ [REQsent] id 3 Len 10 
*Mar 1 04:04:54.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:04:56.722: Vi1 LCP: TIMEout: State REQsent
*Mar 1 04:04:56.722: Vi1 LCP: O CONFREQ [REQsent] id 4 Len 10
*Mar 1 04:04:56.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:04:58.722: Vi1 LCP: TIMEout: State REQsent
*Mar 1 04:04:58.722: Vi1 LCP: O CONFREQ [REQsent] id 5 Len 10
*Mar 1 04:04:58.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:05:00.722: Vi1 LCP: TIMEout: State REQsent
*Mar 1 04:05:00.722: Vi1 LCP: O CONFREQ [REQsent] id 6 Len 10
*Mar 1 04:05:00.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
*Mar 1 04:05:02.722: Vi1 LCP: TIMEout: State REQsent 
*Mar 1 04:05:02.722: Vi1 LCP: O CONFREQ [REQsent] id 7 Len 10 

!--- "O" specifies an outbound packet.

*Mar 1 04:05:02.722: Vi1 LCP: MagicNumber 0x317722F4 (0x0506317722F4)
Router#undebug all

在此输出中有仅O数据包,是出局信息包。为了成功协商PPP,应该有从您的ISP的一I入站数据包发送的每O数据包的。如果数据包是增加入站,但是看不到I数据包,请与您的ISP联系为了验证被发送到Cisco DSL路由器的数据包。

不开放的LCP

是的LCP开放的通常是由不匹配造成的PPP选项。此不匹配发生,当Cisco DSL路由器有配置的一个PPP参数您的ISP不支持,或者,当您的ISP有配置时的一个参数Cisco DSL路由器不支持。此输出显示PPP选项不匹配的示例:

Router#debug ppp negotiation
*Mar 1 04:52:43.254: Vi1 PPP: Treating connection as a callout
*Mar 1 04:52:43.258: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load] 
*Mar 1 04:52:43.258: Vi1 PPP: No remote authentication for call-out 
*Mar 1 04:52:43.258: Vi1 LCP: O CONFREQ [Closed] id 3 len 10
*Mar 1 04:52:43.262: Vi1 LCP: MagicNumber 0x31A2F808 (0x050631A2F808)
*Mar 1 04:52:43.310: Vi1 LCP: I CONFREQ [REQsent] id 180 Len 14
*Mar 1 04:52:43.310: Vi1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 04:52:43.310: Vi1 LCP: MagicNumber 0x39D50E9B (0x050639D50E9B)
*Mar 1 04:52:43.314: Vi1 LCP: O CONFNAK [REQsent] id 180 Len 9

!--- PPP option reject

*Mar 1 04:52:43.314: Vi1 LCP: AuthProto CHAP (0x0305C22305)

!--- PPP option that is rejected

*Mar 1 04:52:43.314: Vi1 LCP: I CONFACK [REQsent] id 3 Len 10
*Mar 1 04:52:43.318: Vi1 LCP: MagicNumber 0x31A2F808 (0x050631A2F808)
*Mar 1 04:52:43.366: Vi1 LCP: I CONFREQ [ACKrcvd] id 181 Len 14
*Mar 1 04:52:43.366: Vi1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 04:52:43.366: Vi1 LCP: MagicNumber 0x39D50E9B (0x050639D50E9B)
*Mar 1 04:52:43.370: Vi1 LCP: O CONFNAK [ACKrcvd] id 181 Len 9 

!--- PPP option reject

*Mar 1 04:52:43.370: Vi1 LCP: AuthProto CHAP (0x0305C22305) 

!--- PPP option that is rejected

*Mar 1 04:52:43.418: Vi1 LCP: I CONFREQ [ACKrcvd] id 182 Len 14
*Mar 1 04:52:43.418: Vi1 LCP: AuthProto PAP (0x0304C023)
*Mar 1 04:52:43.418: Vi1 LCP: MagicNumber 0x39D50E9B (0x050639D50E9B)
Router#undebug all

其I或O数据包,配置否定回答(CONFNAK)是否是预示的PPP配置不匹配。此的什么含义是PPP连接的该一端为PPP选项询问另一侧是无法或不已配置的实行。如果Cisco DSL路由器发送CONFNAK (表示由“O CONFNAK”), Cisco DSL路由器不能实行或没配置为选项ISP发送。如果CONFNAK由您的ISP发送(表示由“CONFNAK”),您配置在Cisco DSL路由器的一个选项您的ISP不是愿意实行。

线路,在CONFNAK描述拒绝的选项后。在此示例输出中,选项是CHAP,但是它可能是所有选项。PPP选项可以配置Cisco DSL路由器的唯一的地方是interface dialer 1.发出show run interface命令拨号1为了查看您的interface dialer 1配置。

如果您的ISP发送I CONFNAK,请寻找在CONFNAK以后匹配线路并且取消他们的命令在interface dialer 1下。如果Cisco DSL路由器发送O CONFNAK,请添加一命令到interface dialer 1适当地协商与您的ISP的PPP。一旦发送数据包的路由器,您也许需要呼叫Cisco TAC为了确定哪些命令在Cisco DSL路由器需要启用。

认证失败

当您的ISP无法验证您的PPP用户名或密码,认证失败发生。有这能发生的两个方案。第一个方案是认证类型不匹配,导致,当您不适当配置路由器时。在本文列出的所有身份验证配置占PAP和CHAP认证类型。对于配置灵活性,您应该安排CHAP和PAP配置。如果不安排两个配置,您也许发现从一debug ppp命令的输出类似此输出:

Router#debug ppp negotiation
00:34:29: Vi1 LCP:O CONFREQ [REQsent] id 53 Len 15 
00:34:29: Vi1 LCP: AuthProto CHAP (0x0305C22305)

!--- Sends CHAP requests

00:34:29: Vi1 LCP: MagicNumber 0x01B63483 (0x050601B63483)
00:34:29: Vi1 LCP: I CONFREQ [REQsent] id 252 Len 14
00:34:29: Vi1 LCP: AuthProto PAP (0x0304C023)

!--- Receives PAP requests from the service provider

00:34:29: Vi1 LCP: MagicNumber 0xBC5233F9 (0x0506BC5233F9)
00:34:29: Vi1 LCP: O CONFREJ [REQsent] id 252 Len 8
Router#undebug all

Router#debug ppp negotiation
00:45:44: Vi1 LCP: I CONFREQ [Listen] id 141 Len 15
00:45:44: Vi1 LCP: AuthProto CHAP (0x0305C22305)

!--- Receives CHAP requests from the service provider

00:45:44: Vi1 LCP: MagicNumber 0xBC5C7DDC (0x0506BC5C7DDC)
00:45:44: Vi1 LCP: O CONFREQ [Listen] id 255 Len 14
00:45:44: Vi1 LCP: AuthProto PAP (0x0304C023) 

!--- Sends out PAP requests

Router#undebug all

!--- Turn off ppp debug


为了更正两验证不匹配问题,参考适当的PPPoA实施选择配置并且重新配置PPP认证。

您能遇到的第二验证问题场景是一不正确PAP用户名或密码。为了确定这是否是问题,请发出debug ppp negotiation命令。假设您的路由器为两质询握手验证协议(CHAP)配置,并且密码认证协议,因为在此指南略述的前配置显示,您的ISP也许不使用PAP认证。

为了确定您的ISP使用的验证,请检查在I CONFREQ数据包的选项发送对您从您的ISP。如果此数据包由呼叫AuthProto的选项跟随PAP,您使用PAP。如果I CONFREQ由呼叫AuthProto的选项跟随CHAP,使用CHAP,并且应该继续到我如何知道我的CHAP用户名和密码是否正确?

如何知道我的PAP用户名和口令是否正确?

在您确认后您的ISP使用PAP,请发出debug ppp negotiation命令确认您的PAP用户名和口令正确。

Router#debug ppp negotiation 
*Mar 2 00:50:15.741: Vi1 PPP: Treating connection as a callout
*Mar 2 00:50:15.745: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
*Mar 2 00:50:15.745: Vi1 PPP: No remote authentication for call-out
*Mar 2 00:50:15.745: Vi1 LCP: O CONFREQ [Closed] id 177 Len 10
*Mar 2 00:50:15.745: Vi1 LCP: MagicNumber 0x35EB5D4F (0x050635EB5D4F)
*Mar 2 00:50:15.789: Vi1 LCP: I CONFACK [REQsent] id 177 Len 10
*Mar 2 00:50:15.793: Vi1 LCP: MagicNumber 0x35EB5D4F (0x050635EB5D4F)
*Mar 2 00:50:17.241: Vi1 LCP: I CONFREQ [ACKrcvd] id 203 Len 14
*Mar 2 00:50:17.241: Vi1 LCP: AuthProto PAP (0x0304C023)
*Mar 2 00:50:17.241: Vi1 LCP: MagicNumber 0x3E1D1E5E (0x05063E1D1E5E)
*Mar 2 00:50:17.245: Vi1 LCP: O CONFACK [ACKrcvd] id 203 Len 14
*Mar 2 00:50:17.245: Vi1 LCP: AuthProto PAP (0x0304C023)
*Mar 2 00:50:17.245: Vi1 LCP: MagicNumber 0x3E1D1E5E (0x05063E1D1E5E)
*Mar 2 00:50:17.249: Vi1 LCP: State is Open
*Mar 2 00:50:17.249: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
*Mar 2 00:50:17.249: Vi1 PAP: O AUTH-REQ id 9 Len 14 from "cisco" 

!--- "cisco" is the PAP username configured on this DSL router.

*Mar 2 00:50:17.297: Vi1 PAP: I AUTH-NAK id 9 Len 27 msg is "Authentication failure"
*Mar 2 00:50:17.301: Vi1 LCP: I TERMREQ [Open] id 204 Len 4
*Mar 2 00:50:17.301: Vi1 LCP: O TERMACK [Open] id 204 Len 4
*Mar 2 00:50:17.305: Vi1 PPP: Phase is TERMINATING [0 sess, 1 load]u
*Mar 2 00:50:19.305: Vi1 LCP: TIMEout: State TERMsent
*Mar 2 00:50:19.305: Vi1 LCP: State is Closed
*Mar 2 00:50:19.305: Vi1 PPP: Phase is DOWN [0 sess, 1 load]

如果有一PAP认证问题,您应该看到LCP状态去开放。直接地,在LCP状态更改您应该看到PPP进入身份验证阶段后。如果下两条线路之一包含I AUTH-NAK,您的PAP用户名或PAP口令不正确。这时,使用命令,此顺序您需要重新配置您的PAP用户名和口令。注意您的PAP用户名和口令区分大小写。

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface dialer 1
Router(config-if)#ppp pap sent-username <username> password <password>
Router(config-if)#end
Router#write memory

如何知道我的CHAP用户名和密码是否正确?

在您确认后您的ISP使用CHAP,请发出debug ppp negotiation命令为了确认您的CHAP用户名和密码正确。

Router#debug ppp negotiation
*Mar 3 02:51:47.287: Vi1 PPP: Treating connection as a callout
*Mar 3 02:51:47.287: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]
*Mar 3 02:51:47.291: Vi1 PPP: No remote authentication for call-out
*Mar 3 02:51:47.291: Vi1 LCP: O CONFREQ [Closed] id 188 Len 10
*Mar 3 02:51:47.291: Vi1 LCP: MagicNumber 0x3B821FF1 (0x05063B821FF1)
*Mar 3 02:51:47.339: Vi1 LCP: I CONFREQ [REQsent] id 204 Len 15
*Mar 3 02:51:47.343: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Mar 3 02:51:47.343: Vi1 LCP: MagicNumber 0x43B3F393 (0x050643B3F393)
*Mar 3 02:51:47.343: Vi1 LCP: O CONFACK [REQsent] id 204 Len 15
*Mar 3 02:51:47.347: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Mar 3 02:51:47.347: Vi1 LCP: MagicNumber 0x43B3F393 (0x050643B3F393)
*Mar 3 02:51:47.347: Vi1 LCP: I CONFACK [ACKsent] id 188 Len 10
*Mar 3 02:51:47.351: Vi1 LCP: MagicNumber 0x3B821FF1 (0x05063B821FF1)
*Mar 3 02:51:47.351: Vi1 LCP: State is Open
*Mar 3 02:51:47.351: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
*Mar 3 02:51:47.395: Vi1 CHAP: I CHALLENGE id 1 Len 32 from "6400-2-NRP3"
*Mar 3 02:51:47.395: Vi1 CHAP: Using alternate hostname cisco
*Mar 3 02:51:47.399: Vi1 CHAP: Username 6400-2-NRP3 not found
*Mar 3 02:51:47.399: Vi1 CHAP: Using default password
*Mar 3 02:51:47.399: Vi1 CHAP: O RESPONSE id 1 Len 26 from "cisco"  

!--- "cisco" is the CHAP username configured on this DSL router.

*Mar 3 02:51:47.447: Vi1 CHAP: I FAILURE id 1 Len 26 MSG is "Authentication failure"
*Mar 3 02:51:47.447: Vi1 LCP: I TERMREQ [Open] id 205 Len 4
*Mar 3 02:51:47.451: Vi1 LCP: O TERMACK [Open] id 205 Len 4
*Mar 3 02:51:47.451: Vi1 PPP: Phase is TERMINATING [0 sess, 0 load]
*Mar 3 02:51:49.451: Vi1 LCP: TIMEout: State TERMsent
*Mar 3 02:51:49.451: Vi1 LCP: State is Closed
*Mar 3 02:51:49.451: Vi1 PPP: Phase is DOWN [0 sess, 0 load]
Router#undebug all

如果有一CHAP认证问题,您应该看到LCP状态去开放。直接地,在LCP状态更改您应该看到PPP进入身份验证阶段后。从此点您看到一系列的CHAP线路。如果这些线路为时显示I失败,您有错误的CHAP用户名和密码。请使用命令此顺序为了更正您的CHAP用户名和密码。注意您的用户名和密码区分大小写。

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface dialer 1
Router(config-if)#ppp chap hostname <username> 
Router(config-if)#ppp chap password <password>
Router(config-if)#end
Router#write memory

当PPP认证是成功的,如何知道?

此示例显示一成功的CHAP协商。

Router#debug ppp negotiation
<... snipped ...>
*Mar 3 03:30:09.335: Vi1 LCP: State is Open
*Mar 3 03:30:09.335: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 1 load]
*Mar 3 03:30:09.379: Vi1 CHAP: I CHALLENGE id 41 len 32 from "6400-2-NRP3"
*Mar 3 03:30:09.379: Vi1 CHAP: Using alternate hostname cisco
*Mar 3 03:30:09.379: Vi1 CHAP: Username 6400-2-NRP3 not found
*Mar 3 03:30:09.383: Vi1 CHAP: Using default password
*Mar 3 03:30:09.383: Vi1 CHAP: O RESPONSE id 41 Len 26 from "cisco"
*Mar 3 03:30:09.431: Vi1 CHAP: I SUCCESS id 41 Len 4

!--- CHAP negotiation was a success.

*Mar 3 03:30:09.431: Vi1 PPP: Phase is UP [0 sess, 1 load] 
<... snipped ...>
Router#undebug all

此示例显示一成功的PAP协商。

Router#debug ppp negotiation
<... snipped ...>
*Mar 3 03:33:19.491: Vi1 LCP: State is Open
*Mar 3 03:33:19.491: Vi1 PPP: Phase is AUTHENTICATING, by the peer [0 sess, 0 load]
*Mar 3 03:33:19.495: Vi1 PAP: O AUTH-REQ id 255 Len 16 from "cisco"
*Mar 3 03:33:19.539: Vi1 PAP: I AUTH-ACK id 255 Len 5
*Mar 3 03:33:19.539: Vi1 PPP: Phase is UP [0 sess, 0 load] 

!--- PAP negotiation was a success.

<... snipped ...>
Router#undebug all

为什么能访问与PPPoE,但是不是其他的一些网页?

当您运行路由器的时,一PPPoE客户端对仅一些网页的访问是常见问题。故意地, PPPoE可以支持1492个字节MTU。所以,您必须保证终端设备派出帧没有大于1492个字节。因为多数PCs和终端用户工作站有1500个字节,默认MTU限制MTU对1492个字节可以是问题。

有调节的MTU大小两个选项:调节MTU大小在路由器并且调节MTU大小在PC。

调节在Cisco DSL路由器的PPPoE MTU大小

重要说明:

只有当运行网络地址转换(NAT)或端口地址转换(PAT)在Cisco DSL路由器,这些配置命令运作。

ip adjust-mss命令在Cisco IOS�软件版本12.2(2)XH更改对ip tcp adjust-mss <mss value>。此变化描述在思科800系列路由器和Cisco 820系列路由器的版本注释上Cisco IOS版本12.2(2)XH的

!
vpdn enable
no vpdn logging
!
vpdn-group pppoe
request-dialin 
protocol pppoe 
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip adjust-mss 1452
 
!--- The TCP MSS command requires an MSS of 1452, not 1492.

 ip nat inside 
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 bundle-enable
!
interface atm0.1 point-to-point
 no ip directed-broadcast
 pvc <vpi/vci>
 pppoe-client dial-pool-number 1 
 !
!
interface dialer1
 ip address negotiated
 mtu 1492
 ip nat outside 
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1 interface dialer1 overload 
!
ip classless 
ip route 0.0.0.0 0.0.0.0 dialer1 
access-list 1 permit <ip address of ethernet0> 0.0.255.255 
!

使用Dr. TCP Utility,调节在PC的PPPoE MTU大小

完成这些步骤为了更改在PC的MTU大小。此过程完成后,系统会保存对注册表的更改。

注意: Dr. TCP Utility是与所有基于Windows个人计算机兼容

  1. 下载Dr. TCP Utility的新版本leavingcisco.com

  2. 刷新浏览器页面以确保页面为最新页面。

  3. 运行Dr.TCP工具。

  4. 从菜单中选择你的以太网适配器;

  5. 在MTU字段键入1492;

  6. 点击“Apply”保存修改,然后点击“Exit”;

  7. 重新启动 PPPoE PC 客户端。

您需要运行工具一次只每个PPPoE客户端PC。

另外的MTU故障排除步骤

如果你使用Dr. TCP更改了MTU大小或者在你的Cisco DSL路由器上更改了MTU大小,而仍然不能访问某些网站,则需要再次调整MTU的大小。在Dr. TCP中把MTU值调整到1452,或者在你的Cisco DSL路由器上把MSS值调整到1412。如果这些数值仍然过大,则继续减小MTU的大小直到调整到所允许的MTU的标准值,在Cisco DSL路由器上,使用Dr. TCP的标准值为1400,使用MSS的标准值为1360。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 71124