语音和统一通信 : Cisco Unified Communications Manager (CallManager)

从Extension Mobility(EM)用户设备配置文件登录的Cisco IP电话,到在EM退出模式下Cisco IP电话的呼叫失败

2016 年 10 月 24 日 - 机器翻译
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简介

本文描述一个原因为什么在登录模式的Cisco IP电话不能呼叫在logout模式的另一Cisco IP电话在与Extension Mobility (EM)的Cisco CallManager环境配置。本文也识别原因并且提供解决方案。这些要素造成失败:

  • 在默认设备配置文件和用户设备配置文件的目录号配置同样。然而,支持此配置。

  • 呼叫转发无应答(CFNA)在用户设备配置文件没有配置。必须设置它为默认设备配置文件的目录号。

先决条件

要求

Cisco建议您有Cisco CallManager知识。

使用的组件

本文档中的信息根据Cisco CallManager版本4.x和以后。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景

设备配置文件组成用特定设备(服务和功能)关联的套属性。设备配置文件包括名称、说明、电话模板、附加模块、目录号、订阅的服务和快速拨号信息。

设备配置文件的两种类型存在:

  • 自动生成的

  • 用户

您能分配用户设备配置文件到用户,因此,当用户登录到设备里,您分配到在该设备上的该用户负载的用户设备配置文件,默认登录设备配置文件。一旦用户设备配置文件装载在电话上,电话拾起该设备配置文件属性。

当您更新电话设置并且选择当前设置生成自动生成的设备配置文件,自动生成的设备配置文件自动地生成。自动生成的设备配置文件关联用一个特定电话为了是注销设备配置文件。您能修改自动生成的设备配置文件,但是不删除它或更改配置文件名称。

拓扑

这些是包括的设备种类:

  • Cisco CallManager

  • 两IP电话

电话设置在图1.呼叫搜索空间(CSS) X表示包含分成A并且分成B。

图1 —电话设置

call-failure-em-1.gif

问题

在方案一中,线路给A和电话B打电话能互相告诉。在方案两中,线路给A打电话不能呼叫在电话B.在电话A和B的Lines 1和2的线路属于不同的分区,但是属于同样CSS。

在方案一中,线路1给A打电话能呼叫在电话B的线路1,并且线路2给A打电话能呼叫在电话B.的线路2。这是情况:

  • EM用户登录到电话A。用户设备配置文件包含此目录号、分区和CSS :

    • Line1 —目录号8571 (分区B, CSS X)

    • Line2 —目录号8571 (分成A, CSS X)

  • EM用户登录到电话B。用户设备配置文件包含此目录号、分区和CSS :

    • Line1 —目录号8572 (分区B, CSS X)

    • Line2 —目录号8572 (分成A, CSS X)

然而,在方案两,当线路1给A在电话B时的呼叫线路1打电话,或者线路2给A在电话B的呼叫线路2打电话,两个失效与快速忙音。这是情况:

  • EM用户登录到电话A。用户设备配置文件包含此目录号、分区和CSS :

    • Line1 —目录号8571 (分区B, CSS X)

    • Line2 —目录号8571 (分成A, CSS X)

  • EM用户登录到电话B. Phone B里不在logout模式。默认设备配置文件包含此目录号、分区和CSS :

    • Line1 —目录号8572 (分成A, CSS X)

总而言之,线路给A和电话B打电话能顺利地互相告诉,如果EM用户登录到两个电话。然而,当电话B在logout模式时,线路给A失败打电话呼叫在电话B的线路,如果EM用户登录到电话A。

原因

当电话在登录模式时,使用特定用户设备配置文件。当电话在logout模式时,使用默认设备配置文件。如果两配置文件用同一个目录号配置,用户设备配置文件优先于设备配置文件,当目录号拨号时。

在方案两中,当线路1打电话时A有一个EM用户登陆并且呼叫在电话B的线路1在logout模式,它失效与急促的忙音。原因是默认设备配置文件有目录号和用户设备配置文件一样。CallManager发送呼叫对用户设备配置文件。因为用户不登录电话,用户设备配置文件没有注册。所以,呼叫失效与急促的忙音。

注意: CallManager呼叫路由根据分区定货在CSS的仍然分配到主叫方。

解决方案

设置CFNA为默认设备配置文件的目录号解决此问题。对于在电话B的线路1,必须设置目录号和用户设备配置文件的CSS为8572X,分别。完成这些步骤:

  1. 登录Cisco CallManager管理。

  2. 选择设备>从菜单栏的设备设置>设备配置文件

  3. 选择特定用户设备配置文件。

    用户设备配置文件配置窗口显示。

  4. 选择在目录号窗格的线路号。

    目录编号配置窗口显示。

  5. 移动对呼叫转发和摘机设置部分(请参阅箭头A在表2)

  6. 输入8572在目的区域。

  7. 从内部的前转无应答的下拉列表选择正确呼叫搜索空间和前转无应答外部(请参阅箭头B在表2)

    图2 —目录编号配置

    call-failure-em-2.gif


相关信息


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