无线/移动 : "无线, LAN (WLAN)"

具有轻量AP和无线局域网控制器(WLC)的Remote-Edge AP (REAP)与配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 19 日) | 反馈


目录


简介

Remote-edge接入点(请收割)功能介绍与Cisco Unified无线网络允许思科轻量级接入点(拉普)的远程部署从无线局域网(WLAN)控制器(WLC)。这做他们分支机构和小零售位置的理想。本文解释如何部署与使用的一个基于REAP的WLAN网络Cisco 1030系列LAP和4400 WLCs。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 了解 WLC 和如何配置 WLC 基本参数

  • 收割操作模式的知识在思科中1030个LAP

  • 一个外部DHCP服务器和域名系统(DNS)服务器的配置的知识

  • 了解 Wi-Fi 保护访问 (WPA) 概念

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 运行固件版本4.2的Cisco 4400系列WLC

  • 思科1030个LAP

  • 运行Cisco IOS�软件版本12.2(13)T13的两Cisco 2800系列路由器

  • 运行固件版本3.0的Cisco Aironet 802.11a/b/g客户端适配器

  • Cisco Aironet Desktop软件版本3.0

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

收割模式使LAP在广域网链路间驻留和仍然能通信与WLC和提供正常LAP的功能。目前只有 1030 LAP 支持 REAP 模式。

为了提供此功能, 1030收割从无线数据飞机分离轻量级接入点协议(LWAPP)控制飞机。思科WLCs相似地仍然使用集中控制和管理使用正常基于LWAPP的接入点(AP),而所有用户数据桥接本地在AP。对本地网络资源的访问在整个广域网中断维护。

收割AP支持两操作模式:

  • 正常收割模式

  • 独立模式

当在收割AP和WLC之间的广域网链路是UP时, LAP在正常设置收割模式。当拉普在正常时运行请收割模式,他们可以支持16 WLAN。

当在WLC和LAP之间的广域网链路断开,对独立模式的已启用REAP的LAP交换机。如果WLAN配置与有线等效保密(WEP)或任何本地认证方法,当在独立模式,收割拉普只可以独立地支持一WLAN,不用WLC时。在这种情况下,收割AP支持的WLAN是在AP配置的第一WLAN, WLAN 1。这是因为大多其他认证方法需要到/从控制器,当广域网链路发生故障时,此操作通过信息不是可能的。在独立模式,拉普支持最低的一套功能。此表显示收割LAP支持的功能集,当在独立模式与收割LAP在正常模式支持的功能比较时(当广域网链路上时,并且对WLC的通信是UP) :

收割LAP在正常支持的功能收割模式和在独立模式

/image/gif/paws/70262/reap_lap_wlc1.gif

表显示在两种模式的REAP拉普不支持多个VLAN。不支持多个VLAN,因为请收割拉普能只驻留在单个子网,因为他们不可执行IEEE 802.1Q VLAN标记。所以,在其中每一的流量服务集标识符(Ssid)在相同子网终止作为有线网络。结果,数据流在有线的侧没有被分离,即使无线数据流可能在Ssid之间的空气被分段。

参考请在分支机构收割部署指南关于的更多信息收割部署,并且如何管理请收割和其限制。

配置

本部分提供有关如何配置本文档所述功能的信息。

为了配置设备实现网络设置,请完成这些步骤:

  1. 配置基本操作的WLC并且配置WLAN

  2. 在远程站点填装安装的AP

  3. 配置2800路由器设立广域网链路

  4. 在远程站点部署收割LAP

网络图

本文档使用以下网络设置:

/image/gif/paws/70262/reap_lap_wlc2.gif

总部连接到有使用的分支机构一条租用的线路。租用的线路在2800系列路由器终止在每个末端。此示例使用开放最短路径优先(OSPF)协议路由在广域网链路的数据与PPP封装。4400 WLC在总部,并且必须在远程办公室部署1030个LAP。1030个LAP必须支持两WLAN。这是WLAN的参数:

  • WLAN 1

    • SSID — SSID1

    • 验证—打开

    • 加密—临时密钥完整性协议(TKIP) (WPA预先共享密钥[WPA-PSK])

  • WLAN 2

    • SSID — SSID2

    • 验证—可扩展的认证协议(EAP)

    • 加密— TKIP

      注意: 对于WLAN 2,在本文的配置使用WPA (802.1x验证和TKIP加密的)。

您必须配置此设置的设备。

配置基本操作的WLC并且配置WLAN

您能使用命令行界面(CLI)的启动配置向导为了配置基本操作的WLC。此外,也可以使用 GUI 配置 WLC。本文解释在WLC的配置与使用CLI的启动配置向导。

首次启动 WLC 之后,它将直接进入启动配置向导。您使用配置向导配置基本设置。可以在 CLI 或 GUI 中运行该向导。这是启动配置向导的示例:

Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_33:84:a0]: WLC_MainOffice
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
Management Interface IP Address: 172.16.1.50
Management Interface Netmask: 255.255.0.0
Management Interface Default Router: 172.16.1.60
Management Interface VLAN Identifier (0 = untagged):
Management Interface Port Num [1 to 4]: 1
Management Interface DHCP Server IP Address: 172.16.1.1
AP Manager Interface IP Address: 172.16.1.51
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (172.16.1.1):
Virtual Gateway IP Address: 1.1.1.1
Mobility/RF Group Name: Main
Network Name (SSID): SSID1
Allow Static IP Addresses [YES][no]: Yes
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
Enter Country Code (enter 'help' for a list of countries) [US]:
Enable 802.11b Network [YES][no]: Yes
Enable 802.11a Network [YES][no]: Yes
Enable 802.11g Network [YES][no]: Yes
Enable Auto-RF [YES][no]: Yes

Configuration saved!
Resetting system with new configuration...

此示例配置在WLC的这些参数:

  • 系统名称

  • 管理接口 IP 地址

  • Ap-manager接口IP地址

  • 管理接口端口号

  • 管理接口VLAN标识符

  • 移动组名称

  • SSID

  • 许多其他参数

这些参数用于设置基本操作的WLC。当在此部分的WLC输出显示, WLC使用172.16.1.50作为管理接口IP地址和172.16.1.51作为Ap-manager接口IP地址。为了配置您的网络的两WLAN,请完成在WLC的这些步骤:

  1. 从WLC GUI,请单击在菜单的WLAN在窗口顶部。

    随即显示 WLAN 窗口。此窗口列出在WLC配置的WLAN。由于您配置与使用的一WLAN启动配置向导,您必须配置此WLAN的其他参数。

  2. 单击为WLAN SSID1编辑

    示例如下:

    reap_lap_wlc3.gif

    这时将显示“WLANs”>“Edit”窗口。在此窗口,您能配置是特定对WLAN,包括一般策略,安全策略, RADIUS服务器的参数和其他。

  3. 做在WLAN > Edit Window的这些选择:

    1. 在一般策略地区中,请检查在管理状态旁边的Enabled复选框为了启用此WLAN。

    2. 从第2层安全下拉菜单选择WPA为了使用WPA WLAN 1。

    3. 在窗口的底部定义WPA参数。

      为了使用在WLAN 1的WPA-PSK,请在WPA参数范围检查在预先共享密钥旁边的Enabled复选框并且进入WPA-PSK的密码短语。WPA-PSK将使用TKIP加密。

      注意: 在客户端适配器配置为了WPA-PSK能工作的WPA-PSK密码短语必须匹配密码短语。

    4. 单击 Apply

    示例如下:

    reap_lap_wlc4.gif

    您配置WPA-PSK加密的WLAN 1。

  4. 为了定义WLAN 2,请点击在WLAN窗口。

    WLAN >New窗口出现。

  5. 在WLAN >New窗口,请定义WLAN ID和WLAN SSID,并且单击应用

    示例如下:

    reap_lap_wlc5.gif

    第二WLAN的WLAN > Edit Window出现。

  6. 做在WLAN > Edit Window的这些选择:

    1. 在一般策略地区中,请检查在管理状态旁边的Enabled复选框为了启用此WLAN。

    2. 从第2层安全下拉菜单选择WPA为了配置此WLAN的WPA。

    3. 在RADIUS服务器区域,请选择适当的RADIUS服务器使用客户端的验证。

    4. 单击 Apply

    示例如下:

    reap_lap_wlc6.gif

注意: 本文档未说明如何配置 RADIUS 服务器和 EAP 身份验证。关于如何配置与WLCs的EAP验证的信息,参考与WLAN控制器(WLC)配置示例的EAP验证

在远程站点填装安装的AP

飞沫是拉普得到控制器列表他们能连接的进程。当他们连接到单个控制器,拉普是消息灵通的在移动组的所有控制器。这样,拉普学习他们在组中需要为了加入所有控制器的所有信息。

为了填装REAP支持AP,请连接AP对有线网络在总部。此连接允许AP发现单个控制器。在LAP在总部后加入控制器, AP下载对应与WLAN基础设施和配置的AP操作系统(OS)版本。所有控制器的IP地址在移动组的转接对AP。当AP有需要的所有信息时, AP可以在远程位置连接。如果IP连通性是可用的, AP能然后发现和加入从列表的最少使用的控制器。

注意: 确保您设置AP “收割”模式,在您关闭他们为了发运他们到远程站点前。您能设置模式在AP级别通过控制器CLI或GUI,或者与使用无线控制系统(WCS)模板。默认情况下AP设置执行正常, “本地”功能。

拉普能使用任何一个这些方法为了发现控制器:

  • Layer2发现

  • 第3层发现

    • 使用使用本地子网广播

    • 使用使用DHCP选项43

    • 使用使用DNS服务器

    • 使用使用通过空气供应(OTAP)

    • 使用使用一个内部DHCP服务器

      注意: 为了使用一个内部DHCP服务器, LAP必须连接直接地到WLC。

本文假设, LAP注册对与使用的WLC DHCP选项43发现机制。关于使用DHCP选项43注册LAP对控制器,以及其他发现机制的更多信息,参考轻量AP (LAP)注册到无线局域网控制器(WLC)

在LAP发现控制器后,您能看到AP注册到在WLC的无线窗口的控制器。示例如下:

/image/gif/paws/70262/reap_lap_wlc7.gif

完成这些步骤为了配置正常的LAP收割模式:

  1. 从 WLC GUI 中,单击 Wireless

    所有AP窗口出现。此窗口列出注册对WLC的AP。

  2. 选择您必须为REAP模式配置的AP并且点击详细信息

    所有特定AP的AP >详细信息窗口出现。在此窗口,您能配置AP的多种参数,包括:

    • AP名称

    • 您能更改到静态)的IP地址(

    • 管理状态

    • 安全参数

    • AP模式

    • AP能连接WLCs的列表

    • 其他参数

  3. 选择从AP模式下拉菜单收割

    此模式只是可用的在REAP支持AP。

  4. 定义AP将使用注册的控制器名称并且单击应用

    您最多可以定义三个控制器名称(主控制器、辅助控制器和第三控制器)。AP 将按照您在此窗口中提供的顺序搜索控制器。因为本示例只使用一个控制器,所以示例将该控制器定义为主控制器。

    示例如下:

    reap_lap_wlc8.gif

您设置REAP模式的AP,并且您能在远程站点部署它。

注意: 在此示例窗口,您能看到AP的IP地址更改对静态,并且静态IP地址192.168.1.5分配。这样分配是因为它是将在远程办公室中使用的子网。因此您使用从DHCP服务器的IP地址, 172.16.1.80,仅在飞沫阶段。在 AP 注册到控制器后,将地址更改为静态 IP 地址。

配置2800路由器设立广域网链路

为了设立广域网链路,此示例以OSPF使用两2800系列路由器对在网络之间的路由信息。这是两路由器的配置示例情形的在本文:

MainOffice
MainOffice#show run
Building configuration...

Current configuration : 728 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainOffice
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 172.16.1.60 255.255.0.0

!--- This is the interface which acts as the default gateway to the WLC.

!
interface Virtual-Template1
 no ip address
!
interface Serial0
 no ip address
!
interface Serial1

!--- This is the interface for the WAN link.

 ip address 10.0.0.1 255.0.0.0
 encapsulation ppp

!--- This example uses PPP. Use the appropriate 
!--- encapsulation for the WAN connection.

!
router ospf 50

!--- Use OSPF to route data between the different networks.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
!
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

BranchOffice
BranchOffice#show run
Building configuration...

Current configuration : 596 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BranchOffice
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0

!--- This is the interface which acts as the default gateway to the LAP.

!
interface Serial0
 no ip address
!
interface Serial1

!--- This is the interface for the WAN link.

 ip address 10.0.0.2 255.0.0.0
 encapsulation ppp
 clockrate 56000
!
router ospf 50

!--- Use OSPF to route data between the different networks.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 autocommand  access enable-timeout 2
!
end

在远程站点部署收割AP

即然您配置在WLCs的WLAN,填装了LAP,并且设立了在总部和远程办公室之间的广域网链路,您准备在远程站点部署AP。

在您在远程站点后加电AP, AP寻找控制器按您在飞沫阶段配置的顺序。在AP查找控制器后, AP向控制器登记。下面是一个示例。从WLC,您能看到AP加入在端口1的控制器:

/image/gif/paws/70262/reap_lap_wlc7.gif

有SSID SSID1的客户端和哪WPA-PSK启用, AP的关联在WLAN有SSID SSID2,并且安排802.1x验证启用的1.客户端, AP的关联在WLAN 2。这是显示两个客户端的示例。一个客户端连接对WLAN 1,并且另一个客户端连接对WLAN 2 :

/image/gif/paws/70262/reap_lap_wlc9.gif

验证

请使用此部分确认您请适当地收割配置工作。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

减少广域网链路。当广域网链路发生故障时, AP丢失与WLC的连接。WLC然后注销登记从其列表的AP。示例如下:

(Cisco Controller) >debug lwapp events enable
Wed May 17 15:04:22 2006: Did not receive heartbeat reply from AP 00:0B:85:51:5A:E0
Wed May 17 15:04:22 2006: Max retransmissions reached on AP 00:0B:85:51:5A:E0  
(CONFIGURE_COMMAND, 1)
Wed May 17 15:04:22 2006: apfSpamProcessStateChangeInSpamContext: Down LWAPP event for 
AP 00:0b:85:51:5a:e0 slot 0
Wed May 17 15:04:22 2006: apfSpamProcessStateChangeInSpamContext: Deregister LWAPP event 
for AP 00:0b:85:51:5a:e0 slot 0
Wed May 17 15:04:22 2006: apfSpamProcessStateChangeInSpamContext: Down LWAPP event for 
AP 00:0b:85:51:5a:e0 slot 1
Wed May 17 15:04:22 2006: apfSpamProcessStateChangeInSpamContext: Deregister LWAPP event 
for AP 00:0b:85:51:5a:e0 slot 1
Wed May 17 15:04:22 2006: spamDeleteLCB: stats timer not initialized for AP 
00:0b:85:51:5a:e0
Wed May 17 15:04:22 2006: Received LWAPP Down event for AP 00:0b:85:51:5a:e0 slot 0!
Wed May 17 15:04:22 2006: Deregister LWAPP event for AP 00:0b:85:51:5a:e0 slot 0
Wed May 17 15:04:22 2006: Received LWAPP Down event for AP 00:0b:85:51:5a:e0 slot 1!
Wed May 17 15:04:22 2006: Deregister LWAPP event for AP 00:0b:85:51:5a:e0 slot 1

debug lwapp events enable命令输出,您能看到WLC注销登记AP,因为WLC没有收到从AP的一个检测信号答复。检测信号应答类似于保活消息。控制器尝试五个连续心跳线, 1秒单独。如果WLC不收到答复, WLC注销登记AP。

当AP在独立模式时, AP电源LED闪烁。联合对第一WLAN的客户端(WLAN 1)仍然关联对AP,因为第一WLAN的客户端为仅WPA-PSK加密配置。LAP处理在独立模式的加密。这是显示状态的示例(当广域网链路发生故障)时客户端连接对与SSID1和WPA-PSK的WLAN 1 :

注意: TKIP是使用与WPA-PSK的加密。

/image/gif/paws/70262/reap_lap_wlc10.gif

连接对WLAN 2的客户端被断开,因为WLAN 2使用EAP验证。此断开出现,因为使用EAP验证需要通信到WLC的客户端。这是表示该EAP验证发生故障的示例窗口,当广域网链路发生故障:

/image/gif/paws/70262/reap_lap_wlc11.gif

在广域网链路是UP后,回到正常的AP交换机收割模式和向控制器登记。也使用EAP验证的客户端出现。示例如下:

reap_lap_wlc12.gif

此输出示例: debug lwapp events enable命令在控制器显示这些结果:

(Cisco Controller) >debug lwapp events enable
Wed May 17 15:06:40 2006: Successful transmission of LWAPP Discovery-Response 
to AP 00:0b:85:51:5a:e0 on Port 1
Wed May 17 15:06:52 2006: Received LWAPP JOIN REQUEST from AP 00:0b:85:51:5a:e0to 
00:0b:85:33:84:a0 on port '1'
Wed May 17 15:06:52 2006: LWAPP Join-Request MTU path from AP 00:0b:85:51:5a:e0is 1500, 
remote debug mode is 0
Wed May 17 15:06:52 2006: Successfully added NPU Entry for AP 00:0b:85:51:5a:e0(index 51)
Switch IP: 172.16.1.51, Switch Port: 12223, intIfNum 1, vlanId 0AP IP: 192.168.1.5, AP 
Port: 5550, next hop MAC: 00:d0:58:ad:ae:cb
Wed May 17 15:06:52 2006: Successfully transmission of LWAPP Join-Reply to AP 
00:0b:85:51:5a:e0
Wed May 17 15:06:52 2006: Register LWAPP event for AP 00:0b:85:51:5a:e0 slot 0
Wed May 17 15:06:52 2006: Register LWAPP event for AP 00:0b:85:51:5a:e0 slot 1
Wed May 17 15:06:54 2006: Received LWAPP CONFIGURE REQUEST from AP 00:0b:85:51:5a:e0 to 
00:0b:85:33:84:a0
Wed May 17 15:06:54 2006: Updating IP info for AP 00:0b:85:51:5a:e0 -- static 1, 
192.168.1.5/255.255.255.0, gtw 192.168.1.1

故障排除

使用本部分可排除配置故障。

故障排除命令

您能使用这些调试指令排除故障配置。

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • 调试lwapp事件enable (event) —显示发生在LAP和WLC之间的事件顺序。

  • 调试lwapp错误enable (event) —显示在LWAPP通信生成的错误。

  • 调试lwapp数据包enable (event) —显示LWAPP数据包踪迹的调试。

  • 调试MAC地址—启用调试为您指定的客户端的MAC。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 70262