语音和统一通信 : Cisco Unified Communications Manager (CallManager)

统一CallManager装载大MOH音频源文件失败

2016 年 10 月 24 日 - 机器翻译
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简介

本文为一个原因记述并提供解决方案为什么Cisco Unified CallManager不能装载大Music on Hold (MOH)音频源文件。

先决条件

要求

思科建议您有Cisco Unified CallManager知识。

使用的组件

本文档中的信息根据思科Unifed CallManager。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景

激活服务器页面定一个给的页能执行的时间的一限制。基本原理是,如果页花些许多时间执行和返回结果,用户变得沮丧并且按Stop按钮在浏览器。

在互联网信息服务器(IIS)所有版本的默认超时设置为90秒。然而,一旦文件加载,页必须执行处于加载的。如果用户转接信息过渡一条缓慢的线路或转接很大数量的信息,超过此限制是容易的。

症状

当您插入一份新的大MOH音频源文件,执行脚本错误发生。新的MOH音频源文件顺利地转码对Ulaw.wav、Alaw.wav、G729.wav和Wb.wav,但是不能插入(请参阅箭头A在表1)。

图1 —插入新建的MOH音频来源

http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-1.gif

此错误消息显示(请参见图2)

Server returned HTTP response code: 500 for URL:
图2 —远程执行脚本错误

http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-2.gif

ASP 0113 Script_timed_out错误消息识别,当此示例输出显示,当您查看对应的IIS错误日志文件。日志文件在c:\WINNT\System32\LogFiles\W3SVC1目录查找:

2006-01-30 21:46:40 10.174.129.246 - 10.174.129.246 80 GET
 /CCMAdmin/_RemoteScripts/rs_mediaresource.asp _method=updateMOHAudioSource&
_mtype=execute&pcount=10&p0=%7BB2D8F578-4C1C-4299-BF06-
45B5A102EF80%7D&p1=3&p2=ciscotac&p3=ciscotac.xml&p4=-794816657&p5=29763044&p6=null&
p7=null&p8=%5C%5C142.174.129.246%5CTFTPPATH%5C&p9=ciscotac.ULAW.wav%7Cciscotac.ALAW.
wav%7Cciscotac.G729.wav%7Cciscotac.WB.wav|-|ASP_0113|Script_timed_out 
500 0 Mozilla/4.0+(compatible;+MSIE+6.0;+Win32) -

原因

ScriptTimeout属性指定脚本能运行的最大数量时间,在终止前。错误生成,当脚本的处理时间超出被选定了ScriptTimeout属性的最大值时。它解释此问题为什么只发生,当您插入大MOH音频源文件。

解决方法

您能增加允许处理一个特定的网站的ASP脚本的时间。更改在IIS的元数据库值为了完成此。

完成这些步骤:

  1. 选择Start > Programs > Administrative Tools > Internet Services Manager打开Internet Services Manager。

  2. 展开树和默认网站。

  3. 用鼠标右键单击Ccmadmin在默认网站下。

  4. 单击 Properties

  5. 点击Home Directory选项。

  6. 点击配置查找在应用设置下。

  7. 点击App Options选项。

    Application Configuration窗口显示(请参见图3)

    图3 —应用程序配置

    http://www.cisco.com/c/dam/en/us/support/docs/unified-communications/unified-communications-manager-callmanager/68980-ccm-large-moh-files-3.gif

  8. 增加ASP脚本超时值对足够编号高防止脚本超时。

    在这种情况下,值增加对180秒(请参阅箭头A在表3)为了成功负载大MOH源文件。

如果收到陈述文件的错误太大,当您设法上传比8秒长的所有音频源文件时,也许归结于您使用的浏览器。Cisco Unified CallManager管理的正式支持的浏览器是:

  • Netscape Communicator 4.X

  • 微软Internet Explorer 5或6

参考的浏览对Cisco CallManager管理欲知更多信息。

Error:未知CM_Media_PayloadType 262

问题

当您尝试上传MOH音频源文件时,进程失效与此错误:

未知CM_Media_PayloadType 262

解决方案

WAV文件不在需要的格式,此错误出现。音频文件必须在这些格式之一中:

  • G.711 A律或mu-law

  • G.729附件A

  • 宽带

并且,请确保它8000兆赫和16位采样。

参考Cisco Bug ID CSCtr11072 (仅限注册用户)欲知更多信息。


相关信息


Document ID: 68980