安全 : Cisco ONS 15454 SDH Multiservice Provisioning 平台 (MSPP)

在ONS15454和Catalyst交换机上通过RPR使用ML卡配置EtherChannel

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 30 日) | 反馈


目录


简介

此文档说明配置EtherChannel和802.1Q的步骤建立隧道使用一台思科Catalyst 3500xl交换机和ML-series卡在Resilient Packet Ring (RPR)间在Cisco ONS 15454环境。

先决条件

要求

Cisco 建议您了解以下主题:

  • Cisco ONS 15454

  • Cisco ONS 15454 ML-Series以太网卡

  • Catalyst 3500xl交换机

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco ONS 15454版本6.x

  • 运行Cisco IOS�软件版本12.0(5)XC的Catalyst 3500xl交换机

  • ML (被捆绑作为ONS15454 6.0版本一部分)该运行Cisco IOS�软件版本12.2(27)SV和以上

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

网络图

本文以两ONS15454节点和两台Catalyst 3500xl交换机使用一个实验室设置。EachONS 15454配备有一个ML1000-2卡,并且Resilient Packet Ring (RPR)被建立在他们之间在ML1000-2卡间。Catalyst 3500 XL的两千兆以太网端口连接到各自ML1000-2卡的两千兆以太网端口。网络图在图1显示

图 1:网络图

/image/gif/paws/69342/f1.gif

配置

配置RPR

完成这些步骤构件RPR :

  1. 创建在POS 0 ML1000-2在ONS15454 A和POS ML1000-2 1之间的一个电路在ONS15454 B.的。

  2. 创建在POS 1 ML1000-2在ONS15454 A和POS ML1000-2 0之间的一个电路在ONS15454 B.的。

  3. 配置在ONS15454 A.的ML1000-2卡。

    1. 启用集成的桥接和路由(IRB)。

      bridge irb
      
    2. 创建网桥1

      Bridge 1 protocol rstp  
    3. 配置SRP接口。

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. 配置接口POS0。

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. 配置接口POS1。

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. 配置在ONS15454 B.的ML1000-2卡。

    1. 启用集成的桥接和路由(IRB)。

      bridge irb
      
    2. 创建网桥1

      Bridge 1 protocol rstp
      
    3. 配置SRP接口。

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. 配置接口POS0。

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. 配置接口POS1。

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

配置以太网信道

完成这些步骤构件EtherChannel :

  1. 配置接口GigabitEthernet0/1和GigabitEthernet0/2在CAT3500_A。

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. 配置接口GigabitEthernet0/1和GigabitEthernet0/2在CAT3500_B。

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. 配置在ONS15454 A.的ML1000-2。

    1. 配置interface gigabitethernet 0和GigabitEthernet1。

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. 配置Port-Channel。

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. 配置在ONS15454 B.的ML1000-2。

    1. 配置接口GigabitEthernet0和GigabitEthernet1。

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. 配置Port-Channel。

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

验证

完成这些步骤验证配置:

  1. 发出show interfaces port-channel命令从在ONS15454 A.的ML1000-2。此命令showsthat EtherChannel包含两千兆以太网端口(请参阅黑体字符)。

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. 发出show interfaces port-channel命令从在ONS15454 B.的ML1000-2。此命令显示EtherChannel包含两千兆以太网端口(请参阅黑体字符)。

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. 发出show cdp neighbor命令在CAT3500_A (请参见图2)。此命令显示CAT3500_B作为其邻居通过EtherChannel。

    图 2:在CAT3500_A的show cdp neighbor

    f2.gif

  4. 发出show cdp neighbor命令在CAT3500_B (请参见图3)。此命令显示CAT3500_A作为其邻居通过EtherChannel。

    图 3:在CAT3500_B的show cdp neighbor

    f3.gif

  5. 执行ping测试。

    1. 配置在CAT3500_A的VLAN2与IP地址192.168.0.2。

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. 配置在CAT3500_B的VLAN2与IP地址192.168.0.4。

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. 发出ping命令在CAT3500_A (请参见图4)

      ping 192.168.0.4
      
      图 4:Ping测试从CAT3500_A到CAT3500_B

      /image/gif/paws/69342/f4.gif

    4. 发出ping命令在CAT3500_B (请参见图5)

      ping 192.168.0.2
      
      图 5:Ping测试从CAT3500_B到CAT3500_A

      /image/gif/paws/69342/f5.gif

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 69342