无线/移动 : WLAN 安全

带内部DHCP和开放式认证的1800 ISR无线路由器配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 10 月 1 日) | 反馈


目录


简介

本文在思科1800集成业务路由器(ISR)提供无线局域网(WLAN)的配置示例。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 在Cisco IOS�软件版本12.3或以上的1800个ISR有先进的IP服务特性组的

    注意: 您能运用相同的配置到任何ISR。配置不是特定对1800系列。

  • 有这些无线网卡的PC :

    • 802.11a

    • 802.11b

    • 802.11b/g a/b/g

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用以下网络设置:

对路由器的无线连接

1800_isr_wireless1.gif

配置

逐步指导

完成这些步骤:

  1. 设置DHCP范围并且排除了地址。

    注意: 不包括地址可选。

    在Cisco IOS软件方面参考DHCP服务器的更多详细说明的Cisco IOS DHCP服务器

  2. 打开同意的路由和桥接,并且组成网桥组。

  3. 分配IP地址建立接口网桥组虚拟接口1 (BVI1)。

  4. 设置无线。

    1. 分配接口Dot11Radio0或Dot11Radio1到网桥组1。

    2. 分配服务集标识(SSID)到无线接口,然后定义开放式验证。

配置

本文档使用以下配置:

1800系列ISR无线和DHCP配置
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

验证

使用本部分可确认配置能否正常运行。

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

请使用这些命令为了验证适当的DHCP和无线操作:

  • show dot11 associations

  • show ip dhcp binding

MAC和IP地址在输出show dot11 associations命令和输出必须配比show ip dhcp binding命令中。示例如下:

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address��� �IP address����� Device������� ���Name����������Parent�������� State��� �
0040.96ac.345c  192.168.2.101�� CB21AG/PI21AG��� WLCLIENT� ��� self���������� Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address��������� Client-ID/������������� Lease expiration������ Type
���������������������Hardware address/
���������������������User name
192.168.2.101��     0100.4096.ac34.5c������ Dec 18 2005 05:07 PM�� Automatic
1800-ISR#

故障排除

使用本部分可排除配置故障。

故障排除命令

注意: 使用 debug 命令之前,请参阅有关 Debug 命令的重要信息

发出debug ip dhcp server packet命令为了调试Ip dhcp server。使用一未加密开启验证WLAN,此命令提供最快速和多数有效方法排除故障。

debug ip dhcp server packet命令显示这些数据处理:

/image/gif/paws/68099/1800_isr_wireless2.gif

此输出debug ip dhcp server packet命令是成功的DHCP请求的示例:

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

故障排除步骤

如果在输出看不到DHCP提供debug ip dhcp server packet命令中,请开始排除故障802.11协议。完成这些步骤:

  1. 请勿验证无线客户端设置、SSID和安全/加密设置。

    注意:SSID必须是相同的在ISR和客户端。在这种情况下, SSID是“思科”。图1图2显示在Cisco Aironet Desktop软件(ADU)和Aironet客户端工具(ACU)的SSID设置。您看到的窗口取决于您使用的无线客户端卡和固件版本。

    图1 –思科ADU SSID设置

    1800_isr_wireless3.gif

    图2 – Cisco ACU SSID设置

    1800_isr_wireless4.gif

    图3 – Windows无线置零

    /image/gif/paws/68099/1800_isr_wireless5.gif

  2. 验证wi-fi兼容性。

    参考wi-fi联盟leavingcisco.com 页为了验证使用无线网卡(NIC)的wi-fi兼容性。

  3. 请与进一步技术支持的思科技术支持联系

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 68099