协作 : 思科呼出选项

IPCC企业的IP 拨号故障

2016 年 10 月 27 日 - 机器翻译
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简介

本文描述一个原因为什么IP拨号程序不能拨号客户,并且提供在Cisco IP Contact Center (IPCC)企业环境的一解决方案。

先决条件

要求

Cisco 建议您了解以下主题:

  • Cisco ICM

  • Cisco 出站选项

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco ICM版本5.x和以后

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

这是一个典型的预测或渐进呼叫流(请参见图1)

  1. IP拨号程序通过Media Routing (MR)接口请求代理程序。

  2. 路由器运行路由脚本选择可用座席。

  3. 路由器返回可用座席。

  4. 外围网关(PG)保留可用座席。

  5. IP拨号程序发出呼叫到代理程序线路1维护保留呼叫。

  6. IP拨号程序然后发出呼叫给客户。

  7. IP拨号程序分析流入实时协议(RTP)数据流,并且检测一个实际人。

  8. 客户呼叫在代理程序的电话到达到第二行。拨号程序预约通过计算机电话集成(CTI)服务器应答客户呼叫。

图1 –典型的预测或渐进呼叫进程

/image/gif/paws/64926/ipdialerfailure_01.gif

图1, DLR代表IP拨号程序,并且RTR代表路由器。

问题

IP拨号程序不能发出呼叫对客户。根据此日志, IP拨号程序不能下载从TFTP server的配置文件:

13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 1 of 50 Attempts 
13:00:06 dialer-baDialer Trace: Getting Configuration File
 [SEPDA005002f000.cnf.xml] from TFTP Server [192.168.210.246] 
13:00:06 dialer-baDialer Trace: Unable to get XML Config file
 [SEPDA005002f000.cnf.xml] from Call Manager; 2 of 50 Attempts 

原因

当您不正确地,配置注册表值TFTPServer此配置问题出现。此问题能也指向CallManager服务器,不用安装的TFTP server。无论如何, IP拨号程序不发出呼叫给客户。

这是TFTPServer的注册定位路径(请参见图2)

HKEY_LOCAL_MACHINE\SOFTWARE\Cisco Systems, Inc.\ICM\<inst_name>\Dialer\TFTPServer
图2 – TFTPServer注册表项

ipdialerfailure_02.gif

解决方案

完成这些步骤以解决此问题:

  1. 运行Cisco ICM拨号程序设置。

  2. 保留所有现有参数,除了CallManager TFTP server的名称。在CallManager TFTP server字段键入正确CallManager TFTP server名称。

    保证此CallManager服务器支持TFTP server功能。

    图3 –去话选项拨号程序属性

    /image/gif/paws/64926/ipdialerfailure_03.gif


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