网络管理 : Cisco ONS 15454 SONET Multiservice Provisioning Platform (MSPP)

访问CTC的多个Java插件安装

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 30 日) | 反馈


目录


简介

本文描述步骤安装多Java插件版本为了访问Cisco传输控制器。

先决条件

要求

Cisco 建议您了解以下主题:

  • Cisco传输控制器

  • Cisco ONS 15454/15327

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco传输控制器

  • Cisco ONS 15454/15327

  • Internet Explorer、Netscape和Mozilla (为了使用在同样PC的三个不同的Java运行时环境(JRE)版本)

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

此部分提供需要的背景信息帮助您了解更加好的本文内容。

多Java插件版本

当您安装多Java插件版本时,您能排除需要删除和重新安装Java插件一不同的版本为了顺利地访问多思科ONS15454/15327操作软件软件版本。在实施以后,您启动根据您要访问节点的操作软件软件版本的相关浏览器。

浏览器信息

您启动CTC的浏览器取决于Java 2运行时的环境、标准版(J2SE) JRE版本ONS15454或15327支持。表1列出每个版本的相关浏览器。

表1 – J2SE JRE每个版本的浏览器

ONS15454或15327支持的版本 将使用的浏览器启动CTC
J2SE JRE版本1.2.2 Microsoft Internet Explorer
J2SE JRE版本1.3.2 Netscape
J2SE JRE版本1.4.2 Mozilla

Mozilla安装

您必须安装Mozilla,即使您已经安装Internet Explorer和Netscape。当您安装所有三个浏览器时,您能使用在同样PC的三不同的JRE版本。

为了安装Mozilla,第一步将下载从www.mozilla.org的Mozilla版本1.7.1leavingcisco.com文件名是mozilla-win32-1.7.1-installer。完成这些步骤:

  1. 运行mozilla-win32-1.7.1-installer。设置的Mozilla - Welcome窗口出现(请参见图1)

    图1 –设置的Mozilla :Welcome窗口

    moza_ctc_64021_f1.gif

  2. 单击 Next。软件许可协议窗口出现(请参见图2)

    图2 –软件许可协议窗口

    /image/gif/paws/64021/moza_ctc_64021_f2.gif

  3. 读许可证,并且单击接受。设置类型窗口出现(请参见图3)

    图3 –设置类型窗口

    moza_ctc_64021_f3.gif

  4. 选择完整单选按钮。单击 Next。快速发射时限出现(请参见图4)

    图4 –快速午餐窗口

    moza_ctc_64021_f4.gif

  5. 单击 Next。Install窗口的开始出现(请参见图5)

    图5 –启动Install窗口

    moza_ctc_64021_f5.gif

  6. 单击 Install 开始安装。

    在安装完成后,设置Mozilla的提示符作为默认浏览器出现(请参见图6)

    图6 – Mozilla安装完成消息

    /image/gif/paws/64021/moza_ctc_64021_f6.gif

  7. 单击否。

Java插件安装

下载Java 2运行时的环境的这些版本,标准版(J2SE)从升阳网站leavingcisco.com

  1. J2SE JRE版本1.2.2 (使用jre-1_2_2_017-windows-i586.exe或以上版本)。

  2. J2SE JRE版本1.3.1 (使用j2re-1_3_1_14-windows-i586.exe或以上版本)。

  3. J2SE JRE版本1.4.2 (使用j2re-1_4_2_06-windows-i586-p.exe或以上版本)。

注意: 如果已经安排Java安装,思科在正确的顺序建议您卸载所有JRE版本,并且再安装他们(请参阅安装JRE顺序),在您安装Mozilla后。

注意: 完成这些步骤为了卸载JRE所有现有版本:

  1. 选择Start > Settings > Control Panel > Add/Remove Programs

  2. 选择您要卸载的JRE版本,并且点击删除

  3. 打开Windows Explorer。

  4. 从程序文件文件夹,请删除所有JavaJavasoft文件夹。

安装JRE顺序

这是安装顺序:

  1. 安装J2SE JRE版本1.4.2。

  2. 安装J2SE JRE版本1.3.1。当提示符出现时,请选择Netscape作为默认浏览器。请使用默认文件夹安装JRE。请勿更换文件夹。

  3. 安装J2SE JRE版本1.2.2。请使用默认文件夹安装JRE。请勿更换文件夹。

在安装以后,请创建一个新的Java策略文件。您能下载JRE 1.3.1_02, Java策略从Cisco软件下载页(仅限注册用户)的安装和发射器策略。

覆盖原始Java策略文件用三J2SE JRE版本的新的Java策略文件。这是路径到不同的版本的Java策略文件:

C:\Program Files\<JavaSoft or Java>\JRE\<JRE release>\lib\security\java.policy

与ONS15454和15327的JRE兼容性

表2关于兼容性的提供信息在ONS15454/15327软件版本、JRE和浏览器中。

表2 –在ONS15454/15327、JRE和浏览器中的兼容性

ONS软件版本 Internet Explorer (JRE 1.2.2.x) Netscape (JRE 1.3.1.x) Mozilla (JRE 1.4.2.x)
2.2.0
2.2.1
2.2.2
2.3.4
3.2.1
3.3.0
3.4.0
3.4.1
4.0.1
4.0,2
4.1.0
4.1.3
4.1.4
4.6.2
4.7
5.0

注意: 如果使用ONS15454/15327 3.2.1或3.3.0发行软件,如果CTC不能启动,请点击删除CTC缓存。然后再请启动CTC。

完成这些步骤为了确定在ONS15454/15327的当前软件版本:

  1. 打开浏览器窗口。

  2. 在地址栏,请键入/getSwVersion跟随的节点的IP地址如显示由在Figure7的A箭头

    对节点的网络连通性必须为成功的命令执行存在。

    Figure7 –确定ONS15454/15327软件版本

    /image/gif/paws/64021/moza_ctc_64021_f7.gif

J2SE JRE设置

此部分列出您必须完成为了指定J2SE JRE发行版本的适当的设置您使用的步骤。

J2SE JRE版本1.2.2

完成这些步骤为了指定J2SE JRE版本的1.2.2设置:

  1. 选择开始>所有Programs> Java插件控制面板

  2. 在Java(TM)插件程序属性筛选,检查Enable (event) Java插件复选框和缓存JAR在内存复选框在基本选项(请参见图8)

    图8 – J2SE JRE版本1.2.2 :基本设置

    /image/gif/paws/64021/moza_ctc_64021_f8.gif

  3. 去高级选项卡。

  4. 选择使用Java插件默认选项,并且检查Enable (event)及时的编译器复选框(请参见图9)

    图9 – J2SE JRE版本1.2.2 :高级设置

    /image/gif/paws/64021/moza_ctc_64021_f9.gif

  5. 去Proxies选项。

  6. 检查使用浏览器设置复选框(请参见图10)

    图10 – J2SE JRE版本1.2.2 :代理设置

    /image/gif/paws/64021/moza_ctc_64021_f10.gif

  7. 单击 Apply

J2SE JRE版本1.3.1

完成这些步骤为了指定J2SE JRE版本的1.3.1设置:

  1. 选择开始>控制面板> Java插件1.3.1_X

  2. 在Java(TM)插件控制面板窗口,请检查Enable (event) Java插件复选框和回收类加载器复选框在基本选项(请参见图11)。

    图11 – J2SE JRE版本1.3.1 :基本设置

    /image/gif/paws/64021/moza_ctc_64021_f11.gif

  3. 去高级选项卡。

  4. 选择使用Java插件默认选项,并且检查Enable (event)及时的编译器复选框(请参见图12)。

    图12 – J2SE JRE版本1.3.1 :高级设置

    /image/gif/paws/64021/moza_ctc_64021_f12.gif

  5. 去浏览器选项卡。

  6. 检查Netscape 6复选框(请参见图13)。

    图13 – J2SE JRE版本1.3.1 :浏览器设置

    /image/gif/paws/64021/moza_ctc_64021_f13.gif

  7. 去Proxies选项。

  8. 检查使用浏览器设置复选框(请参见图14)。

    图14 – J2SE JRE版本1.3.1 :代理设置

    /image/gif/paws/64021/moza_ctc_64021_f14.gif

  9. 单击 Apply

J2SE JRE版本1.4.2

完成这些步骤为了指定J2SE JRE版本的1.4.2设置:

  1. 选择开始>控制面板> Java插件

  2. 选择在JAVA控制台部分的隐藏控制台选项,并且检查在系统托盘复选框的显示Java在基本选项(请参见图15)。

    图15 – J2SE JRE版本1.4.2 :基本设置

    /image/gif/paws/64021/moza_ctc_64021_f15.gif

  3. 去高级选项卡。

  4. 选择使用Java插件默认选项(请参见图16)。

    图16 – J2SE JRE版本1.4.2 :高级设置

    /image/gif/paws/64021/moza_ctc_64021_f16.gif

  5. 去浏览器选项卡。

  6. 检查Mozilla 1.1或以上复选框(请参见图17)。

    图17 – J2SE JRE版本1.4.2 :浏览器设置

    /image/gif/paws/64021/moza_ctc_64021_f17.gif

  7. 去Proxies选项。

  8. 检查使用浏览器设置复选框(请参见图18)。

    图18 – J2SE JRE版本1.4.2 :代理设置

    /image/gif/paws/64021/moza_ctc_64021_f18.gif

  9. 去缓存选项卡。

  10. 检查Enable (event)高速缓冲存储复选框(请参见图19)。

    图19 – J2SE JRE版本1.4.2 :Enable (event)高速缓冲存储

    /image/gif/paws/64021/moza_ctc_64021_f19.gif

验证

完成这些步骤为了验证安装:

  1. 打开适当的浏览器。关于使用的浏览器的信息,请参见表1。

  2. 是否启动城域计划程序验证应用程序执行顺利地。

    注意: 如果使用城域计划程序版本2.5,您需要寻找和创建.bat文件,以便城域计划程序工作。

    注意: 当运行版本4.x.x的您访问ONS15454/15327时,窗口能看上去表明一更旧的策略文件存在。窗口提示您覆盖策略文件。检查不再显示此消息复选框,并且单击不。如果点击YES,原始Java策略文件设置作为默认文件,并且您能不再访问版本2.x.x。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 64021