安全与 VPN : Cisco ONS 15454 SONET Multiservice Provisioning Platform (MSPP)

当CTC是在防火墙里面时,请使用PAT建立在CTC和ONS15454之间的一个会话

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 29 日) | 反馈


目录


简介

当CTC驻留在防火墙里面时,本文为端口地址转换(PAT)提供一配置示例设立会话之间Cisco传输控制器和ONS15454。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • 有关于Cisco ONS 15454的基础知识。

  • 知道哪些Cisco路由器支持PAT。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco ONS 15454版本4.6.X和以上

  • Cisco IOS�软件版本12.1(11)和以上

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

拓扑

拓扑包括这些元素:

  • 一Cisco ONS 15454

  • 一个PC

  • 一个Cisco 2600系列路由器

ONS15454位于外部网络并且作为服务器。PC位于内部网络,并且担当CTC客户端。Cisco 2600系列路由器提供PAT支持。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 使用命令查找工具仅限注册用户)可获取有关本部分所使用命令的详细信息。

网络图

本文档使用以下网络设置:

图1 -拓扑

ctc_ons_pat_01.gif

配置

本文档使用以下配置:

  • Cisco ONS 15454

  • PC

  • Cisco 2600 系列路由器

Cisco ONS 15454配置

10.89.238.192是ONS15454的IP地址(请参阅箭头A在表2),并且10.89.238.1代表默认路由器(请参阅箭头B在表2)

图2 – ONS15454配置

ctc_ons_pat_02.gif

完成这些步骤为了保证CTC与ONS15454联络通过PAT :

  1. 检查在Port复选框的Enable (event)代理服务器在网关设置部分(请参阅箭头C在表2)

  2. 选择仅代理选项(请参阅箭头D在表2)

  3. 单击 Apply

如果不启用代理服务器, CTC失效与这些错误消息:

  • EID-2199 (请参见图3)

  • 失败在IOR信息库初始化时(请参见图4)

图3 – EID-2199错误

ctc_ons_pat_03.gif

图4 – CTC初始化错误

ctc_ons_pat_04.gif

PC配置

172.16.1.254是PC的IP地址(请参阅箭头A在表5),并且172.16.1.1代表默认网关(请参阅箭头B在表5)

图5 – PC配置

ctc_ons_pat_05.gif

路由器配置

此部分提供步骤配置路由器。

完成这些步骤:

  1. 配置内部接口, ONS15454驻留。

    !
    interface Ethernet1/0
     ip address 10.89.238.1 255.255.255.0
     ip nat outside
    !
  2. 配置外部接口, CTC客户端驻留。

    interface Ethernet1/1
     ip address 172.16.1.1 255.255.255.0
     ip nat inside
    !
  3. 配置在路由器的PAT支持。配置表明在内部接口到达,访问列表1允许的所有数据包,共享一个外部IP地址。外部IP地址是10.89.238.1在此配置方面。

    !
    
    !--- Indicates that any packets that arrive on the internal interface, which
    !--- access list 1 permits, share one outside IP address (the address 
    !--- on ethernet1/0).
    
    
    ip nat inside source list 1 int ethernet1/0 overload
    access-list 1 permit 172.16.1.0 0.0.0.255
    !

验证

使用本部分可确认配置能否正常运行。

验证过程

完成这些步骤:

  1. 运行Microsoft Internet Explorer。

  2. 键入在浏览器窗口的地址栏的http://10.89.238.192,并且按回车。

    CTC登录窗口出现。

  3. 键入正确用户名和密码。

    CTC客户端成功连接对ONS15454。

故障排除

本部分提供的信息可用于对配置进行故障排除。

发出debug ip nat detailed命令打开IP NAT被选派的trace。您能查看从172.16.1.254的地址转换到10.89.238.1 (请参阅从10.89.238.1的箭头A在表6)和到172.16.1.254 (请参阅箭头B在表6)

图6 –被选派的Debug ip nat

ctc_ons_pat_06.gif

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 63775