语音 : 介质网关控制协议 (MGCP)

用Unity语音邮件集成在CallManager和Avaya S8700/G650之间配置Q.SIG PRI Trunk

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文目标将提供Cisco用户和业务伙伴步骤配置Q.SIG在Cisco Call Manager和Avaya S8700/G650之间的PRI中继。并且,本文在Cisco Call Manager平台的添加Cisco Unity按顺序如何的详细步骤为思科和Avaya IP电话提供语音邮件支持。这是特别重要在IP-PBX互通性和语音邮件集成要求的情况。Avaya配置屏幕捕获用标准的仿真工具创建。作为替代方案,您能也使用配置任务的Avaya站点管理(ASA)工具在Avaya S8700/G650。输出显示在两种情况下是同样。此IP-PBX互通性和语音邮件集成文档供外部使用使用。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • 使用的Avaya IP-PBX系统是运行Avaya Communication Manager 2.0的Avaya S8700/G650。Q.SIG特性组来有此软件版本的标准。

  • 用于本文的Avaya IP电话是4610SW和4620运行的电话固件版本2.01。

  • Cisco Call Manager 4.1.(2)用于为了用NM-HDV模块控制3745介质网关控制协议(MGCP)网关,运行Cisco IOS�版本12.2.15ZJ3。测验也重复了与Cisco IOS�版本12.3.8.T5。

  • Cisco Unity运行版本4.0(4) SR1使用了语音邮件集成测试。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

测试设置

使用的Avaya IP-PBX系统是运行Avaya Communication Manager 2.0的Avaya S8700/G650。Q.SIG特性组来有此软件版本的标准。使用的AvayaIP电话是4610SW和4620运行的电话固件版本2.01。在Cisco侧, Cisco Call Manager 4.1.2用于用NM-HDV模块控制3745 MGCP网关,运行Cisco IOS�版本12.2.15ZJ3。测验也重复了与Cisco IOS�版本12.3.8.T5。Cisco Unity运行版本4.0(4) SR1使用了语音邮件集成测试。

测试拓扑

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-top.gif

思科和Avaya IP-PBX之间的互通性系统

以下部分提供步骤和屏幕截图帮助您配置在运行Avaya Communication Manager 2.0的Avaya S8700/G650之间的Q.SIG中继和Cisco Call Manager平台运行CallManager版本4.1(2)以提供对Avaya S8700/G650的物理ISDN PRI连接的Cisco 3745 MGCP设备。

在Avaya S8700/G650 IP-PBX系统的步骤

完成这些步骤:

  1. 登陆到S8700服务器。运行display system-parameters customer命令为了保证所有必要的Q.SIG功能在S8700服务器启用。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-proced1.gif

  2. 配置Q.SIG PRI的DS-1卡。

    2.gif

  3. 配置中继组。类型添加中继组# #希望的中继的地方。

    下三屏幕截图与中继配置关连。一旦中继组创建,请添加23个DS0信道到组。这是端口分配的示例:01A0901含义:Gateway- 1,内阁A, Slot- 9, DS0 channel- group1。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

    4.gif

    5.gif

  4. 添加信号组并且指向中继组创建前。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  5. 添加路由模式并且指向它信号组。在本例中,路由模式4指向在步骤4.创建的发信号group- 1。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  6. 添加一个条目到AAR表为了使用您创建路由呼叫的路由模式。在本例中,对Cisco IP电话分机4XXX的呼叫以4使用开始AAR的条目,反过来指向路由模式# 4。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

  7. 保证呼叫方ID启用在每个IP电话发送主叫方名称。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

在Cisco Call Manager的步骤

完成这些步骤:

  1. 在服务参数下,请确保启动路径更换最低和最大时间时间值适当设置为了防止所有问题(例如发夹连接)。

    下两屏幕截图与Q.SIG服务参数设置关连:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-10.gif

    11.gif

  2. 添加Cisco 3745作为MGCP网关并且配置Q.SIG PRI的NM-HDV T-1模块。

    下五屏幕截图与此配置关连:

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. 作为最后一步,请创建Cisco Call Manager代答组为了提供路径建议分机给PBX。确保呼叫接听编号也被输入到路径PINX更换ID服务参数(请参阅对step- 1)。并且, Avaya系统需要路由模式为了路由到代答组。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-8.gif

    注意: 确保这两个集群域内参数(设备- PRI和MGCP网关)Cisco CallManager服务参数下(先进)匹配在PBX的Q.SIG配置。必须正确地配置所有PBX中继作为这些Cisco CallManager参数。

    • ASN.1玫瑰色OID编码:此参数指定如何编码遥控操作服务单元的调用Object ID (OID) (上升了)。除非Cisco技术支持工程师否则,提示请保持此参数集对默认值。这些是必填字段,并且默认是使用本地值

      这些是此参数的有效值:

      • 请使用本地值,多数电话系统支持,并且必须使用,当Q.SIG不同的服务参数设置为ISO时(协议配置文件0x9F)。

      • 请使用全局值(ISO),使用,只有当已连接PBX不支持使用本地值。

      • 请使用全局值(ECMA),必须使用,如果Q.SIG不同的服务参数设置为ECMA (协议配置文件0x91)。

    • Q.SIG变量:当中继为Q.SIG时,配置此参数指定在出站Q.SIG设备信息元素发送的协议配置文件。除非Cisco技术支持工程师否则,提示请保持此参数集对默认值。这是必填字段,并且默认是ISO (协议配置文件0x9F)

      这些是此参数的可用的值:

      • ECMA (协议配置文件0x91),典型地与ECMA PBX一起使用,并且能只使用协议配置文件0x91。如果此服务参数设置为ECMA (协议配置文件0x91),必须设置编码服务参数的ASN.1罗斯OID使用全局值(ECMA)。

      • ISO (协议配置文件0x9F),是当前ISO建议。如果此参数设置为ISO (协议配置文件0x9F),则必须设置编码服务参数的ASN.1罗斯OID使用本地值。

        警告:当使用集群间中继线以被建立隧道的Protocol字段设置为Q.SIG在中继配置窗口在Callmanager管理中时, Cisco CallManager不支持ECMA。如果集对ECMA (协议配置文件0x91)的此服务参数,所有集群间中继线必须有被建立隧道的Protocol字段设置对无。

        qsig.gif

Cisco 3745配置

这是show versionshow running-configuration命令输出在Cisco 3745 MGCP设备。控制器在Cisco 3745的T1 1/0连接对Avaya S8700/G650 DS1 PRI卡。Q.SIG发信号在Cisco 3745和Avaya S8700/G650之间的PRI链路配置。

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

为思科和Avaya IP-PBX之间的互通性测试的功能系统

此部分提供功能列表测试在运行通信管理器2.0的Cisco Call Manager 4.1(2)平台和Avaya S8700/G650之间通过Q.SIG PRI中继:

  • 名称和编号显示(双向)

  • 呼叫转移

  • 在两个系统之间的电话会议

Cisco Unity语音邮件的集成支持思科和Avaya IP电话的

这时,一能使用Q.SIG中继为了做在运行Avaya Communication Manager 2.0的Avaya S8700/G650之间的呼叫和Cisco Call Manager平台运行CallManager版本4.1(2)以提供对Avaya S8700/G650的Cisco 3745 MGCP设备物理ISDN PRI连接。Cisco Unity服务器在Cisco Call Manager平台可以被添加为了提供语音邮件支持给思科和Avaya IP电话。为了启用此,管理员需要配置在Cisco Call Manager平台的Cisco Unity。此部分包括与屏幕截图的步骤如何的能配置在Cisco Call Manager管理管理页的Cisco Unity。

注意: 大多数配置在Cisco语音邮件端口向导执行。

添加Cisco Unity到Cisco Call Manager

完成这些步骤:

  1. 在功能下,请选择语音邮件>Voice邮件端口向导。选择创建一个新的语音邮件服务器并且添加端口到它并且其次单击。

    19.gif

  2. 输入一思科语音邮件服务器名称,例如AvayaUM3,并且其次单击。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-20.gif

  3. 选择希望的语音邮件端口数量并且其次单击。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-21.gif

  4. 送进一说明和设备池语音邮件端口的。在配置示例中, Avaya VMailPorts被输入了作为说明和默认作为设备池。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  5. 送进起始电话号码,例如4406和显示,例如语音邮件,并且其次单击。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  6. Next屏幕要求, “您想要添加这些目录号对线群?”选择是。添加目录号到新的一行组并且其次单击。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  7. 输入匹配语音邮件服务器您以前进入的一个线路组名,例如AvayaUM3。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  8. 到目前为止Next屏幕显示被输入的配置。如果没有对配置的更改请点击芬通社

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  9. 单击添加在搜索列表管理网页的一新的搜索列表

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-6.gif

  10. 输入一搜索列表名和说明,例如Avaya VMailHL。并且,请选择Cisco Call Manager组的默认

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-7.gif

  11. 此屏幕截图是搜索列表的成功的新增内容的结果。单击添加线群

    28.gif

  12. 选择以前配置的线群。在这种情况下,它是AvayaUM3。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-9.gif

  13. Next屏幕捕获显示线群的成功的插入的结果。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-30.gif

  14. 路由计划>路由/寻线>寻线引导。单击从发生的寻线引导屏幕添加一新的寻线引导

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-31.gif

  15. 输入在寻线引导,例如4408,并且选择一搜索列表,例如Avaya语音邮件百升并且点击插入键

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-2.gif

  16. 功能>Voice邮件>Voice邮件试验并且单击添加发生屏幕的一新的语音邮件引导

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-3.gif

  17. 输入匹配寻线引导编号的语音邮件引导编号以前配置。在这种情况下,寻线引导和语音邮件引导编号是4408。

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-4.gif

  18. 功能>Voice邮件>Voice邮件配置文件并且单击添加一个新的语音邮件配置文件

    http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/63790-5.gif

  19. 输入语音邮件配置文件名称和说明,例如AvayaVMailProfile,并且选择语音邮件引导编号在步骤17。在这种情况下,语音邮件引导编号是4408。

    36.gif

  20. 点击功能>Voice邮件>消息等待指示符>Add消息等待指示符(MWI)开/关编号的一新的消息等待数量添加。包括此处消息等待指示符开/关编号的两屏幕截图。

    37.gif

    38.gif

Cisco Unity测试的语音邮件功能

这是Cisco Unity用Avaya IP电话测试的语音邮件功能列表用于通过在运行通信管理器2.0的Cisco Call Manager 4.1(2)平台和Avaya S8700/G650之间的Q.SIG PRI中继访问Cisco Unity语音邮件:

  • 内部问候语

  • 忙线问候语

  • MWI

  • 容易消息访问

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 63790