语音和统一通信 : Cisco Unity

Unity IP传真入站网关配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 11 月 11 日) | 反馈


目录


简介

Cisco Unity入站传真支持与开始用Cisco Unity 3.1(5)和Cisco IOS�软件版本12.2(8)T的Unity IP传真配置向导。此服务允许用户接收传真,当在他们的收件箱的附件和他们可以警告从Cisco Unity电话用户界面(TUI)的新的传真消息。

入站传真由传真网关(Cisco IOS路由器最初接收在这种情况下)。此网关转换传真到与作为TIFF文件附加的传真信息的一电子邮件。网关也添附自动数字标识(ANI) (或主叫方编号)和DNIS (或被叫号码)对“主题:”传真电子邮件的部分。SMTP会话然后用于发送此传真电子邮件到Cisco Unity服务器,与Microsoft Exchange一道,电子邮件接收并且处理。在标题栏的DNIS解析,并且正确目的地收件箱根据Unity IP传真配置向导的先前配置确定。

本文着重Cisco IOS网关的配置,并且什么是必要获得网关与Cisco Unity IP传真功能一起使用。关于Cisco Unity的配置的更多信息入站传真的,参考Unity IP传真入站网关配置示例。关于离线管道或出站网关配置协助,参考Unity IP传真出站网关配置示例

先决条件

要求

本文读者应该有SMTP基础知识和熟悉Cisco IOS VoIP配置。有Unity IP传真配置向导的一个工作的Cisco Unity服务器安装在本文需要使用与定义的网关配置一道为了有一个完整工作系统。在支持的IOS网关侧, Cisco IOS路由器T.37上线管道功能和Cisco IOS软件版本12.2(8)T或者以后与Cisco Unity版本3.1(1)或以上用Microsoft Exchange 2000或2003一起要求作为合作伙伴消息存储。关于IP传真配置的更多信息Cisco Unity部分,参考Unity IP传真配置向导

注意: 介质网关控制协议(MGCP)网络不支持T.37上线管道。当您使用T.37时,参考T.37存储和发送传真配置指南关于平台和其他限制的更多信息。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco3725作为IOS网关

  • Cisco IOS软件版本12.3(8)T4

注意: 网关没有限制到思科37xx平台。有IP PLUS和Cisco IOS软件版本12.2(8)T的所有语音网关应该工作。关于由特定Cisco网关型号的支持的更多信息在Cisco IOS软件版本12.2T,在配置T.37存储和发送传真的参考的表5.1

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

发起入站传真呼叫用户是非常容易的。传真发送类似所有正常传真。然而,它在另一台传真机没有接收。反而,传真在Cisco IOS网关终止。操作类似一个典型的设备终止传真的网关接收传真。网关转换传真到TIFF文件。网关然后形成对有TIFF镜像的已配置的邮件服务器寻址的电子邮件作为附件。ANI和DNIS插入到“主题:”电子邮件的字段。网关然后使用一SMTP会话转接电子邮件到Cisco Unity服务器。从Cisco Unity IP传真功能方面,这些是思科上线管道网关的功能:

  • 作为标准基于G3传真机为了成功接受传真。

  • 转换所有已接收传真页信息到适当的TIFF文件。

  • 请使用SMTP中继传真TIFF文件作为电子邮件到已配置的邮件服务器。必须对在Cisco Unity服务器创建的传真收件箱寻址电子邮件。

  • 确保DNIS编号在电子邮件被输入“主题:” [DNIS=----]相应的格式的字段, ####是入站传真呼叫的DNIS。

  • Cisco Unity IP传真服务不能提供消息到一个隐藏的邮箱。

在事Cisco Unity侧传真收件箱创建使用必须发送到此收件箱。ï ¿  ½这些电子邮件然后解析根据在电子邮件的DNIS “主题所有传真电子邮件的IP传真配置Wizard.ï ¿  ½ :”根据用户定义的规则。ï ¿  ½的字段负责然后到适当的用户的收件箱根据DNIS解析。ïÂ请记住的¿  ½的Cisco Unity传真服务对移动从Cisco Unity传真收件箱的传真电子邮件用户看见实际传真作为电子邮件TIFF附件。ï ¿  ½用户可以警告从Cisco Unity TUI的新的传真消息。

然而并且,配置语音和传真呼叫。ï ¿  ½的同一个编号是技术上可能的,思科不官方支持此,因为为了执行此, IOS路由器必须细听传真音为了从语音呼叫。ï ¿  ½典型地分离传真呼叫,为了语音呼叫呼叫应该去Auto Attendant,或者请振铃用户电话和可能转发对语音邮件。ï ¿  ½,如果路由器已经回答呼叫,然后需要使用路由器播放Auto Attendant。ï ¿  ½这是不理想的在您通常希望的环境提供Auto Attendant功能的Cisco Unity。

网关配置

有您必须在此应用程序的Cisco IOS配置里有能工作的一些命令。其中一些可能用为出站传真(“离线管道”)功能要求的配置命令交迭。

  • 传真interface-type传真邮件在网关需要配置。这通知网关处理T.37存储和发送传真呼叫。没有此命令,因为他们没有通过SMTP,正确地路由已接收传真呼叫发生故障。T.37路由器调试也不可用,直到此命令被添加。记住那,在此命令配置后是重要的,您需要重新加载路由器。

    vnt-3725-51(config)#fax interface-type fax-mail 
    You must reload the router
  • Cisco网关要求另外的软件为了运行T.37传真上线管道。此软件是由网关运行的TCL写脚本,当需要处理已接收传真呼叫时。此脚本软件在路由器的内部闪存可以装载或装载TFTP server。软件从Cisco.com是可下载的,并且在下载的访问部分查找在TCLware下的。为传真上线管道是需要的文件是app_faxmail_onramp.2.0.1.3.tcl。此文件需要是可访问由网关。在这种情况下文件装载到路由器内部闪存:

    vnt-3725-51#copy tftp flash
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_onramp.2.0.1.3.tcl
    Destination filename [app_faxmail_onramp.2.0.1.3.tcl]? 
    Accessing tftp://172.18.106.4/app_faxmail_onramp.2.0.1.3.tcl...
    Loading app_faxmail_onramp.2.0.1.3.tcl from 172.18.106.4 (via FastEthernet0/0): !!!
    [OK - 12262 bytes]
    
    12262 bytes copied in 0.116 secs (105707 bytes/sec)
    vnt-3725-51#

    必须通知路由器关于此文件,并且驻留的地方。这在此全局配置命令帮助下执行:

    vnt-3725-51(config)#call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl 
    vnt-3725-51(config)#
    *Nov 19 15:28:40.094: //-1//HIFS:/hifs_ifs_cb: hifs ifs file read 
       succeeded. size=12262, url=flash:app_faxmail_onramp.2.0.1.3.tcl
    *Nov 19 15:28:40.094: //-1//HIFS:/hifs_free_idata: hifs_free_idata: 0x64FFAF70
    vnt-3725-51(config)# 

    注释从路由器的确认控制台信息文件顺利地读了。如果文件在TFTP server查找而不是闪存,则命令是:

    call application voice onramp tftp://172.18.106.4/app_faxmail_onramp.2.0.1.3.tcl
    

    关于如何下载T.37脚本的更多信息,参考配置T.37存储和发送传真

  • 路由器使用ip domain-name命令在与Exchange的SMTP通信时。没有此命令,从路由器的初始SMTP连接到Exchange包含“EHLO <hostname>”。这造成Exchange终止会话(无效的地址)。对于在本文的示例,网关使用域gateway.com。命令如下所示:

    ip domain name gateway.com
    
  • mta send server <IP address or DNSname> port <number>命令用于指向路由器收到入站传真电子邮件的邮件服务器。没有此命令,路由器在哪里不知道发送已接收传真,并且传真呼叫发生故障。配置此命令多个实例是可能的。然而,在配置里使用仅一审。只使用其他实例,当SMTP处理失效(例如无效rcpt对时:)到第一个所列的服务器。然后下个配置的服务器被搬到列表的顶部。此服务器然后使用随后的上线管道传真呼叫。这是重要记住,当您排除故障时,如果有配置的多邮件服务器。

    在本例中,总是使用14.80.113.13,直到有SMTP处理失败到此服务器。在失败以后, 14.84.31.12被搬到顶部位置由路由器,以便使用所有随后的上线管道传真呼叫。

    mta send server 14.80.113.13 port 25
    mta send server 14.84.31.12 port 25
  • mta send with-subject both命令在“主题指示网关包括呼叫和被叫号码:”电子邮件的线路。因为这用于路由传真电子邮件到适当的邮箱,这对Cisco Unity IP传真功能是重要。当Cisco Unity能使用被叫号码路由呼叫时(mta发送with-subject $d$)仍然推荐使用mta send with-subject both命令

    mta send with-subject both
  • mta发送发件人主机名<name>mta发送发件人用户名<name>命令是需要的防止SMTP处理失败。一有效“从”电子邮件地址以形式“username@hostname”必须由邮件服务器看到。否则SMTP处理被断开,并且传真电子邮件从未被发送。什么在这些命令帮助下配置是什么最终用户在看到“从:”传真电子邮件的字段。“从:”地址为"fax-mail@vnt-3725-51.gateway.com",命令看起来象:

    mta send mail-from hostname vnt-3725-51.gateway.com
    mta send mail-from username fax-mail

    如果希望呼叫号码出现作为用户名,请使用mta send mail-from username $s$命令。

  • 拨号对端需要配置为了通过网关路由传真呼叫。POTS拨号对等配置非常简单。incoming called-number命令允许此dial-peer匹配进入网关的任何入站被叫号码。多数真实世界方案通常有配置的一个特定传真号码。direct-inward-dial命令采取已接收呼叫号码作为是使用的编号,当使一个MMOIP拨号对等体配比时。port命令连结此POTS拨号对等与网关的一个物理端口。重要命令从T.37上线管道方面application <name>命令。此命令连结上线管道传真应用程序与一特定POTS拨号对端。<name>字段由call application voice <name> <file location>命令的用户定义。在本例中, POTS拨号对端使用应用程序上线管道,因为那是以前定义与call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl命令的名称。

    对于出站VoIP侧,多媒体或MMOIP拨号对等体是必要的而不是通常VoIP拨号对等体。类似POTS拨号对等, MMOIP拨号对等体也需要outbound application命令应用程序fax_on_vfc_onramp_app。此application命令参考资料能被看到的脚本,当您查看show call application voice summary命令时。是需要的脚本是fax_on_vfc_onramp_app。记住出站关键字也是重要的,以便此应用程序在呼出只使用通过MMOIP拨号对等体。

    destination-pattern命令用于匹配呼入呼叫索书号对一个特定出站MMOIP拨号对等体。在多数情况下,此拨号对端匹配用用户的入站传真号码。information-type fax命令连结出站mmoip对等体与T.37传真。没有此in命令dial-peer,网关不使用mmoip对等体,并且上线管道传真呼叫发生故障。

    session target mailto :<电子邮件地址>命令识别谁最终用户是从电子邮件方面。当许多T.37上线管道实施使用此命令对一个特定邮件用户时寻址传真电子邮件, Cisco Unity IP传真功能要求电子邮件对用户配置的传真收件箱寻址。所有传真电子邮件被发送对此一个邮箱。Cisco Unity在“主题然后使用DNIS编号:”路由传真电子邮件的电子邮件的字段对适当的最终用户邮箱。

    dial-peer voice 9995590 pots
     application onramp
     incoming called-number .
     direct-inward-dial
     port 2/0:23
    !
    dial-peer voice 1 mmoip
     application fax_on_vfc_onramp_app out-bound
     destination-pattern 9995590
     information-type fax
    session target mailto:fax-in@vnt-dhanes.com

关于产品文档和命令详细信息的更多信息,参考Cisco FAX服务的配置的T.37存储和发送传真部分在IP应用程序指南的。关于一个活动T.37网关的完全配置连接对Cisco Unity服务器,请参阅完整配置示例。入站传真呼叫在ISDN T1PRI 2/0:23接收。然后对Cisco Unity服务器的SMTP出站传真电子邮件通过快速以太网接口0/0离开路由器。

完整配置示例

此配置是一个最小Cisco IOS配置的示例Cisco Unity入站传真功能的。多数必需的配置命令在粗体字体。

vnt-3725-51#show run
Building configuration...
 
Current configuration : 1808 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 2 
no network-clock-participate aim 0 
no network-clock-participate aim 1 
voice-card 2
 dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
!         
!
ip domain name gateway.com
ip name-server 14.80.113.13
no ftp-server write-enable
isdn switch-type primary-ni
!
!
fax interface-type fax-mail
mta send server 14.80.113.13 port 25
mta send subject this is a test fax inbound to unity
mta send with-subject both
mta send mail-from hostname vnt-3725-51.gateway.com
mta send mail-from username fax-mail
 
!
!
controller T1 2/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 2/1
 framing sf
 linecode ami
!
!
interface FastEthernet0/0
 ip address 14.80.51.14 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown 
 duplex auto
 speed auto
!
interface Serial2/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
!
control-plane
!
!
call application voice onramp flash:app_faxmail_onramp.2.0.1.3.tcl
!         
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
!
dial-peer voice 9995590 pots
 application onramp
 incoming called-number .
 direct-inward-dial
 port 2/0:23
!
dial-peer voice 1 mmoip
 application fax_on_vfc_onramp_app out-bound
 destination-pattern 9995590
 information-type fax
 session target mailto:fax-in@vnt-unity.com
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
end

验证

当前没有可用于此配置的验证过程。

故障排除

没有特定当前排除故障此配置的有用的资料。


相关信息


Document ID: 63423