语音和统一通信 : Cisco Unity

Unity IP传真出站网关配置示例

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

出站电传支持与Unity IP传真配置向导并且从Cisco Unity 4.04和Cisco IOSï ¿  ½软件版本12.3(7)T开始。此服务允许用户通过一简单电子邮件发送出站传真。目的地传真电话号码在电子邮件的标题栏包括和发送对该的邮箱Unity IP传真服务检查。服务重新排版消息,回报在相应的格式的所有附件,再寻址,并且传送信息。信息通过简单邮件传输协议(SMTP)传送到IOS网关配置以T.37离线管道功能为了发送传真到目的地电话编号。本文着重Cisco IOS网关的配置步骤。

先决条件

要求

本文读者应该有SMTP基础知识和熟悉Cisco IOS VoIP配置。有Unity IP传真安装的配置向导版本2.0.0.19或以上的一个工作的Cisco Unity服务器在本文需要使用与定义的网关配置一道为了有一个完整工作系统。在支持的IOS网关侧, Cisco IOS路由器T.37离线管道功能和Cisco IOS软件版本12.3(7)T或者以后与Cisco Unity版本4.04或以上用Microsoft Exchange 2000或2003一起要求作为合作伙伴消息存储。关于IP传真配置的Cisco Unity部分的更多信息可以在Unity IP传真配置向导找到。

注意: MGCP网络不支持T.37离线管道。参考T.37存储和发送传真配置指南关于平台的更多信息和其他限制为使用T.37。

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco3725作为IOS网关

  • Cisco IOS软件版本12.3(8)T4

注意: 网关没有限制到思科37xx平台。有IP PLUS和Cisco IOS软件版本12.3(7)T工作的任何语音网关。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

当用户发送电子邮件对IP传真服务邮箱时,包含在主题的[FAXPHONE=----], ####是目的地传真机的编号。IP传真服务责任对:

  • 保证将发送有效和被回报到TIF类型F文件格式的附件。

  • 地址和电子邮件用新的TIF附件对FAX=####@gateway.com。

  • 解释并且采取在从网关(DSN)的行动接收的所有传送状态通知。这能包括重新发送消息对网关(例如,占线信号或没有答案),或者发送通知对最终用户(例如,错误号码)。

Microsoft Exchange负责对:

  • 电子邮件的交付对gateway.com寻址对IOS网关。

  • 所有邮件交付在IP传真邮箱的最终用户之间和在IOS网关和IP之间电传邮箱。信息没有从网关的反之亦然最终用户传送或。

IOS网关责任对:

  • 解释FAX=####@gateway.com、呼叫的放置对####和传真的中继使用标准G3传真协议(T.30和T.4)。

  • 发送传送状态通知(DSN)标记作为“持久误差”对每个已拨传真呼叫的IP传真邮箱。这允许IP传真服务知道传真正确地发送,或者,如果有问题(例如忙碌,无应答,等等)。IP传真服务完全地负责处理重试次数和发送反馈对发送方与取决于在邮件系统系统构成相对。

网关配置

有您必须在Cisco IOS配置里有为了此应用程序能工作的一些命令。一些与为入站传真(“上线管道”)功能要求的配置命令的这些重叠。注意了解和排除故障是更加容易的,如果这些方案分开被采取:

  • 电传interface-type传真邮件—配置此on命令网关。这通知网关处理T.37存储和发送传真呼叫。缺乏此命令造成从Exchange/Unity服务器的流入传真电子邮件发生故障,并且T.37路由器调试不可用,直到此命令被添加。记住那,在此命令配置后是重要的,您需要重新加载路由器。

    vnt-3725-51(config)#fax interface-type fax-mail
    You must reload the router
  • Cisco网关要求另外的软件为了运行T.37传真离线管道。此软件是由网关运行,当需要为传真离线管道的TCL写脚本。此脚本软件在路由器的内部闪存可以装载或装载TFTP server。下载的文件为传真离线管道是在Cisco软件中心查找的app-faxmail-offramp.2.0.1.1.zip文件(仅限注册用户)。此文件需要是可访问由网关。在此输出示例:中,因为有大量空间,文件装载到路由器的内部闪存。

    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    [23454064 bytes used, 104734348 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)
    vnt-3725-51#copy tftp flash:
    Address or name of remote host []? 172.18.106.4
    Source filename []? app_faxmail_offramp.2.0.1.1.tcl
    Destination filename [app_faxmail_offramp.2.0.1.1.tcl]?
    Accessing tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl...
    Erase flash: before copying? [confirm]n
    Loading app_faxmail_offramp.2.0.1.1.tcl from 172.18.106.4 (via FastEthernet0/0): !
    [OK - 5095 bytes]
    Verifying checksum... OK (0xB729)
    5095 bytes copied in 0.076 secs (67039 bytes/sec)
    vnt-3725-51#show flash
    System CompactFlash directory:
    File Length Name/status
    1 23454000 c3725-ipvoice-mz.123-8.T4.bin 
    2 5095 app_faxmail_offramp.2.0.1.1.tcl 
    [23459224 bytes used, 104729188 available, 128188412 total]
    125184K bytes of ATA System CompactFlash (Read/Write)

    必须通知路由器关于此文件,并且驻留的地方。请使用呼叫应用程序语音离线管道flash:app_faxmail_offramp.2.0.1.1.tcl全局配置命令为了完成此。

    如果文件在TFTP server查找而不是闪存,命令如下所示:

    call application voice offramp tftp://172.18.106.4/app_faxmail_offramp.2.0.1.1.tcl
  • mta接收最大<recipients> —此命令指定同时收件人数量SMTP连接的在网关。此命令用于限制网关的资源使用。请记住此命令的默认值是0。如果此命令没有设置为极大值比0,网关不答复任何SMTP请求。这造成所有离线管道处理立即发生故障。

  • mta接收别名<string> —此命令是重要,因为接受作为off-ramp电传的一SMTP别名的识别有效的主机名。在此命令的字符串可以或者是IP地址或DNS键入主机名。此命令是非常重要,因为所有SMTP连接发生故障,如果“rcpt对:”字段域不完全地匹配使用此命令,什么配置,当别名。换句话说,如果入站邮件的目的地主机名匹配一已配置的别名,网关只接受流入的邮件。多个别名可以配置(最大数量是10)为了适应不同的域名和均等IP地址。例如,当IP传真服务传送信息对“FAX=####@gateway.com”时,命令看起来象:

    mta receive aliases gateway.com
  • mta接收生成固定误差—,因为没有它,不是所有的DSN消息是被退还的对IP传真服务邮箱,此命令要求。因为DSN消息是SMTP规格的一部分,邮件服务器(Microsoft Exchange)预计设法处理不是“永久性”错误的任何,在送回消息到发送方前(在这种情况下IP传真服务邮箱)。消息例如用户忙是(默认情况下)己标记作为“瞬变” DSN错误。Exchange尝试单独重新发送消息长期以来时间。配置mta receive generate permanent-error命令强制路由器标记每个DSN消息,因为一个持久误差,因此他们立即被退还的到发送方(IP传真服务邮箱)。服务(基于用户配置)能确定应该尝试在busy/no答案的多少重试次数。此命令仅在Cisco IOS软件版本12.3(7)T和以后。如果此命令不是存在您的路由器,机会是老比的您运行Cisco IOS版本什么要求。

  • mta send server <exchange server>端口25 —此命令指定将使用的服务器为了返回消息到传真邮箱(例如DSN)。这应该是Exchange服务器的IP地址或可以是DNS名。如果DNS名指定, ip name-server <ip address>命令要求,以便DNS能解析名称。

  • Inbound和Outbound Dial Peer要求连结入站SMTP消息与一个呼叫的传真号码以及路由呼叫到一个出站电话电路。例如:

    dial-peer voice 5590 pots
    destination-pattern 991....
    port 2/0:23
    forward-digits all
    prefix 9
    !
    dial-peer voice 2 mmoip
    description off-ramp inbound VoiP from Unity
    application offramp
    information-type fax
    incoming called-number 991
    dsn delayed
    dsn success
    dsn failure
    !

    POTS拨号对等是特殊的没什么。这是需要的为了路由器能路由语音呼叫到电路。此处重要项目是MMOIP拨号对等体。它有“应用程序离线管道”,是名称关联与TCL写脚本(“呼叫应用程序语音离线管道flash:app_faxmail_offramp.2.0.1.1.tcl")。“信息类型传真”也必要告诉系统匹配此dial-peer的呼叫是传真呼叫。另外, incoming called-number语句是需要的。这是连结呼叫号码的简便的方法与dial-peer。注意没有目的地模式。它没有要求,因为此dial-peer只使用入站的呼叫(从VoIP侧)。在本例中,路由器允许接受开始与991的任何编号的传真呼叫。SMTP消息需要被寄给“其中能匹配任何四位数字。POTS拨号对等,由于“目的地模式991....",发送呼叫对PRI (端口2/0:23),当加前缀9.时。所以,一个消息到“9912345@gateway.com"的端口2/0导致呼叫发出在PRI第99912345 (由于prefix 9命令)。

    DSN on命令MMOIP拨号对等体原因传送状态发送为每个情况(延迟/成功/失败)。此单独不是满足的。mta receive generate permanent-error命令可能也要求,以便这些DSN消息全部用错误状态传送,而不是临时。临时潜在不(一很长时间)被退还的对IP传真服务邮箱。

    更加进一步的产品文档和命令详细信息可以在Cisco FAX服务的配置的T.37存储和发送传真部分在IP应用程序指南的找到。一个工作的T.37网关的完全配置连接对Cisco Unity服务器在本文的完整Sample Configuration部分查找。从Cisco Unity服务器的SMTP呼叫在网关然后路由的ISDN T1PRI 2/0:23的快速以太网端口接收。

完整配置示例

此配置是一个最小Cisco IOS配置的示例Cisco Unity出站电传的功能的。多数必需的配置命令在粗体字体。

vnt-3725-51#show run
Building configuration...
Current configuration : 1608 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vnt-3725-51
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 2
no network-clock-participate aim 0
no network-clock-participate aim 1
voice-card 2
dspfarm
!
no aaa new-model
ip subnet-zero
ip cef
! 
no ftp-server write-enable
isdn switch-type primary-ni
!
fax interface-type fax-mail
mta send server 14.84.31.12 port 25
mta receive aliases vnt-3725-51.gateway.com
mta receive maximum-recipients 10
mta receive generate permanent-error
! 
controller T1 2/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2/1
framing sf
linecode ami
!
interface FastEthernet0/0
ip address 14.80.51.14 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial2/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip default-gateway 14.80.51.1
ip classless
ip route 0.0.0.0 0.0.0.0 14.80.51.1
ip http server
!
control-plane
!
call application voice offramp flash:app_faxmail_offramp.2.0.1.1.tcl
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 2/0:23
!
dial-peer voice 5590 pots
destination-pattern 991....
port 2/0:23
forward-digits all
prefix 9
!
dial-peer voice 2 mmoip
description off-ramp inbound SMTP from Unity
application offramp
information-type fax
incoming called-number 991
dsn delayed
dsn success
dsn failure
! 
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
vnt-3725-51#

验证

当前没有可用于此配置的验证过程。

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 62995