Video : ??uBR7200 ????(US)

有线网络的透明LAN服务

2016 年 10 月 27 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

传统上, Cisco电缆调制解调器终端系统(CMTS)用于提供高速的数据服务为家庭用户和为基于IP的第3层虚拟专用网络。

有,然而,需要Layer2连接经营他们的业务的一些客户。

某些原因辩解Layer2虚拟专用网络(L2VPN)的部署包括:

  • 为non-IPv4协议支持

  • 端到端加密

  • 更多网络控制

  • 使用专用IP地址空间

一般, Layer2服务由电话公司(Telco)提供并且使用另外技术,例如租用的线路、帧中继、ISDN, ATM和其他。

使用802.1Q透明LAN服务(TLS)功能的介绍,多项服务操作员(MSO)能有效利用其DOCSIS部署提供L2VPN服务和从而提高其商业提供。

先决条件

要求

本文档的读者应掌握以下这些主题的相关知识:

  • Cisco IOSï ¿  ½软件版本12.2(15)BC2

  • uBR7200VXR平台

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco uBR7246VXR 通用宽带路由器

  • 思科Catalyst 2924-XL (生命周期终止)

  • Cisco 7206VXR路由器

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

什么是在电缆的802.1Q TLS ?

802.1Q TLS以提供为特色方法创建在多个站点之间的L2VPNs,类似于由Telco提供的私有租用的线路,帧中继, ISDN, ATM, SMDS,等等。

在许多情况下, TLS可以查看作为一“帧中继-类似”服务。它能适应许多流量模式,例如点对点,点对多点或者充分地网状了连接。

图1显示802.1Q TLS部署如何概念上看起来VLAN。

图 1

/image/gif/paws/60027/tls_over_cable_01.gif

市场驱动程序

此功能的采用的主要驱动程序是可能性增加收入来源。

802.1Q TLS功能允许MSO与Telco竞争通过提供可以是经济对最终用户的L2VPN服务。

MSO覆盖区已经接触在他们的部署中的许多商业区域。许多那些企业已经订购有线电视服务和现有Layer2服务从Telco。

这些L2 Telco服务倾向于有循环费用,例如本地环路访问, switchport access,等等。

在大多数情况下, 802.1Q TLS服务的部署可以是一样容易象此:

  1. 在客户站点丢弃有线调制解调器。

  2. 请正确提供MSO的网络齿轮。

要做提供更多吸引人和有销路, MSO可能选择一起捆绑有线电视和TLS。

802.1Q TLS操作如何工作?

在802.1Q TLS设置,一特定客户的有线调制解调器配置有由DOCSIS略述的标准的供应方法。

除供应之外, CMTS配置与叫作dot1q地图的定义。dot1q地图包含有线调制解调器MAC地址、VLAN ID和出站接口。这些定义(或捆绑)被传播到服务ID (SID)数据库。

来自一个特定有线调制解调器的流量用VLAN ID在网络标记和然后被派出,可以桥接与从同一客户的其他VLAN。有几方式完成VLAN桥接。

图2表示一个L2VPN点对点结构,说明TLS如何工作。

图 2

/image/gif/paws/60027/tls_over_cable_02.gif

在每个CMTS有绑定与VLAN ID和出站接口的有线调制解调器MAC地址的dot1q地图定义。

假设您跟踪从站点A的一数据包到站点B;以下事件解释CMTS A如何处理从站点回答:的流量

  1. 有线调制解调器采取以太网帧并且添加DOCSIS报头,包括有线调制解调器SID (或SFID)。

  2. 当流量接收时, CMTS执行SID查找。

  3. CMTS根据SID确定流量是否是TLS。

  4. 如果流量是TLS, CMTS调查数据包并且检查源MAC地址。

    1. 如果MAC地址匹配有线调制解调器的MAC地址,则流量发送对第3层交换代码。

    2. 如果MAC地址不匹配有线调制解调器的MAC地址,则流量用适当的VLAN标记在适当的出站接口标记和被派出。

在CMTS B,来自站点A的数据包这样处理:

  1. 当CMTS接收标记的帧时,执行数据库查找确定VLAN是否被映射到有线调制解调器。

  2. 如果找到匹配,则CMTS删除VLAN标记并且添加DOCSIS报头。

  3. CMTS进程新的DOCSIS数据包,依照适当的Cos或QoS参数。

  4. 数据包在电缆接口然后被派出。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

图3说明用于配置的网络拓扑并且验证部分。

图 3

tls_over_cable_03.gif

配置

本文档使用以下配置:

  1. CMTS A

  2. CMTS B

  3. 交换机

  4. 聚合路由器

CMTS A
UBR-1:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.3973.be53 FastEthernet0/1 12 
!

CMTS B
UBR-2:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.39a7.8a67FastEthernet0/0 21 
!

交换机
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         

SW# show vlan id 12

00:44:03: %SYS-5-CONFIG_I: Configured from console by console
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
12   VLAN0012                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
12   enet  100012     1500  -      -      -        -    -        0      0   

SW# show vlan id 21

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
21   VLAN0021                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
21   enet  100021     1500  -      -      -        -    -        0      0

聚合路由器
!         
bridge irb
!         
!         
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/1.12
 encapsulation dot1Q 12
 bridge-group 1
!         
interface FastEthernet0/1.21
 encapsulation dot1Q 21
 bridge-group 1
!         
bridge 1 protocol ieee
!

验证

此部分提供您能使用的,用以确认您的配置正常工作的信息。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

有线调制解调器初始化

当为802.1Q TLS时设置了的调制解调器来联机,绑定调制解调器对VLAN ID和输出接口的地图创建。

发出这些调试指令验证映射:

此输出显示CMTS如何映射VLAN和出站接口,当有线调制解调器来联机时。它也显示下行和关联与VLAN的上行服务流ID。


!--- Logs from CMTS A (UBR-1):

UBR-1# show debug

CMTS:
  CMTS L2 VPN debugging is on
CMTS specific:
  Debugging is on for Address 0000.3973.be53, Mask ffff.ffff.ffff

UBR-1#

cmts_l2vpn_init_cm: cm 0000.3973.be53 on Cable3/0, sid 0xA
map to FastEthernet0/1 VLAN id 12
 Mapped DS srv flow 22 on Cable3/0 to FastEthernet0/1 VLAN 12
 Mapped US srv flow 21 sid 10 on Cable3/0 to FastEthernet0/1 VLAN 12

流量段落

要看到该流量是否来自有线调制解调器或注定对有线调制解调器,您能调试它或查看在计数器。

要调试它,请打开这些调试:

注意: 这些调试只是可用的在uBR7200平台。

当您激活debug cable mac-address MAC地址verbose并且调试有条件的时,电缆的l2-vpn下示例输出显示一数据包的调试从站点A的到站点B。

第一调试行是从站点发出的数据包A。由于数据包是ping信息包,下条调试线路是ping响应。它显示数据包如何发送到有线调制解调器。

UBR-1#

Pkt (size 114) from CM 0000.3973.be53 sid 10 src 0008.a3b6.d371
dst 0008.a3b6.d74b fwd to FastEthernet0/1 vlan 12

Send pkt size 118 from 0008.a3b6.d74b on FastEthernet0/1:vlan 12
to 0008.a3b6.d371 on Cable3/0:0xA CM 0000.3973.be53

要查看字节或信息包计数器,请发出verbose命令显示电缆l2-vpn dot1q-vc-map的MAC地址

UBR-1# show cable l2-vpn dot1q-vc-map 0000.3973.be53 verbose

MAC Address                         : 0000.3973.be53
Customer Name                       :
Prim Sid                            : 5
Cable Interface                     : Cable3/0
Ethernet Interface                  : FastEthernet0/1
DOT1Q VLAN ID                       : 12
Total US pkts                       : 0
Total US bytes                      : 0
Total DS pkts                       : 12
Total DS bytes                      : 816

故障排除

当前没有故障排除此配置的特定可用资料。

设计注意事项

当您部署在DOCSIS网络时的服务有要考虑的几设计因素。一些是特定对电缆侧,并且其他是更多一般问题。

电缆侧(DOCSIS)

管道大小或吞吐量

一般,主要限制在上行带宽。表1显示不同的吞吐量值的近似图。

表 1

DOCSIS版本 信道宽度(兆赫) 调制 近似吞吐量(Mbps)
1.x 1.6 QPSK 2.2
1.x 1.6 16-QAM 4.4
1.x 3.2 16-QAM 8.9
2.0 3.2 64-QAM 13
2.0 6.4 64-QAM 26

DOCSIS版本1.1合并提供上行信道优化的许多功能。其中一些功能包括:

  • 串联

  • 分段

  • 有效负载标头抑制

DOCSIS QoS

做与尽力— DOCSIS版本1.0允许在仅上行的一承诺速率。版本1.1和2.0允许在两个方向的一承诺速率。为了保证承诺信息速率(CIR), CMTS调度器执行在上行的准入控制,防止超量预订。

受控的延迟和抖动— DOCSIS版本1.1's主动授予(UGS)提供一恒定比特率(CBR)象的服务。延迟和抖动可以有效被控制,为要求授予在已修复间隔的流量提供保证最低的数据速率。

安全

横断电缆装置的流量可以巩固与DOCSIS保密性基准接口(BPI),在DOCSIS版本1.0或者BPI+,在DOCSIS新版本。然后,某人在电缆侧的数据不能监听或窃听。

例如对于需要更多安全的客户—,金融机构等等—推荐端到端IPSec策略。在思科的参考的安全

一般问题

QoS

在802.1Q环境,有三个主要QoS地区:

  • 边的CPE CPE如何修正并且标记流量。这是由客户控制的,并且与他们的内部QoS策略是相关的。

  • 边的电缆这依照与DOCSIS协议和有线调制解调器供应。

  • 骨干网— MSO能运用根据服务水平协议的QoS策略。

性能和可扩展性

在CMTS,有拿着数据结构和dot1q地图的内存仅轻微的增量(数据库)。TLS数据包的交换是相同的象为其他数据包。

支持VLAN编号变化基于平台。

桥接组请变化基于平台。

如何延伸在以太网限定范围之外的802.1Q TLS

将有时期,当用户需求连接到是在以太网物理限额之外的站点时;例如,站点用不同的城镇、城市或者州。

在那些情况下, MSO能使用几城域以太网中继服务解决方案之一。

是测试的实验室的两那些解决方案是:

  • 在一个IP核心网络的TLS通过Layer2隧道协议(L2TP)版本3

  • 在一个多协议标签交换(MPLS)核心的TLS通过Ethernet over MPLS (EoMPLS)

附录A -在L2交换机和聚合路由器之间的数据包踪迹

此部分显示一个ping信息包的数据包踪迹在交换机和聚合路由器之间的。注意有两ping请求数据包:一从聚合路由器的站点A和一个从站点的B.聚合路由器。同样适用于ping回复。

Frame 1 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 2 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 3 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 4 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

相关信息


Document ID: 60027