?????? : Cisco CSS 11500 系列内容服务交换机

在CSS 11xxx上的设备对设备冗余的配置示例

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 26 日) | 反馈


目录


简介

本文为内容服务交换机(CSS) 11xxx全套设备冗余提供一配置示例。全套设备冗余提供在两相等地配置的CSSs之间的机箱级别冗余。

先决条件

要求

在尝试此配置前,请保证您符合这些要求:

  • 您使用此冗余配置的两个CSSs一定运行同一个编码版本。运行不同的编码版本不为冗余支持。

  • 期望CSSs的行为是活跃(重要的) /standby (备份);仅主控CSS进程流。

  • 您必须配置CSSs之间的一条专用的快速以太网(FE)链路虚拟路由冗余协议(VRRP)检测信号的。

  • 如果需要一第2层设备的连接在冗余的CSS对等体之间的请勿使用机箱对机箱。请使用VIP冗余。参考配置VIP和虚拟接口冗余欲知更多信息。

使用的组件

本文档中的信息根据CSS 11150 SW版本:6.10构建107。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

相关产品

此配置也可用于以下硬件和软件版本:

  • 所有Cisco CSS 11000 - 11500系列CSS产品

  • Cisco WebNS软件版本5.0和以上

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

当冗余链路定义在两CSSs之间时, CSSs参加冗余配置。使用组播地址224.0.0.18,用于此冗余链路的协议是VRRP。CSSs使用此链路互相维护联系方式和活动状态。仅支持CSSs之间的一条交叉电缆链路。您必须使用交叉电缆连接直接地到冗余CSSs的FE端口。不在两个CSSs之间的使用第2层设备在冗余链路。请勿安装在千兆以太网(GE)端口的交叉电缆;不支持此配置。

注意: CSS 11501, CSS 11503和CSS11506软件版本的7.10.1.02和7.20.0.01和以后GE端口当前支持CSS全套设备冗余协议。

有在此冗余链路检测的两个主要条件推进主控和备份状态两个的CSSs :

  • 第一个情况维护检测信号,是广告每秒钟。主控CSS在冗余链路提供此检测信号,并且备份CSS记录检测信号每三秒(默认)。如果检测信号时代(例如,检测信号在此期限没有检测),则备份接管作为主控。

    新的主控CSS开始派出冗余协议消息以及无偿地址解析协议(ARP)消息更新在相邻节点的ARP表和附加的桥接设备转发表(例如,第二层交换机)有新的主控CSS MAC地址的。CSS传送一ARP请求数据包和一ARP应答数据包每免费ARP调用的。

  • 第二个情况是那VRRP交换机优先级更改。通告最高优先级的CSS协商变得重要。这是链路服务使用的机制和某些特殊命令(下述)启动故障切换事件。

注意,在CSSs是不正确的配置的(例如,两个或多个CSSs设置作为IP冗余主控)情况下, CSS用最高的VRRP IP地址接管作为主控。

Cisco WebNS软件允许您对:

  • 配置多项上行链路服务

  • 请使用根据链路的故障切换断开

  • 请使用配置同步;参考同步一个冗余配置欲知更多信息

配置

本部分提供有关如何配置本文档所述功能的信息。

发出IP冗余命令启用在两用交叉电缆建立接口的CSSs的CSS对CSS冗余。默认情况下,冗余在CSSs禁用,直到您发出两此的on命令CSSs。

当您包括重要的选项用此命令时,您能选定哪个CSS是主控CSS。最初,启动两用交叉电缆建立接口的CSSs确定哪些是主控,并且哪些是备份。初次启动的CSS是主控CSS。如果同时CSSs引导程序,与高IP地址的CSS数字上变为主控。

当您发出ip redundancy master命令在CSS时, CSS变为主控CSS。您能发出此on命令当前主控或备份。如果发出在备份CSS的重要的选项, CSS变为主控,并且另一个CSS自动地变为备份。

如果选定主控CSS, CSS在断开以后收复重要的状态再然后出现。例如,当主控CSS断开时,备份CSS变得重要。当前面的指定主控CSS再出现,然而时, CSS再变为主控。

如果没有需求选定CSS作为主控,当两CSSs是UP时,请勿包括重要的选项,当启用在主控CSS时的冗余。

网络图

本文档使用以下网络设置:

/image/gif/paws/50405/box_to_box_config.jpg

配置

本文档使用以下配置:

  • CSS 11150 FL

  • nws-4-5

CSS 11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


对多项上行链路服务的支持

您能创建关联与路由器IP地址的服务。此服务使主控CSS监控有Keepalive的(ICMP)路由器。如果Keepalive发生故障,主控放弃控制,并且备份CSS采取控制。您能通过发出type redundancy-up命令配置超过一服务;CSSs使用所有冗余uplink端口,当进行故障切换决策。

如果CSS是活跃的,并且丢失作为redundancy-up被选定的所有uplink端口, CSS放弃活动状态并且变为备份。CSS使用冗余协议通知另一个CSS变得激活。如果两CSSs丢失他们的uplink端口, CSS逗留在活动状态45秒,等待上行链路活跃起来。在45秒之后,如果仍有没有可行的上行链路, CSS进入备用模式,给另一个交换机A尝试。这允许两获得机会的CSSs测试他们的uplink端口,无需反复捶打许多时间每分钟。

注意: 当不再有实际链路服务时, CSS进入故障切换。

考虑事项

ip redundancy master命令发出时,此功能禁用。当ip redundancy master命令发出时, type redundancy-up命令不可能配置。当服务通过发出type redundancy-up命令配置时, ip redundancy master命令不可能发出。

配置

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

对物理接口故障切换的支持

如果为冗余配置的任何一个物理接口断开, CSS放弃控制,并且备份CSS立即接管作为主控。此功能根据链路状态与redundancy-up服务相对,根据IP连通性。CSS能确定链路状态,当在备用模式。您必须确保,备份CSS的上行或下行路径不通过此同样接口也运行;这将造成CSS方框摆动重要的状态的所有权。

考虑事项

此功能通过发出ip redundancy master命令禁用。当ip redundancy master命令发出时, interface命令的冗余phy发生故障。当interface命令的冗余phy发出时, ip redundancy master命令发生故障。

配置

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • 嘘冗余—此命令验证CSSs在冗余配置里运行;此命令也显示哪个CSS是主控,并且哪些备份,以及最后故障切换的原因。

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • show log sys.log —此命令显示与信息的消息在CSS设备之间的精通的。

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • show appshow app session —此命令显示APP会话的状态。

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

您能强制备份为维护目的掌握。发出冗余强制主命令配置备份CSS作为一临时主控。因为命令没有复制对running-configuration,这是一临时设置。当您需要采取主控CSS脱机为维护或升级时,此命令在冗余配置里是有用的。

故障排除

目前没有针对此配置的故障排除信息。

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 50405