IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

了解 IS-IS 伪节点 LSP

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 4 月 22 日) | 反馈


目录


简介

本文描述链路状态包(LSP)伪节点。伪节点是由在LAN分段的指定中间系统(DIS)生成LAN的逻辑表示。本文也描述信息的传播到路由器。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档中的信息根据软件和硬件版本关联与:

  • Cisco IOS 软件版本12.1(5)T9。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

DIS和伪节点

此部分描述DIS和伪节点。

DIS 是什么?

在广播多路访问网络,单个路由器选择作为DIS。没有DIS选择的备份。DIS是代表伪节点创建伪节点和操作的路由器。

两项主要任务由DIS执行:

  • 创建和更新报告的链路伪节点LSP对在广播子网的所有系统。欲知更多信息,请参阅Pseudenode LSP部分。

  • 充斥在LAN的LSP。

充斥在LAN意味着DIS发送定期完全序数协议数据单元(CSNPs) (10秒默认设置)汇总以下信息:

  • LSP ID

  • 序列号

  • 校验和

  • 剩余寿命

DIS对充斥负责。它创建并且充斥每路由的新的伪节点LSP级在哪些参与(1级或级别2)和连接的每个LAN的。路由器可以是所有连LAN或连LAN的一子集的DIS,根据IS-IS优先级或第2层地址。DIS也将创建,并且充斥新的伪节点LSP,当邻接设立时,被切断或者刷新间隔计时器超时。DIS机制减少相当数量在LAN的泛滥。

DIS 选择

在LAN,其中一路由器根据接口优先级选择自己DIS, (默认是64)。如果所有接口优先级是相同的,有最高的子网附着点(SNPA)的路由器选择。SNPA是在LAN的MAC地址和本地数据链路连接标识符(DLCI)在帧中继网络。如果SNPA是DLCI并且是相同的在链路的两边,有更高的系统ID的路由器变为DIS。每个IS-IS路由器接口分配L1优先级和L2优先级在范围从0到127。

DIS选择是先发制人的(不同的OSPF)。如果一个新的路由器在LAN启动以一个接口优先级,新的路由器变为DIS。它清除旧有伪节点LSP并且充斥新的一套LSP。

伪节点 (PSN) 是什么?

为了减少全网状邻接数量在节点之间的在多路接入链路,多路接入链路被模拟作为伪节点。因为名称暗示,这是一个虚拟节点。DIS创建伪节点。广播的所有路由器连接,包括DIS,表邻接与伪节点。

伪节点的表示:

pseodonode.gif

在IS-IS中, DIS与其邻居不同步。在DIS创建LAN的后伪节点,发送每个级别的Hello数据包(1和2)每三秒和CSNPs每十秒。Hello数据包表明它是在LAN的DIS该级别的,并且CSNPs描述所有LSP摘要,包括LSP ID、序号、校验和和剩余寿命。LSP总是被充斥对组播地址,并且CSNP机制为所有丢失的协议数据单元(PDU)只更正。例如,路由器能请求一缺少LSP的DIS使用部分序列序号数据包(PSNP)或,反过来,给DIS一新的LSP。

CSNPs用于通知关于所有LSP的其他路由器在一路由器数据库中。类似于OSPF数据库描述符数据包, PSNPs用于请求LSP和确认LSP的收据。

伪节点 LSP

伪节点LSP由DIS生成。DIS报告所有LAN邻居(包括DIS)与量度的伪节点LSP的零。所有LAN路由器,包括DIS,汇报连接对在他们的LSP的伪节点。这类似于在概念在OSPF的网络LSA。

示例

我们将使用以下网络图展示伪节点LSP,生成由DIS,如何用于报告所有LAN邻居。

注意: 在下面的示例中的,动态主机名功能是enable (event)。所以,系统ID自动地被映射对在下面显示命令的产生的输出中显示的路由器主机名。

网络图

ISISpnode.jpg

配置

这些配置使用了路由器显示在网络图中

路由器ISIS
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1
  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

下表划分区域、MAC地址和网络其中每一的上面配置的路由器。注意所有路由器在同一个区域。

路由器 区域 Mac 地址 NET (网络实体标题)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

使用正如此部分所描述的配置的路由器,您能使用show clns is-neighbor命令查看IS-IS邻居:

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

在之前的邻接列表中,请注意对多路访问网络(以太网)的路由器连接全部有同样电路ID。电路ID是路由器用途独特识别IS-IS接口的一八位位组编号。如果接口附加对多路访问网络,电路ID用DIS的系统ID连接。这叫作伪节点ID。注意也, DIS是路由器6由于IS-IS优先级配置在其以太网接口下的那。

IS-IS 数据库

此输出显示从在前面部分描述的其中每一的IS-IS数据库路由器:

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

当之前的输出指示, show isis database命令显示LSP列表在数据库的。在这种情况下,所有路由器是1级路由器在同一个区域,因此他们全都有同样LSP在他们的IS-IS数据库。注意其中每一路由器生成LSP。DIS生成本身的一LSP,并且代表伪节点也生成LSP。在本例中的伪节点LSP是0000.0C4A.4598.01-00。

我们提及LAN的路由器只发送广告对LAN的伪节点。如这些show isis database lsp detail命令输出示例所显示,伪节点报告所有LAN邻居,伪节点LSP的,与量度零— :

  • 路由器6 LSP (如被看到从路由器8)

    注意路由器6通告能只到达其直连网络和伪节点。在这种情况下,伪节点有量度10。如同我们提及了, LAN的路由器通告他们可以被到达到仅LAN的伪节点。

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • 伪节点LSP (如被看到从路由器8)

    伪节点LSP通告有量度的所有LAN邻居零。伪节点LSP由DIS在这种情况下生成,路由器6,代表伪节点。

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • Router2 LSP (如被看到从路由器8)

    再次, Router2 LSP包含信息至于是否能到达其唯一的直连网络和伪节点。

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • 路由器1 LSP (如被看到从路由器8)

    路由器1 LSP为LAN网络包含的唯一的信息是网络,并且是否能到达伪节点。因为路由器1也连接对另一网络,串行网络,此直连网络也通告。

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • 路由器8 LSP

    在这种情况下,路由器8没有连接对LAN,因此不通告对伪节点可以被到达。然而,它通告(该可以被到达)到本身,路由器1和对直连网络。

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息


Document ID: 49627