协作 : Cisco Unified Contact Center Enterprise

Cisco Agent Desktop Enterprise data窗口不能打开

2016 年 10 月 24 日 - 机器翻译
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简介

本文描述Cisco Agent Desktop Enterprise data窗口为什么在Cisco IP Contact Center (IPCC)企业版环境不能打开。

先决条件

要求

Cisco 建议您了解以下主题:

  • Cisco IPCC企业版

  • Cisco Agent Desktop

使用的组件

本文档中的信息基于以下软件和硬件版本:

  • Cisco IPCC企业版版本4.6.2和以上

  • Cisco Agent Desktop版本4.6

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

背景信息

默认情况下, Cisco Agent Desktop窗口是开放的,当呼叫是活跃的时,并且变得最小化,当空闲。这呼叫正常模式

如果您的系统管理员配置Cisco Agent Desktop这样本地管理启用,您能更改从选项菜单的此窗口行为。其他可用的模式包括:

  • 保持Open模式—窗口保持开放,既使当空闲。

  • 总是在顶部模式—窗口保持开放,当空闲和在其他开放应用程序顶部。

  • Stealth模式—窗口出现作为在系统托盘(您的桌面右下角的一个图标)并且打开,当您双击图标。

问题

Cisco Agent Desktop不能打开Enterprise data窗口。窗口在系统托盘保持最小化。当呼叫到达时,数据窗口突出显示,但是不打开。

原因

Cisco Agent Desktop存储运行窗口的大小和位置从上次的。对于此, Cisco Agent Desktop在WindowLeft使用值, WindowTopWindowWidth,并且在企业下的WindowHeight选项在fastcalllocal.ini文件建立接口。默认情况下, fastcalllocal.inifile位于C:\Program Files\Cisco\Desktop\config目录

此问题的根本原因是在WindowLeftWindowTopWindowWidthWindowHeight选项的大负值在fastcalllocal.ini文件(请参阅图1)。

图1 – WindowLeftWindowTopWindowWidthWindowHeight值在fastcalllocal.ini文件

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解决方案

完成这些步骤解决此问题:

  1. 编辑有所有文本编辑的fastcalllocal.ini文件(例如, Notepad)替换在WindowLeftWindowTopWindowWidthWindowHeightwith空白的大负值在fastcalllocal.inifile

  2. fastcalllocal.ini文件只读。


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