IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

IS-IS 中 MTU 不匹配问题

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

中间系统对中间系统(IS-IS) hello被填充对全双工最大传输单位(MTU)大小。填充IS-IS Hello的好处(IIH)对全双工MTU是允许错误早期检测由于传输问题用大帧或由于在相邻接口的不匹配的MTU。

IIH填充符可以为在路由器的所有接口被关闭(在Cisco IOS�软件版本12.0(5)T和12.0(5)S)用no hello padding命令在IS-IS路由过程的路由器配置模式。IIH填充符可以为点对点或多点接口选择性地被关闭与no hello padding multi-pointno hello padding point-to-point命令在路由器配置模式IS-IS路由过程的。使用no isis hello padding interface configuration命令, HELLO填充可能也被关闭根据单个接口基本类型。

用户会禁用HELLO填充按顺序避免浪费网络带宽,万一两个接口MTU是同样或,在转换桥接的情况下。当HELLO填充禁用时, Cisco路由器仍然发送被填充的前五IS-IS hello对全双工MTU大小。这是为了维护发现MTU不匹配的好处。连续的hello不再被填充。

本文展示发生了什么,当有在运行IS-IS的两个连接的路由器接口的一MTU不匹配。在路由器F的MTU从其默认值1500个字节到2000个字节更改用mtu 2000 interface configuration命令。serial interfaces “拍动了”。所以,为了生效的新的MTU值,您必须禁用Serial0用shutdown命令,用no shutdown命令然后启用它。

先决条件

要求

本文档没有任何特定的要求。

使用的组件

本文档不限于特定的软件和硬件版本。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

问题

用于的网络图和配置描述此问题显示此处:

/image/gif/paws/47201/isis_mtu_01.gif

路由器H 路由器 F
clns routing
 !

 interface Serial0
  no ip address
  no ip directed-broadcast
  no ip mroute-cache
  encapsulation frame-relay
  frame-relay lmi-type ansi
 !
 interface Serial0.1 

  ip address 10.10.10.4 255.255.255.0
  no ip directed-broadcast
  ip router isis  
  clns router isis 
  frame-relay map clns 132 broadcast
  frame-relay map clns 131 broadcast
  frame-relay map ip 10.10.10.1 132 broadcast
  frame-relay map ip 10.10.10.3 131 broadcast
 !
 interface Serial0.2 point-to-point
  ip address 10.20.20.4 255.255.255.0
  no ip directed-broadcast
  ip router isis 
  clns router isis 
  frame-relay interface-dlci 130   
 !
 router isis 
  passive-interface Ethernet0
  net 49.0001.4444.4444.4444.00
  is-type level-1
clns routing

!
interface Serial2
mtu 2000
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 clns router isis 
 frame-relay interface-dlci 103   
!
router isis 
 net 49.0001.2222.2222.2222.00
 is-type level-1

在两路由器上,您能看到邻接的状态在路由器F和路由器H之间的用show clns neighbors命令。在从路由器F的输出中,请注意邻接用路由器H在初始状态。在从路由器H的输出中,您能看到邻接用路由器F是类型是,并且协议是末端系统到中间系统(ES-IS)。此输出指示有与无连接网络服务(CLNS)邻接的一问题。

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     294       IS   ES-IS
Router_G       DLCI 131            Se0.1       Up     7         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     27        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

如果启用IS-IS领接信息包调试用debug isis adj-packets命令,您能看到路由器F发送并且接收在Serial2.1子接口的序列IIH。

Router_F# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1,cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1

此输出显示路由器H不接收在Serial0.2的IIH从路由器F。所以, IS-IS邻接没有形成。反而,邻接是终端系统(ES)。

Router_H# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

问题的原因

路由器H不接收从路由器F的hello,因为IIH被填充对链路的全双工MTU,而ES hello没有被填充对全双工MTU大小。这发生,因为路由器F认为MTU是2000年,并且发送2000字节Hello,由路由器H.忽略。

解决方案

解决方案将确保,链路的两边有同样MTU。一种方式执行此将使用mtu命令如显示此处:

Router_F# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)# interface serial 2
Router_F(config-if)# mtu 1500
Router_F(config-if)# shutdown
Router_F(config-if)# no shutdown
Router_F(config-if)# ^Z
Router_F#

现在路由器H和路由器F能变为邻居和路由彼此的流量。

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS
Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

CLNS邻接问题由于MTU不匹配可能也解决使用clns mtu命令如显示此处:

Router_F#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)#interface serial2
Router_F(config-if)#clns mtu 1500
Router_F(config-if)#^Z
Router_F#

相关信息


Document ID: 47201