?????? : Cisco LocalDirector 400 系列

在 LocalDirector 上配置能够检查服务器可用性的 HTTP 重定向

2015 年 8 月 28 日 - 机器翻译
其他版本: PDFpdf | 英语 (2014 年 9 月 30 日) | 反馈


Cisco已宣布Cisco LocalDirector终止销售。更多信息,请参见LocalDirector 400系列生命周期终止和销售终止通知以及产品公告


目录


简介

本文描述如何配置允许您检查在Cisco LocalDirector的服务器可用性的超文本传输协议(HTTP)重定向。HTTP重定向也要求direct IP (DIP)地址的另外的IP地址能允许直接呼叫/浏览。

此配置使用下面软件和硬件版本开发并且被测试。

  • 在清除配置实验室环境的LocalDirector 416。
  • Localdirector软件软件版本4.2.1
  • Microsoft Internet Explorer 5.5
  • Netscape Communicator 4.7

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果在真实网络工作,请保证您了解所有on命令潜在影响使用它以前。

网络图

如何配置 HTTP 重定向以检查服务器可用性

请使用以下步骤配置您的LocalDirector :

  1. 创建以下的一个“A”记录:
    test.testdomain.com <-> 172.18.124.209 VIP
    ns-ms1-dip.testdomain.com <-> 172.18.124.212 DIP 
    ns-ms2-dip.testdomain.com <-> 172.18.124.211 DIP
    ns-ms1.cisco.com <-> 172.18.124.207 REAL 
    ns-ms2.cisco.com <-> 172.18.124.206 REAL
    172.18.124.211 DIP virtual for 172.18.124.206 REAL (aka s2)
    172.18.124.212 DIP virtual for 172.18.124.207 REAL (aka s1)
    

    注意:您需要绑定端口的虚拟IP (VIP), DIP和实际地址,但是您也需要每个实际地址的两个IP地址对真实服务器的出站连接的仍然允许。这允许与为坏端口发送的重置的安全VIP。它也允许其他呼叫对垂度直接地通过真的地址来,当曾经备选IP地址DIP的虚拟地址时。

  2. 创建a (端口范围) VIP地址。应该有在域名系统(DNS)的一个“A”记录条目。
    virtual 172.18.124.209:80:0:tcp is 
    
  3. 创建接受呼叫请求此VIP地址的每个“真实服务器的” DIP。请使用“额外的个人号码”在语句的第一部分。
    direct-ip 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp is
    direct-ip 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp is
    
    系统将创建以下您的:
    real 172.18.124.207:80:0:tcp is
    real 172.18.124.206:80:0:tcp is
    bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
    bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
    
  4. 创建每个真实服务器的统一资源定位器(URL)重定向。这是客户端将重定向的地方,当他们点击VIP时。
    url s2 http://ns-ms2-dip.testdomain.com/%p 302
    url s1 http://ns-ms1-dip.testdomain.com/%p 302
    

    注意:“%p”表示页。

  5. 创建一backup命令对普通的VIP的每个DIP的。这解决收藏书签的问题。如果客户端按书签DIP的URL,并且,如果该DIP (真实服务器)不是可用的(它出现如失败),然后将使用backup命令让客户端再呼叫VIP。
    backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
    backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
    

    注意:HTTPS的重定向用途不同地备份。

  6. 绑定VIP对url命令的其中每一。

    bind 172.18.124.209:80:0:tcp s2
    bind 172.18.124.209:80:0:tcp s1
    
  7. 创建一link命令每个URL的对DIP的第一部分。这创建在DIP和URL之间的一个关联关联与该昵称(例如, s1)。link命令保证,如果DIP失败,然后LocalDirector不会重定向客户端对将呼叫该失败的DIP (是被映射的一对一的与实际IP地址)的URL。
    link s2 172.18.124.211:80:0:tcp
    link s1 172.18.124.212:80:0:tcp
    

show 命令与示例输出

show version 命令

show version命令显示在LocalDirector的软件版本运行。

localdirector# show version
LocalDirector 416 Version 4.2.1

show configuration 命令

show configuration命令显示在LocalDirector的当前运行的配置。

localdirector# show configuration
: Saved
: LocalDirector 416 Version 4.2.1
syslog output 20.7
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
multiring all
no secure  0
no secure  1
no secure  2
ping-allow 0
ping-allow 1
no ping-allow 2
ip address 172.18.124.210 255.255.255.0
route 0.0.0.0 0.0.0.0 172.18.124.1 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
telnet 172.18.124.0 255.255.255.0
telnet 64.105.0.0 255.255.0.0
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location
virtual 172.18.124.209:80:0:tcp is
predictor 172.18.124.209:80:0:tcp roundrobin
real 172.18.124.207:80:0:tcp is
real 172.18.124.206:80:0:tcp is
direct-ip 172.18.124.211:80:0:tcp   172.18.124.206:80:0:tcp is
direct-ip 172.18.124.212:80:0:tcp   172.18.124.207:80:0:tcp is
url s2 http://ns-ms2-dip.testdomain.com/%p 302
url s1 http://ns-ms1-dip.testdomain.com/%p 302
backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
bind 172.18.124.209:80:0:tcp s2
bind 172.18.124.209:80:0:tcp s1
link s2 172.18.124.211:80:0:tcp
link s1 172.18.124.212:80:0:tcp

show statistics 命令

show statistics命令显示实时和虚拟服务器统计信息。

localdirector(config)# show statistics
          Real Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.207:80:0:tcp           1092            8             2
(DIP) 172.18.124.206:80:0:tcp            960            7             1


       Virtual Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.211:80:0:tcp            960            7             1
(DIP) 172.18.124.212:80:0:tcp           1092            8             1
  172.18.124.209:80:0:tcp               3296           26             2
localdirector(config)#

show url 命令

show url命令显示连接信息对URL。

localdirector(config)# show url
Urls:

             Id  Connect    Rcode   State                     Url
             s2        1      302     IS http://ns-ms2-dip.testdomain.com/%p
             s1        0      302     IS http://ns-ms1-dip.testdomain.com/%p
localdirector(config)#

show syslog 命令

show syslog命令显示记录信息(例如日期、时间、级别和输出) :

<165> May 30 11:35:14 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:34 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'slowstart' to 'leastconns'
<162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'slowstart' to 'leastconns'
  

检查配置

请使用以下命令验证配置:

  • show real -显示真实服务器的统计信息和状态。

  • show virtual -显示虚拟服务器、他们的状态、编号连接和负载均衡算法列表。

  • show statistics -请参阅上述

排除配置故障

Syslog 命令

Syslog [主机IP|控制台|输出facility.level]命令可以用于调试或排除故障。

在本例中, http://test.testdomain.com重定向对http://ns-ms2-dip.testdomain.com/。

下列是从系统日志控制台syslog output 20.7的输出示例: :

localdirector(config)# syslog console
localdirector(config)# <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp'
 from 'slowstart' to 'leastconns'
localdirector(config)# <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp'
 from 'slowstart' to 'leastconns'


相关的思科支持社区讨论

思科支持社区是您提问、解答问题、分享建议以及与工作伙伴协作的论坛。


相关信息



Document ID: 46222