IP : IP 版本 6 (IPv6)

6bone连接使用6to4 IPv6的隧道

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文描述企业园区客户(例如,教育机构、一家小软件公司或者一家小制造企业)如何通过使用6to4通道,能连接到6bone。6bone是在IPv6演变和部署的设置的协助在互联网里的IP版本6 (IPv6)测试网络。

本文是一个支持并且补全IPv6部署策略出版物,是可用的在IPv6设计指南的一套文档。

您应该与IPv6部署策略一道读本文改善了解IPv6预部署活动。

先决条件

要求

在您实现6to4通道对6bone前,您必须执行以下任务:

  • 在您将配置运行双协议栈的您的站点识别边界路由器。此边界路由器必须有静态,全球可发送的IPv4地址。

  • 数据许可证要求启用所有IPv6功能。为了验证许可证在的路由器启用,请使用license命令的显示

  • 从6bone ISP,请得到您将使用6bone访问6to4中继路由器的IPv4地址。

    注意: 当您配置您的企业边界路由器的时通道,您必须使用全球可发送的IPv4地址。用于在本文的配置示例的IPv4地址不是全球可发送的和只用于说明目的提供。

  • 保证您的DNS运行(或有等同的功能)柏克来网络名称域(BIND)版本9,为IPv6提供DNS主要组件实施。DNS配置是超出本文的范围之外。

  • 认为当前双协议栈实施在Cisco IOS软件方面允许一个临时网络管理解决方案,允许应用程序例如TFTP,请ping,远程登录和在IPv4或IPv6传输将运行的traceroute。

  • 选择一个IPv6内部路由协议,例如RIPng,是适当的对您的网络配置。为了简化,在本文提交的解决方案使用静态路由。相关IPv4外部路由协议处理外部路由。

  • 配置所有您的双协议栈路由器使用RIP。

参考Cisco IOS IPv6配置库关于配置您的IPv6的网络的更多信息。

使用的组件

本文档中的信息根据与IPv6支持的Cisco IOS镜像。

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

以下图显示企业园区客户的最初的IPv4网络拓扑。此网络使用几路由器提供在本地用户中的IP连通性。对互联网服务提供商的一永久性IPv4连接提供外部连接

/image/gif/paws/45741/6bone_tc_1-01.gif

下表描述用于此解决方案的设备。

设备 企业边界路由器 6bone ISP路由器
主机名 6bone GW ipv6-router
机箱类型 Cisco 3660 路由器 Cisco 7206 路由器
物理接口 2 Ethernet2快速以太网4序列 4 Ethernet2快速以太网4序列
加载的软件 Cisco IOS版本12.2(4)T Cisco IOS版本12.2(4)T
内存 64MV RAM;16 MB闪存 128 MB RAM;20 MB闪存
IP 地址 Ethernet0 :IPv4 192.168.99.1 Tunnel2002 :IPv6 2002:C0A8::1/128 Ethernet0/0 :IPv4 192.168.33.1 Tunnel2002 :IPv6 2002:C0A8:2102::1/128

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

6to4通道如何工作

6to4通道在企业双协议栈边界路由器配置。为6bone注定的所有企业IPv6流量在IPv4路由通过通道到6bone ISP 6to4中继路由器。从6bone的流量到企业主机在IPv4路由通过通道到企业双协议栈边界路由器,然后到IPv6目的地主机。

对使用6to4通道企业的好处如下:

  • Cisco IOS软件软件支持6to4通道。

  • 最终用户主机配置简单—要求最小高架管理。

  • 通道自动;企业特定的配置没有在6to4中继站点要求。6to4通道很好扩展。

  • 此解决方案适应动态IP地址在企业。

  • 通道仅存在处于会话的。

  • 6to4通道要求仅一一次性配置在ISP,同时做6to4中继服务联机对许多企业。

6to4通道的限制

6to4通道使用情况有以下限制:

  • 独立地管理的NAT没有沿通道的路径允许。

  • 您不能容易地实现多归属。

  • 6to4通道机制提供/48地址块;没有其他地址不是可用的。

  • 由于6to4通道配置的多对一,并且隧道流量能于多个终端起源, 6to4通道能提供仅整体数据流信息给ISP。

  • 基础IPv4地址确定企业6to4 IPv6地址前缀,因此对本地IPv6的迁移要求重数网络。

  • 此解决方案对静态或BGP4+路由被限制。

隧道方案

一个小软件公司(认为一个典型的企业园区环境)与IPv4网络与运行在其网络的IPv6的另一家公司讨论合并。要估计连接请影响合并在合并的公司将有,客户要通过连接展开IPv6其知识到6bone。在本文讨论的企业园区客户的业务目标如下:

  • 增益在一已建立IPv6骨干网的IPv6体验使用其现有IPv4拓扑,有一次最小投资的。

  • 在一个真实世界的IPv6环境的测验过渡和运行程序在部署IPv6前。

    过渡步骤是必要从IPv4移植到IPv6的那些步骤。这些步骤包括安装双协议栈路由器和终端系统、隧道机制、域名系统(DNS)服务器,并且,在将来,测试网络地址转换-协议转换(NAT-PT)。

    运行程序与双协议栈主机和终端系统网络管理、网元管理和其他相似的功能涉及。

  • 测验IPv6应用程序和实施在本地工作站。

  • 最小化高架管理关联与6bone连接。

    注意: 虽然6bone包括许多类型组织(例如,院和政府组织、硬件与软件供应商和服务提供商),本文使用期限6bone ISP,当是指在通道的6bone末端的组织时。

配置

您的边界路由器IPv4地址是192.168.99.1。从您的IPv4地址派生您的6to4前缀通过转换IPv4地址的十进制组件对十六进制的然后加前缀“2002年”对发生的十六进制数。因此IPv6节点的6to4前缀在您的网络是2002:C0A8:6301::/128。

如表6.所显示,之前的IPv6地址的C0A8:6301部分从IPv4地址构成通过转换点分十进制表示方法的每个八位位组对其十六进制等同。

十进制 十六进制
192 C0
168 A8
99 63
1 01

此部分存在信息配置在本文描述的功能中。

注意: 有关本文档所用命令的详细信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

此图显示一个典型的6to4通道的拓扑对6bone。

/image/gif/paws/45741/6bone_tc_1-02.gif

配置

您的6bone ISP提供您IPv4地址其6bone边界路由器:192.168.33.1。请使用之前的地址信息通过输入以下命令配置在您的已确定双协议栈边界路由器的一个6to4通道:

企业路由器
ipv6 unicast-routing

interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0

interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4


!--- In some cases, a user will require a data license 
!-- in order to issue the tunnel mode ipv6ip command.

 ipv6 route 2002::/16 Tunnel2002
 ipv6 route ::/0 2002:C0A8:2101::1

在second ipv6 route命令的2002:C0A8:2101::1是ISP 6to4中继路由器的IPv6地址对6bone的该提供访问。地址的C0A8:2101部分从IPv4地址(192.168.33.1)派生6to4中继路由器有些类似于表6。

在通道的另一端,您的6bone ISP的边界路由器会有一配置类似以下IPv6单播路由示例:

ISP 6to4中继路由器
ipv6 unicast-routing

interface ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0

interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

企业路由器6bon2-gw
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname 6bone-gw
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router domain name
!
ip domain-name EnterpriseDomain.com
!
! Configure DNS name servers
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
end
 end

6bone IPv6 ISP路由器
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname ipv6-router
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!
logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router's domain name
!
ip domain-name 6boneISP.com
!
! Configure DNS name servers
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
!
end

验证

此可选任务解释如何确认您的通道配置和工作正常。在任务步骤包含的命令用于所有顺序,并且可能需要被重复

命令输出解释程序仅限注册用户)(OIT) 支持某些 show 命令。使用 OIT 可查看对 show 命令输出的分析。

  • enable (event)

  • show interfaces tunnel number [accounting]

  • ping [protocol]目的地

  • show ip route [address [mask]]

故障排除

目前没有针对此配置的故障排除信息。


相关信息


Document ID: 45741