IP : 开放最短路径优先 (OSPF)

设计大规模与OSPF的服务提供商拨号网络

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

要设计拨号网络是网络服务提供商的(ISP)一项富有挑战性的任务。每个ISP使用一个唯一方法设计拨号网络。然而,所有ISP共享同样关注方面,当他们设计拨号网络,如列出此处:

  • 如何必须传播池路由到ISP核心?

  • 必须用于什么路由协议运载那些路由到核心?

  • 应该在发送前汇总那些拨号路由到核心?

  • 什么,当分配时,必须考虑到池?

  • 如果池是静态的,什么发生?

本文讨论大多上面问题并且处理使用内部网关路由协议(IGP)开放最短路径优先(OSPF)设计实践在ISP拨号环境。OSPF是常用的在ISP核心网络。在本文中,我们避免介绍运载的拨号池路由一份分开的协议—我们使用OSPF传播拨号池路由到核心。

网络拓扑

显示的拓扑此处是典型ISP拨号网络网络拓扑结构。提供的ISP典型地是AS5300或AS5800的拨号服务通常有一系列的Network access servers (NAS)。服务器对IP地址的提供负责对拨号到ISP并且要使用网络服务的所有用户。NAS服务器然后连接到聚合设备,典型地是Cisco 6500路由器。6500路由器传播拨号路由到核心,允许核心路由器为最终用户提供网络服务。图1显示一个典型的Point of Presence (POP)方案。

图1 –典型POP方案

ispdial.jpg

ISP拨号普尔斯

ISP典型地处理池IP地址的两种类型:

  • 静态

  • 中央印制厂

静态池

使用静态池, ISP有特定的IP地址投入每个NAS服务器。遇到专用的IP地址NAS接收一从池的用户。例如,如果NAS1静态池地址范围是192.168.0.0/22,有大约1023个IP地址。遇到NAS1地址接收一在范围的从192.168.0.0到192.168.3.254的用户。

中央池

使用中央池, ISP有一更加大的IP地址范围被分配在所有NAS中在单个POP。遇到NAS的用户收到从中央池的一个IP地址,是非常大范围。例如,如果中央池地址范围是192.168.0.0/18和他们被分配在14个NAS服务器之间,那里是大约14000个IP地址。

与静态池的拨号设计

静态池是更加容易管理从路由角度。当一个静态池在定义NAS时,池需要为路由选则的目的被传播到核心。

请使用这些方法传播从的拨号路由NAS :

  • 创建静态路由对集IP地址范围,指向null0,当池地址重新分配在NAS。

  • 分配在一环回的集IP地址,在与OSPF点对点的网络类型的NAS,包括在OSPF区域的环回。

  • 配置在一区域边界路由器(ABR)的静态路由指向NAS自治系统边界路由器(ASBR)的集IP地址的—这是首选方法,因为汇总可以执行在ABR。

创建静态路由对指向null0的池地址范围

如果使用此方法,必须为每创建静态路由NAS。静态路由必须覆盖例如指向null0的确切的静态池范围地址。,如果静态池地址是192.168.0.0/22,在NAS的静态路由配置是:

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

池地址重新分配到OSPF,传播此信息到核心以类型5外部链路状态通告(LSA)形式。

分配在环回的池地址在与OSPF点对点的网络类型的NAS

如果使用此方法,静态路由没有要求。池地址分配作为在回环接口的一子网。在回环接口的默认网络类型是环回,在OSPF必须leavingcisco.com 通告这就是为什么,根据RFC 2328作为/32 —您必须更改在环回的网络类型到点对点。点对点的网络类型强制OSPF通告环回的子网地址,在这种情况下是192.168.0.0/22。配置如下:

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

此配置创建在路由器LSA的一条路由器残余部分链路和被传播作为内部OSPF路由而不是外部OSPF路由。

配置在ABR的静态路由池地址的,指向NAS (ASBR)

如果使用此方法,您不需要执行在的任何配置NAS。所有配置出现在ABR或聚合设备。地址池是静态的。所以,静态路由容易地生成,并且路由器能指向下一跳各自NAS,自治系统边界路由器(ASBR)。这些静态路由需要再分布到OSPF通过再分配静态子网在OSPF下。例如:

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

因为汇总在ABR,可以执行这是首选方法。汇总在前两个方法能也发生,但是汇总配置是必要的在每NAS与此方法比较,汇总配置是仅必要的在此路由器。

如果静态池是在邻近块,汇总在ABR可以执行,因为所有静态路由在ABR。例如:

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

与动态IP分配的拨号设计从中央地址池

对于此拨号设计,假设,中央IP地址池在远程验证拨入用户服务(RADIUS)服务器配置。每个POP有拨叫号码信息服务(DNIS)编号,并且RADIUS服务器有每DNIS的独立的IP地址池。另外,终止呼叫请求DNIS的所有NAS在同一个区域并且与同一聚合路由器谈。

中央IP地址池带来在路由协议设计的若干复杂性。当您拨号POP的时一个DNIS编号,没有关于您连接的NAS和将分配到您从中央IP地址池为该DNIS的IP地址的保证。结果,在每汇总NAS为地址是不可能的分配在DNIS池外面。重新分配的连接的子网是必要的在每NAS,因此能传播所有信息到ABR或聚合设备。那里一问题此设计—,因为外部LSA可能只汇总在ASBR和在此设计, ASBRs如何NAS服务器, ABR将执行来自NAS的外部路由的汇总?

为了解决此设计问题,思科建议NAS服务器属于的区域在非末节区域配置(请参见图2)

图2 –配置在次末节区域

/image/gif/paws/44944/ispdial2.jpg

参考的OSPF次末节区域(NSSA)关于OSPF NSSAs的更多信息。

这是好处,如果定义了区域作为NSSA :

  • 因为ABR重新生成/翻译LSA类型7成LSA类型5.,所有NAS路由可以汇总在ABR。

  • 每个POP不会运载属于另一个POP的路由,因为NSSA不允许外部LSA。

配置重新分配,连接的子网是必要的在所有NAS,因为在所有NAS间的IP地址池不是静态的—所有NAS能运载在该中央IP地址范围内的任何IP地址。

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

如果执行在所有NAS的此配置,汇总配置在ABR被执行,因为所有LSA类型7s在ABR被重新生成并且翻译到LSA类型5s。由于ABR生成一个全新的LSA类型5,并且通告路由器ID是ABR路由器的ID, ABR作为ASBR并且允许以前是LSA类型7s路由的汇总(产生由NAS)。

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

注意在ABR和NAS之间的区域是NSSA,可以配置如下:

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

区域可扩展性问题

如果有许多NAS服务器在一个区域中,并且每NAS再分布1000个或更多路由到区域里,问题出现—各个领域必须包括多少个NAS服务器?如果所有NAS服务器在同一个区域,区域能变得不稳定,因为区域需要运载从所有NAS服务器的1000个或更多路由。在本例中14个NAS服务器,它能潜在再分布14000个路由,是大量。为了给区域带来更多可扩展性,思科建议您分开区域成几个子区域,保证各个领域不影响其他区域,如果若干不稳定性在一个区域中发生(请参见图3)

图3 –分开区域

ispdial3.jpg

为了确定NAS服务器数量在一个区域保留,您必须确定每路由数量NAS注入。三个NAS服务器在一个区域中可以是够,如果每NAS注入3000个或更多路由。请勿放置很少NAS服务器在各个领域,因为,如果有许多区域, ABR能变为被超载的由于汇总的创建到各个领域。然而,您能解决此问题,如果做所有区域完全钝的NSSA,不允许任何汇总路由再分配到区域。除其自己1000个或更多路由之外,此操作减少每信息量NAS运载,和减少ABR完成汇总LSA再分配到各个领域的负载数量。添加在ABR的no-summary关键字执行配置,如显示此处:

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

ABR和NAS服务器之间的链路在各个领域不需要出去,因此ABR不需要创建摘要到这些已连接路由的各个领域。NSSA主要优点是全部3000个或更多路由在一个区域中不漏到其他区域,因为NSSA不运载外部LSA。当ABR翻译所有NSSA LSA类型7s成area 0时,不发送任何LSA类型5s到其他区域由于NSSA特性。

结论

设计ISP拨号网络可以是富有挑战性的任务,但是与一些考虑事项能改善和提供更多可扩展的解决方案。NSSA的并网可以是有效在可扩展性管理方面,因为允许在每NAS必须运载,当与情况比较没有使用NSSA的相当数量的一大为缩短路由。因为redistribute connected configuration命令在NAS服务器,要求汇总帮助也减少路由表的大小,特别是一旦中央IP地址池。连续IP地址在每块分配NAS在汇总时也帮助,因为每个POP可以汇总到一大块,并且核心不必须运载路由过剩。


相关信息


Document ID: 44944