语音 : 介质网关控制协议 (MGCP)

数字CAS和Cisco CallManager配置示例的MGCP

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文解释如何使用在思科IOSï ¿  ½网关(例如, VG200, 2600, 3600, IAD2400)和Cisco CallManager 3.x媒体汇聚服务器(MCS)之间的介质网关控制协议(MGCP)。它包括一T1随路信令(CAS)连接的配置对公共交换电话网(PSTN)的。远程站点是H.323网关。对Cisco 7960 IP电话的VoIP连接也显示。完成此配置后,可在此配置中使用的所有电话之间进行呼叫。另外,从用于此配置的任何电话路由在PSTN的呼叫将是可能的。

本文假设,读者已经熟悉如何配置在Cisco CallManager的思科IP电话。它也假设,有至少一个IP电话已经活动在Cisco CallManager服务器。

症状:

这是您也许用MGCP网关遇到可能的症状的列表,并且什么检查:

  • 出站或呼出不工作。保证您捆绑媒体和信令的正确MGCP源接口

  • 呼出在最后一数字以后的接收快速忙音拨号。保证您捆绑媒体和信令的正确MGCP源接口

  • MGCP网关没有在Cisco CallManager注册。如果使用在MGCP网关的一个域名,请保证匹配在Cisco CallManager的域名在网关配置下。

先决条件

要求

尝试进行此配置之前,请确保满足以下要求:

  • Cisco IOS网关运行该的Cisco IOS软件版本支持MGCP以Cisco CallManager。

  • 使用Cisco 2611,本文创建。

注意: 还有其他支持 Cisco 路由器上的 MGCP 的 Cisco IOS 软件版本系列。Cisco IOS 软件版本 12.1XM 就是其中一个例子。

警告 警告: 一些 MGCP 命令的语法与其他 Cisco IOS 软件版本中的语法不同。请参阅您的配置的文档以确定需要使用的语法。

使用的组件

此配置用Cisco CallManager 3.3(2)和Cisco IOS软件版本12.2(13)镜像测试。屏幕画面和IOS配置捕获使用软件、硬件和其他设备此处。

  • Cisco2600/1 MFT-T1/1快速以太网有Cisco IOS软件版本12.2(13)的10/100端口

  • 运行在MCS7835的Cisco CallManager 3.3(2)

  • 模拟电话听筒

  • Cisco 7960 IP电话

本文档中的信息都是基于特定实验室环境中的设备编写的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您使用的是真实网络,请确保您已经了解所有命令的潜在影响。

网络图

下面的网络图描述用于此的配置和故障排除目的设置文档。

/image/gif/paws/43802/mgcp_12_2_xn5.gif

对于在Cisco CallManager和Cisco IOS网关之间的推荐的兼容性软件版本,参考Cisco CallManager兼容性矩阵leavingcisco.com

注意: Cisco IOS软件版本12.2(11)T或以后根据ccm-manager命令增强推荐。ccm-manager命令要求Cisco IOS软件版本12.1(5)XM或稍后所有Cisco路由器(2600, 3600)和VG200。

Cisco 2600及3600路由器支持MGCP,如果他们运行Cisco IOS软件版本12.1(3)T或以后。您需要的版本和版本根据您需要启用的功能。Cisco CallManager服务器必须运行3.0(5)a或以后。所有类型路由器的配置是相同。Cisco CallManager配置对于所有类型的路由器都是相同的。

Cisco IOS软件版本12.1(5)xm1及以上版本支持VG200。您需要的版本和版本根据您需要启用的功能。虽然Cisco CallManager更早版本支持VG200,推荐版本3.0(5)a或以上。

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

配置Cisco IOS MGCP网关

本文指南您通过一简单介质网关控制协议(MGCP)配置。仅最低的命令要求设置一个路由器的一个工作配置有一个T1的。

注意: 在运行Cisco IOSï ¿  ½软件版本12.1(5)T或以上的本文的配置为Cisco VG200, 2600或者3600系列路由器工作。对于其他IOS MGCP网关,请检查IOS文档支持的版本。

逐步指导

遵从此步骤配置Cisco IOS MGCP网关。

注意: 本文档的剩余部分是指Cisco2600。(当来运送), Cisco2600从默认配置开始。

  1. 配置在思科2600's以太网接口的一个IP地址并且启用接口。

    router(config)#interface fastether 0/0               
    router(config-if)#ip address 172.16.13.35 255.255.255.224 
    router(config-if)#no shut
    
  2. 分配唯一的名称到Cisco2600,以便Cisco CallManager服务器能识别它。

     router(config)#hostname 2611-4
    
    !--- This is how Cisco CallManager keeps track of the MGCP network
    !--- devices it is communicating with. This name  must be unique.
    
    
  3. 配置Cisco2600运行MGCP作为信令协议。

    2611-7 (config)#mgcp
    
  4. 配置IP地址(或DNS名)对于Cisco CallManager服务器。

    2611-7 (config)#mgcp call-agent 171.69.85.171
    

    注意: 要配置在CallManager群集的冗余思科CallManager请使用这些命令。

    2611-7 (config)#ccm-manager redundant-host [ip address |
      DNS-name] [ip-address | DNS-name]
    2611-7 (config)#ccm-manager switchback {graceful|imm[ediate]
      |sch[edule-time] hh:mmm|uptime[-delay] minutes}
  5. 选择编解码器类型和双音多频(DTMF)中继功能。

    VG200A(config)#mgcp dtmf-relay voip codec all mode out-of-band
    
  6. 要启用Cisco CallManager的支持在MGCP内,请输入此命令。

    VG200A(config)#ccm-manager mgcp
    
  7. 将 MGCP 应用程序绑定到语音端口。

    注意: 请使用show voice port命令确定Cisco 2611有和命令他们安装端口的种类。

    dial-peer voice 999101 pots
     application mgcpapp
     port 1/0:1
    /* T1 digital port */

    注意: 在一些Cisco IOS软件版本中, application MGCPAPP命令区分大小写。除非知道您的版本不区分大小写,否则永远大写输入此命令。您能证实您的版本是否区分大小写,在您配置此命令后,当您查看输出show running-config命令时。Cisco IOS软件版本12.1(5)T不区分大小写。

  8. 确保已启用语音端口。

    注意: shutdownno shutdown 命令会影响语音接口卡 (VIC) 上的这两个端口。输入on命令这些端口一只是必要的。

  9. 启用 IP 连接。

    如果Cisco2600联络的其中任一VoIP设备在不同的subnets/VLANS查找,请启用IP路由并且创建最后一站网关(默认网络)。此步骤解释如何执行两任务。

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 
    <ip_address_of_gateway>

    注意: 在上根本是有语音接口的路由器)的Cisco IOS网关(您能配置路由协议而不是静态路由。重要的是要确保 VoIP 设备之间的 IP 连接。

    注意: 对于VG200,当您启用IP路由时, ip routing命令没在配置里出现,因为通常是默认情况下,并且默认命令不在Cisco路由器配置里通常出现。VG200 Cisco IOS镜像改写默认行为安排IP路由启用由hard coding no ip routing命令到初始配置。初始配置创建,当镜像是引导在有write erase命令清除的其配置的平台时或,当从未配置的启动VG200时。

    ip route 0.0.0.0 0.0.0.0 <ip_address_of_gateway>命令,会让VG200将最后经过的网关安装到它的路由表。show ip route 命令对此进行确认。在下面的示例中的,网关IP地址是172.16.13.35。

    注意: 为使最后选用网关有效,还需要使用 ip classless 命令。默认情况下,ip classless 命令已启用。它是在配置里出现少数Cisco IOS默认命令的之一,当启用时并且出现以no形式,当禁用时。如果您的配置有线路no ip classless,请输入ip classless命令启用ip classless

    警告 警告: 所有拨号计划相关的配置元素是由Cisco CallManager在MGCP管理的终端的MGCP网关(那些控制的,并且不应该配置用application MGCPAPP命令在他们的dial-peer语句)。您不应该配置这些功能中的任一个:

    • 在拨号对端下:

      • destination-pattern
      • session-target
    • 在语音端口下:

      • connection { plar | tie line | trunk }

    Cisco2600当前准备用Cisco CallManager服务器通信。它周期地派出消息为建立连接。当Cisco CallManager服务器配置完成时,连接应该自动地设立自己。您在Cisco2600不应该必须做其中任一促进更改。

    注意: 它是良好的做法重置网关端口,在您完成配置后,如此示例所显示。

    router(config)#voice-port 1/0:1
    router(config-voiceport)#shutdown
    router(config-voiceport)#no shutdown
    

配置

2611-4#show run

Building configuration...
Current configuration : 1480 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 2611-4
enable secret 5 $1$Mg6h$ewJl8p0VQlKWg0zYasUh91
!
memory-size iomem 10
voice-card 1
!
ip subnet-zero
!
isdn switch-type primary-ni
!
ccm-manager mgcp
mta receive maximum-recipients 0
!
controller T1 1/0
 framing sf
 linecode b8zs
 no yellow generation
 no yellow detection
 ds0-group 1 timeslots 1-24 type e&m-wink-start
!
interface Ethernet0/0
 ip address 172.16.13.35 255.255.255.224
 half-duplex
!
interface Ethernet0/1
 no ip address
 shutdown
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
no ip http server
!
call rsvp-sync
!
voice-port 1/0:0
!
mgcp
mgcp call-agent 171.69.85.171 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple

!--- This binds the correct MGCP source interface.

mgcp bind control source-interface Ethernet0/0
mgcp bind media source-interface Ethernet0/0
mgcp profile default
!
dial-peer cor custom
dial-peer voice 99 pots
 application mgcpapp
 incoming called-number .
 port 1/0:1
!
dial-peer voice 88 voip
 destination-pattern 1010
 session target ipv4:172.16.13.42
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
login
line vty 5 15
 login
!

验证Cisco IOS MGCP网关

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

  • 显示ccm —提供Cisco CallManager注册状态。

  • show mgcp endpoint —提供端口状态。

mgcp-t1-cas-ccm-a.gif

2611-4#show mgcp endpoint 

Interface T1 1/0

             ENDPOINT-NAME    V-PORT   SIG-TYPE   ADMIN
         S1/ds1-0/1@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/2@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/3@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/4@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/5@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/6@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/7@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/8@2611-4    1/0:0    e&m-wnk    up    
         S1/ds1-0/9@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/10@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/11@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/12@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/13@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/14@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/15@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/16@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/17@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/18@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/19@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/20@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/21@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/22@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/23@2611-4    1/0:0    e&m-wnk    up    
        S1/ds1-0/24@2611-4    1/0:0    e&m-wnk    up    

配置 Cisco CallManager

此部分在交互作用与MGCP网关和CAS接口详细讨论Cisco CallManager的配置对PSTN。

任务 1:创建 MGCP 网关

在此任务,思科基于2611 MGCP网关创建。本节中的内容同样适用于其他 Cisco IOS MGCP 路由器。唯一的区别是在步骤 3 中选择的平台。

  1. 选择Device > Gateway使用设备向导创建MGCP网关。

    mgcp-t1-cas-ccm-2.gif

  2. 点击Add a New Gateway

    mgcp-t1-cas-ccm-3.gif

  3. 选择网关类型(在这种情况下,它是Cisco26xx)。

    注意: 在Device Protocol字段,请注意唯一选择“没有为MGCP要求”。这意味着协议不需要选择,如果网关是MGCP网关。

    注意: 如果使用另一个Cisco IOS路由器,请选择适当的网关类型(例如Cisco26xx或36xx)。这是唯一不同的步骤。剩余的任务适用于Cisco VG200以及Cisco 2600或3600系列路由器。

  4. 单击 Next

  5. 对于MGCP域名,请使用您分配到Cisco2600的实际主机名(在这种情况下, 2611-4)并且指定2600安装的承载模块(在这种情况下,它是NM-HDV)。

    注意: IAD2400的语音承载模块跟那些不同Cisco VG200、2600及3600。

    注意: MGCP域名参数区分大小写。

    /image/gif/paws/43802/mgcp-t1-cas-ccm-4.gif

  6. 单击 Insert

    注意: 如果Cisco IOS路由器/网关配置与域名ip domain-name词, MGCP Domain Name字段需要包括它。例如, 2600.company.com

    接下来执行任务 2:配置MFT-T1端口

任务 2:配置MFT-T1端口

在此任务, MFT-T1端口配置。这些端口是连接到 PSTN 的端口。在此步骤,您确定端口种类并且分配伴随目录号(DN)。

  1. 识别他们在1个端口T1在slot 1位置安装的语音接口卡模块0和1.在这种情况下。

  2. 单击 Update 以激活更改。

    T1端口出现在右下Next屏幕。它们也称为端点标识符。

    mgcp-t1-cas-ccm-5.gif

  3. 选择被标记的T1端口1/0/0

  4. 选择T1端口的正确类型。

    mgcp-t1-cas-ccm-6.gif

  5. 配置您的在此MGCP成员配置屏幕的参数如所需求并且点击插入键

    注意: 寻找在上面镜像的名称S1/DS1-0@2611-4确定您配置的MGCP设备(2611-4)以及端口S1/DS1-0= Slot 1 Port0。

    /image/gif/paws/43802/mgcp-t1-cas-ccm-7.gif

  6. 点击Reset Gateway选项并且配置每个端口如下:

    点击Add新的波尔特并且配置这些设置。

    Cisco CallManager 3.3(2) :

    • 端口类型:Cisco CallManager 3.3(2)支持仅E&M。

    • 开始端口号:配置的第一个端口。

    • 结束端口号:配置的最后一个端口。

    • 波尔特方向:两呼叫的两个方式。入站为呼入呼叫。出站为呼出呼叫。

    • 发信号Type* :仅信令的两种类型用Cisco CallManager 3.3(2)支持。他们是延迟拨号和WINK启动。

    mgcp-t1-cas-ccm-8.gif

  7. 如剩余步骤所显示,点击插入键并且配置端口特定参数。

  8. 点击波尔特,配置参数,并且点击更新

    mgcp-t1-cas-ccm-9.gif

    接下来执行任务 4:测试电话的本地连通性

任务 4:测试电话的本地连通性

如果已经完成任务配置Cisco2600,发送MGCP消息到尝试的Cisco CallManager服务器建立MGCP关系。如果任务1至4是成功, Cisco CallManager服务器和Cisco2600当前准备路由在所有IP电话注册对Cisco CallManager服务器和PSTN之间的本地呼叫。

您应该也能拨号配置的IP电话以及呼叫从IP电话的模拟电话。设法到/从所有电话完成呼叫在您的配置方面。

注意: 如果你的一些电话不能放置或接收呼叫、查看在您的分区,呼叫搜索空间(CSS),设备池和位置配置。您可以有不允许所有本地电话互相告诉的配置。如果这是实际情形,临时地请安置一个IP电话和一个模拟电话(FXS端口)在同样分区、设备池、位置和CSS并且再尝试测验。

注意: 如果遇到与Cisco IOS网关注册或网关操作的问题,如此示例所显示,请设法重置网关语音端口。

router(config)#voice-port 1/0:1
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

注意: 如果继续有问题,参考箴言报,重置,并且删除Cisco CallManager的MGCP网关并且验证其他故障排除任务的MGCP网关

成功完成此任务后,继续执行任务 5:配置路由模式

任务 5:配置路由模式

在此任务一个简单路由模式创建使电话通过PSTN做呼叫。将使用标准北美编号方案 (NANP) 模式“9.@”。

  1. 从 Cisco CallManager 主菜单中选择 Route Plan > Route Pattern

    /image/gif/paws/43802/mgcp-t1-cas-ccm-10.gif

    除默认之外,这些参数配置:

    字段名称 含义
    路由模式 9.@ 拨号计划的标准的路由模式使用NANP。此路由模式配置提供拨号音(或默认情况下)。
    网关路由器列表 S1/DS1-0@2611-4 在2611-4的T1 1/0:1
    Discard Digits PreDot 丢弃路由模式中“.”之前的所有内容,包括“.”。

    注意: 路由模式“9.@”通常用于美国以外无法使用 NANP 的设备。

    /image/gif/paws/43802/mgcp-t1-cas-ccm-11.gif

  2. 点击插入键并且继续对任务6 :测试 PSTN 呼叫

任务 6:测试 PSTN 呼叫

您应该当前能从在系统的所有电话路由在PSTN的呼叫,当您拨号9时,然后拨号被叫号码,在拨号音回来后。在下面跟踪,呼叫由IP电话被做并且捕获MGCP数据包踪迹。

注意: 如果有任何问题,参考箴言报,重置,并且删除Cisco CallManager的MGCP网关并且验证并且排除故障Cisco IOS MGCP网关关于故障排除任务的更多信息。关于排除故障所有的CAS,请参阅配置和排除故障T1 CAS发信号

Mar  9 06:34:21.523: NTFY 27862 *@2611-4 MGCP 0.1
X: 0
O: 
<---
*Mar  9 06:34:21.567: MGCP Packet received from 171.69.85.171-
200 27862 
*Mar  9 06:34:23.110: MGCP Packet received from 171.69.85.171-

!--- Keepalives sent to and received from the Cisco CallManager.

CRCX 122 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
X: 0
L: p:20, a:PCMU, s:off
M: recvonly
R: DT/oc
S: DT/sup(addr(1,0,1,0))
Q: process,loop

!--- CRCX: CreateConnection 
!--- C: CallId
!--- L: LocalCXOptions   p: packetize period(ms)   a: Compression Algo.
!--- M: Mode
!--- X: RequestIdentifier for the notification request
!--- R: RequestEvents
!--- I: ConnectionId

*Mar  9 06:34:23.146: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:23.146: 200 122 OK
I: 6
v=0
 c=IN IP4 172.16.13.35
m=audio 18546 RTP/AVP 0 100
 a=rtpmap:100 X-NSE/8000
 a=fmtp:100 192-194,200-202
 a=X-sqn:0
 a=X-cap: 1 audio RTP/AVP 100
 a=X-cpar: a=rtpmap:100 X-NSE/8000
 a=X-cpar: a=fmtp:100 192-194,200-202
 a=X-cap: 2 image udptl t38
<---
*Mar  9 06:34:24.885: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:24.885: NTFY 27863 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/oc(dt/sup)
<---
*Mar  9 06:34:24.925: MGCP Packet received from 171.69.85.171-
200 27863 
*Mar  9 06:34:26.271: MGCP Packet received from 171.69.85.171-
MDCX 123 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
L: p:20, a:PCMU, s:off
M: sendrecv
S: 
v=0
o=- 6 0 IN EPN S1/DS1-0/1@2611-4
s=Cisco SDP 0
t=0 0
c=IN IP4 172.16.240.41
m=audio 32112 RTP/AVP 0

!---  MDCX= ModifyConnection
!--- C: CallId
!--- I: ConnectionId 
!--- M: Mode

*Mar  9 06:34:26.287: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:26.287: 200 123 OK
<---
*Mar  9 06:34:34.340: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.340: NTFY 27864 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/ans
<---
*Mar  9 06:34:34.368: MGCP Packet received from 171.69.85.171-
200 27864 
*Mar  9 06:34:34.597: MGCP Packet received from 171.69.85.171-
RQNT 124 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
R: D/[0-9ABCD*#], DT/rel
S: 
Q: process,loop
*Mar  9 06:34:34.609: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:34.609: 200 124 OK
<---
*Mar  9 06:34:42.954: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.954: NTFY 27865 S1/DS1-0/1@2611-4 MGCP 0.1
X: 0
O: DT/sus
<---
*Mar  9 06:34:42.958: MGCP Packet received from 171.69.85.171-
200 27865 
*Mar  9 06:34:42.962: MGCP Packet received from 171.69.85.171-
DLCX 125 S1/DS1-0/1@2611-4 MGCP 0.1
C: A00000000100001a
I: 6
X: 0
R: DT/rlc
S: DT/rel
Q: process,loop
*Mar  9 06:34:42.970: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->
*Mar  9 06:34:42.974: 250 125 OK
P: PS=833, OS=133280, PR=875, OR=140000, PL=0, JI=24, LA=0
<---
*Mar  9 06:34:43.395: send_mgcp_msg, MGCP Packet sent to 171.69.85.171 --->

验证

请参阅验证Cisco IOS MGCP网关部分。

故障排除

参考验证并且排除故障Cisco IOS MGCP网关对更进一步的故障排除信息。


相关信息


Document ID: 43802