宽带电缆 : 电缆管理及服务

使用L2TP建立隧道配置ubr7100的CMTS PPPoE终端

2016 年 10 月 24 日 - 机器翻译
其他版本: PDFpdf | 英语 (2015 年 8 月 22 日) | 反馈


目录


简介

本文提供以太网点对点协议(PPPoE)终端配置示例宽带电缆有线电视网的使用Cisco UBR7100有线调制解调器终端系统(CMTS)作为Local Access Concentrator (LAC)。在本文中, PPPoE会话由Cisco 1600路由器启动作为PPPoE客户端,并且通过对L2TP网络服务器(LNS)的一个安全Layer Two Tunneling Protocol (L2TP)隧道连接传输PPP流量。LNS路由器终止从Cisco CMTS的L2TP通道,并且可能转发流量到公司网络。

开始使用前

规则

有关文档规则的详细信息,请参阅 Cisco 技术提示规则

先决条件

本文读者应该熟悉RFC 2516leavingcisco.com ,描述管理PPPoE的规则,以及有线电缆数据服务接口规范(DOCSIS)协议。本文不描述如何建立物理宽带电缆有线电视网。在尝试前配置PPPoE解决方案, DOCSIS兼容的有线调制解调器必须是联机和操作在桥接模式。关于排除故障CMS的更多信息,参考针对UBR电缆调制解调器不在线问题的故障排除

使用的组件

本文档中的信息基于以下软件和硬件版本。

  • Cisco UBR7100系列和思科uBR7246VXR通用宽带路由器(UBR)仅支持PPPoE终止功能。

  • Cisco CMTS路由器一定运行思科IOSï ¿  ½版本12.2(4)BC1a或以上版本。另外,支持PPPoE终止功能,软件镜像名称必须包括IP+特性组(字母“我”和“s”在软件镜像名称必须出现)。

  • 要支持被捆绑的电缆接口的PPPoE终端, Cisco CMTS路由器一定运行Cisco IOS版本12.2(8)BC2或一最新版本。

  • 客户端软件必须支持PPPoE终端协议。如果计算机操作系统不包括这样支持,用户能使用客户端软件例如WinPoet。本文使用一Cisco1600作为PPPoE客户端。

在此特定的实验室设置的信息根据下面软件和硬件版本。

  • Cisco UBR7111 CMTS运行Cisco IOS版本uBR7100-ik8s-mz.122-11.BC1。

  • Cisco 1600路由器运行Cisco IOS版本思科1600-sy-mz.122-11.T8。

本文档中的信息都是基于特定实验室环境中的设备创建的。本文档中使用的所有设备最初均采用原始(默认)配置。如果您是在真实网络上操作,请确保您在使用任何命令前已经了解其潜在影响。

背景理论

PPPoE提供能力连接主机网络在简单桥接访问设备的到远程接入集中器。PPPoE能允许对电缆接口的直接连接。PPPoE支持在Cisco uBR7100及uBR7200系列路由器的电缆接口的允许客户端前置设备(CPE)在有线调制解调器背后使用PPP作为机制获得他们的IP地址和使用它所有随后数据数据量,类似于拨号PPP客户端。在PPP拨号会议上, PPPoE会话验证,并且IP地址协商在PPPoE客户端和服务器之间,可能是Cisco CMTS路由器或家用网关。使用此型号,每台主机使用其自己的PPP堆叠。所以,访问控制、计费和服务类型可以逐个用户完成,而不是一个每站点基本类型。服务提供商可以支持PPPoE客户端和动态主机配置协议(DHCP) -在同样CM后的基于主机。

PPPoE有两个明显的阶段、一个发现阶段和一个PPP会话阶段。当主机希望启动PPPoE会话时,必须首先进行发现识别对等体的以太网MAC地址和设立PPPoE SESSION_ID。当PPP定义了对等关系时,发现固有地是客户端服务器关系。在发现过程,主机(客户端)发现接入集中器(服务器)。凭网络拓扑,可能有超过主机能通信的一个接入集中器。发现阶段允许主机发现所有接入集中器然后选择一。当发现成功地完成,时他们将使用建立他们的在以太网的点对点连接的主机和所选的接入集中器有信息。一旦PPPoE会话开始, PPP数据在其他PPP封装发送正如。

配置

本部分提供有关如何配置本文档所述功能的信息。

注意: 要查找本文档所用命令的其他信息,请使用命令查找工具仅限注册用户)。

网络图

本文档使用下图所示的网络设置。

/image/gif/paws/43241/pppoe_ubr7200.gif

配置

本文档使用如下所示的配置。

Cisco 1600路由器(PPPoE客户端)
PPPoE_client#show running-config 
Building configuration...

Current configuration : 1099 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PPPoE_client
!
no logging console
enable password cisco
!

username LAC password 0 cisco


!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LNS password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation. 


username user@surf.org


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.


ip subnet-zero
no ip domain lookup
ip domain name surf.org
!
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
!
!
!
interface Ethernet0
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Virtual-Template1
 no ip address
 ip mtu 1492
 no peer default ip address
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface Dialer1
 mtu 1492
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname user@surf.org
 ppp chap password 0 cisco
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
!
access-list 1 permit any
!
!
line con 0
line vty 0 4
 password cisco
 login
!
end

Cisco uBR7100 CMTS (LAC)
LAC#show running-config 
Building configuration...

Current configuration : 2442 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname "LAC"
!
no logging console
enable password cisco
!

!--- Cmts-user name/password sent to LNS to create the L2TP tunnel. 


username LAC password 0 cisco


!--- Lns-user name/password used by LNS to authenticate tunnel creation.

username LNS password 0 cisco


!--- Specifies a username and password for each user to be granted PPPoE access.

!--- This can be configured on the RADIUS authentication servers.

username user@surf.org

no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp
!
ip subnet-zero
!
!
no ip domain lookup
!
ip dhcp pool pppoe
   network 10.1.4.0 255.255.255.0
   bootfile platinum.cm
   next-server 10.1.4.1
   default-router 10.1.4.1
   option 7 ip 10.1.4.1
   option 4 ip 10.1.4.1
   option 2 hex ffff.8f80
   lease 7 0 10
!
ip dhcp pool pppoe_clients
   network 172.16.29.0 255.255.255.224
   next-server 172.16.29.1
   default-router 172.16.29.1
   domain-name surf.org
   lease 7 0 10
!

!--- Enables Virtual Private Dial-Up Networking (VPDN). 

vpdn enable

vpdn logging


!--- VPDN group 1 configures the router to accept PPPoE connections.
!--- Specifies the virtual template used for the virtual interfaces that are created 
!--- for each PPPoE session. 


!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1


!--- VPDN group 2 configures the group to be used for the L2TP tunnel to the LNS. 
!--- PPPoE sessions will be initiated from clients using the domain surf.org.


vpdn-group 2
 request-dialin
  protocol l2tp
  domain surf.org
 initiate-to ip 1.1.1.8
 local name LAC


!--- Disables authentication for creation of L2TP tunnel. 


 no l2tp tunnel authentication
!
!
!
!
interface FastEthernet0/0
 ip address 2.2.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.1.1.6 255.255.255.0
 ip broadcast-address 1.1.1.255
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed 10
!
interface Cable1/0
 ip address 172.16.29.1 255.255.255.224 secondary
 ip address 10.1.4.1 255.255.255.0
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 471000000
 cable downstream channel-id 0
 no cable downstream rf-shutdown
 cable downstream rf-power 51
 cable upstream 0 frequency 32000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable dhcp-giaddr policy 


!--- pppoe enable must be configured on the cable 
!--- interface accepting PPPoE sessions.
!--- This is not necessary on subinterfaces. 

 pppoe enable
!
interface Virtual-Template1
 ip unnumbered FastEthernet0/1
 ip mtu 1492

ppp authentication chap
!

ip classless
no ip http server
!
!
cdp run
!
snmp-server community private RW
snmp-server enable traps tty
alias exec scm show cable modem
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
end

Cisco2500 (LNS)
hostname "LNS"
!
!

!--- Lns-user name/password for the LNS itself. 


username LNS password 0 cisco


!--- Cmts-user name/password for the Cisco CMTS. 


username LAC password 0 cisco


!--- Username and password for the PPPoE client. 
!--- This can be configured on the RADIUS authentication servers.


username user@surf.org password 0 cisco
! 
vpdn enable 
!

!--- Creates a VPDN group and starts VPDN group configuration mode.

vpdn-group 1
accept-dialin


!--- Configures VPDN group for L2TP protocol so that it 
!--- can access the PPPoE server.


protocol l2tp


!--- Specifies the virtual-template number to be used when 
!--- configuring a PPPoE session. 


virtual-template 1


!--- This group terminates L2TP tunnels from the specified CMTS hostname.


terminate-from hostname LAC 


!--- This is the local hostname of the LNS.


local name LNS


!--- Disables authentication for creation of L2TP tunnel. 


no l2tp tunnel authentication
!
!
!
interface Virtual-Template1
ip unnumbered FastEthernet0/1
ip mtu 1492


!--- Surf is used as the pool name, and  
!--- the router will use an address from the 100-net.
 

!--- If a test cannot be found, it will search for the pool with the name default.


peer default ip address pool surf
ppp authentication chap
!
ip local pool surf 100.0.0.1 100.0.0.10

验证

本部分所提供的信息可用于确认您的配置是否正常工作。

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

步骤

要验证IP地址从LNS池被实施,请遵从下面步骤。

  1. 发出show ip local pool命令从LNS。检查命令输出。

    LNS#show ip local pool 
    
     Pool                    Begin              End                   Free     In use 
     surf                    100.0.0.1          100.0.0.10             9         1 
    
  2. 要识别成功的呼叫方,请发出show caller ip命令从LNS。

    LNS#show caller ip 
    
      Line           User                        IP Address      Local Number    Remote Number   <-> 
      Vi29           user@surf.org               100.0.0.1            -                -          in
  3. 要验证LNS的VPDN会话,请发出show vpdn session命令

    LNS#show vpdn session 
    
    L2TP Session Information Total tunnels 1 sessions 1 
    
    LocID RemID TunID Intf          Username                  State    Last Chg  Fastswitch 
    30    299   23629 Vi29          user@surf.org             est      00:16:03  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    %No active PPPoE tunnels 
    

请使用下面步骤验证由PPPoE客户端使用的虚拟模板接口编号。

  1. 发出show vpdn session命令从LAC。检查命令输出。

    LAC# show vpdn session
    L2TP Session Information Total tunnels 1 sessions 1 
    LocID RemID TunID    Intf       Username                 State      Last Chg  Fastswitch 
    299   30    26280    Vi1        user@surf.org            est        00:31:19  enabled 
    
    %No active L2F tunnels 
    
    %No active PPTP tunnels 
    
    PPPoE Session Information Total tunnels 1 sessions 1 
    
    PPPoE Session Information 
    SID       RemMAC              LocMAC           Intf     VASt    OIntf  VLAN/VP/VC 
    1         0030.9413.0556      0008.a328.831c   Vi1       UP     Ca1/0
    
  2. 使用PPPoE,要显示注册与Cisco CMTS的用户,请发出show interface cable modem命令

    LAC#show interface cable 1/0 modem 0 
    SID Priv bits     Type       State          IP address        method            MAC address 
    1 00                 modem    up             10.1.4.2          dhcp            0010.9526.2f57 
    2 00                 modem    up             10.1.4.3          dhcp            0007.0e03.a7e5 
    2 00                 host   unknown          172.16.29.2       static          0007.0e03.a7e4 
    3 00                 modem    up             10.1.4.4          dhcp            0007.0e02.c893 
    3 00                 host   unknown                            pppoe           0030.9413.0556 
    4 00                 modem    up             10.1.4.5          dhcp            0007.0e03.5075 
  3. 要显示当前VPDN域,请发出show vpdn domain命令

    LAC#show vpdn domain 
    Tunnel VPDN Group 
    ------ ---------- 
    domain:surf.org2 (L2TP) 
    

故障排除

故障排除步骤

请使用如下说明排除故障您的配置。

  1. 检查LAC通过发出show ip interface brief命令发现接口的状况。

    如果其中任一个接口发生故障,请检查物理电缆并且确保接口不管理上下降状态。

    LAC#show ip interface brief 
    Interface                 IP-Address        OK?     Method         Status        Protocol 
    FastEthernet0/0            2.2.2.2          YES     NVRAM            up             up 
    
    FastEthernet0/1            1.1.1.6          YES     NVRAM            up             up 
    
    Cable1/0                   10.1.4.1         YES     NVRAM            up             up 
    
    Virtual-Access1            1.1.1.6          YES     TFTP             up             up 
    
    Virtual-Template1          1.1.1.6          YES     unset           down           down 
    
    
  2. 检查在PPPoE_client的接口验证拨号接口启用并且有从LNS池的一个IP地址。

    PPPoE_client#show ip interface brief  
    Interface                  IP-Address      OK? Method       Status                Protocol 
    Dialer1                    100.0.0.1         YES BOOTP        up                    up 
    
    Ethernet0                  unassigned        YES NVRAM        up                    up 
    
    Serial0                    unassigned        YES NVRAM        up                    up 
    
    Serial1                    unassigned        YES NVRAM        up                    up 
    
    Virtual-Access1            unassigned        YES unset        up                    up 
  3. 确保您能ping从PPPoE客户端的LNS。

    PPPoE_client#ping 1.1.1.8 
    
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 1.1.1.8, timeout is 2 seconds: 
    !!!!!  Success rate is 100 percent (5/5), round-trip min/avg/max = 12/12/16 ms 
    
  4. 如果有问题启动L2TP的,请尝试发出lcp renegotiation on-mismatch命令已配置的在LNS下vpdn-group。

    LNS#config t 
    Enter configuration commands, one per line.  End with CNTL/Z. 
    LNS(config)#vpdn-group 1 
    LNS(config-vpdn)#lcp renegotiation on-mismatch 

    注意: LAC代理链路控制协议(LCP),当PPP开始。当LNS开始看到转发的PPP时,查看LCP,并且,如果不是什么它将协商与客户端,它抱怨。lcp renegotiation on-mismatch命令强制LNS重新协商与客户端的LCP。不是所有的客户端将重新协商LCP,然而,大多数。

故障排除命令

命令输出解释程序工具仅限注册用户)支持某些 show 命令,使用此工具可以查看对 show 命令输出的分析。

注意: 在发出 debug 命令之前,请参阅有关 Debug 命令的重要信息

  • debug ppp协商—发出此on命令LNS允许您查看PPP协商处理识别问题或演出,当错误出现时并且开发解决方法。然而,是必要的您了解debug ppp协商输出了解debug ppp协商输出为读和排除故障PPP提供一个全面的方法。

  • debug vpdn 12x数据包错误— Iissuing此命令显示防止隧道建立或正常操作的L2F和L2TP协议错误

  • debug vpdn 12x数据包事件—发出此on命令LNS显示是隧道建立的一部分或关闭的L2TP事件。

  • debug vpdn packet [控制|数据] [detail] -若有发出此on命令LNS或LAC显示协议特殊化信息包报头题头信息,例如序号,标志和长度。

  • debug vpdn event [协议|flow-control] —发出此on命令LNS或LAC显示VPN错误和基本事件在用远端对等体接收窗口为极大值配置比零的流量控制和错误内关联的L2TP协议。

  • debug ppp {chap|pap} —发出此命令显示质询握手验证协议(CHAP),并且密码认证协议那被构件到PPP。

  • debug ip udp —发出此on命令LNS检查输出发现数据包是否从pppoe主机接收。

  • debug aaa per-user —发出从LNS的此命令显示什么属性应用给每个用户,当用户验证。

  • debug radius —使用RADIUS服务器时,当用户验证发出此命令显示关联的信息。

常见问题

Q. Cisco CMTS是否支持PPPoE转发?

A.否。Cisco CMTS路由器不支持PPPoE转发,在流出接口收到从流入接口的PPPoE数据包并且转发他们。Cisco UBR7100系列路由器自动地转发PPPoE流量,当配置为Cisco IOS版本12.1 EC仅支持)的MxU桥接模式(然而,这桥接配置的一结果和不归结于所有PPPoE支持。要提供清晰,任何Cisco CMTS不支持PPPoE转发。

Q. 能否同时有PPPoE客户端和普通动态主机配置协议(DHCP)客户端同一个DOCSIS工厂的?

A.可以。PPPoE终止功能支持同时使用PPPoE客户端和DHCP客户端在同样CMs背后。用户能使用PPPoE他们最初的登录到有线网络,然后使用DHCP允许他们的其他PCs和其他主机获取网络访问的IP地址。

Q. 有没有NPE-300和NPE-400的PPPoE支持在Cisco uBR7200VXR CMTS平台?

A.可以。然而NPE-300处理器达到了其在8月15的结束生产里程碑, 2001年。

Q. 思科ubr10k CMTS平台支持PPPoE ?

A.否。Cisco UBR7100系列路由器和思科uBR7246VXR路由器只支持使用Cisco IOS版本12.2(4)BC1a或以上, PPPoE终止功能。Cisco UBR10012路由器不支持它。

Q. 能运行多少次PPPoE会话在Cisco CMTS平台?

A.支持有NPE-225和NPE-300的4000次PPPoE会话的UBR平台继承一IDB限制10000从Cisco 7200平台,当8000次PPPoE会话用NPE-400时支持。没有有模块化NPEs的ubr7100平台,支持4000次PPPoE会话。这些是理论极限。您必须考虑活动,同时PPPoE会话最大是较少,根据内存数量处理器卡,使用的电缆类型接口卡,每个用户被消耗的带宽和路由器配置。

Q. Cisco IOS什么版本是PPPoE终端支持在EC培训?

A.当曾经Cisco IOS版本12.1 EC时,任何Cisco CMTS路由器不支持PPPoE终止功能。


相关信息


Document ID: 43241